Vraag & Antwoord

OS Linux

Gentoo installatie: genkernelproblemen

3 antwoorden
  • Ik heb van de week voor het eerst Gentoo geïnstalleerd op de zogenaamde makkelijke manier: met behulp van de live cd’s een stage 3 GRP installatie. De gebruikte kernel is daarbij de genkernel die middels “emerge genkernel” en “genkernel all” gecompileerd is. Ook de e100 (Intel ethernet adapter heb ik erna ge-emergd). Ik heb de handleiding gevolgd en toen de installatie compleet was kreeg ik bij het booten een 2-tal foutmeldingen betreffende de netwerkkaart (failed to load e100, problem starting needed services en “problem starting needed services, netmount was not started”. Alle nodige config files mbt deze staan volgens mij juist ingesteld, conform de handleiding. Na wat gegoogle, bleek dat ik lang niet de enige was met deze problemen en wordt er steeds gesuggeerd de kernel zelf te compileren en niet de genkernel te gebruiken. Is het mogelijk middels “genkernel –menuconfig all” wijzigingen aan te brengen in de kernelopties? Of moet ik steeds opnieuw beginnen met de installatie? Worden dan alle instellingen en kernelfiles overschreven? Of is er iemand die dezelfde problemen als ik gehad heeft en het simpel heeft kunnen oplossen? Het probleem en de foutmelding komt ook overeen met topic: http://forum.computertotaal.nl/phpBB/viewtopic.php?t=125739&highlight=gentoo Ik heb evenwel een intel onboard chip die in mijn andere linuxen met e100 probleemloos functioneert
  • Geen netwerk betekend ook geen netwerk-diensten. Dus als je kaart werkt, werken de diensten neem ik aan ook. Ik gerbuik ook gentoo, maar geen genkernel. Ik zou je aanraden om de kernel zelf to configureren en te compileren. Zo weet je meteen wat meer over je systeem. Zorg er dan wel voor dat je een bootloader met die twee verschillende kernels start. Eentje die werkt en eentje waarmee je gaat spelen. Ik zou je aan raden om 2.6.8 als basis te nemen en met 2.6.9-rc1 gaat spelen. suc6 ermee.
  • [quote:eb242a8175="Demonaz"]Ik zou je aanraden om de kernel zelf to configureren en te compileren. Zo weet je meteen wat meer over je systeem.[/quote:eb242a8175] Dit is niet het probleem hoor, genkernel werkt perfect!! :wink: Ik ga ervan uit dat je nics dus intel e100 series zijn.... zoniet kun je met lspci (emerge pcitools) dit controleren... Ok.. on with the problem... :wink: Je moet de "oude originele module (epro100)" activeren in je kernel ( als module [b:eb242a8175][M][/b:eb242a8175] ). Die staat boven de e100 module in de lijst van netwerk adapters in je kernel configuratie: - genkernel --menuconfig all --- > devices --> network --> 10 / 100 Mbit --> hier de originele driver selecteren. Dan paar keer escape tot dat je in het hoofdmenu terug bent. - exit menu --> save? YES hij bakt nu kerneltje.... en modulen *5 bakken koffie later* - cd /usr/src/linux - make modules_install - make install - vi /etc/lilo.conf : pas hier je lilo aan met je nieuwe kernel (en initrd) zoals je blieft - lilo (mag geen fouten geven) - vi /etc/modules.autoload/kernel-versie voeg toe: epro100 verwijder : e100 - reboot - boot in je nieuwe kernel.. suc6 :D

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.