Vraag & Antwoord

OS Linux

Welke Linux distributie?

Anoniem
None
55 antwoorden
  • Het is me inmiddels gelukt, vrijwel op eigen houtje, om m'n Deskjet Hp 950 C werkend te krijgen onder Linux :-D (met behulp van apsfilter)!!! Ik moest daarvoor toch een X Windows Library installeren, maar goed, dat heb ik er dan wel voor over.

    Nu nog delen over het netwerk :-D!
  • Gelukkig heb ik ook genoeg beginners met slack of freebsd of zo succesvol zien beginnen. Maar vooraf wijs ik ze op doorgaans wat intuitievere distro's vwb het grafische werk. Maar als ze toch willen, moedig ik ze zeker aan. Maar gewoon eens wat kijken en de eerste stappen nemen… daarvoor adviseer ik meestal suse, fedora, mandrake, e.d. Of live-cd's als suse-eval en knoppix. Later moedig ik ze aan zoveel mogelijk distro's te testen. Voor de desktop of de server…. maakt niet uit…. Zo vinden ze allen wel hun weg. En ieder zijn eigen stijl kwa reclame he.
  • Yep. Ik vraag meestal wat men wil/verwacht en bereid is ervoor te doen. Bij sommige mensen zie je gelijk dat het geboren Slack of Debian fans zijn ;). Voor anderen zijn Mandrake e.d. geschikter, daar is niets mis mee, het is mooi dat er zoveel goede keuze is…
  • Voor ieder wat wils… om zo een flame maar ff in de kiem te smoren 8)
  • [quote:1657857dd4="MrLeeJohn"]Voor ieder wat wils… om zo een flame maar ff in de kiem te smoren 8)[/quote:1657857dd4]

    I agree 8)
  • Goed, ik ben nu inmiddels zover:

    De Windows PC's zien nu m'n Linux Slackware onder Samba in de lijst staan. Het probleem is echter als volgt: ik kan niet op de Slackware PC inloggen. Hij vraagt dan om een wachtwoord.
    Ik heb al geprobeerd in te loggen als Root + bijbehorend passwoord, maar dat doet hij niet. 'Nobody' werkt ook niet (zonder paswoord).
    Dit is m'n smb.conf file (voorlopig is veiligheid even niet aan de orde, dus ik heb liefst dat hij sowieso niet om een paswoord vraagt, maar desnoods kan ik hem ook op altijd onthouden zetten)

    [global]
    workgroup = mshome
    netbios name = alexande
    load printers = yes
    printing = cups
    printcap name = cups

    [share1]
    path = /tmp

    [share2]
    path = /home/huuruun
    comment = Linux Files

    [printers]
    Comment = All Printers
    path = /var/spool/samba
    browseable = no
    public = yes
    guest ok = yes
    writable = no
    printable = yes
    printer admin = root, @ntadmin

    [homes] (ik weet eigenlijk niet zo goed waarvoor dit dient…)
    guest ok = yes
    read only = no

    Wat doe ik fout?
  • Samba heeft een eigen wachtwoordbestand zie "man smbpasswd". Die homes share kun je daar handig voor gebruiken. Als je een samba password instelt voor jouw useraccount kun je op de windows PC's met je username + samba password toegang tot je home directory krijgen…
  • Dus toch! Ik dacht dat dat alleen de bedoeling was als je een Anonymous Printer Server ofzoiets wilde maken…
  • Hmmm, ik kan nu wel inloggen, maar ik kan alleen bestanden plaatsen in de Root directory… Stel ik wil dat in home doen, moet ik dan in de conf. file zetten 'writable = yes'?

    Vraagje 2: M'n printer doet het voor zover ik weet via apsfilter, heb immers een testpagina afgedrukt (hoe controleer ik trouwens of-ie nog steeds werkt??) Hoe controleer ik nou of deze 'geshared' staat (Windows ziet hem niet?) en ook bij smbstatus (van de Samba 'server') staat hij niet vermeld?

    Edit: Overigens heel erg bedankt voor alle antwoorden tot nu toe!

    PS. Als ik 'lpinfo -v' intik, zegt-ie: Unable to connect to server: Connection refused…
  • printer aansturen kun je beter doen via ipp, dan via samba.
    Windows XP ondersteunt ipp-printers, voor Win '98 kun je een addon installeren vanaf de MS-site.
    In de printerwizard van Windows kies je dan voor 'netwerkprinter' en typ je het ipp-adres in van de printer.

    Max
  • Sorry voor het wat late antwoord, ik heb inmiddels lpmg verwijderd, evenals cups en toen cups weer opnieuw geïnstalleerd… Maar ik krijg nu, zoals ook al eerder, de melding als ik een printer wil installeren (maar ook als telnet 127.0.0.1 doe of lpinfo -v): Unable to connect to server: Connection refused…

    Ik ben dan wél ingelogd als root… Wat is hier mis?

    Edit: Ik denk dat het te maken heeft met een loopback problem als ik het hier zo lees. Er was zo iemand die hetzelfde probleem had onder Woody en die moest onder /etc/network/ naar interfaces kijken en het volgende kijken:

    Check /etc/network/interfaces and see if it looks like:

    # Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
    # /usr/share/doc/ifupdown/examples for more information.
    auto lo
    iface lo inet loopback

    If not, maybe that's the problem.

    Maar aangezien de directory structuur waarschijnlijk anders is onder Slackware (ik heb daar geen network directory), waar moet ik dan zoeken?
  • Over de loopback network device moet je je niet te veel zorgen maken, normaal staat die standaard actief in slackware.
    Je kan dit controleren door als root het commando "ifconfig" te geven, dan zie je alle netwerk devices met IP. (vergelijkbaar met ipconfig onder windows 2000/XP)

    Of je cups effectief hebt draaien kan je makkelijk controleren door in de proceslijst te kijken:
    [code:1:57561a21d7]
    ps -ef |grep cups
    [/code:1:57561a21d7]
    waarna de output iets in de aard van de volgende regel moet bevatten:
    [code:1:57561a21d7]
    root 1006 1 0 Oct01 ? 00:00:03 /usr/sbin/cupsd
    [/code:1:57561a21d7]
    Als dat niet het geval is, moet je het bestand /etc/rc.d/rc.cups executable permissies geven (chmod +x /etc/rc.d/rc.cups) en dan uitvoeren (/etc/rc.d/rc.cups start)

    Als cups dan effectief draait, moet je hem kunnen bereiken door te telnetten naar localhost, maar dan wel op poort 631. (telnet localhost 631)

    Het configureren van de printers kan je dan doen via een web-interface, door te surfen naar http://uw_ip_adres:631/ (mag dus ook vanop een andere pc in je netwerk!)
  • Thanks… Het duurde even, want ik kwam er pas later achter, na het hele commandline gedoe en client-error dingens (wat ik inmiddels heb opgelost), dat je eerst permissions in cupsd.conf moet aanzetten voor andere computers om op daarop te kunnen inloggen, dus het heeft niet heel veel geholpen, maar toch erg bedankt!

    Er blijven echter 2 problemen over:

    Lp staat niet standaard bij cat /proc/devices als ik Slackware opstart, ik moet eerst altijd modprobe lp doen voordat hij er staat.

    Ik kan nog steeds niet printen, Windows ziet de printer wel en installeert er een eigen stuurprogramma voor (is dat wel de bedoeling? Ik las ergens anders dat dat ook niet hoefde ofzo), maar als ik probeer te printen reageert-ie niet (en ik heb bij Samba al eens geprobeerd 'use client printerdriver' toe te voegen, samba gerestart, maar het werkte niet). Ik kan wel via dat Cupswebbrowser idee een testpagina afdrukken…
    Dus wat doe ik dit keer fout? En hoe print ik via IPP zoals Maximiliaan een tijd terug zei?
  • De lp module kan je automatisch laden door in /etc/rc.d/rc.modules te zoeken naar de blokken die beginnen met "PC parallel port support" en "Parallel printer support" en die te uncommenten (#'jes aan het begin v/d lijn weghalen).

    Met samba heb ik weinig ervaring, maar wat het IPP printen betreft:
    http://www.owlfish.com/thoughts/winipp-cups-2003-07-20.html
  • Yea!!! Thanks, het verwijderen van de # voor 'application/octet-stream' deed het hem :-)!

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.