Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

problemen snelheid nieuwe hard-disk

drpanda
5 antwoorden
  • hallo

    ik heb recentelijk een nieuw hard-disk gekocht maar de snelheid is tot mijn verbazing erg laag. Dit merk ik vooral bij het copieeren van foto's dan copieer ik +- 2 gig en dat duurt erg lang.

    even voor de duidelijkheid het betreft hier een maxtor 160 gig schijf op hdb
    mijn andere schijf is een maxtor 120 gig schijf op hda
    het probleem ligt bij de 160 gig schijf

    dus even met hdparm gekeken

    hdparm /dev/hda

    /dev/hda:
    multcount = 16 (on)
    IO_support = 1 (32-bit)
    unmaskirq = 1 (on)
    using_dma = 1 (on)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 256 (on)
    geometry = 65535/16/63, sectors = 240121728, start = 0

    hdparm /dev/hdb

    /dev/hdb:
    multcount = 16 (on)
    IO_support = 1 (32-bit)
    unmaskirq = 1 (on)
    using_dma = 1 (on)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 256 (on)
    geometry = 19929/255/63, sectors = 320173056, start = 0

    en nu komt het probleem

    hdparm -Tt /dev/hda

    /dev/hda:
    Timing buffer-cache reads: 1112 MB in 2.00 seconds = 555.25 MB/sec
    Timing buffered disk reads: 168 MB in 3.04 seconds = 55.34 MB/sec

    hdparm -Tt /dev/hdb

    /dev/hdb:
    Timing buffer-cache reads: 1088 MB in 2.01 seconds = 542.46 MB/sec
    Timing buffered disk reads: 2 MB in 3.53 seconds = 580.59 kB/sec

    het probleem zit hem dus in de kB/s

    ik heb al lopen wisselen van slave naar master en op de andere kabel gezet waardoor deze ook als hda en hdd getest is maar dat gaf geen resultaat.

    weet iemand wat het probleem zou kunnen zijn?
  • Hdparm kan je ook gebruiken om de settings te veranderen…. maar als ik het huidige (bedroevende) resultaat zie dan moet je je ook afvragen of er niet iets mis is met de hardware…. de schijf zelf dus… de rest heb je al uitgesloten lijkt me.
  • ja ik dacht ook al aan de hardware

    met de hdparmsetting werd die niet echt sneller

    als laatste test heb ik hem aan een xpbak gehangen en daar dee die het wel op
    partition magic gaf ook geen foutmeldingen

    ik ga morgen wel even naar de computerwinkel terug neem ik gelijk een knoppix cdtje mee ga ik daar wel effe testen
  • Welke kernel gebruik je? Het schijnt dat 2.4.x problemen kan geven met IDE. Probeer dan 2.6 eens.
  • Als ik jou was zou ik eens een diagnose util van de fabrikant gaan downloaden.
    Dan kun je zien of er hardwarematig idd iets fout zit, anders heb je waarschijnlijk geen verhaal in de winkel.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.