Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

na installatie xorg resolutie niet meer op 1024

musicom76
4 antwoorden
  • Ik heb onlangs Xorg op mijn Archlinux bak gezet. Met veel moeite overigens, want eerst kreeg ik steeds een blank scherm na "startx", waarbij linux meteen vast zat. Maakte niet uit met welke driver / monitor instellingen. Maar goed nu werkt dat, op een probleem na:

    ik krijg hem alleen op 640x480.
    Als ik in de modes section "1024x768" zet, slaat hij het over en gaat hij op de hoogst mogelijke stand staan wat de monitor aankan: 1600nogwat bij 75 hz. dat is niet de bedoeling want ik wil hem op 1024/85hz.

    Hieronder volgt mijn xorg.conf, het weghalen van de Modeline voor 1024 heeft trouwens geen effect gehad. Ik had dat ding er eerst staan in XF86Config omdat ik met dpms niet hoger kwam dan 75hz op die resolutie.

    ————————————————————————————
    Section "Files"
    RgbPath "/usr/X11R6/lib/X11
    gb"
    FontPath "/usr/X11R6/lib/X11/fonts/local/"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
    EndSection
    Section "Module"

    Load "dbe"

    Load "glx"
    Load "GLXCore"
    Load "extmod"
    Load "vbe"

    SubSection "extmod"
    # Option "omit xfree86-dga"
    EndSubSection

    Load "type1"
    Load "freetype"

    EndSection



    Section "ServerFlags"

    Option "blank time" "10" # 10 minutes

    Option "standby time" "20"
    Option "suspend time" "30"
    Option "off time" "60"

    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "AutoRepeat" "25 50"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"


    EndSection

    Section "InputDevice"

    Identifier "Mouse1"
    Driver "mouse"

    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"

    Option "Buttons" "7"
    Option "ZAxisMapping" "4 5"

    EndSection

    Section "InputDevice"
    Identifier "Mouse2"
    Driver "mouse"
    Option "Protocol" "MouseMan"
    Option "Device" "/dev/mouse2"
    Option "SampleRate" "100"
    Option "Emulate3Buttons"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"


    Identifier "iiyama"

    HorizSync 30-96
    VertRefresh 50-160
    # Option "dpms"
    ModeLine "1024x768" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
    EndSection

    Section "Device"
    Identifier "NV AGP"
    VendorName "NVidia
    Driver "nvidia"
    EndSection



    # **********************************************************************
    # Screen sections.
    # **********************************************************************

    Section "Screen"
    Identifier "Screen NVidia"
    Device "NV AGP"
    Monitor "iiyama"
    Option "no accel"
    DefaultColorDepth 24

    SubSection "Display"
    Depth 16
    Modes "640x480" "800x600" "1024x786"
    EndSubSection

    SubSection "Display"
    Depth 24
    Modes "800x600" "1024x786"
    EndSubSection
    EndSection

    # **********************************************************************
    # ServerLayout sections.
    # **********************************************************************


    Section "ServerLayout"

    # The Identifier line must be present

    Identifier "Simple Layout"


    Screen "Screen NVidia"


    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

    EndSection
    ————————————————————————————

    Ik hoop dat iemand er een oplossing voor weet !
  • [quote:61be51ac3b="musicom76"]Ik heb onlangs Xorg op mijn Archlinux bak gezet. (..) ik krijg hem alleen op 640x480. Als ik in de modes section "1024x768" zet, slaat hij het over en gaat hij op de hoogst mogelijke stand staan wat de monitor aankan: 1600nogwat bij 75 hz. [/quote:61be51ac3b] Wat die XF86Config betreft. Heb je die DefaultColorDepth 24 echt nodig? Wellicht kun je beter proberen DefaultColorDepth 16
    En deze
    [code:1:61be51ac3b]
    SubSection "Display"
    Depth 16
    Modes "640x480" "800x600" "1024x786"
    EndSubSection [/code:1:61be51ac3b] zou dan zo kunnen
    [code:1:61be51ac3b]
    SubSection "Display"
    Depth 16
    Modes "1024x786" "800x600" "640x480"
    EndSubSection [/code:1:61be51ac3b]
  • ik heb Iiyama LS704UT en heb de Horisync en Vertrefresh zo staan:

    [code:1:274e6ac6d1]
    Section "Monitor"

    Identifier "Iiyama LS704UT"

    # HorizSync is in kHz unless units are specified.
    # HorizSync may be a comma separated list of discrete values, or a
    # comma separated list of ranges of values.
    # NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
    # USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync 37.50-68.68

    # HorizSync 30-64 # multisync
    # HorizSync 31.5, 35.2 # multiple fixed sync frequencies
    # HorizSync 15-25, 30-50 # multiple ranges of sync frequencies

    # VertRefresh is in Hz unless units are specified.
    # VertRefresh may be a comma separated list of discrete values, or a
    # comma separated list of ranges of values.
    # NOTE: THE VALUES HERE ARE EXAMPLES ONLY. REFER TO YOUR MONITOR'S
    # USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 75-85

    EndSection
    [/code:1:274e6ac6d1]

    zo heb ik hem op 1024x768 op 85hz gekregen, ik draai Slackware 10
  • Doe eens dit want je hebt namelijk de boel omgedraaid:

    SubSection "Display"
    Depth 16
    Modes "1024x786" "800x600" "640x480"
    EndSubSection

    SubSection "Display"
    Depth 24
    Modes "1024x786" "800x600" "640x480"
    EndSubSection


    Schakel die mode line voor het testen in iedergeval eens uit. Een refresh rate instelling kan rare dingen met screen resolutions doen. Bij mij is het namelijk al eens een paar keer voorgekomen dat mijn XServer op een bepaalde resolutie gelockt stond door een verkeerde refresch rate instelling. Als je xserver is opgestart zou je normaal gesproken met CTRL ALT + en CTRL ALT - tussen de verschillende resoluties moeten kunnen switchen.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.