Vraag & Antwoord

OS Linux

[slackware 10] Slack-get installeren

Anoniem
djezzer
5 antwoorden
  • Ik heb het pakket slack-get (gui perlscript om installpkg tool heen) overgehaald van http://slackget.infinityperl.org/slack/index.pl?action=download&LANG=en
    en geinstalleerd met pkgtool.

    Bij het starten krijg ik de volgende melding:
    [code:1:cabf93a4c3]
    root@galaxy:/home/djezzer# slack-get
    Can't locate File/Reader.pm in @INC (@INC contains: /usr/lib/perl5/5.8.4/i486-linux /usr/lib/perl5/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i486-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl .) at /usr/sbin/slack-get line 6.
    BEGIN failed–compilation aborted at /usr/sbin/slack-get line 6.
    [/code:1:cabf93a4c3]

    De aangegeven directories bestaan, perl 5.8.4 heb ik geinstalleerd met swaret.

    Wat kan er nog ontbreken?

    Greetz, dJezzer 8)
  • Dat die dir bestaan is wel logisch…. dat zijn namelijk de plekken waar perl kijkt voor bestanden.
    Het probleem is dat reader.pm niet in een van die directories staat.

    Geen README bij dat proggie…. kan me niet voorstellen dat dit een uniek probleem is.

    PS
    Was het niet mogelijk dit script via CPAN te installeren? Dan krijg je dit soort problemen meestal niet.
  • PeterK, dat was een interessante opmerking die je maakte. Bij CPAN http://search.cpan.org/~dupuisarn/File-Reader-0.7/
    heb ik de missende module gevonden.

    Maar wat bedoelde je met dit (slack-get) script via CPAN installeren?

    Greetz, dJezzer 8)
  • Heel veel perl gerelateerd materiaal kan je via de cpan interface installeren… dat is een soort van package manager voor perl.
    Je start de cpan interface met de opdracht cpan…. :duhhhh: ;)
    In die interface kan je dan bv een opdracht geven om bv SpamAssassin te installeren, zaakt is dan wel dat je weet hoe een package/bundle precies genoemd wordt…. vb

    `install SpamAssassin`

    zal SpamAssassin installeren of updaten (mits ik de naam goed gegokt heb natuurlijk ;)), incl alle depencies.
  • [quote:ef54d6b0d0]Heel veel perl gerelateerd materiaal kan je via de cpan interface installeren… dat is een soort van package manager voor perl[/quote:ef54d6b0d0]
    Ok, dat is een interessant gegeven.

    Is het nodig dat ik het met installpkg geinstalleerde slapt-get pakket eerst verwijder en het dan alsnog met cpan installeer? Of hoef ik alleen de missende module met cpan te installeren?

    Greetz, dJezzer 8)

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.