Vraag & Antwoord

OS Linux

[suse 9.1] NVidia blokkeert toegang tot console?

10 antwoorden
  • Hallo allemaal, Sinds ik de NVidia driver gebruik krijg ik via Ctrl-F1-6 geen toegang meer tot de console. Ik krijg een zwart scherm, of eentje met mozaik (tty1) Ook bij het overgaan van init 5 naar init 3, en het afsluiten van de pc krijg ik niet de gebruikelijke schermen te zien, maar of een zwart scherm, of eentje met mozaiek. Enig speurwerk leerde me dat dit te maken heeft met PAM, of met de toegang tot de groep 'video'. Echter, alle instellingen zijn correct, en de PAM-update is voor SuSE 7.2, en ik gebruik 9.1 (neem aan dat het dan is opgelost ;) ) Wie weet raad? Max
  • is je kb wel geladen als je direct met booten al naar init3 gaat ?? word "mingetty wel op je console's geladen ?? ps ax >> ?? staan daar wel je tty's bij ?
  • alles werkte normaal zonder nvidia, en alles werkt normaal in init 3 maar zodra ik X start met nvidia, dan gaat het fout. Ik krijg simpelweg geen toegang tot de console ook het afsluiten van de pc laat niet de bekende SuSE-logo zien, terwijl die bij het opstarten wel aanwezig is. Het ligt imho dus puur aan nvidia (waarschijnlijk de kernelmodule) en niet aan de verdere configuratie van het systeem.. Max
  • hoe heb je de nvidia driver geinstalleerd ?? mbv YOU ? of handmatig heb je niet perabuis daarna nog een kernel update gedaan ??
  • Via YOU Kan zijn dat daarna een kernelupdate is geweest.. Zou nvidia daardoor opnieuw moeten worden geinstalleerd? Max
  • ok, nvidia opnieuw geinstalleerd, maar geen verschil
  • Ik heb dit probleem al zolang als ik met Linux(Slackware in mijn geval) werk. Blijkbaar een ongelukkige combinatie van driver en videokaart, want ik heb het nooit op kunnen lossen.
  • Dat klinkt niet echt hoopvol ;) Max
  • Troost je met de gedachte dat ik maar een noob ben :wink:
  • [quote:973d8351ed="maximilaan"]Sinds ik de NVidia driver gebruik krijg ik via Ctrl-F1-6 geen toegang meer tot de console. Ik krijg een zwart scherm, of eentje met mozaik (tty1) (..) Kan zijn dat daarna een kernelupdate is geweest.. [/quote:973d8351ed] Ik heb hier gecontroleerd op mijn Athlon XP in SuSE 9.1. Deze pc heeft een GeForce 4400Ti videokaart. Als ik hier eveneens update via YOU, dan staan een aantal pakketten al voor geselecteerd, waaronder een kernel update. Als ik daar dan de nvidia patch bij selecteer, dan is YOU enige tijd bezig te downloaden. Na de reboot blijkt de nvidia driver te werken. Hier zijn enkele outputs [code:1:973d8351ed] jolo@linux:~> dmesg | grep nvidia nvidia: unsupported module, tainting kernel. nvidia: module license 'NVIDIA' taints kernel. 0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336 Wed Jan 14 18:29:26 PST 2004 jolo@linux:~> uname -a Linux linux 2.6.5-7.111-default #1 Wed Oct 13 15:45:13 UTC 2004 i686 athlon i386 GNU/Linux jolo@linux:~> /sbin/lsmod | grep nvidia nvidia 2070120 12 jolo@linux:~> [/code:1:973d8351ed] Bij mij werken de TTY's nog wel. Getest in KDE 3.2.1. [quote:973d8351ed="maximilaan"] Enig speurwerk leerde me dat dit te maken heeft met PAM, of met de toegang tot de groep 'video'. [/quote:973d8351ed] Bij mij is PAM ook geinstalleerd, maar niet geconfigureerd. Heb je het hier over Section "DRI" in /etc/X11/XF86Config [code:1:973d8351ed] Section "DRI" Group "video" Mode 0660 EndSection [/code:1:973d8351ed]

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.