Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Linux opnieuw opstarten na terugplaatsen image

None
6 antwoorden
  • Geachte lezer,

    Ik heb een multibootsysteem gehad van WinXP en SuSE 8.2 op mijn pc.
    Nu heb ik onlangs een ghost-image van XP teruggezet, en die heeft zoals verwacht de MBR overschreven waardoor ik nu geen bootmenu meer krijg.
    Hoewel ik dacht dat ik Suse met een diskette kon opstarten, blijkt tot mijn teleurstelling dat dit niet lukt.
    Als ik met die diskette opstart, krijg ik idd het beginscherm van Grub met de volgende opties: Boot from hard disk, Installation, Installation - ACPI disabled, Installation - safe settings, Manual installation en rescue system.

    Indien ik ik de eerste kies, start gewoon Windows op.
    Mijn vraag: zit ik nu vast aan een nieuwe installatie, of kan ik iets anders doen met de bovenstaande gegevens?
    Indien u een reactie geeft, dan heel graag in stappenplan; weet nog niet echt veel van Linux.

    Alvast bedankt, en een groet.
  • [quote:f8c8496a7b="jhde"]Ik heb een multibootsysteem gehad van WinXP en SuSE 8.2 op mijn pc. (..) en die heeft zoals verwacht de MBR overschreven waardoor ik nu geen bootmenu meer krijg. (..) Mijn vraag: zit ik nu vast aan een nieuwe installatie, [/quote:f8c8496a7b] Nee, een nieuwe SuSE installatie is in dit geval niet nodig. Plaats je SuSE 8.2 in je dvd-speler en start je pc opnieuw op. Bij het eerste scherm dat je ziet, selecteer je Installation. Bij Select your language Nederlands Accepteren. Bij het dialoog wat je dan te zien krijgt, selecteer je Boot geïnstalleerd systeem OK. Als er meerder Linux distro's op pc staan verschijnt er ook nog een dialoog om de juiste root partitie te selecteren.

    Als het goed is, start dan SuSE Linux op. Het zou kunnen dat de grafische schil hier niet wil starten. Maar dat is niet erg. Als je in tekst modus bent terecht gekomen, log je in als root. Is KDE/Gnome wel gestart, log je eerst in als gewone user, en open je een Konsole/Terminal en logt in als superuser. Om de grub bootmanager te herstellen typ je
    [code:1:f8c8496a7b]
    grub-install /dev/hda
    [/code:1:f8c8496a7b][Enter]
  • Hoi Jolo,

    Hartelijk dank voor de reactie.
    Ik ben er gelijk mee aan de gang gegaan, en kwam er daardoor achter dat ik inderdaad aan een nieuwe installatie vastzit.
    Wat is nu het geval? Hij gaf aan dat ie geen linuxpartitie vond.
    Toen schoot het me te binnen, dat bij een teruggeplaatst image eventuele partities opgeheven worden. WindowsXP en Suse 8.2 zaten beide namelijk op dezelfde schijf. Misschien ligt dit aan de manier waarop de image gemaakt is.

    Hoe dan ook; nogmaals dank voor de reactie.

    John.
  • Ik heb dit probleem al meermaals voor gehad. Ik zit veel te prutsen in de software van m'n pc.
    Ik los het dan op door de installatie te herbeginnen, maar in plaats van de boot instructie kies ik dan voor 'update'. Suse zegt dan dat er 1 pakket zal geupdate worden, en bij het herstarten is alles terug als voordien.
  • Hallo (Jolo)
    Ik zit dik in de nesten. Ik heb Suse 8.2 opnieuw geïnstalleerd, maar dan nu niet op een andere partitie op mijn 1e schijf, maar op de 2e.
    Dit alles ging goed totdat ie na cd1 opnieuw moest opstarten. Helaas werd de 2e schijf niet meer herkend (ook niet in het BIOS) en bleef die hangen bij de "warme boot".
    Ik moest hem uitschakelen en weer inschakelen en toen werd de schijf wel weer gezien, maar geen bootmenu (alleen de woorden "GRUB"). Nu heb ik de gegevens van jouw vorige post gebruikt, maar dat is geen redding gebleken. Ik krijg nu de volgende melding: Grub loading stage1.5
    Grub loading, please wait . .
    Error 17
    Verder niets.
    Nu heb ik op de andere partitie enkele mappen staan die ik graag wil kopiëren naar mijn 1e (C) schijf (die ik overigens wel zie als Linux opgestart is), maar dat lukt ook niet.
    Weet iemand hoe dat moet?
    Ik kan wel in linux komen, maar alleen zoals beschreven in de post van Jolo (hierboven) met cd1 van Suse.
    In Windows XP kom ik nu alleen met een opstartdiskette van Win98 door na het opstarten de MBR te overschrijven. Dan zie ik de 2e schijf wel, maar Windows laat weten dat ie niet geformatteerd is.
    De mappen wil ik eventueel ook wel branden op een cd, maar het gekke is dat mijn brander niet gezien wordt, terwijl de cd1 van Suse hierin ligt en wel werkt. Raar he . . ?

    Wie kan mij helpen?
    Alvast dank.
  • [quote:5ee770b6ec="jhde"] Ik heb Suse 8.2 opnieuw geïnstalleerd, maar dan nu niet op een andere partitie op mijn 1e schijf, maar op de 2e. [/quote:5ee770b6ec] Dat zou geen probleem moeten zijn voor SuSE.
    [quote:5ee770b6ec="jhde"] maar geen bootmenu (alleen de woorden "GRUB"). Nu heb ik de gegevens van jouw vorige post gebruikt, maar dat is geen redding gebleken. Ik krijg nu de volgende melding: Grub loading stage1.5
    Grub loading, please wait . .
    Error 17 [/quote:5ee770b6ec] Volgens deze topic, zou er een fout kunnen staan in je /boot/grub/menu.lst
    [quote:5ee770b6ec="jhde"] Nu heb ik op de andere partitie enkele mappen staan die ik graag wil kopiëren naar mijn 1e (C) schijf (die ik overigens wel zie als Linux opgestart is), maar dat lukt ook niet. [/quote:5ee770b6ec] Wat gaat er dan fout? Heb je die partitie op die tweede harde schijf wel kunnen mounten, zonder foutmeldingen? Dan zou je die mappen moeten kunnen kohieren via commando
    [code:1:5ee770b6ec]
    cp -a <gemounte map op 2de hd> <gemounte map op 1de hd>
    [/code:1:5ee770b6ec][Enter]
    [quote:5ee770b6ec="jhde"] De mappen wil ik eventueel ook wel branden op een cd, maar het gekke is dat mijn brander niet gezien wordt, terwijl de cd1 van Suse hierin ligt en wel werkt[/quote:5ee770b6ec]Bedoel je dat je K3b de brander niet ziet? Of wordt deze ook niet meer getoond door [code:1:5ee770b6ec] dmesg | grep hd [/code:1:5ee770b6ec][Enter]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.