Vraag & Antwoord

OS Linux

GTK+ compileren tbv gksu

Anoniem
windowsXP-PRO
10 antwoorden
  • hoi,

    ik wil [code:1:93df5df87b]gtk+-2.4.14[/code:1:93df5df87b] compileren onder Suse9.1

    ik krijg een foutmelding:
    [code:1:93df5df87b]checking for glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0… Package atk was not found in the pkg-config search path.
    Perhaps you should add the directory containing `atk.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'atk' found

    configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
    :/local/gtk+-2.4.14 # whereis atk
    atk:
    :/local/gtk+-2.4.14 # apt-get install atk
    Reading Package Lists… Done
    Building Dependency Tree… Done
    atk is already the newest version.
    [/code:1:93df5df87b]

    hoe los ik die op??

    Evert
  • ik gok dat je atk-devel nodig heb.

    Max
  • En pango-devel
    en glibc-devel van tenminste versie 2.4
  • ok, die heb ik inmiddels

    Als ik nu gtk+ compileer, heb ik dan ook gtk+-devel?

    Het verhaal hierachter is namelijk dat ik een rpm wil bouwen van gksu.
    gksu is een gui voor su.
    Als ik synaptic wil runnen start er namelijk niets. Er wordt niet om een wachtwoordt gevraagd.
    Nu denk ik dat na installeren van gksu dit wel werkt.

    Als iemand me naar een rpm (gksu) voor suse 9.1 kan loodsen ben ik hem / haar zeer dankbaar.

    Evert
  • Daar ga je:

    http://www.tuxme.com/filestore2/download/16/gksu-1.0.7-1.i386.rpm
  • die had ik zelf ook al gevonden
    [code:1:c095a171c4]Evert # rpm -i gksu-1.0.7-1.i386.rpm
    gksu-1.0.7-1.i386.rpm: not an rpm package (or package manifest):
    [/code:1:c095a171c4]
    erg vaag
  • kan ik ongestraft een rpm van bv yoper, nemen??
  • Als ze installeren, dan wel.
  • ok

    het blijft wel een beetje spannedn dan
  • gelukt.

    Yoper heeft een rpm en die is zonder problemen geinstalleerdt.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.

Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord