Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Mail geweigerd door? Server? Modem? Router?

MrLeeJohn
40 antwoorden
  • Ik heb een mailserver (geprobeerd) opgezet. Ik kan mail versturen, maar wanneer ik met bijv. Hotmail reply, krijg ik na een paar uur een foutmelding teruggestuurd.
    Voordat ik aan allerlei instellingen ga morrelen wil ik eerst vragen of iemand a.d.h.v. de melding kan zien waar het probleem zit.

    Reporting-MTA: dns; mx3.argewebhosting.nl
    Arrival-Date: Fri, 7 Jan 2005 07:52:20 +0100

    Final-Recipient: RFC822; test@yolknet.nl
    Action: delayed
    Status: 4.4.1
    Remote-MTA: DNS; yolk.yolknet.nl
    Last-Attempt-Date: Fri, 7 Jan 2005 12:08:08 +0100
    Will-Retry-Until: Wed, 12 Jan 2005 07:52:20 +0100

    —– Transcript of session follows —– <test@yolknet.nl>… Deferred: Connection refused by yolk.yolknet.nl.
    Warning: message still undelivered after 4 hours
    Will keep trying until message is 5 days old

    Loopt het mailtje nu vast bij de server, of al bij de modem
    outer? Of is dat niet af te leiden hieruit?
  • Loopt hier niet al een vraag over?
  • Er liep hier inderdaad al een onderwerp over.
    Het poortje staat gefirewalled. Of door je router, danwel door je firewall rules. Dat is hieruit niet op te maken nee.
    Als je server achter de router staat zul je op zijn minst de poort moeten openen en forwarden…
  • Ja, die gedachte had ik ook al. Op zowel de modem als de router laat ik de poorten 25, 110 en 143 doorsturen naar de server. In dat geval zou de poort door Zonnet geblockt worden lijkt me?
    Op de server heb ik geen firewall geïnstalleerd totdat alles werkt, dus dat kan het ook niet zijn dan.

    Zou het dan toch aan de DSN-instellingen liggen?
  • DNS kan het niet zijn;

    [code:1:0d58445b4e]root@p800:root>telnet yolk.yolknet.nl 25
    Trying 81.59.116.29…
    telnet: Unable to connect to remote host: Connection refused[/code:1:0d58445b4e]

    Dus dat heeft alvast niets te maken met DNS, maar met de poort waarop ik connect.

    En je provider blockt ook niets;

    [code:1:0d58445b4e]23:01:13.465501 IP <MIJNPC>.33112 > dslam29-116-59-81.dyndsl.zonnet.nl.smtp: S 100891475:100891475(0) win 5840 <mss 1460,sackOK,timestamp 127570213[|tcp]>
    23:01:13.515073 IP dslam29-116-59-81.dyndsl.zonnet.nl.smtp > <MIJNPC>.33112: R 0:0(0) ack 100891476 win 0[/code:1:0d58445b4e]

    Ik krijg netjes antwoord van je PC dat de poort onbereikbaar is.
  • Ik bedoelde de DNS op mn server. Zou die misschien niet goed zijn ingesteld?
    Als ik op de server "telnet yolk.yolknet.nl 25" krijg ik ook de melding [quote:4840f0388c]Trying 81.59.116.29…
    telnet: Unable to connect to remote host: Connection refused[/quote:4840f0388c]
    Is dit logisch? Als ik via het externe IP-adres mn website bezoek, dan krijg ik een "HTTP 501 Not Implemented"-pagina.

    Er staat ook "Deferred: Connection refused by yolk.yolknet.nl". Krijg je die melding ook als de provider iets blockt?
  • Als ik je website bezoek op yolk.yolknet.nl werkt het prima. Ook op IP adres. Dus het zou aan je interne DNS kunnen liggen waarom je zelf niet kunt connecten.

    En een connection refused op IP adres kan nooit aan de DNS instellingen liggen. Weet je zeker dat je sendmail uberhaupt gestart hebt?? Probeer eens een "telnet localhost 25" op je server.
  • Als ik `telnet localhost 25` probeer, dan krijg ik dit±
    [quote:d297fc6f0e]
    Trying 127.0.0.1…
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 yolknet.nl ESMTP Sendmail 8.13.1/8.13.1; Sat, 8 Jan 2005 18:53:24 +0100
    [/quote:d297fc6f0e]
  • Goed, dan draait de sendmail daemon, en je PC draait geen firewall vertelde je, dus dan is het je router, kijk de instellingen nog eens goed na.
  • Vaak werkt het niet om van intern te resolven naar een eigen extern adres. Tussenoplossing die ik gebruik is die hostnamen in de hosts-files op te nemen. Werkt bij mij.
  • Ik heb alle instellingen bekeken, zowel op de router als de modem, maar op allebei wordt poort 25 doorgestuurd naar de server. Zie ik nog instellingen over het hoofd misschien?
  • Ok, nu heb ik op mn server DNS ingesteld op de volgende manier:
    [code:1:831806073f]$ORIGIN yolknet.nl.
    $ttl 38400
    yolknet.nl. IN SOA yolk.yolknet.nl. test.yolknet.nl. (
    1104861331 ; Serial, moet na elke verandering in de zone-data worden verhoogd
    10800 ; Refresh: 3 uur
    3600 ; Retry: 1 uur
    604800 ; Expire: 168 uur
    38400 ) ; Default/Minimum TTL: 10,5 uur

    yolknet.nl. IN NS yolk.yolknet.nl.

    yolknet.nl. IN MX 10 mx1.yolknet.nl.
    yolknet.nl. IN MX 20 yolk.yolknet.nl.

    yolk.yolknet.nl. IN A 173.16.0.2

    yolk.yolknet.nl. IN A 173.16.0.2
    www.yolknet.nl. IN CNAME yolk.yolknet.nl.
    mx1.yolknet.nl IN CNAME yolk.yolknet.nl.

    yolknet.nl. IN RP test.yolknet.nl.

    yolknet.nl. IN PTR yolk.yolknet.nl.
    [/code:1:831806073f]

    Ik heb al mail geprobeerd te versturen, maar nog steeds hetzelfde probleem: het versturen lukt, maar een mail terugsturen naar de server lukt niet. Als ik echter met Webmin vanaf de server een mailtje stuur naar test@yolknet.nl, dan komtie direct aan!

    Heb ik misschien nog een POP-instelling of POP-progje nodig om de mail op te halen ergens?
  • Nee het lag al vanaf het begin niet aan je DNS instellingen…
    En aangezien jij zelf de MX host bent voor je domein, en je mail dus bij jouw server word afgeleverd, is er ook niets met POP te doen, want er is geen andere (backup) server waar de mail afgeleveverd word.

    Je DNS staat goed;
    relay=yolk.yolknet.nl. [81.59.116.29], dsn=4.0.0, stat=Deferred: Connection refused by yolk.yolknet.nl

    Je poortje is alleen nog steeds afgeblokt volgens een nmap portscan.
    Ik zou toch maar eens goed naar je router kijken want dit geeft niet zo'n vertrouwen;

    [quote:d8e1823695]root@p800:mail>telnet 81.59.116.29
    Trying 81.59.116.29…
    Connected to 81.59.116.29.
    Escape character is '^]'.
    CONEXANT SYSTEMS, INC.
    ACCESS RUNNER ADSL CONSOLE PORT 3.29


    LOGON PASSWORD> ***************************[/quote:d8e1823695]

    Zeker ook omdat er een aantal exploits voor deze router zijn, zeker met deze oude firmware.
  • Let op:
    soms moet je behalve een portforward ook nog opgeven dat een poort geopend moet worden!
  • Ok, dus het ligt echt aan de beveiliging en niet aan de instellingen als ik het goed begrijp. Is af te leiden of het om de beveiliging aan de kant van de provider of aan mijn kant ligt? Volgens de website van Zonnet heb ik met ADSL Family de mogelijkheid om servers op te zetten. Dus een mailserver zou dan toch mogen.
    Ik gebruik een Sweex Modem en een SMC router. Voor zover ik me kan herinneren ben ik nooit een optie tegengekomen om poorten open te zetten of dicht te zetten. Ik zal het straks als ik thuis ben controleren.
  • Thuisgekomen gelijk weer aan de slag met het probleem. Ik heb de server direct op mn Sweex Annex A modem aangesloten en alle instellingen opnieuw gecontroleerd, maar wederom zonder resultaat. Op internet vond ik deze pagina http://www.adslforum.nl/topic.asp?TOPIC_ID=10808 maar die heeft me ook niet kunnen helpen.

    De handleiding van de modem heb ik geplaatst op http://172.16.0.2/computertotaal/. Uit de handleiding maak ik op dat wanneer je een poort forward, hij automatisch wordt opengezet. Of heb ik dat verkeerd?
    Iemand nog nieuwe suggesties? Mijn inspiratie begint een beetje op te raken. Misschien moet ik instellingen gaan posten, of zou dat niet veel helpen?
  • Dat ga is dus echt niet allemaal doorlezen op dat forum. Hoewel…. oke ff dan….

    Iemand zegt: "Goed, inmiddels een mailtje ontvangen van Sweex met de mededeling dat de firewall in de ADSL Annex-A wireless router niet kan worden uitgeschakeld. Van Sweex kreeg ik de suggestie om één van de aangesloten PC's een fixed IP te geven, en die in de DMZ te zetten."

    Heb je hier wat aan? Als jij zo'n ding hebt (en dat suggereer je door die url) ben je wel dubbel aan het routeren door er nog een SMC-router achteraan te plakken. Als ik je postings doorlees snap ik geen barst van je setup hoor.

    Verder…… oew die telnet op de router open…. gelijk dicht gooien!

    En idd poort 25 staat niet open. Doe eens voor de zekerheid "/sbin/service iptables stop" of "/etc
    c.d/iptables stop". Zou echt niet de eerste keer zijn dat iemand na dagen klooien ziet dat toch de firewall aan staat.

    Wat blockt dan die poort 25? Of is toch die poort niet goed geforward?

    Neem alles eens stap voor stap door. Een warrig onderzoekje zal je niet verder helpen….
  • Het lijkt erop dat alles nu goed staat ingesteld op mijn thuisnetwerk. Ik heb op de modem en op de router het IP-adres van de server in een DMZ gezet. Het probleem is nog steeds niet opgelost.

    Ik heb met ShieldsUp en met de Sygate-poortscan gekeken wat er nog openstaat. In plaats van poorten "Closed" heb ik nu bijna alles "Stealth" (dus dat is gelijk mooi meegenomen. Ook Telnet staat nu op Stealth.
    Het resultaat wat ik nu heb:
    21 FTP OPEN
    25 SMTP Closed
    80 HTTP OPEN
    110 POP3 Closed
    143 IMAP Closed

    Alle andere poorten zijn Stealth. De poorten 25, 110 en 143 heb ik op de modem en router ingesteld om door te sturen naar de server. Zowel op een client als de server krijg ik bovenstaand "poorten-lijstje".
    Het lijkt dus niet aan de modem of de router te liggen lijkt me?
  • Als je een ps doet op je servert, krijg je dan een soortgelijk response?

    [code:1:239fadca3a]ps ax|grep send

    24169 ? Ss 0:01 sendmail: accepting connections[/code:1:239fadca3a]
  • Haha, geen idee wat het commando doet, maar ik krijg een soortgelijk iets ja±
    [code:1:15cae5c571] 2124 ? Ss 0:00 sendmail: accepting connections
    2132 ? Ss 0:00 sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue
    10107 pts/1 R+ 0:00 grep send[/code:1:15cae5c571]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.