Vraag & Antwoord

OS Linux

Mail geweigerd door? Server? Modem? Router?

Anoniem
MrLeeJohn
40 antwoorden
  • Ik heb net de helpdesk gebeld van Zonnet en er staan geen poorten geblokkeerd volgens de medewerker. De standaardpoorten als 25, 80 en 21 staan bij elk Zonnet-product open.
    Dan zou het probleem dus bij de modem, router of server liggen. Vanmiddag heb ik de (gratis) usb-modem er bijgepakt en geïnstalleerd onder een Win98 zonder firewall. De modem en router heb ik er tijdelijk uitgetrokken. Alle poorten zouden dus open moeten staan. Mooi dus niet! Nog steeds werd 25 geblockt.

    Echt een heel vaag probleem begint het nu te worden!
  • Op het modem moet je forwarden naar ipadres op je router. En op je router moet je weer forwarden naar je server. Net als een keten.
  • Win98 en portforwarding? dacht het niet nee… dat gaat alvast niet werken….
  • Ja, dat heb ik dus ook gedaan. Van de modem geforward naar de router, van de router door naar de server (net als met de web- en ftp-server, die probleemloos werken).

    Win98 gebruik ik nu niet meer. Nu test ik met WinXP en Fedora, aangezien ik met Win98 dus geen vooruitgang merkte in het probleem.
  • Ik denk dat je eerst eens heel rustig stap voor stap je probleem moet gaan analyseren.

    Geen forwarding…. ping je ipadres. Forward modem naar router…. ping je ipadres. Forward dan ook van router naar modem…. ping je ipadres.

    Als dat goed gaat lukt het forwarden in principe. Dat moet je eerst doen. Post je resultaten maar hier van iedere stap.
  • Ik heb voor de mailserver precies hetzelfde gedaan als voor de web- en ftp-server. En die werken probleemloos. Dus wel erg raar dat de mail het niet doet.

    Hier zijn wat instellingen van mijn modem, misschien dat jullie daar iets uit kunnen opmaken?

    Enabled? VPI VCI Static IP Address Subnet Mask Gateway
    Yes 0 32 0.0.0.0 0.0.0.0 0.0.0.0

    IGMP: disabled
    PPP Configuration: niet
    NAT Configuration: NAPT
    DHCP Relay: Disabled
    IGMP Proxy: Disabled
    PPP reconnect on WAN access: Disabled
    PPP Half Bridge: Disabled
    RIP System Wide Configuration: Disabled

    Poorten 21, 80, 25, 110, 143 worden doorgestuurd naar de router (TCP en UDP)
  • Tja… als web en ftp wel werken, dan weet ik het zo op afstand ook niet. Sorry.
  • Ja, dat is juist het gekke. Het gaat om die ene service. Web en ftp doen wat ze moeten doen, maar de mail blijft ergens hangen.
  • Is het misschien een goed idee om mijn instellingen van sendmail te posten? Zou daat misschien een fout in zitten?
  • Tja…. zou kunnen… maar je kunt er lokaal via poort 25 wel op, maar van buitenaf niet. Zeg ik dat goed? Lijkt me geen sendmail-issue dan.
  • Ja, daar lijkt het inderdaad wel op. Ik denk dat Sendmail kijkt of het mailtje Internet op moet, of dat het direct kan worden afgeleverd. Als ik een mailtje stuur met Webmin van de ene gebruiker naar de andere, met als toevoegsel @yolknet.nl dan wordtie direct afgeleverd.

    Toch denk ik dat het probleem wel ergens op de server zit. Vannacht heb ik een theorietje bedacht. Poort 25 wordt zowel voor inkomend als uitgaand verkeer gebruikt? Zo ja, dan zou op de clients ook geen mail binnen moeten komen en dat is niet het geval.
    Verder staat er bij de Mail Failures:[quote:25d3c97c33]The original message was received at Tue, 11 Jan 2005 16:20:19 +0100 from smtp1.versatel.nl [62.58.50.88]

    —– Transcript of session follows —– <root@yolknet.nl>… Deferred: Connection refused by [b:25d3c97c33]yolk.yolknet.nl.[/b:25d3c97c33]
    [/quote:25d3c97c33]
    De systeemnaam weet hij toch niet als het bij de router of modem al fout gaat? Dus dan zou een bericht worden tegengehouden door de server.
    Of zit ik nu verkeerd te redeneren?
    In de DNS-instellingen heb ik yolk.yolknet.nl als tweede MX-record staan trouwens. De eerste is mx1.yolknet.nl
  • Aaah, dat lijkt inderdaad op een slechte configuratie , blijkbaar krijg je dus wel connecties van bepaalde hosts?
    En nee, poort 25 is de SMTP poort (verzenden van mail), clients halen mail op door POP3 op poort 110.
  • Ik heb screenshots van de verschillende instellingen gemaakt. Ze staan op www.yolknet.nl/computertotaal/
    Ik hoop dat jullie er een fout in zien. Het lijkt me tenminste dat de fout in de senmailconfiguratie zit, want een firewall gebruik ik (nog) niet.
  • En ik heb er ook de M4 configuratie neergezet. Verder heb ik dus niks ingesteld staan.
    Ik hoop dat iemand er wat mee kan
  • Klopt dat port=smtp, addr=127.0.0.1 ?

    Klopt dat ip-adres zo?
  • Dat is het loopback-adres van de machine toch? Wat voor ander adres zou er dan moeten staan? Met deze instellingen kan ik mailen naar buiten en heen en weer mailen tussen gebruikers op de server
  • smtp port options gewoon weghalen, en op "DEFAULT" zetten.
  • :D
    Jullie zijn mijn helden! Ik had 127.0.0.1 al eens veranderd in het externe en daarna in het internet IP-adres, maar dat werkte niet op een of andere manier. Nu ik het heb veranderd in [code:1:b329f0da14]DAEMON_OPTIONS(`Default')dnl[/code:1:b329f0da14] werkt eindelijk de mailserver. Ik was de hoop al een beetje aan het verliezen dat het ooit nog ging werken.

    MrLeeJohn en Tekkie, reuze bedankt voor jullie tips en aanwijzingen!
  • Ja zo kun je lang zoeken… :roll:

    Blij dat het uiteindlijk allemaal werkt, en we toch fout zaten door direct de router de schuld te geven… :-?
  • Ja, inderdaad. En letterlijk naar de foutmelding kijken he: refused bij yolk.yolknet.nl

    Ik vond het al zo raar dat een mailserver andere instellingen nodig heeft dan web- en ftp-servers. Maar ben blij dat het allemaal nu is opgelost.
    Nogmaals duizendmaal dank voor jullie tijd en tips e.d.!

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.