Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[Ubuntu]HP 3400C scanner

Wim Sturkenboom
6 antwoorden
  • Ik probeer mijn HP 3400C scanner (via USB) aan de gang te krijgen onder Ubuntu.

    Van sourceforge de sane-code gedownload voor deze scanner maar wil niet compileren. Dit kan liggen aan een verkeerde versie van libusb (0.1.5 vereist).

    In Synaptic wordt onder de package-naam versie 0.1.4 weergegeven, met daarbij onder de geinstalleerde versie en de laatste versie 1:0.1.8-11. Onder de properties van de package wordt ook gerefereerd naar directories met 0.1.4.
    De vraag is welke versie er nu geinstalleerd is.

    Het compileren gaat fout op een (systeem-)include-file, die inderdaad niet op de juiste plek staat. Deze bevat echter ook niet de prototypes van functies die in de source-code worden gebruikt.

    Als ik moet upgraden naar versie 0.1.5, hoe doe ik dat?
    1)
    Huidige package verwijderen? Lijkt niet zo'n goed idee omdat er wel het een-en-ander van afhangt (bv ubuntu-desktop).
    2)
    Alle files verwijderen en vervangen met nieuwe versie (die eerst gecompileerd moet worden).
    3)
    Nieuwe versie na compilatie over de oude files heengooien?
    4)
    Nieuwe versie na compilatie in een neiuwe directory gooien

    Als ik moet downgraden naar versie 0.1.5, wat zijn dan de implicaties?

    PS Mijn Ubuntu computers hangen niet aan het internet om diverse redenen, dus moet ik downloaden via andere machines en vervolgens 'kopieren'.
  • Behalve dat het ubuntu package systeem "confused" raakt en je scanner gaat werken is er niets aan de hand.

    Heb trouwens gisteravond toevallig ubuntu ook geinstalleerd op mijn laptop, en was, op zijn minst, niet onder de indruk. Ga het dan ook weer zsm verwijderen. Ik stel voor dat je dat ook doet.
  • Als ik moet upgraden naar versie 0.1.5, hoe doe ik dat?
    1)
    Huidige package verwijderen? Lijkt niet zo'n goed idee omdat er wel het een-en-ander van afhangt (bv ubuntu-desktop).
    is de desktop afhankelijk van lib-usb?
    Vreemd..
    Maar verwijderen zou alleen betekenen dat je Ubuntu package system niet meer klopt.


    2)
    Alle files verwijderen en vervangen met nieuwe versie (die eerst gecompileerd moet worden).
    3)
    Nieuwe versie na compilatie over de oude files heengooien?

    Beide komen op hetzelfde neer.


    4)
    Nieuwe versie na compilatie in een neiuwe directory gooien

    Kan ook, waarbij je uiteraard wel goed onderscheid moet maken tussen welk programma welke usb-bibliotheken gaat gebruiken.
    Als het om een upgrade gaat zijn bovenstaande opties makkelijker denk ik.

    Als ik moet downgraden naar versie 0.1.5, wat zijn dan de implicaties?

    Downgraden moet je nooit doen, omdat het systeem een nieuwere versie verwacht en de oudere versie mogelijk functionaliteit onbeert die Ubuntu nodig heeft.

    Kun je niet via APT een nieuwere versie van lib-usb installeren?
    Biedt Ubuntu zelf geen SANE aan?


    Max
  • [quote:29232c4102="maximilaan"]Kun je niet via APT een nieuwere versie van lib-usb installeren?
    Biedt Ubuntu zelf geen SANE aan?Max[/quote:29232c4102]Heb geen internet connectie op die machines, dus werkt APT volgens mij niet.
    SANE zit erin, maar geen support voor de nieuwere (nou ja) HP scanners.
    [quote:29232c4102="Tekkie"]
    Heb trouwens gisteravond toevallig ubuntu ook geinstalleerd op mijn laptop, en was, op zijn minst, niet onder de indruk.[/quote:29232c4102]Waarom niet?
  • [quote:f8723d94ab="Wim Sturkenboom"][quote:f8723d94ab="maximilaan"]Kun je niet via APT een nieuwere versie van lib-usb installeren?
    Biedt Ubuntu zelf geen SANE aan?Max[/quote:f8723d94ab]Heb geen internet connectie op die machines, dus werkt APT volgens mij niet.
    SANE zit erin, maar geen support voor de nieuwere (nou ja) HP scanners.
    [/quote:f8723d94ab]
    Ok, maar dan zou je vanaf een andere pc de benodigde bestanden van een APT-server af kunnen halen.

    Max
  • Waarom niet?

    * Geen keuze in desktop bij installatie. Gnome is traaag op mijn 64MB RAM laptop. Zelfs KDE had beter geweest.
    * Desktop achtergrondje is een plaatje dat de helft van die 64Mb al wegvrat in zijn eentje, direct moeten verwijderen.
    * Kwam met alle tools die ik niet nodig had, en zonder de tools die ik wel nodig had.
    * Moest als eerste de /etc/ directory induiken om zaken goed te zetten, de defaults waren niet wat ik gewend ben.
    * hdparm niet geactiveerd.
    * Root wachtwoord reset moest ik gaan opzoeken op het internet. Sudo is mij te omslachtig. En na 5 jaar *NIX ervaring wens ik niet uit root gelockt te worden.
    * Weinig keuze aan software paketten, de geinstalleerde paketten waren vrijwel niet te verwijderen zonder hun package systeem te confusen.
    * Kan openoffice dat de halve hdd wegvreet niet verwijderen zonder tegen errors van hun package systeem aan te lopen. Heb openoffice ook niet in het startmenu zien staan, maar misschien niet goed gekeken.

    Nee gaat er vanavond weer af.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.