Vraag & Antwoord

OS Linux

ati drivers voor FC3. installeren gelukt

22 antwoorden
  • Hoi Ik heb kernel [code:1:f3bd3e6302]~]$ uname -r 2.6.9-1.681_FC3 [/code:1:f3bd3e6302] nu wil ik de ATI-driver installeren die gisteren is vrij gegeven: [url=http://www.ati.com/support/drivers/linux/radeon-linux.html?type=linux&prodType=graphic&prod=productsLINUXdriver&submit.x=13&submit.y=2&submit=GO%21]ati-drivers[/url] Ik was gewendt dat ik als kernel-source meestal zoiets als kernel-source-2.6.9-...rpm nodig had. Mijn vraag is of [code:1:f3bd3e6302]2.6.9-1.681_FC3.src.rpm [/code:1:f3bd3e6302] hetzelfde is? zie ook [url=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/SRPMS/] hier [/url] Dank
  • De kernel-source wordt inderdaad kernel-source-2.6.9-...rpm genoemd. Voor het installeren van de ati drivers in Fedora Core 3 is deze niet vereist. De kernel headers zouden voldoende moeten zijn. Ik heb hier zojuist deze nieuwe ati drivers in Fedora Core 3 geïnstalleerd. Ik heb hier eveneens geen kernel-source in FC3. Alleen bleek het configureren met fglrxconfig niet helemaal goed te gaan. De juiste keyboard driver werd niet geladen, waardoor X niet wilde starten. Uiteraard had ik eerst van de oude xorg.conf een backup gemaakt. Nadat ik de gegevens over de juiste keyboard driver via copy en paste van de backup naar de nieuwe xorg.conf had geplakt, kon X weer opstarten. Tuxracer doet het. Volgens glxinfo staat direct rendering op Yes. Alleen heb ik de indruk dat het aantal frames dat glxgears toont aan de lage kant is.
  • dank
  • Jolo, of iemand anders Hoe heb jij een backup terug kunnen zetten van xorg.conf ?? Evert
  • [quote:9d73e6c28f="windowsXP-PRO"]Hoe heb jij een backup terug kunnen zetten van xorg.conf ?? [/quote:9d73e6c28f] Had je dan een backup gemaakt van de originele xorg.conf voordat je de fglrx drivers compileerde/installeerde? In dat geval zou je 'm eroverheen kunnen kopiëren. Ik noemde mijn backup xorg.conf.radeon [code:1:9d73e6c28f] cp /etc/X11/xorg.conf.radeon /etc/X11/xorg.conf [/code:1:9d73e6c28f][Enter] Maar hoe is bij jouw dan het compileren/installeren van de fglrx drivers verlopen?
  • Jolo, dat is het juist. Ik ben er (nog) niet aan begonnen. Ik vindt het eerlijk gezegd beangstigend. Installeren van een RPM kan ik wel. Echter, als ik vragen moet beantwoorden, ik neem aan dat ik dat moet, dan klap ik dicht., zeker als ik het risico loop dat X niet meer start :oops: :oops: vandaar deze vraag
  • [quote:692c9bc5c8="windowsXP-PRO"] zeker als ik het risico loop dat X niet meer start [/quote:692c9bc5c8] In dat geval [code:1:692c9bc5c8] cp /etc/X11/xorg.conf /etc/X11/xorg.conf.radeon [/code:1:692c9bc5c8][Enter] Eventueel zou je die xorg.conf kunnen printen. Als je voor installatie type Workstation (Werkstation) dan zou je deze fglrx drivers moeten kunnen installeren. Het beste is dan na het maken van die backup van die xorg.conf om Fedora Core 3 op te starten in tekst modus. Dus X niet actief. Dan kunnen de fglrx drivers worden geïnstalleerd volgens de [url=http://www.ati.com/support/infobase/linuxhowto-ati.html]instructies van de ATI site. [/url] Het moeilijkste gedeelte is waarschijnlijk de configuratie met fglrxconfig. Als je de specificaties van je monitor bij de hand hebt, kan er eigenlijk weinig mis gaan. Een andere mogelijkheid om de oude radeon drivers terug te zetten, is door Fedora Core 3 op te starten in tekst modus en inloggen als root of superuser, en te typen [code:1:692c9bc5c8] system-config-display [/code:1:692c9bc5c8][Enter]
  • hoi gebasseerd op : http://www.fedoraforum.org/forum/showthread.php?p=193356#post193356 kom ik tot de ontdekking dat Livna ook ATI-drivers levert. Stomme vraag misschien, maar als ik ze installeer, ben ik dan klaar, of dien ik alsnog allerlei stappen uit te voeren? Evert
  • [quote:39111e4c1c="windowsXP-PRO"]dat Livna ook ATI-drivers levert. (..) maar als ik ze installeer, ben ik dan klaar, of dien ik alsnog allerlei stappen uit te voeren? [/quote:39111e4c1c] Volgens [url=http://www.fedoraforum.org/forum/showthread.php?p=158775#post158775]deze discussie[/url] zou je niet veel hoeven te configureren. Maar dat wil niet zeggen dat deze dan geconfigureerd zijn, zoals jij dat wenst. Controleer nadat de ATI Livna zijn geïnstalleerd, op zijn minst de Section "Monitor" in je /etc/X11/xorg.conf
  • dank.. Hier kan ik wat mee Evert
  • ok Jolo Dit is gelukt. Na installeren :[code:1:8363b62d0d]]$ uname -r 2.6.10-1.741_FC3 [/code:1:8363b62d0d] en bijbehorende ati-drivers heb ik gere-boot. Alles werkt nog naar behoren. Echter, wat bedoel je met: [code:1:8363b62d0d]op zijn minst de Section "Monitor" in je /etc/X11/xorg.conf[/code:1:8363b62d0d] ik heb ook xorg.conf ge-backuped. Opstarten van tuxracer levert een zwart beeld aan de linkerkant Ik heb ook de titel een beetje aangepast. ik heb een benq v772 monitor: [code:1:8363b62d0d]Product Line BenQ Value Model V772 Manufacturer BenQ General: Dimensions (WxDxH) 16 in x 16.2 in x 16.6 in Weight 33.7 lbs Color White Power Device Type Display / CRT Diagonal Screen Size 17" Image Max Resolution 1280 x 1024 / 67 Hz Dot Pitch 0.23 mm[/code:1:8363b62d0d]
  • [quote:4700cb6dda="windowsXP-PRO"]Echter, wat bedoel je met: [code:1:4700cb6dda] op zijn minst de Section "Monitor" in je /etc/X11/xorg.conf [/code:1:4700cb6dda][/quote:4700cb6dda] Voornamelijk of er bij de HorizSync en de VertRefresh wel de juiste waarden staan vermeld, en dus niet hoger zijn dan de specificaties van je monitor. Heb je de snelheid van de drivers al getest met [code:1:4700cb6dda] glxgears [/code:1:4700cb6dda][Enter] [quote:4700cb6dda="windowsXP-PRO"] Opstarten van tuxracer levert een zwart beeld aan de linkerkant [/quote:4700cb6dda] Alleen tuxracer of ook de KDE/Gnome desktop? Als die zwarte rand niet al te groot is, zou die nog wel bijgesteld kunnen worden met de knopjes op de monitor.
  • [code:1:f768e6a29f]]$ glxgears 1658 frames in 5.0 seconds = 331.600 FPS 3688 frames in 5.0 seconds = 737.600 FPS 5059 frames in 5.0 seconds = 1011.800 FPS 3728 frames in 5.0 seconds = 745.600 FPS 4456 frames in 5.0 seconds = 891.200 FPS 5230 frames in 5.0 seconds = 1046.000 FPS 5283 frames in 5.0 seconds = 1056.600 FPS 5353 frames in 5.0 seconds = 1070.600 FPS 4590 frames in 5.0 seconds = 918.000 FPS 5361 frames in 5.0 seconds = 1072.200 FPS 5422 frames in 5.0 seconds = 1084.400 FPS 5300 frames in 5.0 seconds = 1060.000 FPS 5358 frames in 5.0 seconds = 1071.600 FPS 5388 frames in 5.0 seconds = 1077.600 FPS 4435 frames in 5.0 seconds = 887.000 FPS 5366 frames in 5.0 seconds = 1073.200 FPS 5282 frames in 5.0 seconds = 1056.400 FPS 5072 frames in 5.0 seconds = 1014.400 FPS [/code:1:f768e6a29f] ik heb tuxracer opgestart in KDE ik heb een paar mpeg filmpjes. Die haperen tijdens afspelen
  • heb ik die zwarte balk ook als ik ut2004 installeer en speel?
  • [quote:0b2ac60e38="windowsXP-PRO"] 5072 frames in 5.0 seconds = 1014.400 FPS [/quote:0b2ac60e38] Was dat wel de score met het venster, van die grafische raderen die je ziet draaien actief? Want zelf had ik de indruk dat als je de Konsole, waaruit je glxgears had gestart actief maakt, dat de score dan lager wordt. [quote:0b2ac60e38="windowsXP-PRO"] heb ik die zwarte balk ook als ik ut2004 installeer en speel?[/quote:0b2ac60e38] Dat lijkt me wel. Als het goed is, wordt tuxracer in volledig scherm gedraaid. Dat wil zeggen de zelfde grootte als de KDE desktop. Maar was/is die zwarte balk bij jou dan zo breed, dat het niet weg te regelen is met de knopjes van de monitor? Met de geïnstalleerde fglrx drivers van ATI zelf, had ik bij mij slechts een smalle zwarte balk die ik met de knopjes van de monitor kon wegregelen. Omdat je een backup had gemaakt van je xorg.conf voordat je de ATI livna drivers had geïnstalleerd, kun je deze nog vergelijken met je gewijzigde xorg.conf. Controleer dan behalve die Section "Monitor" ook nog Section "Modes" en Section "Screen"
  • jolo het scherm met de radaren was actief De zwarte balk is ongeveer 5cm breed als tuxracer is gestart evert
  • vergeet alles maar Die drivers zijn k.....e :evil: alles liep vast Dan maar geen ut2004
  • [quote:834c394421="windowsXP-PRO"]alles liep vast Dan maar geen ut2004[/quote:834c394421] Wanneer liep alles vast? Toen je ut2004 startte, of nadat je een nieuw profiel maakte, tijdens Loading? ut2004 heb ik hier niet. Maar wel ut2003. Ik heb deze geïnstalleerd in Fedora Core 3. Bij mij werkt deze in combinatie met de fglrx drivers van de ATI site. Alleen als ik de Tutorial laat draaien, en verder het toetsenbord en de muis niet aanraak, dan wordt het beeld door de scherm beveiliging zwart. Het ut2003 beeld kan ik dan niet meer terug krijgen door op de muis te klikken, of het toetsenbord. X of ut2003 zijn dan niet vast gelopen. Alleen moet X dan wel weer opnieuw gestart worden via [Ctrl] [Alt] [Backspace] Ook als ik tuxracer wil starten nadat ik ut2003 heb afgesloten, moet X herstart worden. Een ding moet ik toch nog even recht zetten. Dat tuxracer en dus ook ut2003 kan toch groter zijn dan de Gnome desktop. Bij mij kwam ut2003 zelfs iets aan de linkerkant naast het beeld. Ik heb ook dit kunnen bijstellen met de knopjes van de monitor. Tuxracer is dan nog steeds volledig scherm. Alleen de Gnome desktop wordt dan iets kleiner. Die 17 inch monitor die ik heb kan namelijk meerdere configuraties onthouden. Dit is bij de glxgears score in Fedore Core 3 met de ATI drivers op een Pentium 266 Mhz 128 MB RAM met een Radeon 9000. [code:1:834c394421] jolo@Vigor13 ~]$ glxgears 6570 frames in 5.0 seconds = 1314.000 FPS 6481 frames in 5.0 seconds = 1296.200 FPS 6571 frames in 5.0 seconds = 1314.200 FPS 6571 frames in 5.0 seconds = 1314.200 FPS 6558 frames in 5.0 seconds = 1311.600 FPS 6576 frames in 5.0 seconds = 1315.200 FPS 6596 frames in 5.0 seconds = 1319.200 FPS 6540 frames in 5.0 seconds = 1308.000 FPS 6592 frames in 5.0 seconds = 1318.400 FPS 6589 frames in 5.0 seconds = 1317.800 FPS 6593 frames in 5.0 seconds = 1318.600 FPS 6589 frames in 5.0 seconds = 1317.800 FPS 6585 frames in 5.0 seconds = 1317.000 FPS [jolo@Vigor13 ~]$[/code:1:834c394421]
  • [quote:f499bbfea4="jolo"]Wanneer liep alles vast? Toen je ut2004 startte, of nadat je een nieuw profiel maakte, tijdens Loading? ut2004 heb ik hier niet. Maar wel ut2003. [/quote:f499bbfea4] Nee, UT2004 heb ik nog niet eens geinstalleerdt. Ik was gewoon een filmpje aan het kijken met mplayer. En ineens.....BOEM,, alles bevroren Ik merkte nadat ik de driver had geinstalleerdt en gere-boot had, al allerlei vertragingen op. evolution werdt traag, kde-menu openen ook. De drivers zijn eraf gesmeten. Dank
  • :D gelukt. Ik heb de drivers van ATI zelf geinstalleerdt. Ik had alleen problemen met de monitor. Super grootte iconen ed, na rebooten Questie van de nieuwe xorg.conf vergelijken met de backup, en evetueel copy /paste doen bij de sectie monitor [code:1:5a21efb525]~]$ fglrxinfo display: :0.0 screen: 0 OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: RADEON 9200 DDR Generic OpenGL version string: 1.3.4893 (X4.3.0-8.10.19)[/code:1:5a21efb525] 8) echter, bij afspelen tuxracer heb ik rechts nog steeds een zwarte balk van 5 cm. Het bureablad heeft dit niet Is hier een pijnloze oplossing voor? Evert

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.