Vraag & Antwoord

OS Linux

Kernel 2.6.11 & nvidia 1.0-6629 werken niet met agpgart

3 antwoorden
  • Ik heb de nieuwe Kernel 2.6.11 die twee dagen geleden werd uitgebracht, gecompileerd en geïnstalleerd. Eerst in Slackware 10.1 dan in Debian Sarge. Ik gebruikte daarvoor dezelfde .config bestand, als in kernel 2.6.10. Dat compileren en installeren ging goed. Alleen wilde daarna de nvidia drivers (1.0-6629) niet installeren. Het gaat om de foutmelding in [url=http://www.nvnews.net/vbulletin/showthread.php?t=44469]deze[/url] en [url=http://www.gentooforum.de/thread.php?threadid=4705]deze discussie[/url] Het uitschakelen van AGP in de kernel options bleek te werken. De agpgart module was toch bedoelt om een agp videokaart optimaal te laten werken. Ik heb nog even vergeleken Slackware 10.1 met kernel 2.6.10 met de agpgart module, waarbij ook nog de agp module van het moederbord chipset werd geladen, met kernel 2.6.11 zonder de agpgart module. In beide gevallen toonde glxgears (met de Konsole op de voorgrond) ongeveer 8400.000 FPS (16 bit kleuren), voor mijn agp Geforce 4400 Ti op mijn Athlon XP 1700+ met 512 MB RAM. Zou het niet werken van de agpgart module van kernel 2.6.11 in combinatie met nvidia drivers te maken hebben met het verschijnen van de nieuwere PCI-Express videokaarten?
  • De NVidia drivers hebben zelf een aansturing voor de GART ingebouwd voor de meeste chipsets, en die heeft de voorkeur boven de kernel-GART driver. Alleen als je grove problemen ondervind met de NVidia GART zou je de kernel GART moeten proberen. Je kunt zien welke GART implementatie word gebruikt in /proc/driver/nvidia/agp/status En je kunt de NVidia GART expliciet aan/uit zetten dmv de optie Option "NvAGP" in je X server configuratie. eea staat volgens mij ook in de documentatie bij de NVidia drivers uitgelegd.
  • [quote:2437e43ccd="Tekkie"]De NVidia drivers hebben zelf een aansturing voor de GART ingebouwd voor de meeste chipsets, en die heeft de voorkeur boven de kernel-GART driver.[/quote:2437e43ccd] Maar het zal toch een reden hebben dat Linux distributies als SuSE en Mandrake standaard de agpgart module gebruiken. Ook Mandrake PowerPack Edition waarin al 3D drivers (waaronder nvidia) zitten, gebruikt de agpgart module. [quote:2437e43ccd="Tekkie"] Je kunt zien welke GART implementatie word gebruikt in /proc/driver/nvidia/agp/status [/quote:2437e43ccd] Inderdaad. Kernel 2.6.10 [code:1:2437e43ccd] Status: Enabled Driver: AGPGART AGP Rate: 4x Fast Writes: Disabled SBA: Disabled [/code:1:2437e43ccd] Kernel 2.6.11 agp Disabled [code:1:2437e43ccd] Status: Enabled Driver: NVIDIA AGP Rate: 4x Fast Writes: Disabled SBA: Disabled [/code:1:2437e43ccd] [quote:2437e43ccd="Tekkie"]Alleen als je grove problemen ondervind met de NVidia GART zou je de kernel GART moeten proberen. [/quote:2437e43ccd] Zoiets als het probleem op http://www.nvnews.net/vbulletin/archive/index.php/t-106.html Of ik die heb weet ik niet. Ik heb er nog geen spellen op getest. [quote:2437e43ccd="Tekkie"] eea staat volgens mij ook in de documentatie bij de NVidia drivers uitgelegd.[/quote:2437e43ccd] Het belangrijkste staat er inderdaad. Behalve natuurlijk waarom de agpgart module van kernel 2.6.11 niet meer werkt in combinatie met de nvidia drivers. Wellicht werkt dat weer wel bij de volgende versie van de nvidia drivers.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.