Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[Ubuntu 5.0.4] Hoe krijg ik toegang tot m'n Windows-deel ?

maximilaan
8 antwoorden
  • Na installatie van Ubuntu-distro had ik nog geen toegang tot mijn Windows-partities.

    Volgens de faq van dit forum leek het alsof ik aan fstab de regel toevoeg :
    [code:1:2d0355e9b6]
    /dev/hda1 /windows/C vfat noauto,user,umask=000 0 2
    [/code:1:2d0355e9b6]

    Als ik dan in de bestandsverkenner kijk dan zie ik wel de drive, maar heb ik nog geen toegang tot mijn bestanden.

    Ik merkte dat ik nog twee stappen nodig had :
    - een directory aanmaken met de naam '/windows/C' zoals in fstab-regel
    - aanroepen van 'mount' commando in een root-terminal

    Het lijkt er op dat alles min of meer toevallig 'goed' ging, aangezien na een reboot alle links zijn behouden.
    Klopt dit ?
    Het lijkt mij nogal 'vreemd' dat ik een directory heb aangemaakt die nu als 'link' naar de drive in kwestie dient. Voor mijn gevoel heb ik nu een onbereikbare directory met de naam '/windows/C' …

    btw :
    Ubuntu zelf bevalt mij uitstekend. :)
    Installatie was een eitje. Alleen de muis leek in eerste instantie niet te werken, maar na het uitschakelen van 'legacy'-usb-ondersteuning voor het toetsenbord in het bios ging het goed.
    't is wel nog wennen dat sommige dingen niet automatisch gaan zoals dat bij Windows altijd het geval was.
  • Hier staat het antwoord op je vraag en nog veel meer:

    http://ubuntuguide.org/
  • lol … ja die had ik ondertussen ook gevonden.
    Had ik het toch voor een aardig deel goed gedaan :)

    Verklaart overigens nog steeds niet of dat 'mkdir'-commando van mij zo'n goed idee was.
    Gebeurt dat soms automagisch als ik 'mount -a' doe zoals in die uitleg ?

    // – edit –
    do'h … moet zelf eens beter lezen. Het staat zo ook in die link.
  • [quote:cf9ec669e4]Het lijkt mij nogal 'vreemd' dat ik een directory heb aangemaakt die nu als 'link' naar de drive in kwestie dient. Voor mijn gevoel heb ik nu een onbereikbare directory met de naam '/windows/C' …
    [/quote:cf9ec669e4]

    Linux werkt niet met driveletters, zoals Windows doet, maar met mountpoints.
    Een mountpoint is een gewone map (in principe een lege map, maar dat hoeft niet) waaraan de Linux-kernel de device koppelt.
    Vanuit jouw situatie bekeken, als Windows niet gemount is, dan is de map /windows/c gewoon een lege map op je linux-systeem.
    Je kunt er ook bestanden naar toe schrijven.
    Op het moment dat je de windows-partitie mount is de map het beginpunt van de Windows-partitie geworden.


    Max
  • Voor linux is het idd 'logisch', want zo zijn hda1 & andere drives ook in het bestandsysteem opgenomen.
    Het lijkt alleen raar als je het niet gewend bent om zo over die directories te denken.
  • [quote:2fc4fc2eff="JaFO"]Voor linux is het idd 'logisch'[/quote:2fc4fc2eff]

    Het is ook logischer ;) En het mooie is je kunt bij Linux een directory binnen een directory aan een ander device koppelen :D Probeer dat maar eens met windows ;) Bijvoorbeeld zoiets:

    [code:1:2fc4fc2eff]
    /dev/hda6 /var
    /dev/hda7 /var/log
    /dev/hda8 /var/tmp
    [/code:1:2fc4fc2eff]
  • [code:1:65aec2cce9]/dev/hda1 /windows/C vfat noauto,user,umask=000 0 2 [/code:1:65aec2cce9]
    Als je noauto veranderd in auto, dan wordt je windows partitie bij het opstarten automatisch gemount in de map /windows/C en is het niet meer nodig om het met de hand te doen.
  • Schijnbaar is dat bij Ubuntu niet nodig, want na een reboot had ik de links nog steeds dacht ik. Ik heb ondertussen echter Ubuntu opnieuw geinstalleerd (had een beetje een erg zooitje gemaakt toen ik mp3-support dacht te installeren) en toen de ubuntu-faq gevolgd en dus geen 'noauto' gebruikt.

    Rare is wel dat ik die allereerste keer ook extra 'harddisks' bij 'Mijn computer'-scherm had staan, terwijl ik dat nu niet heb. Nu heb ik alleen maar 'bestandsysteem'. Schijnbaar heeft het te maken met waar ik '\windows\C' plaats in relatie tot user en/of root.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.