Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[SUSE 9.0] SAX2 werkt niet meer

None
18 antwoorden
  • Hoi,

    bij het opstarten van SAX2 via de terminal krijg ik de volgende melding:
    [code:1:c3edfdffb7]SaX: initializing please wait…
    Storable object version 2.08 does not match $Storable::VERSION 2.13 at /usr/lib/perl5/5.8.1/i586-linux-thread-multi/DynaLoader.pm line 249.
    Compilation failed in require at /usr/X11R6/lib/sax/init.pl line 16.
    BEGIN failed–compilation aborted at /usr/X11R6/lib/sax/init.pl line 16.
    [/code:1:c3edfdffb7]

    Voorheen had ik dit niet, maar mogelijk komt dit omdat ik een update heb uitgevoerd? Als ik het programma vanuit het menu selecteer, krijg ik geen foutmelding, maar start SAX gewoon niet op. Hoe moet ik dit oplossen?
  • http://www.google.nl/search?hl=nl&q=Storable+object+version+does+not+match+%24Storable&meta=

    Ik denk dat je de upgrade het beste kunt gaan terug draaien. Of je linux-distro upgraden naar een nieuwere versie als dat mogelijk is.
  • Terugdraaien kan denk ik niet, aangezien ik niet weet hoe lang die error er als is. Heb sax al een hele tijd niet meer opgestart, terwijl ik wel geupdate heb. Upgraden zou wel beter zijn in dat geval, maar naar de SuSe Professional 9.3 (al weer geloof ik) upgraden kost 45 euro, of je moet het downloaden maar daar heb ik minder goede ervaringen mee.

    Maar de eerste hit op Google biedt misschien wel een uitkomst. Ik zal dat eerst eens proberen alvorens tot aanschaf van een upgrade pakket over te gaan! In ieder geval bedankt :wink:
  • Yep… hier http://forums.dixiesys.com/index.php?showtopic=5477 lijkt het antwoord te staan he….
  • Sorry voor het omhoog schoppen van het topic. :oops:

    Het probleem bestaat nog altijd, ondanks talloze pogingen het probleem te verhelpen. De link in de post hiervoor is ook iets te ingewikkeld voor mij helaas :cry:

    Wil iemand mij op een simpele manier uitleggen wat te doen om sax2 weer te laten werken? Ik vermoed dat ik Perl moet updaten of in ieder geval aanpassen?

    Offtopic: Kan je trouwens direct van SuSe Professional versie 9.0 naar 10.0 updaten, of moet je dan eerst 9.1, 9.2 etc. downloaden en over 9.0 installeren? Blijven de instellingen dan behouden? Is de update ook te downloaden van internet (op de Novell site vind ik alleen de volledige versie van 10.0, geen update)?
  • [quote:23113adf65="psychonetics"]
    Wil iemand mij op een simpele manier uitleggen wat te doen om sax2 weer te laten werken? Ik vermoed dat ik Perl moet updaten of in ieder geval aanpassen?
    [/quote:23113adf65]
    Je bent op zich niet van Sax2 afhankelijk, probeer bijv. het programma [b:23113adf65]xorgconfg[/b:23113adf65] of [b:23113adf65]xorgcfg[/b:23113adf65] als je xorg als X-server hebt, en [b:23113adf65]XFree86Config[/b:23113adf65] (of iets andere naam, ik weet deze niet meer uit mijn hoofd) als je XFree86 als X-server hebt.

    [quote:23113adf65]
    Offtopic: Kan je trouwens direct van SuSe Professional versie 9.0 naar 10.0 updaten, of moet je dan eerst 9.1, 9.2 etc. downloaden en over 9.0 installeren? Blijven de instellingen dan behouden? Is de update ook te downloaden van internet (op de Novell site vind ik alleen de volledige versie van 10.0, geen update)?[/quote:23113adf65]
    Updateversies bestaan niet, bij windows niet, en ook bij linux niet :)

    SUSE updaten naar een hogere versie gaat vrij vaak mis.
    Je kunt daarom beter een nieuwe installatie doen.
    Of je instellingen behouden blijven hangt een beetje af van welke instellingen je bedoelt.

    persoonlijke instellingen worden opgeslagen in de map /home. Als je daar een backup van maakt en na de installatie terugzet, dan blijven je persoonlijke instellingen behouden.

    systeemwijde instellingen, zoals internetverbinding, windows-netwerk, printer/scanner/etc configuratie worden opgeslagen in de map /etc..

    Je kunt bijv. de instellingen voor je samba-netwerkje backuppen door /etc/smb op cd te branden en naderhand te gebruiken om het netwerk weer in te richten.

    Zaken als internet, hardware, randapparatuur etc. wordt over het algemeen tijdens de installatie geconfigureerd, dus daar heb je geen backup oid voor nodig.

    Bij een nieuwe installatie is het aan te raden om de map /home een eigen partitie te geven.
    Op die manier zorg je er voor dat je bij een volgende upgrade je geen zorgen hoeft te maken over je documenten/persoonlijke instellingen: je hoeft alleen tijdens de nieuwe installatie aan te geven welke partitie je als /home wilt gebruiken…

    Succes, Max
  • Zelf maar ik altijd een tar bestandje van de gehele etc directory - op die manier kun je behalve de samba settings, ook andere zaken terug halen, mocht je ze vergeten zijn. Uiteraard niet klakkeloos terug eroverheen tarren na nieuwe installatie…
  • [quote:441672a4ed="maximilaan"]
    OK, zal eerst eens uitzoeken wat ik als X-server heb dan :oops: Ik had SAX2 eigenlijk nodig om mijn bureaublad goed te krijgen op het beeldscherm (met oprekken en verschuiven etc.).
    [/quote:441672a4ed]
    Volgens mij kan dat ook met XVidTune. Kijk anders eens naar het programma guidance dat te vinden is op www.simonzone.com

    [quote:441672a4ed]
    Maar goed, blijft het feit dat Perl (denk ik) niet goed gecompileerd is of zo, en ik neem aan dat dat ook voor andere applicaties gevolgen kan hebben. Bovendien wil ik graag weten hoe die fout is ontstaan en hoe die eventueel op te lossen is :)
    [/quote:441672a4ed]
    Zoek perl eens op in de softwaremodule van yast, kijk onder tabblad [versies] (rechts onderin als je het perlpakket hebt aangeklikt), en kijk welke versie je hebt en wie die aanbiedt (als perl rood is gekleurd, dan heb je een versie die door de yast online update is aangeboden..)
    Je kunt perl downgraden naar de versie van de installatie-cd door die aan te klikken bij [versies], en dan het vinkje naast het perl-pakket aan te klikken zodat die verandert in een zwart-groene Z.
    Datzelfde geldt voor Sax, mocht de fout toch in sax zitten, en niet in perl.

    [quote:441672a4ed]
    [quote:441672a4ed="maximilaan"]
    Updateversies bestaan niet, bij windows niet, en ook bij linux niet :)
    [/quote:441672a4ed]
    Huh? Maar in de winkel heb ik wel eens zien liggen SuSe 9.0 Update (of Upgrade)? Is dat iets anders?)
    [/quote:441672a4ed]
    Da's gewoon de volledige versie, maar dan voor een vriendelijkere prijs :)
    En volgens mij zitten er geen of minder boeken bij de upgrade-versie.
    Met de komst van suse10 zijn de verschillende versies overigens afgeschaft, suse10 kent nog maar 1 winkelversie.


    [quote:441672a4ed]
    Nou, qua instellingen hoef ik niet zoveel te bewaren geloof ik. Ik vrees dat het meeste wat ik zelf ingesteld heb toch niet goed is :oops: 8) Ach, zo leer je het wel denk ik.
    Maar al mijn documenten, dvd's en mp3's staan op de Linux-partitie (ReiserFS) en ik kan die niet terugschrijven naar Windows (NTFS). En ik hoopte die met een upgrade te bewaren (zoals dat ook bij Windows gebeurt?). Met een volledig nieuwe install ben ik die dus kwijt.
    [/quote:441672a4ed]
    Bij een upgrade blijven die inderdaad behouden.
    Maar net als bij Windows is de kans aanwezig dat de upgrade mislukt en je met een kapotte installatie achterblijft..


    [quote:441672a4ed]
    Bovendien is er van SuSe 10 geen studentenversie en over het algemeen is een upgrade-versie (als die bestaat) toch goedkoper dan de volledige. En bij downloaden mis je weer producten die mogelijk inbreuk maken op auteursrecht.
    [/quote:441672a4ed]
    suse10 kost rond de 50 euro, terwijl de upgradeversie van 9.3 boven de 60 euro kostte.
    Dus zonder studentenversie/upgradeversie ben je toch nog met suse10 goedkoper uit :)
    Verder is het niet zo dat de downloadversie bepaalde software niet meelevert, de cd-iso's zijn exact hetzelfde als die van de winkelversie.
    (opensuse uitgezonderd)

    [quote:441672a4ed]
    En als student heb ik ik niet al te veel te besteden, dus een dvd-brander, nieuwe schijf of de volledige versie kopen zit er niet echt in :cry:
    [/quote:441672a4ed]
    Ik zou voor 30 euro een cd-brander kopen en suse10 downloaden :)
    Met die cd-brander kun je dan meteen je documenten backuppen ;)

    [quote:441672a4ed]
    Ik zal eens kijken wat er in /etc staat, maar ik kan me niet voorstellen dat daar instellingen instaan die ik zelf gewijzigd heb of die reuze belangrijk zijn. [/quote:441672a4ed]
    Als je geen handmatige aanpassingen hebt gedaan voor bepaalde serversoftware, smb-netwerken etc hoef je van /etc geen backup te maken denk ik..

    Rinse
  • Ikzelf heb altijd de gewoonte om data en homedirs op een aparte partitie te zetten, zodat je de systeem partitie gewoon kunt formatteren. Maar dat is een beetje mosterd na de maaltijd.
    En er zijn genoeg Linux distributies die geen geld kosten waaruit je kunt kiezen, je MOET niet SuSE installeren, het is een KEUZE - en een dure ook nog.
  • [quote:9646945d28="Tekkie"]Ikzelf heb altijd de gewoonte om data en homedirs op een aparte partitie te zetten, zodat je de systeem partitie gewoon kunt formatteren. Maar dat is een beetje mosterd na de maaltijd.
    En er zijn genoeg Linux distributies die geen geld kosten waaruit je kunt kiezen, je MOET niet SuSE installeren, het is een KEUZE - en een dure ook nog.[/quote:9646945d28]
    De volgende keer dat ik Linux installeer, zal ik ook zeker een aparte partitie aanmaken. Liefst eentje die ook nog toegankelijk is vanuit Windows, maar dat zie ik dan wel weer.

    Ik had voor SuSe gekozen omdat ik gehoord had dat die wel makkelijk was in gebruik. Toen ik een keertje een studentenversie voor de helft van de gewone prijs zag liggen dacht ik 'mooi, neem ik mee'. Zodoende draai ik nu SuSe.
    Ik wil ook graag een keertje Red Hat of Debian uitproberen, maar zelf heb ik geen bijzonder snelle verbinding. Bovendien heb ik wel eens problemen gehad met zelf branden van ISO's (dat schijnt nu met Nero makkelijker te gaan) en had ik graag wat documentatie bij mijn distributie en ondersteuning van SuSe zelf.

    En dat SuSe duur is…zelf heb ik altijd Windows gebruikt, dus dan valt het wel mee. Zeker omdat je 2 boeken erbij kreeg, 5 cd's en een dvd en een hele mooie doos. :)
  • [quote:b27f354877="Tekkie"]
    En er zijn genoeg Linux distributies die geen geld kosten waaruit je kunt kiezen, je MOET niet SuSE installeren, het is een KEUZE - en een dure ook nog.[/quote:b27f354877]

    Hmm, dat verbaast me…

    SUSE kost in de winkel iets van 50 euro, en als je dat er niet voor over hebt, dan kun je de 5 iso-cd's gewoon downloaden…

    Dus wat is er duur aan SUSE?

    Max
  • Oeps, weer verkeerde knoppie :(

    [quote:b66620211c="psychonetics"][quote:b66620211c="maximilaan"]
    OK, zal eerst eens uitzoeken wat ik als X-server heb dan :oops: Ik had SAX2 eigenlijk nodig om mijn bureaublad goed te krijgen op het beeldscherm (met oprekken en verschuiven etc.).
    [/quote:b66620211c]
    Volgens mij kan dat ook met XVidTune. Kijk anders eens naar het programma guidance dat te vinden is op www.simonzone.com

    [quote:b66620211c]
    Maar goed, blijft het feit dat Perl (denk ik) niet goed gecompileerd is of zo, en ik neem aan dat dat ook voor andere applicaties gevolgen kan hebben. Bovendien wil ik graag weten hoe die fout is ontstaan en hoe die eventueel op te lossen is :)
    [/quote:b66620211c]
    Zoek perl eens op in de softwaremodule van yast, kijk onder tabblad [versies] (rechts onderin als je het perlpakket hebt aangeklikt), en kijk welke versie je hebt en wie die aanbiedt (als perl rood is gekleurd, dan heb je een versie die door de yast online update is aangeboden..)
    Je kunt perl downgraden naar de versie van de installatie-cd door die aan te klikken bij [versies], en dan het vinkje naast het perl-pakket aan te klikken zodat die verandert in een zwart-groene Z.
    Datzelfde geldt voor Sax, mocht de fout toch in sax zitten, en niet in perl.

    [quote:b66620211c]
    [quote:b66620211c="maximilaan"]
    Updateversies bestaan niet, bij windows niet, en ook bij linux niet :)
    [/quote:b66620211c]
    Huh? Maar in de winkel heb ik wel eens zien liggen SuSe 9.0 Update (of Upgrade)? Is dat iets anders?)
    [/quote:b66620211c]
    Da's gewoon de volledige versie, maar dan voor een vriendelijkere prijs :)
    En volgens mij zitten er geen of minder boeken bij de upgrade-versie.
    Met de komst van suse10 zijn de verschillende versies overigens afgeschaft, suse10 kent nog maar 1 winkelversie.


    [quote:b66620211c]
    Nou, qua instellingen hoef ik niet zoveel te bewaren geloof ik. Ik vrees dat het meeste wat ik zelf ingesteld heb toch niet goed is :oops: 8) Ach, zo leer je het wel denk ik.
    Maar al mijn documenten, dvd's en mp3's staan op de Linux-partitie (ReiserFS) en ik kan die niet terugschrijven naar Windows (NTFS). En ik hoopte die met een upgrade te bewaren (zoals dat ook bij Windows gebeurt?). Met een volledig nieuwe install ben ik die dus kwijt.
    [/quote:b66620211c]
    Bij een upgrade blijven die inderdaad behouden.
    Maar net als bij Windows is de kans aanwezig dat de upgrade mislukt en je met een kapotte installatie achterblijft..


    [quote:b66620211c]
    Bovendien is er van SuSe 10 geen studentenversie en over het algemeen is een upgrade-versie (als die bestaat) toch goedkoper dan de volledige. En bij downloaden mis je weer producten die mogelijk inbreuk maken op auteursrecht.
    [/quote:b66620211c]
    suse10 kost rond de 50 euro, terwijl de upgradeversie van 9.3 boven de 60 euro kostte.
    Dus zonder studentenversie/upgradeversie ben je toch nog met suse10 goedkoper uit :)
    Verder is het niet zo dat de downloadversie bepaalde software niet meelevert, de cd-iso's zijn exact hetzelfde als die van de winkelversie.
    (opensuse uitgezonderd)

    [quote:b66620211c]
    En als student heb ik ik niet al te veel te besteden, dus een dvd-brander, nieuwe schijf of de volledige versie kopen zit er niet echt in :cry:
    [/quote:b66620211c]
    Ik zou voor 30 euro een cd-brander kopen en suse10 downloaden :)
    Met die cd-brander kun je dan meteen je documenten backuppen ;)

    [quote:b66620211c]
    Ik zal eens kijken wat er in /etc staat, maar ik kan me niet voorstellen dat daar instellingen instaan die ik zelf gewijzigd heb of die reuze belangrijk zijn. [/quote:b66620211c]
    Als je geen handmatige aanpassingen hebt gedaan voor bepaalde serversoftware, smb-netwerken etc hoef je van /etc geen backup te maken denk ik..

    Rinse[/quote:b66620211c]
  • Het downgraden van Perl heeft het probleem opgelost. Ik kan weer in Sax2. 8)

    Geen idee waar het verder aan lag, maar ik ben dan ook geen gevorderde linux-gebruiker of programmeur :) Voorlopig houd ik deze versie van Perl maar aan, mochten andere programma's moeilijk gaan doen omdat Perl terug is gezet, dan kom ik wel weer terug hier ;)

    offtopic: wat is er aan de hand als een programma in yast een rode achtergrond heeft, in plaats van een rood lettertype?
  • [quote:efede3a92d]offtopic: wat is er aan de hand als een programma in yast een rode achtergrond heeft, in plaats van een rood lettertype?[/quote:efede3a92d]
    Geen idee, nooit meegemaakt nog :)
    Om welke software gaat het?
    Misschien betreft het software dat conflicten veroorzaakt met andere software?

    Rinse
  • Ow wacht, dat is exact hetzelfde, alleen staat het bij inst. vers., helemaal aan de rechterkant :oops:

    Dus eigenlijk is dat goed als 't rood is, want dan is het geupdate?
  • rode tekst geeft aan dat het geinstalleerde pakket niet voor komt op een van de installatiebronnen van yast.
    Dat is het geval als je een online update doet (die komt van een ftp-server, niet van je installatiedisks), en bij software die je zelf hebt gedownloadt en geinstalleerd (al dan niet met yast, doch altijd wel als rpm-bestand).
    Verder zullen pakketten rood worden als je een bepaalde installatiebron verwijderd.

    Rood geeft dus min of meer aan dat je de software echt kwijt bent als je het verwijderd.
  • Duidelijk, bedankt! 8)
  • Die programmanamen met een rode achtergrond zitten er bij mij ook een aantal tussen.
    Dit is ontstaan na de installatie van KDE 3.5.
    Het programma/versienummer van de geinstalleerde is dan hoger dan de beschikbatre versie.
    Alles werkt overigens perfect met KDE 3.5 voor zover ik tot zover heb ervaren.

    -hws-

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.