Vraag & Antwoord

OS Linux

Debian GNU/Linux 3.1 r0 Test

Anoniem
None
21 antwoorden
  • Ik heb de onlangs uitgebrachte Debian GNU/Linux 3.1 r0 geïnstalleerd. De installatie ging ongeveer als volgt. Ik startte PC1die Athlon XP 1700+ met 512 MB RAM op met Debian GNU/Linux 3.1 r0 DVD1. Om de 2.6.x kernel te installeren typte ik bij de boot: [code:1:c4013f9f43] linux26 [/code:1:c4013f9f43][Enter] daarna volgde Choose Language, Land/Regio kiezen, Toetsenbordindeling.

    Dan kon het netwerk worden geconfigureerd. Indien Debian twee netwerkkaarten detecteert, zoals in mijn PC1 het geval is, kan hier de Primair Netwerk apparaat worden geselecteerd. Ook kan er een Computernaam en een Domeinnaam worden opgegeven.

    Daarna volgde het indelen van de harde schijven. Ik had mijn 200 GB harde schijf al van te voren ingedeeld met Partitie-Expert. Dus ik hoefde hier alleen een partitie selecteren, die ik voor de root partitie wilde gebruiken, het bestandensysteem selecteren, en het aanhecht punt selecteren. Dan Klaar met instellen partities en Schijfindeling afsluiten & veranderingen naar schijf schrijven.

    Nadat dit nogmaals moet worden bevestigd, start de basis installatie. Als dat is voltooid kan de GRUB opstart loader worden geïnstalleerd. Ik heb 'm geïnstalleerd in MBR. Windows XP Home en alle Linux distributies die op deze harde schijf staan, werden door de Debian installer in de GRUB menu geplaatst.

    Nadat DVD1 uit de dvd-speler is verwijderd, moet de pc opnieuw worden opgestart. Daarna kan deze weer worden terug geplaatst. Dan start de Debian-basis systeem configuratie. Waarin de Tijdzone kan worden geconfigureerd. Dan root wachtwoord en ook nog een gewone gebruikers account met wachtwoord.

    Dan Configuratie APT, die je ook nog achteraf kunt configureren met commando [code:1:c4013f9f43] apt-setup [/code:1:c4013f9f43][Enter] Dan Software selectie. Dat kan handmatig. Maar het eenvoudigst is het gewoon Desktop omgeving te selecteren. Dan wordt zowel KDE 3.3.2 en Gnome 2.8.2 geïnstalleerd. Dan volgt xserver xfree86 configuratie: Muis en Beeldscherm en e-mail configuratie. Nadat de installatie voltooid was, bleek Gnome de default Desktop Environment te zijn.

    Omdat in PC1 een tv-kaart zit met een saa7134 chipset moest er achteraf nog wat wijzigingen worden aan gebracht in /etc/X11/XF86Config-4 zoals in Section "Module" een hekje voor: Load "dri" en toegevoegd : Load "v4l" in Section "Device" werd Driver "vesa" gewijzigd in "nv"

    Omdat dat tv-kaart minimaal kernel 2.6.10 nodig heeft, (anders werkt het tv-geluid niet) en Debian 3.1 kernel 2.6.8 heeft, heb ik de kernel-source 2.6.11.11van www.kernel.org gecompileerd en geïnstalleerd. Waarna ik voor mijn Geforce 4400 Ti nvidia drivers NVIDIA-Linux-x86-1.0-7664-pkg1.run kon installeren. En in /etc/X11/XF86Config-4 Section "Device" Driver "nv" kon worden gewijzigd in "nvidia"

    Voor de teletekst heb ik een gepatchte versie van alevt geïnstalleerd. De alevt RPM die ik in SuSE 9.2 had gemaakt met checkinstall, converteerde ik met alien in een debian package. Ik heb ook nog debian package numlockx geïnstalleerd, zodat in X NumLock aan staat.

    OpenOffice.org 1.1.3 was al geïnstalleerd. Maar omdat ik in SuSE 9.3 OpenOffice.org 2.0 Beta al gewent was, heb ik die ook in Debian geïnstalleerd. Samen met de Nederlandstalige spel-check.


    Met alevt bleek er nog wel een klein probleempje te zijn. Toen ik deze in een Terminal startte [code:1:c4013f9f43] alevt [/code:1:c4013f9f43][Enter] verscheen de foutmelding [code:1:c4013f9f43]
    alevt
    alevt: /dev/vbi: No such file or directory
    alevt: cannot open /dev/vbi [/code:1:c4013f9f43] /dev/vbi bestond niet. Ik kon dit weliswaar op lossen via commando [code:1:c4013f9f43] ln -s /dev/vbi0 /dev/vbi [/code:1:c4013f9f43] alevt werkte toen. Alleen bleek na een reboot die link te zijn verdwenen. Dus net zoiets wat ook het geval met in Slackware met de kernel 2.6.x in deze topic. De daarin geboden oplossing
    [code:1:c4013f9f43] chmod -x /etc/rc.d/rc.udev [/code:1:c4013f9f43] of omdat deze script in Debian op een andere plaats staat [code:1:c4013f9f43] chmod -x /etc/init.d/udev [/code:1:c4013f9f43] werkte wel. De link bleef nu wel staan na de reboot.

    Omdat ik na die wijziging geen toegang meer had tot mijn USB apparaten
    [code:1:c4013f9f43]

    jolo@linux:~$ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda15 / ext3 defaults,errors=remount-ro 0 1
    /dev/hda6 none swap sw 0 0
    /dev/hdb /media/cdrom0 iso9660 ro,user,noauto 0 0
    /dev/hdc /media/cdrom1 iso9660 ro,user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    /dev/sda /media/usb0 auto rw,user,noauto 0 0
    /dev/sdb /media/usb1 auto rw,user,noauto 0 0

    jolo@linux:~$ mount /media/usb0
    mount: I could not determine the filesystem type, and none was specified
    jolo@linux:~$ mount /media/usb1
    mount: I could not determine the filesystem type, and none was specified
    jolo@linux:~$[/code:1:c4013f9f43] heb ik die wijziging weer ongedaan gemaakt
    [code:1:c4013f9f43] chmod 755 /etc/init.d/udev [/code:1:c4013f9f43] Na de reboot werkte de USB apparaten weer.

    Het probleem met alevt heb ik op een andere manier opgelost. Door 'm te starten via Gnome menu via commando [code:1:c4013f9f43] alevt -vbi /dev/vbi0 [/code:1:c4013f9f43]
    Het doel van deze Test is om uiteindelijk dat ik in plaats van SuSE Linux, Debian GNU/Linux ga gebruiken als Hoofd distributie. Het is een hele omschakeling, Vooral omdat ik KDE gewent ben in plaats van Gnome. Gnome 2.8.2 in Debian heeft een icoon met de naam Computer, waarin onder andere de verwisselbare apparaten zijn te openen. Toen ik in /etc/fstab deze regel toegevoegde
    [code:1:c4013f9f43] /dev/hda1 /mnt/c ntfs ro,noauto,umask=0222,users 0 0[/code:1:c4013f9f43] verscheen ook deze als c in icoon Computer.

    Wellicht wordt Debian nog wel mijn favoriete distributie. Maar dat zal de tijd moeten leren. Overigens staat in deze review ook nog nuttige info over Debian 3.1.
  • Dank Jolo. Ik heb de indruk dat de gebruikte PC een MediaCenter functie heeft? Ik kan nl geen andere reden bedenken voor een TV kaart ;) Welke kaart gaat het om, ik zit er nl aan te denken mijn huidige PC om te gaan bouwen tot MediaCenter, uiteráárd op Debian ;)

    Groet, M.V. Wesstein
  • In PC1 heb ik een Pinnacle PCTV Stereo tv-kaart Ik gebruik 'm hoofdzakelijk voor de teletekst, en om eventueel te controleren of een bepaald tv-programma al is begonnen, zodat ik dan de 'grote' tv kan aanzetten. Om te gebruiken als MediaCenter functie, vind ik die tv-kaart niet geschikt.
  • Aha. Dank voor de waarschuwing, da's alvast 1 kaart minder om weg te strepen ;) Ik heb gisteren (meer: vanmorgen errug vroeg ;)) nog ff zitten zoeken op internet en de Hauppage PVR 350 lijkt me voor een Linux-based Mediacenter de meest bruikbare keuze op dit moment. Helaas is z'n grotere broer (PVR 500) met 2 TV tuners nog niet opgenomen in de ondersteuning van bv Mythtv, maar ik begrijp dat daar hard aan gewerkt wordt. Er is een "HowTo" lijst voor diverse distro's om Mythtv te installeren, met een beetje rondneuzen kom je al snel leerzame dingen tegen: kijk maar Ik vond ook een commerciele aanbieder van Open Source MediaCenter software http://plutohome.com/ welke een Debian Sarge based kickstart CD-iso aanbiedt. Iemand al geprobeerd wellicht?

    Groet, M.V. Wesstein
  • Wat die PVR-500MCE betreft, vond ik nog wel deze info.

    Ik ben intussen verder gegaan met deze Debian GNU/Linux 3.1 r0 Test. Het viel me wel op dat de lettertypes niet juist waren, als ik in Xawtv met de linker muis knop van kanaal wilde veranderen. Maar daar kon ik met Google niet direct een oplossing voor vinden.

    Als ik Debian als Hoofd distributie wil gaan gebruiken, zou ik er dus ook cd/dvd's moeten kunnen branden. In SuSE gebruikte ik K3b. Alleen ken ik geen goede Gnone brand programma's. Echter in Computer!Totaal mei 2005 las ik, dat er een Nero is voor Linux. Ik heb deze zonder problemen kunnen installeren. Alleen toen ik NeroLinux startte bleken de lettertypes te klein te zijn. Deze kon ik alleen lezen met een vergrootglas.

    De oplossing van dit probleem vond ik in een discussie op cdfreaks. Het antwoord van AgustinCordoba bleek ook hier te werken. Bovendien het bovengenoemde probleem met de niet juiste lettertypes van de kanalen in Xawtv, bleek daarmee ook opgelost te zijn.
  • Aha, die pagina over de PVR500 was ik nog niet tegengekomen. Dank :)

    Inmiddels is er een update fout gegaan, waardoor ik geen beeld meer had. Een nieuwe net-install bleek het probleem niet te verhelpen. Van die oude install weet ik nog dat ik k3b gewoon kon installeren middels apt, te bereiken via Debian > apps in het menu.

    Groet, M.V. Wesstein
  • [quote:18498ca9af]In SuSE gebruikte ik K3b. Alleen ken ik geen goede Gnone brand programma's.[/quote:18498ca9af]Probeer GnomeBaker eens.
  • [quote:91b244aa37="M.V. Wesstein"]Van die oude install weet ik nog dat ik k3b gewoon kon installeren middels apt, te bereiken via Debian > apps in het menu. [/quote:91b244aa37] De meeste KDE applicaties zullen ongetwijfeld werken in Gnome. Om aan Gnome te wennen, dacht ik dat het beter is om in plaats van KDE- vervangende applicaties te gebruiken.

    [quote:91b244aa37="7_feet_up"]Probeer GnomeBaker eens.[/quote:91b244aa37] Ziet er niet slecht uit. Maar gebruik voorlopig liever NeroLinux. Ik had onlangs de Windows versie Nero 6.6 Reloaded aangeschaft. Daarmee heb ik dus een licentie voor die NeroLinux.


    Nog even iets anders. Het lijkt erop dat mijn Gnome menu op PC1 in de war is geraakt. Sinds gisteren avond bleek deze te zijn gemixt met de KDE applicaties. Ik weet niet hoe dit gebeurd is, maar de KDE applicaties horen in ieder geval niet in het Gnome menu te staan.

    Bovendien de applicaties die ik zelf aan het Gnome menu had toegevoegd, Xawtv AleVT en OpenOffice.org 2.0 Beta, zijn daaruit verdwenen. Die applicaties zelf zijn niet verdwenen. Ze kunnen nog steeds gestart worden in een Terminal. En Xawtv staat nog wel in Toepassingen > Debian > Weergevers > xawtv.
  • Kijk Jolo, da's nou het mooie van OSS als Linux: je bent helemaal vrij om vertrouwde KDE applicaties onder Gnome te gebruiken ;) Je zit dus niet aan Gnome vast, in het Debianproject is ruimte genoeg om met KDE te werken, ook al zijn de ontwikkelaars overtuigde "Gnomies" :lol:

    Groet, M.V. Wesstein
  • Indrukwekkende bespreking Jolo, knap!
  • [quote:0a15ec3606="jolo"]
    Nog even iets anders. Het lijkt erop dat mijn Gnome menu op PC1 in de war is geraakt. Sinds gisteren avond bleek deze te zijn gemixt met de KDE applicaties. Ik weet niet hoe dit gebeurd is, maar de KDE applicaties horen in ieder geval niet in het Gnome menu te staan. [/quote:0a15ec3606]
    Dat klinkt raar als je bedenkt dat je hiervoor SuSE gebruikte.
    Immers, SUSE maakt geen onderscheid tav uit welke bron een programma komt, alles wordt samen in 1 menu samengevoegd.
    En zo hoort het ook ;)
  • SuSE Professional 9.3 gebruik ik ook nog wel, maar nu wel iets minder. Ik probeer van Debian 3.1 mijn hoofd-distributie te maken.

    Bij Debian zouden geen KDE applicaties in de Gnome menu moeten staan. Immers deze staan al in de Debian menu. Dat de KDE applicaties nu wel in de Gnome menu staan, zou te maken kunnen hebben met het installeren van een van de packages. Want Nautilus bleek te zijn verdwenen.

    Ik heb Nautilus wel weer opnieuw kunnen installeren. Echter applications:/// werkt niet meer. Want dan verschijnt de foutmelding
    [code:1:c6a36907ba]
    Kan lokatie niet weergeven

    "applications:///" is geen geldige locatie.

    Controleer de spelling en probeer opnieuw.
    [/code:1:c6a36907ba]
  • Ik geloof dat de mogelijkheid om het menu te bewerken met nautilus er vanaf gnome 2.10 uit is gesloopt. Er staat wel ergens een xml-bestandje in je home-directory (ik weet niet uit m'n hoofd waar, ik zit op m'n werk achter een windows computer) die je gewoon met een editor kunt bewerken.
  • Klopt, Gnome 2.10 gebruikt een nieuwe menuopmaak die nog geen editor kent.
    Er is overigens wel een editor te vinden (in python oid geschreven) die door iemand anders is geschreven.
    Kijk evt op de gnome-software site voor zo'n progje.

    Max
  • Hm, er was inderdaad via ap-get geupdated naar Gnome 2.10. Ik heb deze update weer ongedaan gemaakt. Niet door Gnome te downgraden naar versie 2.8.3. Want dat is "not done". Maar door Debian 3.1 opnieuw te installeren. Het menu editen in Gnome werkt weer.

    Omdat ik echter vandaag een hardware probleem heb vastgesteld op PC1. Op de pc waarop ik deze Debian Test doe dus. Zal ik dus eerst dat probleem proberen op te lossen. Als dat niet lukt zal ik deze test waarschijnlijk overhevelen naar PC2. Mijn Dual Pentium III 1000 Mhz met 512 MB RAM. In ieder geval bedankt voor de reacties tot nu toe.
  • [quote:2065320a4b="jolo"]Omdat ik echter vandaag een hardware probleem heb vastgesteld op PC1.[/quote:2065320a4b] Het hardware probleem lijkt inmiddels opgelost. De test kan verder gaan. Om te kunnen printen heb ik cups geinstalleerd. Ook heb ik de PPD drivers van mijn PSC 750xi printer gedownload, en deze geinstalleerd via [code:1:2065320a4b] gnome-cups-add [/code:1:2065320a4b][Enter] dat lijkt te zijn gelukt. Dat wil zeggen. Ik kon de juiste printer selecteren. Maar toen ik de test pagina wilde printen, gebeurde er niets. Als ik in OpenOffice.org een print opdracht geef, komt deze wel te staan in Print Jobs. Alleen staat er dan bij Status: pending. Er wordt dus niets afgedrukt.

    [Edit]

    Ik vergat de HPOJ- en HPIJS drivers te installeren. Ik heb deze alsnog geinstalleerd. En weer opnieuw [code:1:2065320a4b] gnome-cups-add [/code:1:2065320a4b][Enter] Als ik dan een test pagina wil pinten, werd er alleen onzin geprint. Gevolgd door het uitwerpen van lege vellen papier. Ik heb de print opdracht op de printer zelf, moeten annuleren.

    [/Edit]

    [Edit 2]

    Ik heb via http://localhost:631/printers/ de niet werkende printers verwijderd. En daarmee de printer opnieuw geinstalleerd. Dan wordt de test pagina wel goed afgedrukt.

    [/Edit 2]
  • uw eerste regel heeft mij nu al twee maal geholpen.
    nl.
    [code:1:05156b973e]linux26[/code:1:05156b973e]

    Op één systeem (AMD XP1700) wou hij zonder dit geen grub diskette schrijven voor het booten bij de install. (Allez hij wou wel, maar hij deed het niet correct)

    Op een ander systeem (PIV 3Ghz) wou hij men sata schijven niet zien.


    Thanx!!
  • [quote:649ddd89cc="maximilaan"]Klopt, Gnome 2.10 gebruikt een nieuwe menuopmaak die nog geen editor kent.
    Er is overigens wel een editor te vinden (in python oid geschreven) die door iemand anders is geschreven.
    Kijk evt op de gnome-software site voor zo'n progje.

    Max[/quote:649ddd89cc]

    'smeg' is een simpele gnome menu editor die ik in Ubuntu gebruik, die zal bij Debian ook wel in de repos staan denk ik
  • [quote:48fcc9aaac="abraracourcix"]uw eerste regel heeft mij nu al twee maal geholpen. nl. [code:1:48fcc9aaac] linux26 [/code:1:48fcc9aaac]Op één systeem (AMD XP1700) wou hij zonder dit geen grub diskette schrijven voor het booten bij de install. (Allez hij wou wel, maar hij deed het niet correct) [/quote:48fcc9aaac] Dus ongeveer net zo een systeem als waar ik Debian GNU/Linux 3.1 r0 op heb geïnstalleerd.
    [quote:48fcc9aaac="abraracourcix"] Op een ander systeem (PIV 3Ghz) wou hij men sata schijven niet zien. [/quote:48fcc9aaac] Goed om te weten dat Debian GNU/Linux 3.1 r0 met de kernel 2.6.8 op een sata hard schijf geïnstalleerd kan worden.

    [quote:48fcc9aaac="angkor"]'smeg' is een simpele gnome menu editor die ik in Ubuntu gebruik, die zal bij Debian ook wel in de repos staan denk ik[/quote:48fcc9aaac] De Ubuntu versie van smeg versie 0.7.5 kan bij mij niet geïnstalleerd worden. De python versie is te oud
    [code:1:48fcc9aaac]
    debian:/home/jolo# dpkg -i smeg.deb
    Selecteren van voorheen niet geselecteerd pakket smeg.
    (Database inlezen … 126467 bestanden en mappen geïnstalleerd.)
    Uitpakken van smeg (uit smeg.deb) …
    dpkg: vereistenproblemen verhinderen de configuratie van smeg:
    smeg is afhankelijk van python (>= 2.4); maar:
    Versie van python op het systeem is 2.3.5-2.
    smeg is afhankelijk van python2.4-gtk2 (>= 2.6); maar:
    Pakket python2.4-gtk2 is niet geïnstalleerd.
    smeg is afhankelijk van python2.4-libxml2 (>= 2.6.17); maar:
    Pakket python2.4-libxml2 is niet geïnstalleerd.
    smeg is afhankelijk van python-xdg (>= 0.14); maar:
    Pakket python-xdg is niet geïnstalleerd.
    smeg is afhankelijk van python2.4-glade2 (>= 2.6); maar:
    Pakket python2.4-glade2 is niet geïnstalleerd.
    dpkg: fout bij afhandelen van smeg (–install):
    vereistenproblemen - blijft ongeconfigureerd
    Fouten gevonden tijdens behandelen van:
    smeg
    debian:/home/jolo# [/code:1:48fcc9aaac] Aangezien ik python niet wil updaten, kan smeg niet worden geïnstalleerd. Ik gebuik daarom nog steeds de oude versie van Gnome 2.8.3.

    Maar toch bedankt voor het meedenken.
  • [quote:25aabafac3="jolo"]Aangezien ik python niet wil updaten, kan smeg niet worden geïnstalleerd.[/quote:25aabafac3]
    Aangezien het gebruikelijk is in Linux-land dat updates asap worden doorgevoerd zul je daar ongetwijfeld een héle goede reden voor hebben. Je maakt ons nieuwsgierig ;)

    Groet, M.V. Wesstein

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.