Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[gentoo] laptop krijgt geen ip van router

Anoniem
None
22 antwoorden
  • Ik heb een Linksys wireless-G router staan om zo mijn laptop en pc smaen op internet te krijgen. Maar helaas gaat het niet zoals het hoort. De laptop krijgt verbinding met de router, maar krijgt geen ip-adres toegewezen. De desktop-pc werkt goed.

    Heb ik een instelling op mijn laptop over het hoofd gezien? Met een gewone kabel doet de laptop het wel.
  • Draadloos krijg je geen ip op je laptop en met een utpkabel wel begrijp ik uit je post?

    Ik heb hetzelfde gehad met mijn laptop + Suse + draytek router.
    Via DHCP kreeg ik geen ip op mijn draadloze kaartje dat wel prima herkent werd verder. Toen ik een vast IP instelde werkte het draadloos prima.
    Het lijkt er dus op dat er ergens een verschil zit in het gebruik van dhcp tussen router en laptop….
  • [quote:ea0933f9ff="Sjoerd Boerhout"]Draadloos krijg je geen ip op je laptop en met een utpkabel wel begrijp ik uit je post?[/quote:ea0933f9ff]Dat heb je goed begrepen :wink:
  • Dhcp is nogal eens zwak bij wlan-routers. Probeer het eens met statische adressen. Werkt dat? Of heb je wpa aan terwijl de waln-card in je flappie alleen wel kan?
  • [quote:6db5d2b2b7="MrLeeJohn"]Dhcp is nogal eens zwak bij wlan-routers. Probeer het eens met statische adressen. Werkt dat? Of heb je wpa aan terwijl de waln-card in je flappie alleen wel kan?[/quote:6db5d2b2b7]Bedoel je met "statische adressen", een adres op de laptop in de net-config? Als ik de op de router de dhcp-server uit zet, krijg ik helemaal geen verbingen meer.

    Verder gebruik ik WEP zowel op de laptop als router. Ook zie ik op de laptop het mac-adres van de router als AP.
  • Hierbij een dump van iwconfig:
    [code:1:c210ae4ced]lo no wireless extensions.

    eth0 no wireless extensions.

    sit0 no wireless extensions.

    wlan0 IEEE 802.11g ESSID:"linksys" Nickname:"linksys"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:12:17:C7:DE:18
    Bit Rate=54 Mb/s Tx-Power:24 dBm
    RTS thr:off Fragment thr:off
    Encryption key: "een sleutel he" Security mode:open
    Power Management:off
    Link Quality:100/100 Signal level:-39 dBm Noise level:-256 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:12539 Missed beacon:0
    [/code:1:c210ae4ced]
  • Ik zie dat je waarschijnlijk een open wlan hebt :o omdat ik een unchanged ssid (linksys) zie. Kijk eens naar http://mrlee.homelinux.net/wlan.htm .

    Verder bedoel ik met statisch dat je niet met dhcp werkt maar de ip-gegevens met de hand invoert (inetconfig, yast, setup, ifconfig, whatever).
  • [quote:57ecc97aea="MrLeeJohn"]Ik zie dat je waarschijnlijk een open wlan hebt :o omdat ik een unchanged ssid (linksys) zie. Kijk eens naar http://mrlee.homelinux.net/wlan.htm .

    Verder bedoel ik met statisch dat je niet met dhcp werkt maar de ip-gegevens met de hand invoert (inetconfig, yast, setup, ifconfig, whatever).[/quote:57ecc97aea]Wat bedoel je met open? Ik heb wel een WEP-key en een MAC-filter waarbij alleen aangegeven MAC-adressen verbinding mogen maken.

    De ssid heb ik even zo gelaten. Die wilde ik als alles zou werken veranderen. Je hebt wel mooie tips op je pagina staan. Maar helaas werkt mijn laptop nog steeds niet. Als ik in de config bijv 19.2.168.1.101 aan de laptop meegeef, kan ik geen eens de router pingen. Weet je nog meer mogelijkheden om dit op te lossen?
  • Heb je in gentoo een rc-script voor wlan0 gemaakt (kopie van het net.eth0 script) en deze gestart?
  • > Als ik in de config bijv 19.2.168.1.101 aan de laptop meegeef, kan ik geen eens de router pingen.

    Dan heb je dat niet goed gedaan, denk ik. Maaruh… als je eerst de router kon pingen dan heeft het niks met wep en als die sh&t te maken. En bevestigt het mijn idee van dhcp.

    Dus…. manual je ip-adres goed instellen. Welke distro gebruik je?
  • [quote:643272d8b6="MrLeeJohn"]> Als ik in de config bijv 19.2.168.1.101 aan de laptop meegeef, kan ik geen eens de router pingen.

    Dan heb je dat niet goed gedaan, denk ik. Maaruh… als je eerst de router kon pingen dan heeft het niks met wep en als die sh&t te maken. En bevestigt het mijn idee van dhcp.

    Dus…. manual je ip-adres goed instellen. Welke distro gebruik je?[/quote:643272d8b6]Ik heb de router nooit kunnen pigen. Maar ik krijg wel, bij een "iwconfig", het MAC-adres van de router te zien. Dus ik neem aan dat ze communiceren. Hoe kan ik checken of voor de rest alles goed gaat?

    Even de zaak vanuit een andere hoek bekijkend he. Zou het ook aan mijn wlan-kaart in mijn laptop kunnen liggen? Ik gebruik gentoo op mijn laptop. Tis een amd64 met een broadcom wlan-kaart. Dus gebruik ik ndiswrapper.
  • > Hoe kan ik checken of voor de rest alles goed gaat?

    Zonder tcpip goed werkend? Lijkt me lastig.

    > Even de zaak vanuit een andere hoek bekijkend he. Zou het ook aan mijn wlan-kaart in mijn laptop kunnen liggen?

    Tja, kan altijd, maar daar zou ik niet vanuit gaan.

    > Ik gebruik gentoo op mijn laptop. Tis een amd64 met een broadcom wlan-kaart. Dus gebruik ik ndiswrapper.

    Gentoo… heb ik nooit gebruikt. Kan iemand even uitleggen hoe hij het makkelijkste manual een ipadres (met gateway en dns-servers) configureert?
  • [quote:baa5e15971="MrLeeJohn"]Ik gebruik gentoo op mijn laptop. Tis een amd64 met een broadcom wlan-kaart. Dus gebruik ik ndiswrapper.

    Gentoo… heb ik nooit gebruikt. Kan iemand even uitleggen hoe hij het makkelijkste manual een ipadres (met gateway en dns-servers) configureert?[/quote:baa5e15971]Dat weet ik en heb ik ook al geprobeerd. Maar helaas geen resultaat. Even voor de weet. Dat moet in /etc/conf.d/net .
  • Tja.. doe het allemaal anders eens zonder encryptie. Is sowieso de eerste keer per AP wel het handigste. En later pas encryptie erop.
  • [quote:86656be27d="MrLeeJohn"]Tja.. doe het allemaal anders eens zonder encryptie. Is sowieso de eerste keer per AP wel het handigste. En later pas encryptie erop.[/quote:86656be27d]Ja dan werkt het wel. hij heeft netwerkverkeer :-) Nu ga ik alles langzaam dichtgooien en kan ik lekker o mijn balkon internetten.

    Thanx allemaal :P
  • Bah, idd als ik een WEP-key in de router aanzet, dan krijg ik geen verbinding meer. Zonder WEP-key is het zeker niet zo veilig he.
  • Noodzakelijke stappen:

    - ssid-naam veranderen
    - ssid-broadcasting uit zetten
    - encryptie aan (liefst wpa, desnoods wep)

    Lees mijn wlan-docje maar….
  • [quote:8723146501="MrLeeJohn"]Noodzakelijke stappen:

    - ssid-naam veranderen
    - ssid-broadcasting uit zetten
    - encryptie aan (liefst wpa, desnoods wep)

    Lees mijn wlan-docje maar….[/quote:8723146501]Ja ik heb je wlan-docje gelezen.
    - ssid naam is veranderd
    - ssid broadcasting staat uit
    - encryptie staat uit :( wep werkt dus niet en asl ik wpa probeer te gebruiken, krijg ik een "cant read /etc/wpa_supplicant.conf"-error. Daar kan ik dus ook weinig mee.

    Dus ik doe elke keer als ik het internet gebruik even de encryptie uit. Het is niet zo veilig, maar beter dan niks. Ik hoop dat ik er snel achterkom hoe ik de encrytie goed werkend krijg.
  • Is geen linux-probleem. Misschien eens met een windows-bak proberen…. gaat toch iets simpeler en er zijn meer mensen die je daarmee kunnen helpen.
  • [quote:ec13300272="MrLeeJohn"]Is geen linux-probleem. Misschien eens met een windows-bak proberen…. gaat toch iets simpeler en er zijn meer mensen die je daarmee kunnen helpen.[/quote:ec13300272]En waar haal ik een windows-laptop vandaan :lol:

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.