Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Slackware current

Pinky & The Brain
35 antwoorden
  • Hallo,

    Ik probeer mijn nieuwe systeem te installeren en had voor de verandering weer eens een debian iso netinstall gedownload.
    Toch wil ik nu al weer terug naar mijn slackware.
    Op mijn oude computer draai ik slackware 9.0 geloof ik, maar dat kan ook 9.1 zijn.
    Nu zou ik slackware weer gaan downloaden omdat dit mij tot nu toe altijd goed was bevallen, maar ik kan geen slackware current iso vinden.
    De 9.1 iso heb ik al binnen, maar liever zou ik current proberen i.v.m. de nieuwe hardware.
    Voor current kan ik alleen een tree vinden welke ik dan zelf moet branden.

    Is er een mogelijkheid om een slackware current iso te downen of moet ik dat zelf maken ?
    Indien je dit zelf moet maken, heb je dan wel een bootable cd ?

    P&B
  • Van Slackware current bestaat er geen officiele iso zoals je hebt gemerkt.
    Current iso's worden wel aangeboden, maar officieel niet gepubliceerd.

    Het nadeel is dat de iso's snel verouderen en bij elke wijziging zou je een nieuwe iso moeten maken.
    Je kunt o.a. hier een 'current iso' vinden HIER en zoals je ziet is deze al weer iets verouderd :wink:.

    Verder zou je ze ook zelf kunnen maken met mkisofs.
  • Of lees isolinux/README.TXT, je kunt eenvoudig zelf een ISO maken.
  • [quote:0a5d2bfb88="yohanman"]Je kunt o.a. hier een 'current iso' vinden HIER en zoals je ziet is deze al weer iets verouderd[/quote:0a5d2bfb88] Wat de datum van die iso betreft lijkt ie me recent genoeg. Alleen is zo te zien de default kernel nog steeds 2.4.x, dus inderdaad verouderd.

    [quote:0a5d2bfb88="Pinky & The Brain"]De 9.1 iso heb ik al binnen, maar liever zou ik current proberen i.v.m. de nieuwe hardware.[/quote:0a5d2bfb88] Slackware 10.1 die je zelf compileert met kernel 2.6.12.4 zou ook moeten voldoen. Voor nieuwe hardware zou je ook Ubuntu 5.0.4 kunnen proberen.
  • Het wil niet lukken ….

    Slackware curent staat er op met een 2.4 kernel, maar graag zou ik een 2.6 kernel draaien natuurlijk.
    Nu heb ik een kernel gedownload (2.6.12.5 van kernel .org) en op zich heb ik geen problemen met het compilen er van.
    Het probleem is echter dat ik van verschillende componenten niet weet welke module ik moet kiezen.
    Volgens mij maak ik de juiste keuzes en ik heb ook bijna alle mogelijke combinaties geprobeerd, maar het werkt nog steeds niet zoals gewenst.

    Momenteel heb ik nog problemen met de framebuffer, het geluid en de netwerkkaart.
    Onder de 2.4 kernel werkt dat allemaal wel, maar als ik xconfig draai dan probeer ik verschillende instellingen, maar de juiste kan ik blijkbaar niet vinden ?!

    Ik heb een Asus A8N-SLI deluxe, met nforce4 chipset, een audigy 2 ZS geluidskaart een sata HD etc.
    Ik maak gebuik van de geintegreerde nvidia netwerkkaart (de marvel heb ik momenteel nog niet geactiveerd) en van een geforce 6600 pci-e.

    Het vreemde is dat wanneer ik mijn systeem boot met de nieuwe kernel het beeld weg valt als ik de framebuffer in de kernel activeer.
    Het systeem start echter wel door en als ik na het booten mijn gebruikersnaam + wachtwoord intyp en dan startx uitvoer, dan opent KDE netjes en heb ik wel weer beeld.
    Er is dus iets mis met mijn framebuffer instelling.
    Ik heb zowel vesa als nvidiaframebuffer geprobeerd zonder resultaat.

    Mijn netwerkkaart (de nforce chipset nic) zie ik niet tussen de mogelijke networkdevices staan.
    Wel andere gigabit lan adapters, maar ik weet dus niet welke nic ik moet kiezen.

    Ook de geluidskaart wordt niet juist geconfigureerd hoewel ik wel de juiste module heb geselecteerd, maar dat is van latere zorg
    Eerst moet de framebuffer en netwerkkaart goed !

    Het vreemde van dit alles …. het werkt wel met de voorgebakken 2.4 kernel van slackware dus wordt het wel ondersteund nietwaar ?
    Is er een mannier om er achter te komen hoe de opties in die 2.4 kernel zijn gekozen ?
    Dan zou ik die kunnen overnemen naar mijn eigen 2.6 kernel.

    Dat is het nadeel van die nieuwe hardware … zo heb ik voor athlon64/clawhammer gekozen in de kernelconfig, omdat mijn vence core er nog niet tussen stond.

    <edit>
    Hmmm, zou de nic er misschien niet tussenstaan omdat deze onderdeel van de chipset is ?
    Mijn nforce4 chipset kan ik echter helaas nog niet vinden … maar de 2.4 kernel pakt hem wel ?
    </edit>
  • Lees eerst nu dit eens goed, want alleen met kernel 2.6.x kom je er niet:

    ftp://ftp.nluug.nl/pub/os/Linux/distr/slackware/slackware-current/testing/packages/linux-2.6.12.3/

    Btw om je geluid aan de praat te krijgen zul je ook ALSA drivers moeten installeren die staan ook in de bovengenoemde directory.
  • [quote:3380e1ee26="Pinky & The Brain"]Het vreemde van dit alles …. het werkt wel met de voorgebakken 2.4 kernel van slackware dus wordt het wel ondersteund nietwaar ?
    Is er een mannier om er achter te komen hoe de opties in die 2.4 kernel zijn gekozen ?
    Dan zou ik die kunnen overnemen naar mijn eigen 2.6 kernel. [/quote:3380e1ee26] Heb je de [code:1:3380e1ee26] /sbin/lsmod [/code:1:3380e1ee26] output van de voorgebakken 2.4 kernel van slackware, al vergeleken met de output van je eigen 2.6 kernel?
  • Je kunt ook het slackware kernel 2.6 package installeren. Die zal dezelfde drivers hebben als de 2.4 kernel.
  • [quote:4723790079="lckarssen"]Je kunt ook het slackware kernel 2.6 package installeren. Die zal dezelfde drivers hebben als de 2.4 kernel.[/quote:4723790079]

    Dat heb ik dus inmiddels gedaan en ik probeer nu de 2.6.12313 kernel uit het package van slackware te bakken.
    Alles gaat goed met instellen en compileren.
    Zodra ik echter ga booten, dan gaat alles oké tot aan deze melding :
    [code:1:4723790079]
    VFS: Cannot open root device "803" or unknown-block(8,3)
    Please append a correct "root=" boot option.
    Kernel panic - not syncing: VFS: Unable to mount fs on unknown-block(8,3)
    [/code:1:4723790079]
    En dan zit het systeem vast als en huis en kom je er alleen uit met een harde reset.
    Nu heb ik van alles geprobeerd, maar ik begrijp niet waarom deze fout nog steeds op treed.
    Ik heb support voor mijn controllers aan staan in de kernel en niet als lkm, verder zou de kernel het (reiserfs) filesystem ook moeten kunnen benaderen.
    Lilo is ook juist geconfigureerd.

    Ook heb ik al alles gelijk gezet als de 2.6.12.5 kerenl, want deze boot wel gewoon maar dan zonder framebuffer en nic.
    Toch blijft de kernel dan nog hangen met bovenstaande foutmelding.

    Wat zou hier het probleem kunnen zijn ?
    Het lijkt er op alsof de sata niet wordt ondersteund ?
    Maar waarom kan deze het eerste deel van de kernel dan wel laden ?
    Dan is er iets mis met het filesystem misschien ?
  • Ik vermoed toch dat de kernel het filesystem niet kan lezen. Zeker weten dat het Reiserfs is, en dat de versie juist is?

    Kun je je lilo.conf eens posten om te zien of het niet toch daar misgaat?
  • Ik bedenk me net dat kernel 2.4 een SATA disk als ide disk ziet (/dev/hd?) en kernel 2.6 'm ziet als SCSI disk (/dev/sd?).

    Kijk dus even of je dat in lilo goed hebt staan (en pas dan meteen je /etc/fstab aan).
  • [quote:b5ef25dd0d="lckarssen"]Ik vermoed toch dat de kernel het filesystem niet kan lezen. Zeker weten dat het Reiserfs is, en dat de versie juist is?

    Kun je je lilo.conf eens posten om te zien of het niet toch daar misgaat?[/quote:b5ef25dd0d]
    Reiserfs staat aan in de kernel en is rechtstreeks in de krenel gecompiled en dus niet als LKM.
    Mijn lilo ziet er zo uit :
    [code:1:b5ef25dd0d]
    oot = /dev/sda
    message = /boot/boot_message.txt
    prompt
    timeout = 120

    # VESA framebuffer console @ 1024x768x64k
    vga = 791

    # mijn nieuwe kernel welke ik nu probeer te gebruiken maar nog vastloopt :
    image = /boot/vmlinuz-generic-2.6.12.3
    root = /dev/sda3
    label = Linux-2.6.12.3
    read-only
    #

    # De 1ste poging met de gedownloade 2.6 kernel van kernel,org welke kwel boot maar waar de framebuffer en nic niet werken. :

    image = /boot/vmlinuz-2.6.12.5
    root = /dev/sda3
    label = Linux-2.6.12.5
    read-only
    #

    # Windows partitie deze gaat er af zodra linux weer optimaal is geconfigureerd :
    other = /dev/sda1
    label = Windows
    table = /dev/sda
    #
    [/code:1:b5ef25dd0d]
    Tot dusver mijn lilo, dus dat zou goed moeten zijn.
    p.s. al het uitgecomentarieerde heb ik weggelaten om he forum niet onnodig te vervuilen :wink:
    [quote:b5ef25dd0d]
    Ik bedenk me net dat kernel 2.4 een SATA disk als ide disk ziet (/dev/hd?) en kernel 2.6 'm ziet als SCSI disk (/dev/sd?).

    Kijk dus even of je dat in lilo goed hebt staan (en pas dan meteen je /etc/fstab aan).
    [/quote:b5ef25dd0d]

    Ik weet dat sata in de 2.6 kernel onder scsi devices valt en dat je de sata optie uit de ide sectie niet moet gebruiken.
    Zoals gezegd werkt exact de zelfde kernel config met de de 2.6.12.5 kernel wel (al mis ik daar mijn nic en framebuffer).
    Het is dus waarschijnlijk geen probleem met sata, anders was de kernel in eerste instantie ook niet geboot toch ?

    P&B
  • Hmm, lilo.conf lijkt in orde.

    Als je een diff doet van de .config files van de twee kernels, zie je daar dan nog belangrijke verschillen?
    [quote:6433c202c6]Het is dus waarschijnlijk geen probleem met sata, anders was de kernel in eerste instantie ook niet geboot toch ?[/quote:6433c202c6]
    Dat weet ik niet zeker. Het hangt er vanaf hoe lilo precies werkt.
    Volgens mij gaat het ongeveer zo:
    Als je lilo uitvoert wordt er een instructie in de MBR gezet waar de kernel precies kan worden gevonden, zodat hij opgestart kan worden. De kernel laadt zichzelf dan en gaat vervolgens op zoek naar het filesystem uit de root= regel om te zien wat er verder gedaan moet worden.

    Als je schijf genoemd wordt tijdens de hardware detectie van de kernel, dan is de chipset in elk geval herkend en wordt de kans groter dat je toch iets mis hebt met het filesystem.
  • Dat denk ik niet. Het FS wordt (zoals ik het begrijp) ook gebruikt door de wel boot-bare 2.4 kernel. Daarmee zou je het FS als fout-bron moeten kunnen uitsluiten. Er zou wel een verschil kunnen zijn in de manier waarop een 2.6 kernel het FS benaderd tov de standaard 2.4 kernel, maar aangezien de 2.6 kernel bij mij wat multimedia probs gaf draai ik nog immer de standaard 2.4 kernel van Debian Sarge en kan ik daar dus niks definitiefs over zeggen. Lijkt me overigens sterk dat er zo'n verschil zou zijn, eea is vastgelegd in voorschriften enzo.

    Groet, M.V. Wesstein
  • Sorry, ik bedoelde niet dat z'n filesysteem brak was ofzo, eerder dat toch de juiste ondersteuning voor de benodigde versie van reiserfs ontbreekt.

    Zoals je zegt, als het fs onder 2.4 goed werkt, zal dat onder 2.6 ook zo moeten zijn.

    Ik ben "destijds" van 2.4 naar 2.6 gestapt met een SATA drive, en dat ging goed. Het enige lastige was dat Slackware's CD van 2.4 uitgaat en dus alles met /dev/hd? aanspreekt ipv /dev/sd?. Maar na wat editten in lilo.conf en fstab was alles weer OK.
  • [quote:1ccd4d094d="lckarssen"]Sorry, ik bedoelde niet dat z'n filesysteem brak was ofzo, eerder dat toch de juiste ondersteuning voor de benodigde versie van reiserfs ontbreekt.

    Zoals je zegt, als het fs onder 2.4 goed werkt, zal dat onder 2.6 ook zo moeten zijn. [/quote:1ccd4d094d]Dan zijn we het weer eens :)
  • [quote:3e0effa4db="Pinky & The Brain"] Slackware curent staat er op met een 2.4 kernel, maar graag zou ik een 2.6 kernel draaien natuurlijk. Nu heb ik een kernel gedownload (2.6.12.5 van kernel .org) en op zich heb ik geen problemen met het compilen er van. Het probleem is echter dat ik van verschillende componenten niet weet welke module ik moet kiezen. [/quote:3e0effa4db] Er zou in de map op één van de Slackware cd's in de map testing > source > linux-2.6.x een voorbeeld config file moeten staan. Zoiets als [b:3e0effa4db] config-2.6.x [/b:3e0effa4db] Bijvoorbeeld [code:1:3e0effa4db] cp config-2.6.* /usr/src/linux-2.6.12.5/.config [/code:1:3e0effa4db][Enter] Uiteraard loop je de kernel opties na. Er zal ongetwijfeld wat moeten worden aangepast.

    Ik heb deze voorbeld config file ook gebruikt. Ik had 'm vanaf cd2 van Slackware 10.1. Als ik deze gebruik (aangepast) in Slackware 10.1 en nu ook in die Slackware-current, dan lijkt de frame-buffer te werken met de 2.6.12.x kernel. Ik kan 'm niet wijzigen. De resolutie is bij mij waarschijnlijk 800x600. Maar de text is goed leesbaar. Ik gebruik overigens niet de lilo.conf van Slackware, maar grub vanuit een andere Linux distributie.
  • Oké, vele pogingen later vermoed ik dat er iets anders aan de hand was, want de config lijkt goed en toch blijven de problemen.
    Daarom heb ik gepoogd het systeem opnieuw te installeren m.b.v. de 2 gebrande cd's.
    Nu blijk ik deze echter niet meer te kunnen installeren, want in de 1ste cd zitten al zitten cruciale fouten !
    De eerste keer dat ik geinstalleerd heb is mij nooit een fout / error bericht opgevallen, maar nu is het elke poging raak en meestal zijn het belangrijke packages zoals glibc of de gcc compiler die 'beschadigd' zijn.
    De iso.images zijn goed, want die heb ik met md5 gecontroleerd.
    De cd's zullen wel beschadigd zijn ? (in enkele dagen tijd ? :-?).

    Misschien speelde dit de eerste installatie ook al, maar is het mij tijdens de installatie niet opgevallen.
    Nu wil ik proberen om slackware anders te installeren, maar dat zal moeilijk worden.

    Grofweg zijn er 2 opties.
    Installeren over het netwerk vanaf een andere linux computer.
    Of ik kan de installatiemedia op een andere partitie van de nieuwe computer kopieren, namelijk een ntfs partitie.

    Wat is het verstandigst ?
    Zelf denk ik dat (indien mogelijk vanaf een ntfs partitie) het installeren vanaf de zelfde schijf het simpelst is, omdat je dan niet met netwerk systemen hoeft te klooien (weet namelijk ook niet of netwerk wel functioneerd met standaard slackware kernel, want is nforce4 nic).
    Dan zal ik via windows met FTP moeten proberen een slackware mirror lokaal te mirrorren op mijn ntfs schijf.
    Tot zover zie ik geen problemen … dat moet wel lukken, maar heb ik dan ook een mogelijkheid om te controleren of alles goed gekopieerd is en dat er geen beschadigde / corupte bestanden zijn ?

    P&B

    p.s. Dit is ook de reden van de aanschaf van het nieuwe systeem.
    Ik wil graag weer een normaal functionerend systeem met randapperatuur wat [b:70a4e49149]wel[/b:70a4e49149] werkt.
    Dan zal ik echter eerst wel mijn OS goed er op moeten zien te krijgen …
  • Waarom brand je de ISOs niet nog een keer? Of alleen CD1, KDE kun je altijd later toevoegen, en als je Gnome gebruikt kun je beter Dropline Gnome gebruiken.

    Is de machine verder wel stabiel? Kan het niet zo zijn dat het geheugen brak is en dat er dus tijdens het uitpakken iets misgaat?
    Je hebt het over een lokale NTFS partitie, dus ik neem aan dat windows wel fatsoenlijk werkt (dan is de hardware OK, lijkt me)?

    Slackware over NFS installeren is mogelijk (kun je gewoon tijdens setup kiezen), dat heb ik regelmatig gedaan. Of de NF4 NIC ondersteund wordt weet ik eigenlijk niet. Maar dan nog heb je een bootfloppy of een bootable CD nodig en op die andere PC moeten dan toch de slackware packages staan. Dus kun je net zo goed de ISO nog eens branden zoals ik al zei. Of mis ik iets?

    Als je van elk pakket de signature moet gaan controleren ben je ook wel even bezig. Dus weer die nieuw gebrande ISO?! :P


    Succes!
  • [quote:356fac16a9="Pinky & The Brain"] De eerste keer dat ik geinstalleerd heb is mij nooit een fout / error bericht opgevallen, maar nu is het elke poging raak en meestal zijn het belangrijke packages zoals glibc of de gcc compiler die 'beschadigd' zijn. De iso.images zijn goed, want die heb ik met md5 gecontroleerd. De cd's zullen wel beschadigd zijn ? (in enkele dagen tijd ?[/quote:356fac16a9] Dat is niet erg waarschijnlijk. Tenzij de cd's fysiek zijn beschadigd. Had je bij het branden van de cd's wel gebruik gemaakt van de optie: Verify? En weet je zeker dat er niet iets mis is met je dvd-speler. Heb je het installeren van Slackware-current ook al geprobeerd via je dvd-brander?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.