Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Krijg connectie van phpBB2 naar MySQL niet aan de praat

None
6 antwoorden
  • Ik draai Apache op FC4, ik probeer phpBB2 aan de praat te krijgen. MySQL geinstalleerd, phpBB2 gedownload en geplaatst onder /var/www/html, als ik de install.php invul en op submit druk, krijg ik:[code:1:ee916351cd]
    The PHP configuration on your server doesn't support the database type that you chose
    [/code:1:ee916351cd]
    Ik kies voor mysql 4.x, maar hetzelfde gebeurd op 3.x

    geinstalleerde versies:
    mysql-server-4.1.12-2.FC4.1
    php-5.0.4-10.3
    httpd-2.0.54-10.1
    kernel 2.6.12-1.1398_FC4

    Het probleem is veel voorkomend en in eerste instantie dacht ik het ook gevonden te hebben door een posting waarin vermeld stond dat de hasing vanaf mysql 4.1 gewijzigd was, opstarten met[code:1:ee916351cd] /etc/init.d/mysqld start –old-passwords [/code:1:ee916351cd]
    zou de oplossing moeten zijn, maar ook dat biedt geen soelaas, ook werd er geopperd om SElinux uit te schakelen wat ik heb gedaan middels[code:1:ee916351cd]setenforce 0[/code:1:ee916351cd] wie kan me verder helpen of iig zeggen waar te kijken.
    tnx
  • Wat voor info spuwt info.php ?
    Heb niet veel kennis van php, maar welke api / interface gebruik je voor het conecten met mysql ?
  • Volgesmij komt het omdat PHPBB php 5 niet ondersteund ;)
  • [quote:717c3524a5="Pinky & The Brain"]Wat voor info spuwt info.php ?
    Heb niet veel kennis van php, maar welke api / interface gebruik je voor het conecten met mysql ?[/quote:717c3524a5]
    phpBB2 legt de connectie naar de mysql-db, die geeft ook de melding…
  • [quote:c5dac997b7="L/H"]Volgesmij komt het omdat PHPBB php 5 niet ondersteund ;)[/quote:c5dac997b7]
    Mmmm, dat zou ook nog kunnen, zal eens php4 installeren….
  • Ok, heb hem uiteindelijk aan de praat gekregen (gewoon met php5 8) )…vond een howto(tje) die uitging van FC4 en die deed een groupinstall, waarbij er wat extra packages werden geinstalleerd, kon toen nog geen connectie maken, bleek dat de mysql geen db had aangemaakt, handmatig middels de inmiddels geinstalleerde phpadmin aangemaakt en toen deed ie het.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.