Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

floppy verwijderen in linux

jolo
6 antwoorden
  • Ik heb mijn floppy drive (fysiek) verwijderd, maar als ik in het BIOS selecteer dat ik geen floppy disk drive meer heb, wil mijn SuSe 9.0 professional niet meer opstarten.

    Laat ik die instelling staan in het BIOS, dan start SuSe wel op, maar moet ik eerst de F1 toets indrukken voordat de bootmanager op het scherm verdwijnt.

    Vraag: hoe kan ik ervoor zorgen dat ik de FDD verwijder uit SuSe, zodat ik direct de bootmanager krijg en SuSe normaal kan opstarten?
    Ik heb "umount /dev/fd0" geprobeerd (weet niet of dat het goede commando is?), maar dan krijg ik de melding dat 'het station niet aangekoppeld is (volgens mtab)' .
  • SUSE wil niet opstarten…
    Welke foutmelding geeft SUSE tijdens de poging om op te starten?

    umount zal inderdaad niet werken, daarmee koppel je een aangekoppelde diskette af.
    En je hebt geen diskettestation, dus heb je ook geen aangekoppelde diskette :)
    Om het diskettestation uit suse te verwijderen pas je /etc/fstab aan, waarin je de regel voor /dev/fd0 verwijdert.

    Maar dat staat los van je opstartprobleem.
  • SuSe geeft geen foutmelding; normaal gesproken kan je op F2 drukken om details te zien. Dat kan ik om de een of andere reden niet (was ook al voordat SuSe niet wilde opstarten denk ik).

    Wel duurt het opstarten langer dan vlak na de installatie, maar dat kan ook komen doordat mijn harde schijf inmiddels gevuld is met allerlei bestanden?

    Dat van umount was ik inderdaad ook al achter. Ik altijd maar denken dat dat was om fysieke stations af te koppelen :D

    Ik denk dat het aanpassen van /etc/fstab de oplossing zal geven. Ga ik straks even proberen. Bedankt in ieder geval :wink:

    Maar waarom staat dat los van mijn opstartprobleem? Ik dacht dat SuSe probeerde het diskettestation te vinden en bleef hangen omdat hij die niet kon vinden? Want als ik in de BIOS opgeef dat het diskettestation wel bestaat, krijg ik vlak na het opstarten een foutmelding ("Floppy disk fail (40)"), maar start SuSe wel op.
  • Als er een fout in /etc/fstab staat, dan krijg je de foutmelding 'error bad entry line XXX in /etc/fstab' en gaat suse verder met opstarten.
    Verder wordt de tekstregel in /etc/fstab in principe pas aangesproken als je een flop wilt mounten.

    Opstarten zou alleen langer mogen duren als je meer services laat opstarten (dus dat je aanvullende software hebt geinstalleerd die tijdens het opstarten moet worden geinitialiseerd), niet omdat er meer op de schijf staat.
    Om een of andere reden is SUSE niet blij met de hardwarewijziging.

    Dit staat ook beschreven in de support database van suse:
    [quote:c76531cd7c]
    Symptom:
    During the installation the system hangs whith the message:
    Checking partitions:
    hda

    Cause:
    The floppy in your BIOS is deactivated. The kernel fails when it tries to recognize the hard disk partitions as there's no floppy device available.
    Solution:
    Please activate the floppy in your BIOS settings, even if there's no existing physical device.
    [/quote:c76531cd7c]

    Max
  • Ik heb ook geen floppy drive in mijn systeem, je moet niet vergeten om naast de floppy drive zelf in BIOS uitschakelen onder "general" ofzo, ook de floppy controller uit te zetten onder "integrated pheripials" in de BIOS.
  • Bedankt voor de reacties!
    [quote:8203af61f1="Tekkie"]Ik heb ook geen floppy drive in mijn systeem, je moet niet vergeten om naast de floppy drive zelf in BIOS uitschakelen onder "general" ofzo, ook de floppy controller uit te zetten onder "integrated pheripials" in de BIOS.[/quote:8203af61f1]
    Die optie heb ik niet geloof ik. Heb alles waarvan ik denk dat het met mijn floppy te maken heeft uitgezet in het BIOS, maar SuSe wil nog altijd niet opstarten. Misschien omdat ik een (te) oud moederbord heb (Asus CUV4X-E)? :oops:

    Wat uit de supportdatabase komt van SuSe lijkt wel op mijn probleem inderdaad, maar als ik failsafe start blijft hij hangen bij het volgende:
    [code:1:8203af61f1]ttyS00 at 0x03f8 (irq = 4) is a 16550A
    ttyS01 at 0x02f8 (irq = 3) is a 16550A
    RealTime Clock Driver v1.10e[/code:1:8203af61f1]
    Daarna doet hij niks meer, dus ligt niet aan het controleren van de partitie HDA?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.