Vraag & Antwoord

OS Linux

JRE installeren onder SuSE 10.0 lukt niet

Anoniem
maximilaan
11 antwoorden
  • Ik zit met een vreemd probleem. Ik heb destijds SuSE 10.0 geinstalleerd via internet, tijdrovend, maar Java Runtime Environment werkte in ieder geval (o.a. nodig voor het gebruk van de OpenOffice database). Omdat een paar andere programma's vastliepen heb ik uiteindelijk SuSE 10.0 op 5 cd's gedownload en gebrand en opnieuw geinstalleerd. Ik dacht met het downloaden van Mozilla Firefox 1.5 van mijn JREproblemen af te zijn, maar nee dus. Ik krijg een scherm waarin staat dat ik ontbrekende plugins moet downloaden, ik word keurig naar de website van Sun geleid waar ik kies voor het bestand 'jre-1_5_0_06-linux-amd64-rpm.bin' (ik heb een AMD Athlon 64 machine). Nadat ik, geheel volgens de installatieprocedure, met chmod a+x het bestand toegankelijk heb gemaakt, typ ik het commando " ./jre-1_5_0_06-linux-amd64-rpm.bin" in, en dan krijg ik de melding "line 1: File: command not found". Het lijkt erop dat ik eerst nog een ander bestand moet installeren, is dat zo? Via YaST heb ik al de selectie "Java" geinstalleerd, maar dat zijn oo maar twee bestanden en dat verandert niets aan de foutmelding die ik krijg. De directories /usr/lib/java-1-4 enz. zijn ook allemaal leeg, dus dat lijkt me ook niet helemaal in orde. Is er iemand die hier hulp bij kan bieden?
  • [quote:2fb137fb8c="Luuk.de.Ruiter"]heb ik uiteindelijk SuSE 10.0 op 5 cd's gedownload en gebrand en opnieuw geinstalleerd. (..) ik word keurig naar de website van Sun geleid waar ik kies voor het bestand 'jre-1_5_0_06-linux-amd64-rpm.bin' (ik heb een AMD Athlon 64 machine)[/quote:2fb137fb8c] Maar heb je de jre die op 1 van die 5 cd's staan al geprobeerd. [code:1:2fb137fb8c] java-1_5_0-sun-1.5.0_03-2.x86_64.rpm [/code:1:2fb137fb8c] Deze zou je moeten kunnen installeren via Yast > Software installeren en verwijderen. Als je in Zoeken bijvoorbeeld typt [code:1:2fb137fb8c] sun [/code:1:2fb137fb8c][Enter] dan zou je 'm moeten kunnen vinden.
  • [quote:a6dfff726c="Luuk.de.Ruiter"]Ik dacht met het downloaden van Mozilla Firefox 1.5 van mijn JREproblemen af te zijn, maar nee dus. [/quote:a6dfff726c]
    Dat kan, firefox heeft namenlijk een plugin nodig om de JRE te kunnen benaderen.
    Typ even [b:a6dfff726c]about:plugins[/b:a6dfff726c] in de locatiebalk van firefox om te kijken welke plugins je hebt en waar firefox die vindt.

    De JRE zelf hoef je dus niet te installeren (die heb je al)
  • Als ik in YaST [b:fe68cd9c27]"jre"[/b:fe68cd9c27] intyp, zie ik dat er een JRE-pakket geinstalleerd is, 1.5.0_01. Er staat zo"n hangslotje voor. Als ik met mijn cursor over dit pakket ga, krijg ik een tekstbox met de mededeling
    " jre
    Geinstalleerde versie jre 1.5.0_01-fcs-c86_64
    Niet voor installatie beschikbaar"
    Ik krijg sterk de indruk dat ik dat hangslotje moet openbreken, maar dat lukt me niet.
    Zit hier wellicht de sleutel tot de oplossing van mijn probleem?

    Overigens staat op mijn installatie-cd's geen enkel RPM-bestand dat ook maar enigszins lijkt op jre-enz. Als ik [b:fe68cd9c27]"sun"[/b:fe68cd9c27] intyp in YaST krijg ik 1 pakket te zien waarmee ik een chinees lettertype kan installeren. Ik heb toch ook nog een keer het bovenstaande jre-bestand gewoon zelf gedownload. Dat kon ik overigens wel uitpakken en er een RPM-bestand van maken. Toen ik dat met YaST wilde openen kreeg ik de mededeling dat jre niet op het medium was te vinden.
  • [quote:caaf0677cf="Luuk.de.Ruiter"]Als ik in YaST [b:caaf0677cf]"jre"[/b:caaf0677cf] intyp, zie ik dat er een JRE-pakket geinstalleerd is, 1.5.0_01. Er staat zo"n hangslotje voor. Als ik met mijn cursor over dit pakket ga, krijg ik een tekstbox met de mededeling
    " jre
    Geinstalleerde versie jre 1.5.0_01-fcs-c86_64
    Niet voor installatie beschikbaar"
    [/quote:caaf0677cf]
    De optie [help->symbolen] vertelt je precies wat dat hangslotje inhoudt.

    Even gekopieerd uit YaST:
    [code:1:caaf0677cf]
    Beschermd
    Dit pakket is geïnstalleerd en zou niet aangepast mogen worden, vooral niet omdat andere pakketten onopgeloste afhankelijkheden kunnen hebben of kunnen krijgen. Gebruik deze status voor pakketten derden die niet door eventuele, met de distributie meegeleverde, nieuwere versies overschreven mogen worden.
    [/code:1:caaf0677cf]
    Of in gewoon nederlands, JRE is op jouw systeem geinstalleerd, en om te voorkomen dat bijv. de yast online update of het installeren van een ander pakket die een andere JRE-pakketversie als afhankelijkheid heeft de JRE-versie van je systeem vervangt is er een slotje op gezet.


    [quote:caaf0677cf]
    Ik krijg sterk de indruk dat ik dat hangslotje moet openbreken, maar dat lukt me niet.
    [/quote:caaf0677cf]
    Hoe doe je dat dan?
    1 x erop klikken, en het slotje is weg ;)

    [quote:caaf0677cf]
    Zit hier wellicht de sleutel tot de oplossing van mijn probleem?
    [/quote:caaf0677cf]
    Neen

    [quote:caaf0677cf]
    Overigens staat op mijn installatie-cd's geen enkel RPM-bestand dat ook maar enigszins lijkt op jre-enz.
    [/quote:caaf0677cf]
    Dit is hem:
    http://www.novell.com/products/linuxpackages/professional/java-1_5_0-sun.html

    [quote:caaf0677cf]
    Als ik [b:caaf0677cf]"sun"[/b:caaf0677cf] intyp in YaST krijg ik 1 pakket te zien waarmee ik een chinees lettertype kan installeren.
    [/quote:caaf0677cf]
    klopt :)
    je kunt beter zoeken op java, runtime, environment…

    [quote:caaf0677cf]
    Ik heb toch ook nog een keer het bovenstaande jre-bestand gewoon zelf gedownload. Dat kon ik overigens wel uitpakken en er een RPM-bestand van maken. Toen ik dat met YaST wilde openen kreeg ik de mededeling dat jre niet op het medium was te vinden.[/quote:caaf0677cf]
    hoe open je een bestand met YaST?

    Anyway, JRE is gewoon geinstalleerd, dus dat is het prolbeem niet ;)

    Je moet zoals gezegd de javaplugin voor mozilla hebben.
    Heb je al gekeken met [b:caaf0677cf]about:plugins[/b:caaf0677cf] of je die plugin hebt?
    Volgens is dat overigens deze:
    http://www.novell.com/products/linuxpackages/professional/java-1_4_2-sun-plugin.html

    Max
  • Hoi Max,

    Ik begrijp intussen wel dat JRE op mijn system is geinstalleerd, maar dat een aantal plug-ins ontbreken. Op de een of andere manier zien kennelijk een aantal programma's dit toch anders. Bij het openen van een database bestand krijg ik ook de mededeling dat deze toepassing een JRE nodig heeft, die hij kennelijk niet vindt.

    Met About:plugins[/] zie ik dat er twee plug-ins zijn geinstalleerd, de Shockwave Flash en de Default plugin:
    [i:931d706581]Bestandsnaam: libflashplayer.so
    Shockwave Flash 7.0 r25[/i:931d706581]
    en
    [i:931d706581]Bestandsnaam: libnullplugin.so[/i:931d706581].
    Bij dit laatste bestand staat overigens dat hij niet aktief is.
    Het installeren van Macromedia Flashplayer loopt vast op de uiteindelijke mededeling "Your architecture, 'x86_64', is not supported by the
    Macromedia Flash Player installer." Nou, dat lijkt me een duidelijke boodschap.

    Die java plugins die jij noemt heb ik allemaal al een keer geproberd, maar bij het installeren via YaST (en inderdaad niet openen zoals ik schreef) krijg ik uiteindelijk de mededeling dat jre niet op het medium gevonden is.
  • Wat ik me afvraag: je hebt een 64-bits systeem, en je hebt 5 suse cd's gedownload.
    Maar suse biedt geen 64-bit op cd aan?
  • [quote:1625fd42de="Luuk.de.Ruiter"]
    Die java plugins die jij noemt heb ik allemaal al een keer geproberd, maar bij het installeren via YaST (en inderdaad niet openen zoals ik schreef) krijg ik uiteindelijk de mededeling dat jre niet op het medium gevonden is.[/quote:1625fd42de]

    is het medium een ftp-site?
    Zo ja, ga dan naar [wijzig installatiebron] klik de bron aan en kies voor [wijzigen->verversen]
    Waarschijnlijk bevat de bron nieuwere versienummers dan yast verwacht, zodat de pakketten uit de database van yast niet meer op de server staan..
  • IK heb het probleem op een geheel andere wijze opgelost. Ik heb de commerciele versie aangeschaft en nu doet alles het zoals het hoort. Ik geef toe, niet echt een sportieve oplossing, maar hij werkt wel! Bedankt in ieder geval voor het meedenken en aandragen van oplossingen!
  • Op zich wel een verstandige oplossing, omdat de winkelversie van suse 64 bit alle software bevat, de download-versie bevat slechts een selectie..

    Max
  • Java zit toch in de extra inst-source-java?
    Daar heb ik mijn Java 5 in zijn geheel vandaan gehaald.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.

Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord