Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Waarom commandoregel bij SUSE 10?

None
15 antwoorden
  • Na de installatie van SUSE 10 had ik verwacht een grafische interface te zien, of begrijp ik het allemaal niet? Ik ben een beginnende Linux gebruiker. Ik heb mijn username en password ingevoerd en nu?
  • Waarschijnlijk heb je voor een minimale installatie ofzo gekozen. Dan zit er misschien geen desktop environment bij.
  • Geplaatst: 30 Dec 2005 12:06 Onderwerp:

    ——————————————————————————–

    Waarschijnlijk heb je voor een minimale installatie ofzo gekozen. Dan zit er misschien geen desktop environment bij.


    :x Alles volgens het boekje gedaan, dus niets minimaals. Kan iemand mij helpen?
  • Kan het zijn dat de machine wat traag is met het inschakelen van het grafische gedeelte?

    Ik heb zelf wel eens in SUSE dat hij enige tijd op de login blijft hangen en pas na ongeveer een minuut verder gaat met het grafische deel.

    Waarom dat zo is weet ik ook niet.

    -hws-
  • [quote:6742c842d3="hws"]Kan het zijn dat de machine wat traag is met het inschakelen van het grafische gedeelte?

    Ik heb zelf wel eens in SUSE dat hij enige tijd op de login blijft hangen en pas na ongeveer een minuut verder gaat met het grafische deel.

    Waarom dat zo is weet ik ook niet.

    -hws-[/quote:6742c842d3]

    9/10 keer komt dat omdat het resolven van je hostnaam niet goed werkt, maak een specifieke entry voor je hostnaam in /etc/hosts en laat dmv nsswitch.conf de resolver eerst naar de hosts file kijken.
    Dit soort dingen kunnen soms optreden als je je machine een naam geeft die (toevallig) op het internet door dns resolved kan worden, resultaat is dat je een verkeerd ip adres voor je naam terug krijgt, met alle gevolgens van dien.
  • [quote:980b262d41="wvdhee"]Na de installatie van SUSE 10 had ik verwacht een grafische interface te zien, of begrijp ik het allemaal niet? Ik ben een beginnende Linux gebruiker. Ik heb mijn username en password ingevoerd en nu?[/quote:980b262d41] Had je wel bij de installatie instellingen voor een Desktop installatie met KDE of Gnome gekozen? En had je na installeren van de eerste cd en de vereiste reboot, de installatie kunnen voortzetten? Check ook nog even deze Installing Suse 10 from CDs.
  • [quote:4297ca6336="jolo"][quote:4297ca6336="wvdhee"]Na de installatie van SUSE 10 had ik verwacht een grafische interface te zien, of begrijp ik het allemaal niet? Ik ben een beginnende Linux gebruiker. Ik heb mijn username en password ingevoerd en nu?[/quote:4297ca6336] Had je wel bij de installatie instellingen voor een Desktop installatie met KDE of Gnome gekozen? En had je na installeren van de eerste cd en de vereiste reboot, de installatie kunnen voortzetten? Check ook nog even deze Installing Suse 10 from CDs.[/quote:4297ca6336]

    Bij de eerste reboot liep het mis, toen heb ik voor failsafe gekozen en toen ging die verder met installeren met cd2. Ik denk dat ik het beste het helemaal over kan doen of niet? Kan ik de huidige installatie verwijderen en hoe doe ik dat?
  • bij herinstallatie mietert suse automagisch de vorige installatie er volledig af, dus je hoeft niks handmatig te verwijderen.

    Dat de 2e boot mislukt baart wel zorgen, mocht dat bij je volgende installatie weer zo zijn, dan moeten we even uitvogelen welk onderdeel van je systeem niet herkend/ondersteund wordt door suse.

    Max
  • iets anders, 'failsafe' is bij suse een tekstmodus.
    Wat je kunt proberen is om in te loggen als root, en dan [b:6ea697aa91]init 5[/b:6ea697aa91] in te typen.
    Start het grafische gedeelte dan wel op, dan is er niks aan de hand, er moet dan alleen even ergens worden ingesteld dat je in runlevel 5 wilt opstarten ipv het runlevel waar suse nu in opstart.
  • Max,

    Bedankt! Alleen moet ik elke keer in failsafe opstarten en dan init 5 toetsen, dan doet ie ut. Hoe kan ik dit oplossen? :D
  • [quote:a48f75e772="wvdhee"]Alleen moet ik elke keer in failsafe opstarten en dan init 5 toetsen, dan doet ie ut. Hoe kan ik dit oplossen?[/quote:a48f75e772] Dus je bedoelt dat de grafische modus dan start? Dan start je yast > Systeem > Runlevel editor. Klik dan op Expert mode. Dan zou je moeten selecteren onder

    Standaard runlevel instellen nadat is opgestart naar:

    5: Full multiuser met netwerk en displaymanager.

    Klik dan op Voltooien.
  • [quote:3fad3c62b4="jolo"] Dus je bedoelt dat de grafische modus dan start? Dan start je yast > Systeem > Runlevel editor. Klik dan op Expert mode. Dan zou je moeten selecteren onder

    Standaard runlevel instellen nadat is opgestart naar:

    5: Full multiuser met netwerk en displaymanager.

    Klik dan op Voltooien.[/quote:3fad3c62b4]

    DIt stond al goed. Het probleem zit m missschien in opstarten bij Grub. Na het starten van GRUB zie ik grafisch een menu met de volgende mogelijkheden: SUSE LINUX 10.0 (werkt niet de comp loopt niet verder, ik kan alleen resetten), Windows (werkt), Dis_kette, SUSE LINUX 10.0 (Failsafe) (deze wekt en dan moet ik inloggen als root en init 5 ingeven, dan werkt ie.

    Heb of weet jij een oplossing, trouwens alvast een goed oud en nieuw! :wink:
  • [quote:efdf9f3d59="wvdhee"] SUSE LINUX 10.0 (Failsafe) (deze wekt en dan moet ik inloggen als root en init 5 ingeven, dan werkt ie. [/quote:efdf9f3d59] Dat is omdat de boot opties in failsafe zijn zoiets als
    [code:1:efdf9f3d59]
    vga=normal showopts ide=nodma apm=off acpi=off noresume selinux=0 nosmp noapic maxcpus=0 edd=off 3 [/code:1:efdf9f3d59] Door die 3 in de boot opties start deze, zoals maximilaan al opmerkte op in tekstmodus.
    [quote:efdf9f3d59="wvdhee"]Heb of weet jij een oplossing, trouwens alvast een goed oud en nieuw!y [/quote:efdf9f3d59] Je zou er achter kunnen proberen te komen welke van die boot opties je echt nodig hebt. Om dat te testen, zonder dat je echt iets wijzigt, start je de pc opnieuw op. Zodra het grafische bootmenu van SuSE verschijnt, druk je op Esc, en op [Enter]. Dan selecteer je de SuSE regel die bij jouw niet goed werkt. (De normale opstart modus van SuSE.) Dan druk je op de letter e. Dan selecteer je de kernel regel. Dan druk je weer op de e. Dan druk je 1 maal op de spatiebalk. Dan kun je een boot optie intypen. Te beginnen met [code:1:efdf9f3d59] acpi=off [/code:1:efdf9f3d59] Dan druk je op [Enter] en op de letter b. De rest is een kwestie van uitproberen. Je kunt dit veilig testen. Want je wijzigt hiermee niets in je /boot/grub/menu.lst

    Zodra je de juiste boot opties hebt gevonden, kun je deze wijziging doorvoeren via YaST. En ook een goed oud en nieuw.


    Edit:

    Bij nader inzien blijkt het testen van welke boot optie je nodig hebt, toch eenvoudiger te kunnen. Zodra het grafische bootmenu van SuSE verschijnt, druk je op F2 waarna de boot optie kan worden getypt. Bijvoorbeeld
    [code:1:efdf9f3d59] acpi=off [/code:1:efdf9f3d59][Enter]
  • [quote:84be6fced2="wvdhee"]Max,

    Bedankt! Alleen moet ik elke keer in failsafe opstarten en dan init 5 toetsen, dan doet ie ut. Hoe kan ik dit oplossen? :D[/quote:84be6fced2]
    typ even op de prompt dit commando:
    [b:84be6fced2]kdesu kwrite[/b:84be6fced2]

    Wacht totdat kwrite is gestart en open daarmee het bestand [b:84be6fced2]/etc/inittab[/b:84be6fced2]

    In dat bestand zoek je deze tekst:
    id:3:initdefault:

    Die verander je in
    id:5:initdefault:

    De 3 dus in een 5

    De 3 kan ook een ander cijfer zijn, maar de 5 geeft init 5 aan, en die wil je standaard gebruiken.

    Herstart suse om te kijken of dat werkt.

    Heb zelf dit geintje toevallig met een suse-installatie gehad.
    Geen idee waarom suse dit op init 3 zet, maar alla..

    Max
  • [quote:1ba5fe305c="maximilaan"]typ even op de prompt dit commando:
    [b:1ba5fe305c]kdesu kwrite[/b:1ba5fe305c]

    Wacht totdat kwrite is gestart en open daarmee het bestand [b:1ba5fe305c]/etc/inittab[/b:1ba5fe305c]

    In dat bestand zoek je deze tekst:
    id:3:initdefault:

    Die verander je in
    id:5:initdefault:

    De 3 dus in een 5

    De 3 kan ook een ander cijfer zijn, maar de 5 geeft init 5 aan, en die wil je standaard gebruiken.

    Herstart suse om te kijken of dat werkt.

    Heb zelf dit geintje toevallig met een suse-installatie gehad.
    Geen idee waarom suse dit op init 3 zet, maar alla..

    Max[/quote:1ba5fe305c]


    Thnx 't werkt. hij draait prima.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.