Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Run bestand (?)

vanaggelen
17 antwoorden
  • Hallo,
    Ik heb gisteren een ati-driver gedownload en het installeren lukt niet. Het blijkt een 'run' bestand te wezen en dat ken ik niet. Het reageert ook niet op de commando-regel zal ik maar zeggen (terminal dus) Ook weet ik niet zeker welke bits-versie van SuSE ik heb, dit werd bij ATI gevraagd. IK heb een DVD SuSE 10 van de boekhandel van 'LINUX-Format'. Verder Pentium 4 PC, 3 Gz. Medion.
    Kaart: ATI Radeon X700Pro .
    Graag hulp,
    Groeten
    Ries
  • Heb je[code:1:1fc39cfb7a]chmod +x <bestandsnaam>[/code:1:1fc39cfb7a]gedaan? Daarna[code:1:1fc39cfb7a].sh <bestandsnaam>[/code:1:1fc39cfb7a]Zou moeten werken :)
  • [quote:7189224e23="M.V. Wesstein"]Heb je[code:1:7189224e23]chmod +x <bestandsnaam>[/code:1:7189224e23]gedaan? Daarna[code:1:7189224e23].sh <bestandsnaam>[/code:1:7189224e23]Zou moeten werken :)[/quote:7189224e23]

    Opdracht uitgevoerd!
    Dat .sh command werd niet herkend.
    Het bestand is wel groen geworden) Dat staat toch voor uitvoerbaar?
    Klop nu. Met dezelfde bestandsnaam op de commando-regel kreeg ik reachtie en ging de machine draaien. Er is geinstalleerd. Wat moet ik nog uitpluizen. (driver natuurlijk) Maar ik had inmiddels een halve ATI toestand in m'n K Menu gekregen en dat is nog niet helemaal OK. Dat had zo'n resolutie-keuze etc. moeten worden. Misschien een herstart?
    Groetjes
    Ries
  • [quote:e38c6037b1="vanaggelen"]Ik heb gisteren een ati-driver gedownload en het installeren lukt niet. Het blijkt een 'run' bestand te wezen (..) IK heb een DVD SuSE 10. [/quote:e38c6037b1] Heb je deze ATI Installer HOWTO for SUSE/Novell users al gecheckt?
    [quote:e38c6037b1="vanaggelen"] Ook weet ik niet zeker welke bits-versie van SuSE ik heb, dit werd bij ATI gevraagd. IK heb een DVD SuSE 10 van de boekhandel van 'LINUX-Format'.[/quote:e38c6037b1] Je hebt de 32 bit versie.
  • [quote:8ab565fb6f="jolo"][quote:8ab565fb6f="vanaggelen"]Ik heb gisteren een ati-driver gedownload en het installeren lukt niet. Het blijkt een 'run' bestand te wezen (..) IK heb een DVD SuSE 10. [/quote:8ab565fb6f] Heb je deze ATI Installer HOWTO for SUSE/Novell users al gecheckt?
    [quote:8ab565fb6f="vanaggelen"] Ook weet ik niet zeker welke bits-versie van SuSE ik heb, dit werd bij ATI gevraagd. IK heb een DVD SuSE 10 van de boekhandel van 'LINUX-Format'.[/quote:8ab565fb6f] Je hebt de 32 bit versie.[/quote:8ab565fb6f]

    Bedankt zover!
    Groet,
    Ries
  • [quote:7385dc9c90="vanaggelen"][quote:7385dc9c90="jolo"][quote:7385dc9c90="vanaggelen"]Ik heb gisteren een ati-driver gedownload en het installeren lukt niet. Het blijkt een 'run' bestand te wezen (..) IK heb een DVD SuSE 10. [/quote:7385dc9c90] Heb je deze ATI Installer HOWTO for SUSE/Novell users al gecheckt?
    [quote:7385dc9c90="vanaggelen"] Ook weet ik niet zeker welke bits-versie van SuSE ik heb, dit werd bij ATI gevraagd. IK heb een DVD SuSE 10 van de boekhandel van 'LINUX-Format'.[/quote:7385dc9c90] Je hebt de 32 bit versie.[/quote:7385dc9c90]

    Bedankt zover!
    Groet,
    Ries[/quote:7385dc9c90]

    Hallo,

    Nou.. ja..?! ik ben er nog niet. Hoewel het er wel goed uitzag krijg ik nu in YAST2 >Hardware>Grafische kaart en monitor, de zaak niet open. Even een klokje en dat is het. En dan kan ik niks veranderen. Dan zit het niet goed! Eerder met andere Linux-jes gehad. Je zit zo in de problemen met dat spul.
    Groeten.
    Ries
  • open eens een terminal/konsole en typ [b:cf81386e69]sax2[/b:cf81386e69]

    Max
  • Ik heb allereerst de versie gecheckt en dat zit goed!
    Dan heb ik de 'ATI Installer HOWTO for SUSE/Novell users' erbij gepakt en vlgns. die gebruiksaanw. de stappen tot en met het aanmaken van een rpm bestand uitgevoerd.
    Er staat een keurig rpm bestand in m'n map (dat liep mooi!)
    Nu heb ik gisteren al een keer de driver ge-installeerd. Kan ik nu nog eens die rpm eroverheen installeren?
    Ik kijk ook nog even naar sax2 maar dan kan je m.i. dus alleen de kaart veranderen en waarom doet de grafische toenadering via Yast >Hardware>Grafische kaart en monitor het nog steeds niet.
    Hoop dat die rpm dat rechtzet, maar mag dat?
    Groetjes
  • [quote:05bffbdc52]waarom doet de grafische toenadering via Yast >Hardware>Grafische kaart en monitor het nog steeds niet.[/quote:05bffbdc52]
    Die start sax2 op.
    Waarom dat fout gaat weet ik niet, maar als je sax2 rechtstreeks kunt benaderen lijkt me dat op dit moment niet zo'n probleem
    met sax2 kun je de videokaart, monitor, toetsenbord en muis instellen.
  • sax2 kan ik wel opstarten.
    Bij de videokaart staat alles zoals het stond, ik word er niet veel wijzer van.
    In de HOWTO van ATI staat verder dat je dat driverinstaller pakket moet compileren met
    <bestandsnaam> .sh
    Dat is natuurlijk wat JOJO bedoelde maar dan andersom en aan compileren wil ik nog niet denken. Dat lijk me te ingewikkeld.
    Het valt dus niet te controleren of de driver goed geïnstalleerd is?
    Groet,
    Ries :roll:
  • Nou, heb je de driver nu wel of niet gecompileerd?

    Max
  • [quote:7919484828="vanaggelen"] Dat is natuurlijk wat JOJO bedoelde maar dan andersom en aan compileren wil ik nog niet denken. Dat lijk me te ingewikkeld.[/quote:7919484828] Zelfs ik weet even niet wat er bedoelt wordt. Behalve dan dat mijn user naam [b:7919484828] jolo [/b:7919484828] is.

    De instruckties in die link die ik gaf, waren toch niet helamaal volledig. Ik heb daarom een aanvullende link http://susehelp.l4l.be/suse/hardware/ati-radeon.html Ook op deze link heb ik een opmerking. In plaats van sudo kun je ook gewoon als root in loggen. Ook staat daar het sax2 commando
    [code:1:7919484828] sudo sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile[/code:1:7919484828][Enter] Daarvan in de plaats typ je alleen
    [code:1:7919484828] sax2 -r -m 0=fglrx [/code:1:7919484828][Enter] Ik heb deze drivers bij mij inmiddels met succes geinstalleerd, op een oude Pentium II 300 Mhz met 256 MB RAM met een Radeon 9000 in SuSE 10.
  • Max
    Zie bericht d.d. Di 03 jan 2006.

    Ik heb de Installer aan de praat gekregen die dag!
    Daarna volgde een welkomsscherm van ATI, en heb voor de meest logische opties gekozen.
    Da's alweer een paar dagen geleden en hoewel ik broodnuchter achter m'n pc zit heb ik helaas geen fotografich geheugen. Er is hier ook sprake geweest van een Display Driver voor X.Org 6.8
    Bij m'n beste weten heb ik daar voor gekozen. Toen volde nog een gestoei om onderin het scherm te komen wat onmogelijk was!!! Klote ATI!!!
    Als ik in mijn (van die installer) gemaakte rpm kijk en dat vergelijk met m'n schijf, zie ik wel ATI dingen maar b.v. een fglrx bestand (wat geloof ik te maken heb met compileren) zit er niet in. Pad: /user/lib/fglrx. Zit wel in de rpm.
    Ik kan nu: 1 de installer nog eens draaien (bericht 2 van boven) en met duidelijker info komen. Het word toch gewoon overgeschreven?
    2. Die 'rpm' proberen.

    Maar ja, het word dan toch compileren… en dat voor een beginner???.. ik heb al 2 wkn in het donker gezeten na de instalatie. en nu goed beeld. (huiverig)
  • Compileren is veel eenvoudiger dan met rpm's gaan zitten stoeien m.i. - ik geef er over het algemeen de voorkeur aan; in gemiddeld drie commando's heb je iets geinstalleerd. Weest niet bang voor dingen die je niet kent, het klinkt allemaal een stuk ingewikkelder dan het in feite is.
  • [quote:9ffd659a80="Tekkie"]Compileren is veel eenvoudiger dan met rpm's gaan zitten stoeien m.i. - [/quote:9ffd659a80]
    Mja, dat ben ik niet met je eens.
    Als je linux-installatie voldoet aan de verwachtingen van het compilatiescript, dan is het compileren/installeren inderdaad slechts 3 commando's (maar bij rpm is dat dan 1 commando).
    Voldoet je installatie niet aan de verwachting, dan moet je de onopgeloste afhankelijkheden 1 voor 1 oplossen.
    En je bent afhankelijk van de kwaliteit van het configuratiescript: soms loopt ./configure goed door het systeem heen, maar geeft make de nodige foutmeldingen waardoor het compileren alsnog mislukt…

    IMHO is het verstandiger om als leek met rpm te werken in combinatie met een pakketbeheerder die via internet/installatie-cd's eventuele afhankelijkheden kan oplossen.
  • [quote:664a6fafcd="vanaggelen"] Er is hier ook sprake geweest van een Display Driver voor X.Org 6.8. Bij m'n beste weten heb ik daar voor gekozen.[/quote:664a6fafcd] Deze? [code:1:664a6fafcd] fglrx_6_8_0-8.20.8-1.i386.rpm [/code:1:664a6fafcd] De 32 bit versie X.Org 6.8 rpm van 13.4 MB groot heb ik geinstalleerd. Die ATI Driver Installer van 68.8 MB groot, heb ik dus niet geprobeerd.
    [quote:664a6fafcd="maximilaan"] Als je linux-installatie voldoet aan de verwachtingen van het compilatiescript, dan is het compileren/installeren inderdaad slechts 3 commando's (maar bij rpm is dat dan 1 commando). [/quote:664a6fafcd] Eigenlijk compileert die fglrx_6_8_0-8.20.8-1.i386.rpm van ATI ook. Want er staat toch niet voor niks in die SuSE Help site dat de volgende pakketten geinstalleerd worden:
    [code:1:664a6fafcd]
    kernel-source

    gcc

    glibc-devel
    [/code:1:664a6fafcd] Dat compileren gebeurd als het goed is, automatisch nadat de rpm geinstalleerd is. En ook staat in die SuSE Help site dat het voor het installeren van die rpm de grafische moet worden verlaten met het init 3 commando. Zelf adviseer ik de pc te herstarten. Bij de SuSE bootmenu te drukkenn op F2 en te typen [code:1:664a6fafcd] init 3 [/code:1:664a6fafcd][Enter] En al helemaal als het is om een mislukte rpm installatie overnieuw te doen.
    [quote:664a6fafcd="vanaggelen"] Als ik in mijn (van die installer) gemaakte rpm kijk en dat vergelijk met m'n schijf, zie ik wel ATI dingen maar b.v. een fglrx bestand (wat geloof ik te maken heb met compileren) zit er niet in. Pad: /user/lib/fglrx. Zit wel in de rpm. [/quote:664a6fafcd] Maar als je die rpm installeert, dan komem deze in
    [code:1:664a6fafcd] /lib/modules/fglrx [/code:1:664a6fafcd] Als er daarna niet automatiche gecompileerd wordt, cd je naar de map [code:1:664a6fafcd] /lib/modules/fglrx/built_mod [/code:1:664a6fafcd] Daar geef je het commando [code:1:664a6fafcd] sh make.sh [/code:1:664a6fafcd][Enter] Het is best mogelijk dat er enige Warnings en wellicht een Error getoond worden. De instrucktie wat je moet doen wordt getoond. Dus terug CDen naar [code:1:664a6fafcd] /lib/modules/fglrx [/code:1:664a6fafcd] voor het commando [code:1:664a6fafcd] sh make_install.sh [/code:1:664a6fafcd][Enter] Bij deze commando zouden geen foutmeldingen behoren te worden getoond. Bij mij werd deze output getoond
    [code:1:664a6fafcd]
    - creating symlinks
    - recreating module dependency list
    - trying a sample of the kernel modules
    done.
    [/code:1:664a6fafcd]
    Waarna dus nog steeds in tekst modus commando[code:1:664a6fafcd] sax2 -r -m 0=fglrx [/code:1:664a6fafcd][Enter] Voordat = staat overigens het cijfer nul.

    Als bij het herinstalleren van de rpm de melding verschijnt, dat deze al geinstalleerd is, gebruik je de force optie
    [code:1:664a6fafcd] rpm -Uvh –force fglrx_6_8_0-8.20.8-1.i386.rpm [/code:1:664a6fafcd][Enter]
  • O.K. Jolo,
    Ik ben ook geen 'chicken'. En vlgns. mij kan het ook niet veel slechter worden.
    Heb trouwens het dikke pakket gedownload van +/- 70 MB.
    Je aanwijzingen heb ik opgescheven en tezamen met die HOWTO en die andere welke ik uitgeprint heb moet het lukken.
    Wie niet waagt die niet wint, zeggen ze toch!
    Ik neem een duik in het diepe

    :wink:

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.