Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Nieuwe Ubuntu Install: "Failed to start X server"

maximilaan
4 antwoorden
  • Hallo Mensen,

    Voor de allereerste keer installeer ik Ubuntu op mijn nieuwste pc. Na wat problemen met cd's die niet werkten en amd's cool and quiet (nu disabled) heb ik Ubuntu eindelijk goed geinstalleerd. :)

    Maar dan, "Faild to start X server". En dan een login prompt. Geen mooi inlogscherm en Gnome desktop.

    Als ik kies voor een "x server output" te bekijken zie ik daar ongeveer in het midden staan "Fatal server error: no screens found".

    Mijn systeem ziet er als volgt uit:

    Amd64
    1 gig dual channel geheugen
    DFI mobo met Nforce 4 ultra chipset
    Ati x800 gt 256mb PCI-E
    17" TFT

    Iemand een oplossing, of in ieder geval iets wat mij in de juiste richting stuurt?

    Alvast bedankt,
  • [quote:ae01d43b9a="CompuSmurf"]Hallo Mensen,

    Voor de allereerste keer installeer ik Ubuntu op mijn nieuwste pc. Na wat problemen met cd's die niet werkten en amd's cool and quiet (nu disabled) heb ik Ubuntu eindelijk goed geinstalleerd. :)

    Maar dan, "Faild to start X server". En dan een login prompt. Geen mooi inlogscherm en Gnome desktop.
    [knip]
    [/quote:ae01d43b9a]
    Lukt het je dan ook als root in te loggen in dat terminal scherm?
    Dan kun je tenminste wat.
    Kennelijk is de automatische instelling van je video-kaart door Ubuntu mislukt.
    Video kaart een te nieuw type? dit komt vaak voor bij Linux. Indien dit zo is,
    dan lost het probleem zich na enige tijd wel op.
    Google eens wat rond met je "<type videokaart> Linux" om een geschikte linux driver voor je ATI kaart te vinden (en hoe die te installeren). Het kan nutig zijn de nieuwste kernel te compileren en te installeren.
    Kort gezegd: je file /etc/X11/xorg.conf deugt niet.
    Je stelt dat in met het proggie /usr/X11/bin/xorgconfig
    In zoverre een draak van een proggie, dat je helemaal opnieuw moet beginnen als je een typefout maakt, maar het werkt altijd, in tegenstelling tot de andere instel-proggies, die onder X werken (dat heb je dus nog niet).
    Wellicht kun je voor de VESA optie gaan als het niet lukt.
    Hopelijk heb je iets aan deze aanwijzingen. Heb zelf geen ATI video-kaart.
  • Had ati niet zelf een Linux driver te downloaden staan op hun website?
  • ok, bedankt voor de antwoorden :)

    ben al stukken verder nu, ik heb de kaart als vesa ingesteld en kan grafisch werken. Ik moert nu nog even uitzoeken hoe het met de ati drivers werkt

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.