Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[linux-newbie] installeren

jasperlevink
15 antwoorden
  • Hallo mensen.

    Ik heb GCC uitgepakt op mijn linuxserver (in een eigen map in /bin/). Als ik de configuratie uitvoer (./configure in de map waar ik GCC heb uitgepakt) krijg ik de volgende fout:
    cat: ./BASE-VER: No such file or directory
    configure: error: cannot find install-sh or install.sh in . ./.. ./../..

    Ik weet niet helemaal wat het betekend en wat ik er er aan moet doen.

    Groeten.
    Jasper
  • Welke Linux versie gaat het om? (distro) In alle versies heb je pakketbeheertooltjes (apt-get in Debian en -achtigen, Yast in Suse) die dit soort taken voor je uitvoeren.
  • Enneeh..over het algemeen is het niet gebruikelijk om bestanden "uit te pakken naar /bin/" - als je iets wilt uitpakken om te installeren, compileren of iets anders doe je dat in je homedirectory.
  • en yum voor fedora>>> yum update

    duidelijke titel trouwens
  • Als ik help intik krijg ik:
    GNU bash, version 2.05b.0(1)-release (i386-redhat-linux-gnu).
    Ik werk remote via Putty.

    Misschien vinden jullie t raar dat ik niet weet op wat voor systeem ik aan t werken ben: Ben voor een vriend wat aan het programmeren in PHP en wilde mcrypt installeren. Daarvoor was een C-compiler nodig maar deze was nog niet geïnstalleerd. Dat probeer ik nu te doen…

    Thanks.

    ps. sorry voor de titel
  • Ok, geen probleem. Geef eens het commando[code:1:4cd10ddc72]whereis apt yast yum[/code:1:4cd10ddc72]en post het resultaat in dit draadje. Als het systeem 1 van deze pakkettooltjes kent zal je een melding terug krijgen, anders blijft het veld leeg. Dit gaat natuurlijk alleen als je rootrechten hebt op dat systeem (maar aangezien je wat wilt installeren zal dat naw geen probleem zijn)
  • Ik krijg dit resultaat:

    # whereis apt yast yum
    apt:
    yast:
    yum:
    #
  • Doe eens een
    cat /etc
    edhat-release
    Dat kunnen we zien welke redhat versie je gebruikt. Als het (zo te zien aan je bash versie ) 7.1 is, kun je hier een rpm halen voor rh 7.1 met mcrypt; http:/
    pms.troels.arvin.dk/libmcrypt/
  • Red Hat Enterprise Linux AS release 3 (Taroon Update 4)
    AS is versie 9 toch?

    Daarvan staat op de site die je noemt geen rpm…
    Ik heb deze geprobeerd:
    http://dag.wieers.com/packages/libmcrypt/libmcrypt-2.5.7-1.dag.rh90.i386.rpm

    (vind m sowieso nogal klein (100kb))

    vervolgens heb ik in / uitgevoerd:
    rpm -Uhv libmcrypt-2.5.7-1.dag.rh90.i386.rpm

    Maar hij werkt nog niet…
  • 100kb is best mogelijk. Maar wat de output was van je rpm commando dat je hierboven beschrijft is veel belangrijker. Was het succesvol of faalde de installatie?
  • Dit is de output:
    warning: libmcrypt-2.5.7-1.dag.rh90.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
    Preparing… ########################################### [100%]
    1:libmcrypt ########################################### [100%]
  • Dan is hij dus geinstalleerd. En wat wil je er nu mee? Zou je de vraag ook niet beter kunnen stellen op een php forum? Ik bijvoorbeeld heb geen idee wat je ermee wilt, of wat het is.
  • Hmm, deze vraag loopt ook op het nedlinux-forum..

    Max
  • klopt. was eigenlijk niet de bedoeling. sorry..
  • Het lijkt me dat je nu nog een PHP module moet installeren om er gebruik van te gaan maken. BTW. Als het server OS netjes via Red Hat network is geinstalleerd kun je ook met up2date software installeren, bijv:

    [code:1:d546e7ad4c]
    up2date-nox <packagenaam>
    [/code:1:d546e7ad4c]

    Niet zo comfortabel als YUM. maar het werkt :). Voor een volledige lijst van opties zie [b:d546e7ad4c]man up2date[/b:d546e7ad4c]. Overigens is RHEL3 op Red Hat 9 gebaseerd, maar het is geen Red Hat 9 (!).

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.