Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Ubuntu Repositories fout (?)

None
4 antwoorden
  • Hallo mensen, ik ben sinds kort "veroordeeld" tot Linux, nou zit ik daar niet zo mee…ik zit alleen met het feit dat ik een ontzettende linux n00b ben…en ik dit probleempje ff niet kan oplossen.

    Ok, ik denk dat ik een fout heb gemaakt tijdens het manueel veranderen van mijn repositories "sources.list", want als ik het "apt-get update" commando geef kotst de terminal een zooi tekst met onderaan een lijstje van die "W: Coudln't stat source……."met als laatste dit:
    [code:1:1c34ea4540]
    W: Couldn't stat source package list http://ubuntu-backports.mirrormax.net hoary-backports
    estricted Packages (/var/lib/apt/lists/ubuntu-backports.mirrormax.net_dists_hoary-backports_restricted_binary-amd64_Packages) - stat (2 No such file or directory)
    W: You may want to run apt-get update to correct these problems
    E: Some index files failed to download, they have been ignored, or old ones used instead.
    duckman@ubuntu:~$
    [/code:1:1c34ea4540]
    De oplossing is vast dood eenvoudig…op het stupide af….maar ja ik weet hem niet en heb hem nog kunnen googlen…(btw ik gebruik ubuntu 5.10)

    Dus een beetje help van de l33t h4x0r5….

    thx,

    Drew.

    [i:1c34ea4540]edit;
    Ik heb een backup gevonden in de folder met de sources.list van voor mijn geklooi. Heb nu weer aangepast en het lijkt te werken….alleen niet het prog waar ik de repositories voor had aangepast. Nvidia drivers instaleren, als ik de installer start (sudo sh NVIDIA-Linux-x86_64-1.0-8756-pkg2.run) zeikt ie dat ie niet "system utility `ld`" kan vinden, whatever dat is.

    edit2:
    Dit heb ik ook op kunnen lossen, moest een ander progje instaleren…alleen nu zeikt de instaler dat ik eerst uit de x-server moet voor de instaler wil werken. Nou hoorde ik dat ik met ubuntu niet naar "init 3" kan ofzo. Wat ik dus moet hebben is een command line en de x-server afgesloten….help? :(
    [/i:1c34ea4540]
  • [quote:06a65f2e40="Drewster"]Wat ik dus moet hebben is een command line en de x-server afgesloten….help? :(
    [/quote:06a65f2e40]
    <Control>+<Alt>+<F1> tegelijk drukken. Vervolgens inloggen op die console en "sudo /etc/init.d/gdm stop" intikken.
  • [quote:24ca7c314c="Drewster"]W: Couldn't stat source package list http://ubuntu-backports.mirrormax.net hoary-backports
    estricted Packages (/var/lib/apt/lists/ubuntu-backports.mirrormax.net_dists_hoary-backports_restricted_binary-amd64_Packages) - stat (2 No such file or directory)
    W: You may want to run apt-get update to correct these problems
    E: Some index files failed to download, they have been ignored, or old ones used instead.
    duckman@ubuntu:~$



    Ik heb een backup gevonden in de folder met de sources.list van voor mijn geklooi. Heb nu weer aangepast en het lijkt te werken….alleen niet het prog waar ik de repositories voor had aangepast. Nvidia drivers instaleren, als ik de installer start (sudo sh NVIDIA-Linux-x86_64-1.0-8756-pkg2.run) zeikt ie dat ie niet "system utility `ld`" kan vinden, whatever dat is.

    [/quote:24ca7c314c]

    Check nog even je sources.list dat er geen 'Hoary' meer in voorkomt. Je gebruikt versie 5.10 en dat is breezy. Het mixen van repositories kan problemen opleveren. Die mirrormax repo moet er dus uit.

    Check hier voor een automatische sources.list generator:

    http://www.ubuntulinux.nl/source-o-matic

    Verder hoef je niet per se handmatig de nvidia drivers te installeren. Als je de juiste repositories in je sources.list hebt staan kun je via apt met:

    [code:1:24ca7c314c]sudo apt-get update
    sudo apt-get install nvidia-glx
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup ##voor de zekerheid maak je hier een backup van je xorg.conf
    sudo nvidia-glx-config enable[/code:1:24ca7c314c]

    de nvidia-driver installeren.

    Wel even uitloggen (of rebooten) om X opnieuw op te starten.

    succes.
  • Ik wilde persee de nieuwste drivers….maar ik geloof dat ik voor elkaar heb, het uitzetten van x was niet genoeg ik moest ook een of andere kernel ophalen, heb een site kunnen vinden die het stap voor stap uitlegt….heb hier alleen niet de link…

    Was ook vergeten te vertellen dat ik de 64 bit versie heb, wat me bezield heeft die op te halen ipv de 32 I don't know maar ik ga zo snel mogelijk de 32 bit versie ophalen. Ik wordt helemaal gek van al die shit die niet werkt op de 64 bit versie, bv RAR ondersteuning, heeeeeeeel irritant. Heb een beetje het gevoel alsof ik met een beta releas bezig ben, heb me gister behoorlijk op zitten eten erover toen ik er mee bezig was en het niet lukte.

    iig bedankt voor de hulp,

    Drew

    [i:029b706037]edit: dit is trouwens de link naar de site met een redelijk, zeg maar behoorlijk, uitgebreide uitleg over het instaleren van de NVIDIA drivers. Ook al was ik er nog net iets blijer mee geweest als er ook bij had gestaan wat je bij elke handeling nou precies aan het doen was…

    Edit 2; heb mijn repositories aangepast door gebruik te maken van source-o-matic op de ubuntu site….had iemand ook wel ff wat eerder kunnen vertellen btw….oh ja heb ook maar de 32 bit versie eropgezet…misschien heeft dat ook geholpen…
    [/i:029b706037]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.