Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

/ read only gemount ; HD kapot?

Anoniem
None
16 antwoorden
  • Hoi,

    na een korte tijd "vreemde" dingen op mijn Suse 10 install (pc hing, kon geen terminal openen enzo) kreeg ik gisteren ineens een heel brakke startup en kwam ik erachter dat / als "read only" was gemount. ctrl-alt-F10 gaf telkens herhalend de fout:
    [code:1:627b90b025]
    kernel: ata3 : status=0x51 (DriveReadySeekComplete Error)
    kernel : ata3 : error=0x40 (uncorrectable error)
    kernel : ata3 : end_request : I/O error, dev sda , sector 16263066
    [/code:1:627b90b025]
    fsck geeft geen verbetering. Gelukkig staat /home op een andere partitie die wel correct wordt gemount, maar ik vetrouw het niet.
    [list:627b90b025]is dit te herstellen?
    is formatteren en herinstalleren een oplossing?
    is mijn HD kapot aan het gaan?
    hoe kan ik het beste veilig stellen wat er nog te redden is?
    [/list:u:627b90b025]
    De pc is net nieuw, dus nog met garantie. Is 1 kapotte sector voldoende om vervanging te eisen?
  • [quote:b179e08fc0]De pc is net nieuw, dus nog met garantie. Is 1 kapotte sector voldoende om vervanging te eisen?[/quote:b179e08fc0]
    Da's vaak het begin van het einde. Ik zou idd een andere schijf eisen.
    Dat suse de schijf readonly mount, daarover moet ook iets te lezen zijn in de bootmessages. Start suse eens op en druk op [esc] om die bootmessages te volgen, of voer het commando [b:b179e08fc0]more dmesg[/b:b179e08fc0] uit in een console en kijk of je daar meldingen tegenkomt met betrekking tot het readonly mounten van de schijf.

    Rinse
  • Tijdens het booten gaat het te snel om te volgen, en dmesg lezen lukte niet. Maar wellicht kwam dat omdat ik toen nog in init5 startte; ik zal vanavond eens proberen.
    (Hoewel vlgs mij iedere keer booten de zaak verergert…)
  • Het is niet nodig om het tijdens het booten te doen, je kunt altijd nog daarna dmesg gebruiken, of /var/log/messages bekijken ;)
  • [quote:cd11e11cc7="rolfb"]
    (Hoewel vlgs mij iedere keer booten de zaak verergert…)[/quote:cd11e11cc7]
    mocht er data op die schijf staan, snel backuppen!!
    Heb zelf gehad dat ik 40 gig aan data kwijt was vlak voordat ik door had dat de schijf kapot was..
  • Ben al aan het bedenken hoe ik dat het beste kan doen;
    18 gig op dvd-tjes branden is niet echt handig.
    Laptop van de vrouw draait windoos, en ik neem aan dat backuppen naar ntfs alle file-permissies vern**kt.(?) "Effe" een externe HD kopen vind ik ook zo duur.
    Kortom: uiteraard snel backuppen, maar moet nog bepalen hoe…
  • koop een 2e interne HD :)
    of hang de kapotte HD in een andere pc en blaas de 18 gig over naar diens schijf.

    of zet een netwerkje op oid.
    Evt permissies kun je behouden door alle bestanden met tar te verpakkken.
    kijk even welk tar-commando de permissies behoudt

    Verder zie ik weinig problemen met permissies van documenten (die stellen niet zoveel voor).
    op het moment dat je iets terugkopieert naar de linux-schijf krijgen de documenten de gebruikelijke permissies terug.
  • helaas heb ik maar 1 pc met SATA, dus schijf omhangen wordt 'm niet.
    Maar ik denk dat ik nog wel een IDE schijf heb die ik er effe in kan knopen…
  • [quote:77669dbba2="rolfb"]kreeg ik gisteren ineens een heel brakke startup en kwam ik erachter dat / als "read only" was gemount. ctrl-alt-F10 gaf telkens herhalend de fout:
    [code:1:77669dbba2]
    kernel: ata3 : status=0x51 (DriveReadySeekComplete Error)
    kernel : ata3 : error=0x40 (uncorrectable error)
    kernel : ata3 : end_request : I/O error, dev sda , sector 16263066
    [/code:1:77669dbba2][/quote:77669dbba2] Die bovenste regel van die foutmelding heb ik ook al eens gehad in deze discussie. Maar dat was wel gewoon read/write. Hoe ik deze foutmelding ben kwijt geraakt, weet ik niet meer. Die harde schijf uit die discussie gebruik ik nog steeds.

    Had je dat / als "read only" was gemount gecheckt via commando
    [code:1:77669dbba2] cat /proc/mounts [/code:1:77669dbba2][Enter]
    [quote:77669dbba2="rolfb"]De pc is net nieuw, dus nog met garantie. Is 1 kapotte sector voldoende om vervanging te eisen?[/quote:77669dbba2] Dat zou voldoende kunnen zijn. Heb je die harde schijf dan al getest met de diagnostische software van de harde schijf fabrikant?
    [quote:77669dbba2="Gentoo_Kip"] Het is niet nodig om het tijdens het booten te doen, je kunt altijd nog daarna dmesg gebruiken, of /var/log/messages bekijken[/quote:77669dbba2] Maar als / bij de TS wordt gemount als "read only", hoe wordt er dan geschreven naar /var/log/messages?

    [quote:77669dbba2="rolfb"]Ben al aan het bedenken hoe ik dat het beste kan doen;
    18 gig op dvd-tjes branden is niet echt handig. (..) "Effe" een externe HD kopen vind ik ook zo duur. [/quote:77669dbba2] Een externe HD lijkt anders wel de beste optie. Bovendien als je al een reserve HD hebt liggen, is de aanschaf van een externe HD case voldoende. Zie ook deze gathering-tweakers discussie over [Ervaringen] Externe harde schijven en behuizingen.
  • [quote:82cccbc026]Dat zou voldoende kunnen zijn. Heb je die harde schijf dan al getest met de diagnostische software van de harde schijf fabrikant? [/quote:82cccbc026]
    Heb vd site van maxtor een diagnostisch dingetje gedownload (ISO-file) en op een cd gebrand (ja, bootable gemaakt), maar die vindt mijn schijf helemaal niet. Ligt kennelijk aan de nvidia chipset begrijp ik…
    Heb gebeld met de winkel; er ligt al een nieuwe schijf voor me klaar.
    Ook al zou ik het met een reformat op kunnen lossen; het gevoel een slechte schijf te hebben zal me altijd blijven achtervolgen, dus ik ga maar voor de vervanging. Complete re-install en (erger) herinrichting heb ik sowieso toch… :cry:
  • Als je de 2e schijf hebt ingebouwd zou je met bv een Knoppix cd je hele oude schijf naar de nieuwe kunnen kopiëren met het dd commando:[code:1:98a79cfba7]dd if=<pad/naar/oude_schijf> of=<pad/naar/nieuwe_schijf>[/code:1:98a79cfba7]Zie ook de manpages van dd :)
  • Maar dd kopieert ook de lege sectors. Ligt het dan niet meer voor de hand dat de TS het probeert met Part Image? Part Image is ook op een Knoppix Live CD. Check hierover ook dit artikel over Knoppix: Systeem- en netwerktools in PDF formaat.
  • heb ik ook wel eens gehad..
    gewoon partitie opnieuw formateren was de oplossing, nooit meer last van gehad.

    bijv:

    mk2fs -j /dev/ice for ext3
    mkreiserfs /dev/ice for reiserfs
  • [quote:561a843bff]
    Als je de 2e schijf hebt ingebouwd zou je met bv een Knoppix cd je hele oude schijf naar de nieuwe kunnen kopiëren met het dd commando:[/quote:561a843bff]
    Helaas betreft het geen 2e schijf, maar een vervangende schijf. Heb dus geen moment dat ik beide schijven gelijkertijd in de pc heb zitten….

    [quote:561a843bff]
    heb ik ook wel eens gehad..
    gewoon partitie opnieuw formateren was de oplossing, nooit meer last van gehad.
    [/quote:561a843bff]

    Ik denk dat ik toch altijd het gevoel zou blijven houden een "slechte" schijf te hebben. Je leest zovaak dat 1 rotte sector de opmaat is voor een heleboel volgende…
    Anyway, dank voor het meedenken. Inmiddels heb ik alles dat van belang is op DVD (Ja, ook ik val in de categorie "pas goed over backups gaan nadenken als het zich voordoet…";), en heb ik me erbij neergelegd dat ik moet reïnstallen…
  • [quote:bd752571bb="rolfb"]
    Helaas betreft het geen 2e schijf, maar een vervangende schijf. Heb dus geen moment dat ik beide schijven gelijkertijd in de pc heb zitten….
    [/quote:bd752571bb]
    Je hebt hoe dan ook 2 schijven, de oude en de nieuwe ;)
    En een beetje leverancier staat het je toe om de data van de oude naar de nieuwe te kopiëren…

    Max
  • Ben inmiddels weer een beetje op orde met mijn nieuwe HD, maar krijg helaas telkens fouten dat klauncher niet werkt…
    (Maar daar zal ik een nieuwe topic voor starten met de juiste probleem-omschrijving.)
    Iedereen dank voor het meedenken!

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.