Vraag & Antwoord

OS Linux

Kan driver niet verwijderen / installeren

4 antwoorden
  • Hallo,.. Na de installatie van OpenSuse 10.1 heb ik de printerdriver geïnstalleerd voor de Brother HL1430. Deze gaf echter wat foutmeldingen bij de installatie. Nu heb ik begrepen dat het updaten in 10.1 met Yast en Zen nogal problematisch is. Daarom heb ik Smart geïnstalleerd voor de installatie van pakketjes. Echter het probleem is nu dat ik de brother driver niet kan installeren. Het systeem geeft aan dat deze al is geïnstalleerd. Wanneer ik deze echter wil verwijderen is dit niet mogelijk omdat een aantal bestanden ontbreken. Kortom: ik heb iets wat ik er niet kan afgooien, maar ook niet kan repareren door de nieuwe versie opnieuw te installeren... Heeft iemand een idee hoe ik de printerdriver kan installeren?
  • [quote:e772f82f23="barbatruuk"]Na de installatie van OpenSuse 10.1 heb ik de printerdriver geïnstalleerd voor de Brother HL1430. Deze gaf echter wat foutmeldingen bij de installatie. [/quote:e772f82f23] Hoe had je deze geïnstalleerd? Gebruikelijk gaat dat via Yast > Hardware > Printer. Daar zouden printers verwijderd en toegevoegd kunnen worden. Het valt me trouwens op dat bij Printermodel bij fabrikant Brother, dat bij Model HL-1430 in het lijstje staat. (Van openSuSE 10.0) [quote:e772f82f23="barbatruuk"]Nu heb ik begrepen dat het updaten in 10.1 met Yast en Zen nogal problematisch is. Daarom heb ik Smart geïnstalleerd voor de installatie van pakketjes.[/quote:e772f82f23] Welke pakketten? [quote:e772f82f23="barbatruuk"]Wanneer ik deze echter wil verwijderen is dit niet mogelijk omdat een aantal bestanden ontbreken. [/quote:e772f82f23] Welke bestanden?
  • [quote:12b1254681="jolo"][quote:12b1254681="barbatruuk"]Na de installatie van OpenSuse 10.1 heb ik de printerdriver geïnstalleerd voor de Brother HL1430. Deze gaf echter wat foutmeldingen bij de installatie. [/quote:12b1254681] Hoe had je deze geïnstalleerd? Gebruikelijk gaat dat via Yast > Hardware > Printer. Daar zouden printers verwijderd en toegevoegd kunnen worden. Het valt me trouwens op dat bij Printermodel bij fabrikant Brother, dat bij Model HL-1430 in het lijstje staat. (Van openSuSE 10.0) [quote:12b1254681="barbatruuk"]Nu heb ik begrepen dat het updaten in 10.1 met Yast en Zen nogal problematisch is. Daarom heb ik Smart geïnstalleerd voor de installatie van pakketjes.[/quote:12b1254681] Welke pakketten? [quote:12b1254681="barbatruuk"]Wanneer ik deze echter wil verwijderen is dit niet mogelijk omdat een aantal bestanden ontbreken. [/quote:12b1254681] Welke bestanden?[/quote:12b1254681] Nee... ik heb de hl1430lpr-1.1.2-1.i386.rpm gedownload van de brother website. (http://solutions.brother.com/linux/sol/printer/linux/lpr_drivers.html). Deze kon ik openen met de Software Installer. Dit is wat ik krijg als ik de software wil verwijderen: [code:1:12b1254681] pc:/home/mart/Desktop # smart remove hl1430lpr Loading cache... Updating cache... ######################################## [100%] Computing transaction... Removing packages (1): hl1430lpr-1.1.2-1@i386 81.2kB will be freed. Confirm changes? (Y/n): y Committing transaction... Preparing... ######################################## [ 0%] /var/tmp/rpm-tmp.27916: line 1: /usr/local/Brother/inf/setupPrintcap: Onbekend b estand of map error: %preun(hl1430lpr-1.1.2-1.i386) scriptlet failed, exit status 127 Saving cache... [/code:1:12b1254681] Dit bestand is echter wel aanwezig: [code:1:12b1254681] pc:/usr/local/Brother/inf # ls -al totaal 20 drwxr-xr-x 2 root root 200 2006-08-24 22:44 . drwxr-xr-x 4 root root 96 2006-08-24 22:44 .. -rw-r--r-- 1 root root 550 2004-02-03 10:24 brHL1430func -rw-r--r-- 1 root root 165 2004-02-03 10:24 brHL1430rc -rw-r--r-- 1 root root 408 2004-02-03 10:24 brPrintList -rw-r--r-- 1 root root 215 2004-02-03 10:24 paperinf -rwxr-xr-x 1 root root 1623 2004-02-03 10:24 setupPrintcap [/code:1:12b1254681] [/code]
  • [quote:74f4b912fa="barbatruuk"]ik heb de hl1430lpr-1.1.2-1.i386.rpm gedownload van de brother website. [/quote:74f4b912fa] Bedoel je dat zonder deze driver niet werd herkend? En heb je de driver al geprobeerd te verwijderen als superuser via commando [code:1:74f4b912fa] rpm -e hl1430lpr [/code:1:74f4b912fa][Enter]

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.