Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Grub niet te installeren met Suse 10.2

Prin0096
5 antwoorden
  • Geachte forumgenoten.
    Ik heb opensuse 10.2 gedownload en ik probeer hem te installeren. Alles gaat goed, behalve het installeren van de GRUB.
    Tijdens installatie van Linux geeft hij al aan dat hij een Error 23: Error while parsing number heeft.
    Het gegenereerde commando wat gebruikt wordt is
    [code:1:b93a92e0b7]setup –stage2=/boot/grub/stage2 (hd0) (/dev/hdc,0)[/code:1:b93a92e0b7]
    Hierop wordt de error 23 gegeven.

    Na installatie opnieuw geboot met de DVD en het systeem geboot, maar de GRUB is niet te installeren op de bootsector van hdc (een 60 GB IDE schijf)
    Wie weet raad?
  • [quote:20c4bba049="Prin0096"]Ik heb opensuse 10.2 gedownload en ik probeer hem te installeren. (..) behalve het installeren van de GRUB. (..) Hierop wordt de error 23 gegeven [/quote:20c4bba049] Je zou openSuSE dan nog wel kunnen opstarten via de SuSE dvd. Start de pc op via openSuSE dvd. Selecteer Installation > Bij Installation Mode klik je op Other > Boot installed System OK. Als het partition or System to Boot dialoog verschijnt, selecteer je de partitie waarop openSuSE 10.2 op geïnstalleerd is, en Boot.

    Het zou kunnen dat SuSE dan niet grafisch opstart. Log dan in als root. Zodat je via het grub-install commando, grub opnieuw kunt installeren. Indien GRUB hier weer een foutcode geeft, post dan eventueel de output van commando [code:1:20c4bba049] fdisk -l [/code:1:20c4bba049][Enter] Een andere mogelijkheid wordt geboden op http://www.linuxquestions.org/questions/showthread.php?p=2347410#post2347410 Waarbij je dan in plaats van /dev/hda6 de root partitie van jouw openSuSE installatie typt.
  • Ik heb het systeem daarna geboot met de DVD en vervolgens de geinstalleerde partitie opgestart.
    Een GRUB install gaf hier dezelfde fout (error while parsing number)

    Na de kerstdagen ga ik de tweede suggestie van je proberen.
    Alvast bedankt!
  • Het heeft allemaal niet geholpen. Ik blijf de fout houden.
    Zie output fdisk -l. Hdc1 is de linux root partitie. hdc2 is de swap, hdc3 is gemount op de /home directory.
    [code:1:cac3a27276]linux-rob:~ # fdisk -l

    Disk /dev/hdc: 61.4 GB, 61492838400 bytes
    255 heads, 63 sectors/track, 7476 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hdc1 * 1 1305 10482381 83 Linux
    /dev/hdc2 1306 1567 2104515 82 Linux swap / Solaris
    /dev/hdc3 1568 4830 26210047+ 83 Linux
    /dev/hdc4 4831 7475 21245962+ c W95 FAT32 (LBA)

    Disk /dev/hdd: 122.9 GB, 122942324736 bytes
    255 heads, 63 sectors/track, 14946 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hdd1 2 14946 120045712+ f W95 Ext'd (LBA)
    /dev/hdd5 2 14946 120045681 7 HPFS/NTFS

    Disk /dev/sda: 203.9 GB, 203928109056 bytes
    255 heads, 63 sectors/track, 24792 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 6527 52428096 7 HPFS/NTFS
    /dev/sda2 6528 24791 146705580 f W95 Ext'd (LBA)
    /dev/sda5 6528 24791 146705548+ 7 HPFS/NTFS

    Disk /dev/sdb: 203.9 GB, 203928109056 bytes
    255 heads, 63 sectors/track, 24792 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 6527 52428096 7 HPFS/NTFS
    /dev/sdb2 6528 24791 146705580 f W95 Ext'd (LBA)
    /dev/sdb5 6528 24791 146705548+ 7 HPFS/NTFS

    Disk /dev/dm-0: 203.9 GB, 203928108032 bytes
    255 heads, 63 sectors/track, 24792 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/dm-0p1 * 1 6527 52428096 7 HPFS/NTFS
    /dev/dm-0p2 6528 24791 146705580 f W95 Ext'd (LBA)
    /dev/dm-0p5 6528 24791 146705548+ 7 HPFS/NTFS

    Disk /dev/dm-1: 53.6 GB, 53686370304 bytes
    255 heads, 63 sectors/track, 6526 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    This doesn't look like a partition table
    Probably you selected the wrong device.

    Device Boot Start End Blocks Id System
    /dev/dm-1p1 ? 13578 119522 850995205 72 Unknown
    Partition 1 does not end on cylinder boundary.
    /dev/dm-1p2 ? 45382 79243 271987362 74 Unknown
    Partition 2 does not end on cylinder boundary.
    /dev/dm-1p3 ? 10499 10499 0 65 Novell Netware 386
    Partition 3 does not end on cylinder boundary.
    /dev/dm-1p4 167628 167631 25817+ 0 Empty
    Partition 4 does not end on cylinder boundary.

    Partition table entries are not in disk order

    Disk /dev/dm-2: 150.2 GB, 150226481664 bytes
    255 heads, 63 sectors/track, 18263 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    This doesn't look like a partition table
    Probably you selected the wrong device.

    Device Boot Start End Blocks Id System
    /dev/dm-2p1 ? 13578 119522 850995205 72 Unknown
    Partition 1 does not end on cylinder boundary.
    /dev/dm-2p2 ? 45382 79243 271987362 74 Unknown
    Partition 2 does not end on cylinder boundary.
    /dev/dm-2p3 ? 10499 10499 0 65 Novell Netware 386
    Partition 3 does not end on cylinder boundary.
    /dev/dm-2p4 167628 167631 25817+ 0 Empty
    Partition 4 does not end on cylinder boundary.

    Partition table entries are not in disk order
    linux-rob:~ #
    [/code:1:cac3a27276]

    Edit: Via de DVD de geinstalleerde partitie gestart, installatie afgemaakt en vervolgens met dit systeem de GRUB geinstalleerd.
    Dit ging zonder problemen :roll:
    Schiet mij maar lek, maar hij doet het :)
  • Dat wordt veroorzaakt door raid arrays. Gebeurt volgens mij ook als je niet boot van de array. De oplossing is om hem pas toe te voegen nadat je geinstalleert hebt.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.