Vraag & Antwoord

OS Linux

Kubuntu start niet meer op.

Anoniem
pjotr123
13 antwoorden
  • Sinds een korte periode gebruik ik Kubuntu 6.06.

    Helaas wil Kubuntu niet meer opstarten . Na het vragen van mijn wachtwoord lijkt het wel alsof de PC een runlevel omlaag gaat en de X-server herstart wordt. Vervolgens krijg ik weer mijn aanmeldings-window'tje waar ik opnieuw mijn wachtwoord in moet toetsen.


    Iemand enig idee? Alvast bedankt!
  • Probeer eens dit:
    Opstarten in beperkte herstelmodus (recovery mode). Dan in terminal intikken: startx (gevolg door Enter)

    Dan kom je, als het goed is, in een grafische omgeving waarin je problemen kunt opsporen.

    Alternatief:
    Wederom: opstarten in herstelmodus
    intikken: sudo dpkg-reconfigure xserver-xorg
    In de dan volgende vragenriedel telkens meefietsen met het voorgestelde antwoord, geen enkele eigen keuzes maken. Dat geeft het beste resultaat (foutje in progje).

    Daarna: sudo reboot

    Helpt dit?

    Groet, Pjotr.
  • Helaas, geen verschil.


    Met startx krijg ik de melding 'The process for the system protocol died unexpectedly' en 'Failes to connect to the SDP server (please make sure that sdpd is running: without it, other devices will not be able to find out which services your computer offers.).

    Als ik dit vervolgens weer af wil sluiten, krijg ik eerst de mededeling: 'error opening security policy file /etc/X11/xserver/SecurityPolicy', vervolgens 7 keer '(EE) xf86OpenSerial: Cannot open device /dev/wacom No such file or directory. Error opening /dev/wacom : No such file or directory'.

    Ik vermoed dat het probleem ontstaan is vanwege een tekort aan vrij geheugen. Inmiddels heb ik wat ruimte gemaakt.


    Wederom dank!
  • OK. En heb je het door mij geadviseerde alternatief ook al geprobeerd?

    Groet, Pjotr.
  • Jazeker, maar dat maakt geen verschil…
  • OK. Dan is een handmatige aanpassing van je xorg.conf aan de orde. De probleemregels hebben betrekking op Wacom devices. Die kun je uitschakelen.

    Doe nu eens dit:
    PC opstarten met de Kubuntu LiveCD.

    Dan in de xorg.conf op de harde schijf (en dus niet op de virtuele harde schijf van de LiveCD-sessie!) ploegen naar:
    /etc/X11/xorg.conf

    Open die xorg.conf met een simpel tekstverwerkertje (Kate).

    Ga nu naar het gedeelte over Wacom, en zet een # voor elke regel waar er nog geen voor staat. Zo schakel je de Wacomregels uit.

    Voorbeeld van het wacomdeel uit mijn eigen xorg.conf (ik heb er dus geen # voor staan):
    [code:1:0d47c459b1]
    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection
    [/code:1:0d47c459b1]

    Daarna herstart.

    Helpt dit?

    Groet, Pjotr.
  • …helaas… …inmiddels ben ik nog verder van huis…


    Als ik via de live-CD Kubuntu opstart kan ik niet bij mijn HD komen. Ik krijg de foutmelding dat de HD's ge-mounted moeten worden.


    Zodoende heb ik een console login gedaan en heb via 'sudo vi xorg.conf' de #-jes kunnen plaatsen.


    Als ik nu opstart krijg ik in eerste instantie de diverse meldingen dat van alles en nogwat geopend word (de gebruikelijke dingen), maar zodra mijn monitor een modus hogergeschakeld dient te worden (vlak voordat je in kunt loggen), gebeurt dit niet. Het enige wat ik nu zie is het Kubuntu-logo :-( Console login (of wat voor login dan ook) lukt dus ook niet meer…


    Nog enig idee? Wederom bedankt voor het meedenken.
  • Moeilijk…… ik weet het zo niet. Misschien kun je toch beter een schone herinstallatie doen?

    In dat geval: probeer eens de Gnomeversie (Ubuntu en niet Kubuntu); ik heb zelf het gevoel dat die iets robuuster in elkaar zit. Het vreselijke bruine thema kun je gewoon veranderen, gelukkig.

    De keuze voor 6.06 is een goede: dat is de LTS-versie, extra stabiel en betrouwbaar.

    Haal 'm hier:
    ftp://ftpserv.tudelft.nl/pub/Linux/releases.ubuntu.com/6.06/ubuntu-6.06.1-desktop-i386.iso

    Groet, Pjotr.
  • [quote:3f66b9f36a="pjotr123"]Moeilijk…… ik weet het zo niet. Misschien kun je toch beter een schone herinstallatie doen?

    In dat geval: probeer eens de Gnomeversie (Ubuntu en niet Kubuntu); ik heb zelf het gevoel dat die iets robuuster in elkaar zit. Het vreselijke bruine thema kun je gewoon veranderen, gelukkig.
    [/quote:3f66b9f36a]
    Dat is echt 10x onzin. De keuze van de DE heeft totaal geen invloed op de stabiliteit van Linux.
  • [quote:6d291627c7="eddein"]Helaas, geen verschil.


    Met startx krijg ik de melding 'The process for the system protocol died unexpectedly' en 'Failes to connect to the SDP server (please make sure that sdpd is running: without it, other devices will not be able to find out which services your computer offers.).

    Als ik dit vervolgens weer af wil sluiten, krijg ik eerst de mededeling: 'error opening security policy file /etc/X11/xserver/SecurityPolicy', vervolgens 7 keer '(EE) xf86OpenSerial: Cannot open device /dev/wacom No such file or directory. Error opening /dev/wacom : No such file or directory'.
    [/quote:6d291627c7]
    Op het forum van Ubuntu geven deze foutmeldingen zeer veel hits.
    http://www.ubuntuforums.org/search.php?searchid=13748975
  • [quote:4b253ab735="eddein"]Helaas, geen verschil.


    Met startx krijg ik de melding 'The process for the system protocol died unexpectedly' en 'Failes to connect to the SDP server (please make sure that sdpd is running: without it, other devices will not be able to find out which services your computer offers.).

    Als ik dit vervolgens weer af wil sluiten, krijg ik eerst de mededeling: 'error opening security policy file /etc/X11/xserver/SecurityPolicy', vervolgens 7 keer '(EE) xf86OpenSerial: Cannot open device /dev/wacom No such file or directory. Error opening /dev/wacom : No such file or directory'.
    [/quote:4b253ab735]
    Op het forum van Ubuntu geven deze foutmeldingen zeer veel hits.
    http://www.ubuntuforums.org/search.php?searchid=13748975
  • [quote:49ece27eee="Joris"]
    Dat is echt 10x onzin. [/quote:49ece27eee]

    Allemachtig. Dringend advies: overweeg eens een cursus sociale vaardigheden. Dat zal je veel gelukkiger maken.

    Inhoudelijk: ik heb zelf praktijkervaring met zowel Ubuntu als Kubuntu; ik praat dan ook nadrukkelijk vanuit mijn eigen indruk.
  • [quote:c1d365bb5d="pjotr123"][quote:c1d365bb5d="Joris"]
    Dat is echt 10x onzin. [/quote:c1d365bb5d]

    Allemachtig. Dringend advies: overweeg eens een cursus sociale vaardigheden. Dat zal je veel gelukkiger maken.

    Inhoudelijk: ik heb zelf praktijkervaring met zowel Ubuntu als Kubuntu; ik praat dan ook nadrukkelijk vanuit mijn eigen indruk.[/quote:c1d365bb5d]
    Kan tegen kritiek, vooral als je onzin verkoopt.
    Ubuntu, Xubuntu en Kubuntu zijn alledrie even robuust opgezet. Ze zijn alledrie namelijk precies dezelfde Linux distro's.
    Het kan zijn dat KDE slechter in Kubuntu is geïmplenteerd. Maar dan heeft KDE niks met de stabiliteit van Ubuntu te maken, maar met de kwaliteit van KDE.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.