Vraag & Antwoord

OS Linux

hardschijf toevoegen, server

24 antwoorden
  • ik draai hier een debian servertje. met 2 harde schijven, alleen hij ziet er maar 1 die van 4gig de grootere van 10gig ziet hij niet. nu kan ik hem toevoegen in webmin alleen dan is hij na restart weer weg :S hoe kan ik hem instellen dat hij bijde schijven ziet, en het liefst automatich door gaat op de andere als de ene vol is, want die van 4gig is bijna vol en ik draai wat websites er op. dus straks kunnen mijn gebruikers ineens niks meer uploaden. het zouw daarom wel handig zijn als die dan automatich de gegevens op de andere schijf zet. ik gebruikte eerst centos daar zag hij me andere hardeschijf wel :S
  • Heb je de nieuwe schijf toegevoegd aan het bestand /etc/fstab?
  • [quote:9df9ca0c21="maximilaan"]Heb je de nieuwe schijf toegevoegd aan het bestand /etc/fstab?[/quote:9df9ca0c21] hij zat er al in tijdens de instalatie maar ik heb daar niks toegevoegd nee dit staat er: [code:1:9df9ca0c21]# /etc/fstab: static file system information. # # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc defaults 0 0 /dev/hdc1 / ext3 defaults,errors=remount-ro 0 1 /dev/hdc5 none swap sw 0 0 /dev/scd0 /media/cdrom0 iso9660 ro,user,noauto 0 0 /dev/sda1 /disk2 ext2 suid,dev,exec 0 0[/code:1:9df9ca0c21] en die laaste regel disk2 heb ik een webmin gemaakt als ik het zo zie, maar hij doet het dus niet :S
  • Heb je ook een partitie gemaakt op die schijf en er een bestandssysteem opgezet (geformatteerd)?
  • [quote:908aa4f891="Tekkie"]Heb je ook een partitie gemaakt op die schijf en er een bestandssysteem opgezet (geformatteerd)?[/quote:908aa4f891] ja dat heb ik gedaan, nu ook nog is handmatig via een tut. maar als ik mount command doe krijg ik dit: [code:1:908aa4f891]mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so[/code:1:908aa4f891]
  • [quote:34f864ff0f="mats17"]maar als ik mount command doe krijg ik dit: [/quote:34f864ff0f] Welk commando was dat? Had je het geprobeerd via commando [code:1:34f864ff0f] mount -a [/code:1:34f864ff0f][Enter] En je had neem ik aan, die map /disk2 ook aangemaakt. Zou je eventueel de output kunnen posten van commando [code:1:34f864ff0f] cfdisk /dev/sda [/code:1:34f864ff0f][Enter]
  • [quote:dd53cafbd6="jolo"] [code:1:dd53cafbd6] cfdisk /dev/sda [/code:1:dd53cafbd6] [/quote:dd53cafbd6] [code:1:dd53cafbd6] matsserver:~# cfdisk /dev/sda cfdisk 2.12p Disk Drive: /dev/sda Size: 9173114880 bytes, 9173 MB Heads: 255 Sectors per Track: 63 Cylinders: 1115 Name Flags Part Type FS Type [Label] Size (MB) ------------------------------------------------------------------------------ sda1 Boot Primary Linux ext3 9171,19 [Bootable] [ Delete ] [ Help ] [Maximize] [ Print ] [ Quit ] [ Type ] [ Units ] [ Write ] Toggle bootable flag of the current partition [/code:1:dd53cafbd6] [quote:dd53cafbd6="jolo"] [code:1:dd53cafbd6] mount -a [/code:1:dd53cafbd6] matsserver:~# mount -a /dev/sda1 /mnt/sda1 na deze staat er in webmin 13gig ruimte ik ga nu even restarten [/quote:dd53cafbd6] EDIT: bij het opstarten geeft ie een foutmelding over de hardeschijf en moet in control-D drukken om verder te gaan
  • [quote:b12b491d27="mats17"]EDIT: bij het opstarten geeft ie een foutmelding over de hardeschijf en moet in control-D drukken om verder te gaan[/quote:b12b491d27] Dat kan gebeuren als er een fout staat in je /etc/fstab Waarom eigenlijk [code:1:b12b491d27] mount -a /dev/sda1 /mnt/sda1 [/code:1:b12b491d27] in plaats van [code:1:b12b491d27] mount -a [/code:1:b12b491d27] Als Debian niet meer wil starten, zou je nog moeten kunnen opstarten in recovery mode.
  • met mount -a krijg ik dit: [code:1:daa97db017] matsserver:~# mount -a mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so [/code:1:daa97db017]
  • Je hebt in je /etc/fstab staan; [quote:b003554872]/dev/sda1 /disk2 ext2 suid,dev,exec 0 0[/quote:b003554872] ext2 dus, terwijl in de output van cfdisk staat; [quote:b003554872]sda1 Boot Primary Linux ext3 9171,19[/quote:b003554872] ext3 dus - het zou waarschijnlijk wel schelen als je in je fstab ook ext3 zou zetten dus.
  • na het volgen van een tut is dat allemaal al aangepast, want toen heb ik die schijf geformateerd en gepationeerd als ext3 hij ziet er ondertussen zo uit(dus ook al voor het opnieuw opstarten): [code:1:7cdd77facf]# /etc/fstab: static file system information. # # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc defaults 0 0 /dev/hdc1 / ext3 defaults,errors=remount-ro 0 1 /dev/hdc5 none swap sw 0 0 /dev/scd0 /media/cdrom0 iso9660 ro,user,noauto 0 0 /dev/sda1 /mnt/sda1 ext3 default 2 1 [/code:1:7cdd77facf]
  • [quote:abb468ea48="mats17"][code:1:abb468ea48] /dev/sda1 /mnt/sda1 ext3 default 2 1 [/code:1:abb468ea48][/quote:abb468ea48] Misschien is het een overtiep fout, maar de optie "default" op die regel moet ook "defaults" zijn - met een "s" erachter - zoals in de regels erboven.
  • nu heeft het command mount -a geen foutmelding meer:) ook is in me control panel het aantal gig weer verhoogd zal nu weer even restarten
  • tijdens restart weer de zelfde fout, heb hem even overgeschreven omdat ik hem net niet kon vinden in een log. [code:1:07e57dbb9c]checking all file systems fsck 1.37 (21-ma-2005) fsck.ext3: No suck drives or adress while trying to open /dev/sda1 possibly not existent or swap device? fsck failed. please repair manaully[/code:1:07e57dbb9c]
  • Ziet ernaar uit dat de sata driver nog niet geladen is op het moment dat hij de disk probeert te mounten. Eigenaardig, meestal zit dat al in de initrd. Blijkbaar mag je die bij Debian zelf gaan toevoegen. Heb net op de volgende [url=http://xtronics.com/reference/SATA-RAID-debian-for-2.6.html]pagina[/url] de volgende instructies gevonden die je zou kunnen gebruiken; [code:1:1bcdff84df]edit /etc/mkinitrd/mkinitrd.conf and change: MODULES=most to ###MODULES=most MODULES=dep Now run #mkinitrd -o /boot/initrd.img-2.6.8-1-k7-smp-md 2.6.8-1-k7-smp[/code:1:1bcdff84df] Wel je de initrd filenamen en kernel versie aanpassen naar jouw versies.
  • ik heb [code:1:278b09a9ad]mkinitrd -o /boot/initrd.img-2.4.27-3-386 2.4.27-3-386[/code:1:278b09a9ad] gedaan( de file in me boot folder heet: initrd.img-2.4.27-3-386) en toen ging die een tijdje laden, en toen heb ik gereboot maar nog steeds te zelf fout :cry:
  • Een 2.4 kernel zelfs, da's vrij antiek. Ik vind het eigenlijk al een klein wonder dat je sata schijf werkt.. Misschien een optie om eens een upgrade te doen naar de nieuwe Debian 4.0 met 2.6 kernel, waarschijnlijk ben je dan ook direct van dit soort problemen af.
  • [quote:cdd2e92f9d="Tekkie"]Een 2.4 kernel zelfs, da's vrij antiek. Ik vind het eigenlijk al een klein wonder dat je sata schijf werkt.. Misschien een optie om eens een upgrade te doen naar de nieuwe Debian 4.0 met 2.6 kernel, waarschijnlijk ben je dan ook direct van dit soort problemen af.[/quote:cdd2e92f9d] ik heb deze debian laast nog van de site gedownload :S staat nu denk maandje op me server ofzoiets welke kan ik het beste nemen dan?
  • Slechte timing zullen we maar zeggen, Debian staan niet bekend om de vele releases (eens in de 2 jaar ofzo) maar toevallig is afgelopen 8 April de nieuwe versie "Debian Etch" uitgekomen. Waarschijnlijk ben jij daar dan net een paar dagen voor geweest...
  • [quote:1a5341883b="Tekkie"]Slechte timing zullen we maar zeggen, Debian staan niet bekend om de vele releases (eens in de 2 jaar ofzo) maar toevallig is afgelopen 8 April de nieuwe versie "Debian Etch" uitgekomen. Waarschijnlijk ben jij daar dan net een paar dagen voor geweest...[/quote:1a5341883b] ja ik lees het nu op hun site, zal ik 1 van de komende nachten maar even de server opnieuw instaleren :(

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.