Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Installeren Clamav geeft dependency probleem

pvl
10 antwoorden
  • Ik maak gebruik van een Linux server Debian Sarge 3.1 en daarop wilt ik een virusscanner installeren die samenwerkt met exim4.
    Tijdens de installatie met apt-get krijg ik de volgende melding:[code:1:24a97955f0]The following packages have unmet dependencies:
    clamav-daemon: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
    Depends: libclamav2 (>= 0.91.1) but it is not going to be installed
    Depends: lsb-base (> 3.0) but it is not going to be installed
    clamav-freshclam: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
    Depends: libclamav2 (>= 0.91.1) but it is not going to be installed
    Depends: lsb-base (> 3.0) but it is not going to be installed
    courier-authdaemon: Depends: courier-authlib (>= 0.58) but it is not going to be installed
    Depends: lsb-base (>= 3.0-10) but it is not going to be installed
    E: Broken packages
    [/code:1:24a97955f0]Als ik het goed begrijp gebruik ik nu een nieuwere versie van libc6 dan dat gewenst is?
    Als dit zo is hoe kan ik het dan oplossen?
    Alvast bedankt voor de hulp.
  • ik vermoedt dat je sources.list niet goed is geconfigureert, waardoor je niet alle pakketen kan installeren.

    kwestie van je sources bekijken. geen idee welke,, ik gebruik suse.
  • [code:1:d9f2eb28ae]# deb cdrom:[Debian GNU/Linux testing _Etch_ - Official Snapshot i386 NETINST Binary-1 20070315-20:52]/ etch contrib main

    deb http://ftp.debian.nl/debian/ etch main contrib non-free
    deb-src http://ftp.debian.nl/debian/ etch main contrib non-free

    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib[/code:1:d9f2eb28ae]Pas je sources.list aan zodattie er zo uit ziet, dan doe je[code:1:d9f2eb28ae]apt-get update && apt-get dist-upgrade[/code:1:d9f2eb28ae]Hierna zal je server erg lang gaan kauwen op de upgrade, dus haal de server tijdelijk off-line (alleen Apache dan, dus de pagina's zijn tijdelijk niet beschikbaar) zodattie in alle rust en ongestoord kan kauwen ;) Reboot in de nieuwe kernel (Etch default: 2.6.18, Sarge heeft max 2.6.8 ) Hierna kun je ClamAV installeren.
  • Het leek erop dat alles goed gegaan was maar,
    tijdens de installatie kreeg ik de melding dat ik na afloop install-keymap ( 8 ) nog moest toepassen, ik weet echter niet wat ik hiermee moet doen?
    Na afloop kreeg ik de melding: Errors were encountered while processing uml-utilities…
    Vanaf een client lukt het niet meer om contact te krijgen met de serever met ssh.
    Rechtstreeks op de server inloggen lukt wel.
    uname -a geeft: Linux Server 2.4.31 (niet gewijzigd)
    cat /etc/debian_version geeft 4.0 (was 3.1)
    Kan iemand mij raad geven wat te doen?
  • Jawel: kernel upgraden. 2.4 is echt te oud aan t worden, zelfs Slackware is over naar 2.6 :o Controleer of de ssh server nog geinstalleerd is.
  • [code:1:2bb15d4343]Reboot in de nieuwe kernel (Etch default: 2.6.18, Sarge heeft max 2.6.8 ) Hierna kun je ClamAV installeren[/code:1:2bb15d4343]
    Is het zo dat ik een bepaalde handeling had moeten doen om met de nieuwe kernel op te starten of had ie het automatisch moeten doen?
  • Als je tijdens het installeren Debian Sarge 3.1 de 2.6x kernel wilt gebruiken, kan dat via de boot option [code:1:62e49ddf47] linux26 [/code:1:62e49ddf47] Check ook http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=170267 en http://www.debian.org
    eleases/stable/installmanual
  • Het blijkt dat ssh nog geinstalleerd is. Ik heb alleen wel geconstateerd dat ik de verbinding met internet en het lokale net ben verloren.
    Een geluk is dat de server wel gewoon opstart.
    Uit de handleiding van het opwaarderen naar Etch heb ik gehaald dat ik eerst de kernel (Sarge) had moeten opwaarderen naar 2.6 en daarna naar Etch had moeten opwaarderen.
    Ik had ook geen backup gemaakt van de instellingen en belangrijke bestanden.
    Omdat ik nog niet zoveel ervaring heb om dit soort problemen op te lossen zou ik willen vragen hoe ik dit aanpak?
    Ik zal om te beginnen van zoveel mogelijk belangrijke bestanden alsnog een backup maken.
    Wat wordt dan de volgende stap die ik moet doen?, ik neem aan dat ik nu niet de kernel kan opwaarderen naar 2.6 of vergis ik me?
  • [quote:23f6f95b5d="pvl"]ik neem aan dat ik nu niet de kernel kan opwaarderen naar 2.6 [/quote:23f6f95b5d] Je zou het kunnen proberen via commando apt-get. Check deze Kernel upgrade mini-HOWTO http://skolelinux.org/security/kernel-upgrade Check ook nog http://www.webhostingtalk.nl/scripting-techniek-beveiliging/109622-debian-update-upgrade.html
  • Ik heb geprobeerd de kernel2.6 vanaf de Sarge cd te installeren, helaas is dit niet gelukt, en eindigt hij met de foutmelding die ik al eerder heb gehad:
    Errors were encoutered while processing
    uml-utilities.
    Ik zal proberen eerst de verbing met het internet weer in de lucht te krijgen…
    Of toch iets anders?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.