Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[SuSE 10.2] Geen geluid en geen internet

sasas
14 antwoorden
  • Hallo,

    Ik ben juist van start gegaan met linux, ik heb nu suse 10.2. Alles werkte vlotjes, alleen duurde de installatie lang, maar nu dat linux er is kan ik geen muziek luisteren of internetten…

    Ik heb een internetkaart, Wireless G Desktop Adapter (DWL-G510), van D-link, maar bij netwerkverbindingen wordt ze niet gevonden. Maar als ik dan bij beheersinstellingen kijk, vind ik wel bij Draadloos LAN en bij Netwerkkaart "D-link Network Controller" - dat zal wel dezelfde zijn als mijn kaart? Maar hoe kan ik deze kaart dan toevoegen om ermee op het net te raken?

    Verder gebruik ik een Sound Blaster Vibra16C geluidskaart, maar ik kan de volumeregeling niet openen ofzo, want dan komt er:
    "Geen volumeregelingselementen en/of apparaten voor GStreamer gevonden"
    Is deze kaart misschien te oud? Nochtans wordt ze wel herkend bij de beheersinstellingen.


    En dan nog één vraagje: Is het normaal dat Linux heeel traag opstart? Het duurt zonder overdrijven 5x zo lang als met mijn Windows PC.



    Alvast heel erg bedankt voor hulp enz. En heeft iemand nog goede "tips en tricks" zijn voor linux, laat mij dan iets weten
  • [quote:5be15719e8="sasas"]
    Ik heb een internetkaart, Wireless G Desktop Adapter (DWL-G510), van D-link, maar bij netwerkverbindingen wordt ze niet gevonden. Maar als ik dan bij beheersinstellingen kijk, vind ik wel bij Draadloos LAN en bij Netwerkkaart "D-link Network Controller" - dat zal wel dezelfde zijn als mijn kaart? Maar hoe kan ik deze kaart dan toevoegen om ermee op het net te raken?[/quote:5be15719e8]

    Open even het programma yast en kijk bij [netwerkapparaten->netwerkkaart] of hij je draadloze netwerkkaart ziet.
    Zo ja, loop dan even de instellingen na.
    Zo neen, dan heeft opensuse geen drivers voor de kaart.
    Mogelijk kun je de windows-drivers gebruiken om de kaart werkende te krijgen.
    Dit is wel even wat uitzoekwerk, op http://nl.opensuse.org/Ndiswrapper_howto staat een uitleg.

    [quote:5be15719e8]
    Verder gebruik ik een Sound Blaster Vibra16C geluidskaart, maar ik kan de volumeregeling niet openen ofzo, want dan komt er:
    "Geen volumeregelingselementen en/of apparaten voor GStreamer gevonden"
    Is deze kaart misschien te oud? Nochtans wordt ze wel herkend bij de beheersinstellingen.[/quote:5be15719e8]

    Ik ken gnome verder niet, maar vermoed dat je enkele gstreamer-modules mist.
    Werkt het geluid wel goed in yast?


    [quote:5be15719e8]
    En dan nog één vraagje: Is het normaal dat Linux heeel traag opstart? Het duurt zonder overdrijven 5x zo lang als met mijn Windows PC.
    [/quote:5be15719e8]
    linux is inderdaad trager dan windows qua opstarten, maar 5 x trager is wel erg traag.
    Kan komen doordat je chipset niet goed wordt ondersteund of doordat iets niet goed meestart met suse.
    Druk op de toets [esc] om het opstartscherm weg te halen en de opstartmeldingen te lezen. Kijk even of hij ergens langere tijd op wacht.

    [quote:5be15719e8]
    Alvast heel erg bedankt voor hulp enz. En heeft iemand nog goede "tips en tricks" zijn voor linux, laat mij dan iets weten[/quote:5be15719e8]
    www.opensuse.org is een goede portal met een schat aan informatie over SUSE.
  • [quote:8d55979c99]Open even het programma yast en kijk bij [netwerkapparaten->netwerkkaart] of hij je draadloze netwerkkaart ziet.
    Zo ja, loop dan even de instellingen na.
    Zo neen, dan heeft opensuse geen drivers voor de kaart.
    Mogelijk kun je de windows-drivers gebruiken om de kaart werkende te krijgen.
    Dit is wel even wat uitzoekwerk, op http://nl.opensuse.org/Ndiswrapper_howto staat een uitleg. [/quote:8d55979c99]

    Op deze site staat inloggen als root, dat doe ik door op ctrl+alt+f1 te drukken. Maar als ik dan

    "lspci -v | less"

    ingeef,geeft hij

    "lines ?-?/? (END)" ->dan druk ik op q, want niets anders werkt!


    Wat doe ik verkeerd?

    En wat bedoel je met werkt het geluid in Yast? Ik heb nog geen enkel liedje ofzo kunnen horen.

    Alles al veel dank!
  • Licht het niet aan de codecs dat je geen geluid kan afspelen?

    Ik heb trouwens hier veel gevonden, ook wat codecs betreft.
  • als root inloggen kun je het beste even vanuit een grafische terminal doen, bijv. gnome-terminal.
    Da's een soort dosvenster zoals je onder windows gewend bent.
    In zo'n venster wordt je root met het comando [b:ca8c4e73a8]su[/b:ca8c4e73a8]

    lspci geeft bij mij een lijst met 69 regels tekst.
    als je het commando niet als root uitvoert krijg je inderdaad [b:ca8c4e73a8]"lines ?-?/? (END)[/b:ca8c4e73a8] te zien, teken dat het commando de pci-configuratie niet kan uitlezen.
  • Sorry, maar ik was even op vakantie 8)

    Alleszins al erg bedankt voor de antwoorden!
    Maar het grootste probleem is eigenlijk dat het internet niet werkt, want nu moet ik altijd op mijn vader zijn computer gaan om dan iets te kunnen doen met mijn linux…

    Zijn er echt geen drivers ofzo, want dan kan ik later alle geluidsoverlast regelen!
  • En ja, ik ben vergeten te zeggen, maar kan je met de installatiecd iets doen?
    Het zijn wel allemaal windows-bestanden, maar toch…?
  • Op mijn flaptop staan zowel openSUSE 10.2 als Ubuntu 7.04. Ik heb dus ervaring met beide. In jouw geval stel ik voor: probeer Ubuntu eens? Ubuntu is "Linux voor beginners", de "instappersLinux". Helemaal gericht op gemakkelijke bediening. Overigens ook prima geschikt voor ervaren Linuxgebruikers! :-)

    Ubuntu start veel sneller op dan openSUSE. Bovendien is in Ubuntu het installeren van multimediacodecs heel simpel:
    https://help.ubuntu.com/community/NlMultimediaapplicaties

    Ubuntu haal je hier:
    http://www.ubuntulinux.org

    Voor het installeren van een ouwe ISA Soundblaster 16-bits geluidskaart doe je in Ubuntu dit:

    1. Toepassingen - Hulpmiddelen - Terminalvenster
    tik in:
    sudo gedit /etc/modules

    voeg daarna de volgende regel toe aan dat tekstbestandje:

    snd-sb16

    Opslaan en sluiten

    3. Daarna wederom in de terminal:
    sudo gedit /etc/modprobe.d/sound

    voeg daarna de volgende regel toe aan dat tekstbestandje:

    options snd-sb16 isapnp=0 port=0x220 irq=5 dma8=1 dma16=5

    Opslaan en sluiten

    4. Daarna in de terminal:
    sudo update-modules

    5. Daarna volledige herstart van je PC.

    Klaar! Je hebt nu geluid.

    Groet, Pjotr.
  • Ik ben toch aan het proberen met suse, nu ben ik ndiswrapper aan de praat aan het krijgen. Op deze site vond ik mijn info
    http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,installation/
    Maar wat is [i:df154e3f34]link to the kernel source[/i:df154e3f34]?

    Want hierbij krijg ik errors…
  • Ik krijg dus deze foutmelding:

    Can't find the kernel build files in lib/modules/2.6.18.2-34-default/build ; give path to kernel build directory with
    KBUILD = <path> argument to make

    … ofzoiets ongeveer, ik heb het over moeten schrijven. Welk path moet ik dus opgeven?
  • wil je niet teleurstellen, maar je bent denk ik nog vrij onervaren met linux???

    draadloos onder linux werkt nog niet zoals onder windows.

    Koppel je linux pc gewoon via een rj45 kabel aan je modem.
    je zal zien dat je dan wel internet gaat hebben.

    Ga daarna via internet je geluidsprobleem oplossen en ga eens lekker kijken wat linux allemaal kan en te bieden heeft.

    ga pas daarna kijken of je draadloos kan instellen.
  • Mmmm… ik heb al veel zitten googlen en draadloos internet gaat even goed als met windows, alleen heb je de drivers nodig.

    Check deze sites even na en je zal zien dat mijn kaartje (d-link DWL-G510) wel degelijk zou moeten werken op linux.

    http://www.linuxquestions.org/hcl/showproduct.php?product=2115
    http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,list_c-f/#d
  • Beste mensen,

    Ik ben dan toch maar overgestapt naar Ubuntu 7.04, en ik heb de geluidsproblemen kunnen fixen - heel erg bedankt pjotr123 - maar nu het internet…

    Ik heb nu rechtsboven in de menubalk een "netwerkicoontje", en als je er op drukt heb je keuze tussen
    - Wired Network
    - Wireless Network
    Linksys (en dan "signaalblokjes")

    Nu is het echt vreemd, want ik heb soms 2 van de 5 blokjes signaal, maar als ik dan wil verbinden krijg ik "no network connection".

    Moet ik nog andere dingen bijpassen ofzo?


    En ja, er is nog iets heel vreemds, de PC sluit niet meer af!
    Als ik op shutdown druk, begint hij met afluiten, maar bij het "UBUNTU"-scherm valt hij stil! Hoe komt dat nu weer?
  • Fijn dat het geluid nu werkt!

    Afsluiten: dat is een punt waar Ubuntu het slechter doet dan openSUSE, althans bij oude PC's (met een oud BIOS). Bij zulke oude PC's moet je inderdaad uiteindelijk, nadat de balk is "leeggelopen", handmatig de PC uitzetten.

    Bij verreweg de meeste nieuwe PC's speelt dit probleem niet (enkele uitzonderingen daargelaten).

    Maar op dit punt wint openSUSE, ere wie ere toekomt! :-)

    Netwerkverbinding:
    kijk eens op dit forum rond (of stel er je vraag):
    http://forum.ubuntu-nl.org

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.