Vraag & Antwoord

OS Linux

Oplossing voor het niet afspelen van systeemgeluiden Ubuntu!

28 antwoorden
  • Naar aanleiding van een artikel in de computertotaal heb ik Ubuntu 7.10 geinstalleerd en alles is goed gegaan. Nu heb ik alleen de volgende vraag. Ik zou graag geluiden willen horen, als ik bijvoorbeeld ergens op klik of bij een waarschuwing. Nu krijg ik bij een foutmelding een standaard pieptoon te horen (Deze pieptoon komt niet uit mijn geluidsboxen), en als ik ergens op klik hoor ik niks. Als ik naar 'systeem / voorkeuren / geluid' ga, heb ik het volgende ingesteld. [b:853d3b9558]Tabblad apparaten:[/b:853d3b9558] Alles op automatisch detecteren, behalve geluidsopnames (stilte) Als ik op testen klik, krijg ik een irritante hoge toon te horen die wel uit mijn geluidsboxen (Logitecht) komt. Geluid werkt dus. Bij standaard Mixerschuiven heb ik bij apparaat voor HDA VIA VT82xx (Alsa mixer) gekozen. Ik kan ook kiezen voor OSS Mixer, maar dat maakt geen verschil. [b:853d3b9558]Tabblad geluiden:[/b:853d3b9558] Softwarematig geluidsmixen inschakelen (ESD) aangevinkt Systeemgeluiden afspelen aangevinkt Bij systeemgeluiden heb ik voor het gemak even overal voor sirene gekozen, behalve het aan- en afmelden. (hier staan de standaardgeluiden voor het aan en afmelden) [b:853d3b9558]Tabblad Systeembel[/b:853d3b9558] Systeembel inschakelen aangevinkt, zichtbare systeembel niet aangevinkt. [b:853d3b9558]Probleem:[/b:853d3b9558] Bij het aanmelden krijg ik wel netjes het opstartgeluid te horen. Bij een mp3 of film hoor ik ook geluid. Maar als ik ergens op klik, of bij een foutmelding hoor ik nog steeds de standaard pieptoon. Wie weet hier de oplossing voor. Zou toch wel graag willen weten waarom het niet werkt :cry: [b:853d3b9558]Oplossing is gevonden! :D Standaard ondersteund Ubuntu 7.10 geen systeemgeluiden, installeer daarom het pakket esound![/b:853d3b9558]!
  • Kijk hier eens: http://computertip.googlepages.com/geluidskaartinubuntu Groet, Pjotr.
  • Bedankt voor je reactie! Ik heb het geprobeerd, maar ik heb waarschijnlijk geen externe geluidskaart, want als ik de on board geluidskaart in het bios uitschakel, dan heb ik helemaal geen geluid meer. Weet je misschien waar het nog meer aan kan liggen? (Zeer leuke website heb je trouwens, heb er veel van geleerd en is lekker duidelijk! :wink: )
  • Nou, geluid werkt bij jou wel, allleen niet bij de acties die je hebt ingesteld. Loop die instellingen eens goed na en kies bijv. een ander geluidje.
  • Bedankt voor je reactie, maar het heeft helaas geen zin om de geluiden te veranderen. Ik krijg alleen het geluid te horen bij opstarten.
  • [quote:a303d615fa="martijnosss"]Bedankt voor je reactie! Ik heb het geprobeerd, maar ik heb waarschijnlijk geen externe geluidskaart, want als ik de on board geluidskaart in het bios uitschakel, dan heb ik helemaal geen geluid meer. Weet je misschien waar het nog meer aan kan liggen? (Zeer leuke website heb je trouwens, heb er veel van geleerd en is lekker duidelijk! :wink: )[/quote:a303d615fa] Bedankt voor het compliment. :-) Er staan nog meer mogelijke oplossingen op die webpagina, niet alleen die van de twee conflicterende geluidskaarten. Heb je die andere oplossingen ook al geprobeerd, met name alsamixergui?
  • Ik heb ook het programma Alsa Mixer geinstalleerd, klopt het dat het geluid alleen komt uit PCM? Bij alle andere opties maakt het geen verschil of ik de geluidsbalk harder of zachter zet. Is er misschien een standaard opstelling die ik moet gebruiken
  • [quote:1c19a4d9c7="martijnosss"]Alsa Mixer geinstalleerd, [/quote:1c19a4d9c7] Als je die Alsa Mixer bedoelt, die rechts bovenaan het Paneel zit, kan dat kloppen. En zou je in Alsa Mixer via Bewerken > Voorkeuren er nog volume regelaars er aan toe kunnen voegen. Maar als je niet de juiste geluiden hoort bij acties, dan zou je zoals maximilaan al voorstelde deze checken. Dus Systeem > Voorkeuren > Geluid > Geluiden. Nadat je bij Systeemgeluiden een geluid hebt geselecteerd, check je of deze goed klinkt via Afspelen.
  • Met alsamixergui heb je een nog grotere beheersing van je geluidskaart (nog meer schuifjes).
  • Bedankt voor alle tips, maar ik geloof dat het probleem niet helemaal duidelijk is. Alle geluiden doen het gewoon bij mij, ook als ik naar systeem voorkeuren, geluid ga en druk op afspelen dan doet alles het gewoon. Alleen wil ik graag een geluid horen als ik bijvoorbeeld ergens op klik (zoals bij Windows) of bij een waarschuwing. Ik heb bij het tabblad voorkeuren, geluid, systeemgeluiden ingesteld dat bij alle acties het geluid sirene wordt afgespeeld. (ik heb het ook met andere geluiden geprobeerd), maar ik krijg alleen geluid bij het opstarten, of als ik een mp3/film afspeel. Verder heb ik ook AlsaMixerGui geïnstalleerd, en heb ik wat geschoven met de geluidsbalken, maar ik hoor nog steeds geen geluiden, als ik bijvoorbeeld op een programma klik. Is dit eigenlijk wel mogelijk, want alles lijkt gewoon goed te werken?
  • [quote:91038e379a="martijnosss"]Bedankt voor je reactie, maar het heeft helaas geen zin om de geluiden te veranderen. Ik krijg alleen het geluid te horen bij opstarten.[/quote:91038e379a] Hmm, da's vaag. ik weet dat je dat bij kde kunt oplossen door arts (de geluidsserver) te omzeilen en systeemgeluiden te laten afspelen door aplay. Bij gnome is ESD de geluidsserver, en misschien de boosdoener? Kijk eens of gnome de mogelijkheid biedt om de systeemgeluiden op een andere manier af te spelen.
  • Niet ieder Linux ondersteunt (volledig) iedere geluidskaart (en nog minder videokaarten); Ubuntu en Suse pakken wel goed mjn VIA-onboard-geluid maar bijvoorbeeld Pardus weer niet.
  • Ik heb eindelijk de oplossing gevonden! :D Standaard ondersteund Ubuntu 7.10 geen systeemgeluiden meer. Door het pakket [b:1aeec97065]esound[/b:1aeec97065] te installeren, worden de systeemgeluiden weer gewoon afgespeeld!
  • Hi, de vraag is nu of er niet nieuwe problemen zijn geintroduceerd. Ik gebruik zelf Debian en Gnome, daar wordt Esound nog altijd standaard geinstalleerd, vooral ten behoeve van die systeemgeluiden die ervan afhankelijk zijn. De vraag is of esound nu exclusief de geluidskaart claimt, met als gevolg dat alleen toepassingen die hun output naar esound sturen geluid produceren. Ik ben dus erg benieuwd of al je andere programma's nog geluid produceren. In de toekomst zal Esound verdwijnen: het is gewoon overbodig geworden. --Japser.
  • Hoi Jasper, ik ben er inderdaad achter gekomen dat sommige programma's geen geluiden meer geven, maar tot nu toe ben ik dit alleen tegengekomen voor windows programma's die via wine werken. :( Maar dit probleem kan ik oplossen door tijdelijk systeemgeluiden uit te schakelen. :) Ik hoop dat in de nieuwe 8.04 de systeemgeluiden wel standaard ondersteund worden als esound gaat verdwijnen!
  • Hi, nu heb ik nog een vraag voor je: Esound kan werken op 2 manieren, met libesd0 -of- met libesd-alsa0 . Welke van de twee is nu bij jou geinstalleerd ? Je kan dat bekijken met het commando: [code:1:f429d7966c]apt-cache policy libesd0[/code:1:f429d7966c] Als ik het allemaal goed heb begrepen kan esound met libesd-alsa0 z'n werk doen zonder de boel te blokkeren. --Japser.
  • Ik heb net even gekeken en bij mij is libesd-alsa0 geïnstalleerd. Ik neem aan dat dat hierdoor zowel de systeemgeluiden als programmageluiden onder Ubuntu gewoon werken. (Ben nog geen problemen tegengekomen :D)
  • Mooi zo! Hier houdt mijn wijsheid op. --Japser.
  • Zou ik jullie mogen vragen hoe ik libesd-alsa0 kan installeren? ik zit nl met hetzelfde probleem dat ik geen 2 geluiden tegelijk kan afspelen. :oops: alvast bedankt! Groetjes Louke :wink:
  • Als het goed is wordt libesd-alsa0 automatisch geïnstalleerd bij het installeren van Esound. Heb je de laatste versie van esound geïnstalleerd?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.