Vraag & Antwoord

OS Linux

opwaardeerknop

22 antwoorden
  • Even een vraagje over de opwaardeerknop in de Update Manager. Ik las o.a. het volgende : "Vermijd de opwaardeerknop! Gebruik liever niet de opwaardeerknop die in Update Manager verschijnt, wanneer er een nieuwe Ubuntuversie beschikbaar is. Een schone installatie, dus met formatteren en al, levert in de praktijk de minste problemen op. Bij elk besturingssysteem onder de zon. Dit komt onder andere door de instellingen die er in de oude versie staan. Die veroorzaken soms complicaties in de nieuwe versie." Ik vind Ubuntu geweldig, maar toen ik dit las bekroop mij enigszins dat vervelende Microsoft gevoel! Juist van een Linux-distro zou ik verwachten dat opwaarderen naar een nieuwe versie zonder problemen zou moeten verlopen, gelet op de zeer hoge kwaliteit van dit OS. Dit i.t.t. Windows. Ok, Windows upgraden is in principe vragen om ellende. Oud nieuws. Het is geen kritiek die ik lever, maar het verbaast mij. Zou het dan wellicht niet handig zijn om Ununtu na opwaardering van een 'downgrade'-mogelijkheid te voorzien, wanneer de nieuwe versie inderdaad (teveel) problemen mocht blijken te geven? Op 31 oktober a.s. komt Intrepid Ibex (8.10) uit las ik en die opwaardeerknop is toch wel erg verleidelijk moet ik zeggen! Zou me een hoop werk schelen. Ik weet niet hoe de meningen/ervaringen onder andere Ubuntu-deskundigen omtrent de 'opwaardeerknop' zijn, maar ik ben er erg benieuwd naar..... Nogmaals, die knop is echt erg verleidelijk en ze zullen hem er toch niet voor niets plaatsen.........
  • [quote:b6b7d54459="jan13011965"]Even een vraagje over de opwaardeerknop in de Update Manager. Ik las o.a. het volgende : "Vermijd de opwaardeerknop! ........[/quote:b6b7d54459] Van harte mee eens, voor elke Linux distro, en ook Ubuntu. De redenen heb je zelf al aangegeven. Wel kun je de hoeveelheid nieuwe-installatie-werk flink beperken door /home in een aparte partitie te plaatsen. Maak een backup van je huidige instellingen, die voornamelijk in /etc staan, redt /usr/local en speur naar verdere voor jou specifieke proggies en data in /, en backup die ook. Maak een nieuwe installatie (in de partitie waar nu / staat). Door de nieuwe file /etc/fstab te editen (mbv. de backup van etc/fstab)kun je /home weer naar de oorspronkelijke home-partitie laten wijzen, en meestal zal alles weer gewoon werken. Have fun.
  • Douwe bedankt voor je reactie! Heb je zelf daadwerkelijk slechte ervaringen met de opwaardeerknop? Wanneer het blijkbaar erg verstandig is om dat ding te mijden, blijf ik het toch vreemd vinden WAAROM DAT DING ER DAN WEL IS? Zijn er wellicht twee kampen binnen de Ubuntu community : pro-opwaardeerknop en contra-opwaardeerknop??? Ik zou wel eens de voors en tegens van Ubuntu-ers willen vernemen. Beetje eigenwijs misschien, maar ik ben nogal een 'spitter'.
  • Ik gebruikte in SUSE juist heel vaak de DVD in de functie "upgrade", als een soort van grote schoonmaak. Wel verdwenen daardoor SOMS sommige tussentijds geïnstalleerde zaken (maar niet allemaal). Hetzelfde doe ik ook vaak met Windows en ondanks waarschuwingen tegen dezelfde problematiek ben ik daarin nooit iets kwijtgeraakt. Opwaarderen naar een hogere versie gaat inderdaad wel eens wat rommeliger maar komt meestal in Linux wel goed door die opwaardering een of meer keren te herhalen; onder Windows ook ongeveer zo maar wel eens een minder stabiel eindresultaat en vervormde bestandsnamen. Bovendien missen SOMMIGE Windows-CD's de upgrade-mogelijkheid, maar kunnen wel, eenmaal schoon geïnstalleerd, voortaan als reparatie / opschoning installeren.
  • Ik heb er nog weinig verkeerds over gehoord, het werkt gewoon prima voor wie gemak verkiest. Toch zullen er altijd oude bestanden achterblijven en dan de instellingen van diverse software waar een nieuwere versie voor mee komt. Zelf doe ik ook liever een schone installatie, tis zo gepiept evenals je favo software toevoegen. De verborgen mappen in de home verwijder ik dan ook(wel een backup). Alleen van enkele progs met veel instellingen en natuurlijk de mail etc laat ik staan of haal terug uit de backup. Is er eens een probleem weet je in ieder geval dat het daar niet aan kan liggen.
  • [quote:60198acb47="jan13011965"]Wanneer het blijkbaar erg verstandig is om dat ding te mijden, blijf ik het toch vreemd vinden waarom dat ding er dan wel is? [/quote:60198acb47] Om te kunnen upgraden naar de nieuwe Ubuntu versie, met behoud van configuratie instellingen. Wat er gaat gebeuren als je de Upgrade knop gebruikt, kun je lezen op dit oude artikel over [url=http://www.debianadmin.com/upgrade-ubuntu-606-dapper-drake-to-ubuntu-10-edgy-eft.html]Upgrade Ubuntu 6.06 (Dapper Drake) to Ubuntu 6.10 (Edgy Eft)[/url] waarin staat dat hetzelfde ook via apt-get commando's kan. Wat er eventueel mis zou kunnen gaan kun je lezen op http://www.oreillynet.com/onlamp/blog/2006/10/aptget_distupgrade_broken_goin.html
  • gister eens een upgrade gedaan van 7.10 naar 8.4 om eens te testen. bericht verscheen: 71 pakketten worden verwijderd, 219 nieuwe pakketten opgehaald en 1079 pakketten krijgen een upgrade Totale download 891Mb en totaal 1298 pakketten. Ook nog een melding over wat oude pakketten die niet verwijderd konden worden en een paar keer de vraag of een aangepast bestand moest blijven of vervangen mocht worden. Heb alles maar laten vervangen voor de nieuwe versie. Verliep verder prima en kwam geen vreemde dingen tegen.
  • Hallo Athlon, Hartelijk dank voor je 'test'! Erg leuk om eens daadwerkelijk te horen hoe een upgrade is verlopen. En vooral ook dat alles goed is gegaan. Ik begrijp dus dat alle hardware en software(instellingen) gewoon goed functioneren? Geen apparaten die plotseling vreemd doen of helemaal niet meer werken? Ook het geluid werkt op alle fronten : browser, systeemgeluiden, players, video? Dat gaf n.l. bij mij destijds wat problemen (zie deze thread : http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=187537). Ik ben geneigd om de volgende conclusie te trekken : probeer de opwaardeerknop in eerste instantie uit (WEL UITERAARD BELANGRIJKE DATA EERST BACKUPPEN!). Werkt alles na de upgrade prima, dan is dat mooi. Werkt het niet geheel naar behoren dan kun je alsnog een 'schone' installatie doen. Wanneer iemand het hier niet mee eens is, voel je vrij om je mening/ervaringen te laten horen! (Da's de reden waarom ik deze thread o.a. heb geplaatst). Jolo, jij trouwens ook nog bedankt voor je links!
  • Je hebt het goed begrepen. Het werkt hier als een speer. Over een goede week komt een nieuwe versie, kan ik het nogmaals proberen :D Ook vanwege de opbouw is het toch niet met dat andere OS te vergelijken met wat me gewend zijn van een upgrade. Kortom, een schone installatie is altijd lekker maar wie beren op de weg ziet moet maar lekker een upgrade doen.
  • Athlon, ik ga ook maar eens 'wild' doen en de opwaardeerknop gebruiken voor een upgrade naar Intrepid Ibex. Waar ik ook nog benieuwd naar ben, is of je ook kunt upgraden waarbij je een of meerdere versies 'overslaat'. Dus bv van versie 7.10 naar 8.10 (waarbij versie 8.04 dus 'overgeslagen' wordt)? Past de opwaardeerknop zich automatisch aan, aan de NIEUWSTE Ubuntu versie? Heeft iemand hier ervaring mee?
  • [quote:7987f70f04="jan13011965"]is of je ook kunt upgraden waarbij je een of meerdere versies 'overslaat'. Dus bv van versie 7.10 naar 8.10 (waarbij versie 8.04 dus 'overgeslagen' wordt)? [/quote:7987f70f04] Dat kan waarschijnlijk niet. Zie bijvoorbeeld deze thread op het Engelstalige Ubuntu forum over [url=http://ubuntuforums.org/showthread.php?t=935684]Upgrade path from 7.10 to 8.10 - can I skip 8.04[/url] Check ook nog deze [url=http://www.ubuntugeek.com/upgrade-ubuntu-804-hardy-heron-to-ubuntu-810-intrepid-ibex-beta.html]Upgrade Ubuntu 8.04 (Hardy Heron) to Ubuntu 8.10 (Intrepid Ibex) Beta[/url] Als ik die commando geef in Ubuntu 8.04.1 dan zie ik in update manager: De nieuwe distributie-versie '8.10' is beschikbaar. Maar geef ik dit commando op een PC met Ubuntu 7.10 dan verschijn in update manager de melding: De nieuwe distributie-versie '8.04 LTS' is beschikbaar. Waarschijnlijk is de stap van Ubuntu 7.10 naar 8.10 te groot.
  • Nog maar even wachten met Intrepid Ibex want is nog niet klaar. Ben zelf nog maar pas over op 8.04 overigens want was er eerst niet zo weg van. Firefox 3 had ook nogal wat strubbels in begin. Is nog niet zo stabiel als de oudere versie maar tgaat nu wel. eergisteren de pjuter van m'n dochter ook laten upgraden naar 8.04. Ook geen centje pijn verder. Kon nu ook de nw flash 10 nemen, in 9.10 staat ie niet in de pakketbeheerder. In synaptic nog wat restanten kunnen verwijderen, wordt daar netjes aangegeven als er nog wat achter gebleven is. Ik had niks gezegd en ze heeft er nog niets van gemerkt zelfs hihi
  • Athlon, Intrepid is vanaf donderdag beschikbaar (30 oktober) tenminste voor zover mij bekend of ik moet ergens iets gemist hebben. Jij levert hier trouwens wel even het keiharde bewijs (tot 2x toe zelfs) dat upgraden via de opwaardeerknop probleemloos kan werken. Ik ga het dus ook met Intrepid proberen alleen is dit even afhankelijk van het verhaal van Jolo of dat dus lukt van 7.10 naar 8.10. (Jolo, bedankt trouwens voor je links!). Bij troubles laat ik het hier wel even weten. Ben ook benieuwd of jouw upgrade(s) naar Intrepid wederom vlekkeloos verlopen! Laat het even weten. Thx! Mijn situatie is overigens zo dat ik 2 computers heb met verwisselbare sledes (die ik aan of uit kan zetten) waarin de nodige harde schijven gehuisvest zijn. Ik zorg er altijd voor dat ik een werkende Ubuntu-versie heb op beide computers, waarop ik kan terugvallen, mochten er problemen zijn met de nieuw(st)e versie. Werkt perfect!
  • Daarnet op een van m'n computers een upgrade gedaan via de opwaardeerknop van versie 7.10 naar versie 8.04 (zodra Intrepid overmorgen beschikbaar is gaat ie dus naar 8.10). Alles verliep vlekkeloos! Geen centje pijn! Bewijs computer nr. 3 waarbij alles prima gaat ....... Zodra ik van 8.04 naar 8.10 heb geupgraded laat ik weten of ook voor deze actie de vlag uit kan.
  • [quote:8457acd0a2="jan13011965"] Daarnet op een van m'n computers een upgrade gedaan via de opwaardeerknop van versie 7.10 naar versie 8.04 (..) Alles verliep vlekkeloos [/quote:8457acd0a2] Mooi dat het je is gelukt. Maar heb je dan ook al in 8.04.1 al je favoriete applicaties uitgeprobeerd? Werkte in Firefox 3.0 direct je favorieten en plug-ins uit Firefox 2.0? En had je voor en na de upgrade gecheckt op harddisk verbruik via commando [code:1:8457acd0a2] df -h [/code:1:8457acd0a2][Enter] Of check dit eventueel zodra Ubuntu 8.10 uitkomt. Dat zou inderdaad op donderdag 30 oktober kunnen zijn. Maar een dag later zou ook nog wel kunnen.
  • Geupgraded van 8.04 naar 8.10 (Intrepid) via de opwaardeerknop. De meeste zaken functioneren normaal, echter een aantal zaken lopen niet. Dus voor het eerst wat gesputter. Ik heb inmiddels begrepen dat het niet verstandig is om DIRECT bij het uitkomen van een nieuwe versie te upgraden, omdat er dan nogal wat bugs aanwezig zijn. Het beste kun je een maand of twee wachten. Dan zijn de meeste bugs eruit (met dank aan Pjotr!). De zaken die bij mij niet lopen zijn de volgende : 1) Update-manager geeft aan dat er een update is (libcssl 0.9.8). Wanneer ik die wil installeren gaat het fout en krijg de volgende melding : 'An error occurred. The following details are provided: E: /var/cache/apt/archives/libssl0.9.8_0.9.8-10.1ubuntu2_i386.deb: corrupted filesystem tarfile - corrupted package archive '. Is hier wat aan te doen of is het gewoon afwachten totdat er een nieuw niet-corrupt package archive is? (Is de eerste keer dat ik dit meemaak met Ubuntu) 2) Ik probeer een iso-bestand (video) met VLC (0.9.4) af te spelen, echter VLC start op en sluit daarna direct weer. Ook met Totem player lukt het niet. Wie weet de oplossing? 3) Xsane herkent m'n all-in-one wel (HP PSC 1310 series), echter ik kan niets inscannen. De scan-knop is disabled('greyed out'). Ook hier weer of iemand de oplossing weet? 4) Ik probeer van pc01 in m'n LAN naar pc 02 te gaan om daar een gedeelde map in te zien. M'n wachtwoord wordt gevraagd. Ik vul dit netjes in, echter steeds weer komt hetzelfde venster tevoorschijn met steeds weer dezelfde vraag om m'n wachtwoord. Iemand de oplossing? Tenslotte dit : Ik moet zeggen dat ik bij de upgrade van 8.04 naar 8.10 toch wat gemengde gevoelens heb. Kreeg ook tijdens de upgrade enkele foutmeldingen (of je Windows upgrade zal ik maar zeggen.....). Bij een volgende nieuwe distributie kijk ik eerst de kat uit de boom alvorens te upgraden. Maandje of twee wachten dus. Maar dit is mijn persoonlijk ervaring. Misschien dat bij anderen de upgrade soepeltjes verliep..........
  • 1.Werkt [code:1:1df216b7f0] sudo apt-get update [/code:1:1df216b7f0][Enter] dan nog wel zonder foutmeldingen? En als je synaptic start. En daarin klikt op Speciale filters en Gebroken. Welke pakketten worden dan getoond? Wellicht dat je die kunt verwijderen en opnieuw kunt installeren. 2.Ik heb VLC nog niet getest. Check alvast op het Engelstalige Ubuntu forum deze thread over onderwerp [url=http://ubuntuforums.org/showthread.php?t=966864]Intrepid Multimedia Apps crashing[/url] 3.Mijn HP PSC 750xi werkt zo te zien wel in Ubuntu 8.10. Ook het scannen. Over jouw HP PSC 1310 zou je deze link even kunnen checken http://openprinting.org/show_printer.cgi?recnum=HP-PSC_1310 4.Welke howto had je daarvoor gebruikt? Op welke van de twee heb je Ubuntu 8.10? En lukt het andersom ook niet?
  • 1) Heeft zich inmiddels vanzelf opgelost na het laten updaten door de update-manager. Ging alles maar zo makkelijk...... 2) Thread gecheckt, maar zie daar zo gauw (nog) geen oplossing voor het VLC/Totem en meerdere (video)players. Na updates nogmaals getest. Probleem blijft. Jolo, werken VLC en de overigen bij jou wel normaal? Heb je al e.e.a. kunnen uitproberen? 3) Is inmiddels ook opgelost. Ging ook vanzelf na updates..... 4) En ook dit probleem is opgelost. Na wat uitpuzzelen bleek dat ik bij het delen van een map ALLEDRIE de opties moest aanvinken! Wachtwoord werd toen niet meer gevraagd. Klein vraagje heb ik nog wel : ik neem aan dat de opties die je kunt aanvinken bij het delen van een map enkel op m'n LAN betrekking hebben? Dat dit dus enkel geldt voor de pc's in mijn (thuis)netwerk en niemand van buiten het netwerk een pc in m'n LAN kan benaderen?
  • [quote:a70413c5de="jan13011965"] Probleem blijft. Jolo, werken VLC en de overigen bij jou wel normaal? Heb je al e.e.a. kunnen uitproberen? [/quote:a70413c5de] Ik heb alvast VLC en de afhankelijkheden geïnstalleerd. Nog niet getest. Welke pakketten had je verder nog geïnstalleerd? Zijn bij jou de opties bij tabbladen te selecteren of licht-grijs. Heb je nog andere videoformaten kunnen proberen? En via Totem? //Edit 7 november Inmiddels heb ik VLC kunnen uitproberen met een .flv video filmpje. Als ik daarop dubbel-klik in Ubuntu 8.10 dan start Totem. Dus klikte ik met de rechter muisknop op dat video bestand > Openen met VLC media player, dan wordt dat filmpje gewoon getoond met geluid.
  • Ik heb VLC ook even getest met verschillende formaten video-filmpjes en dan werkt alles prima! Probleem lijkt zich dus enkel voor te doen met iso-bestanden. Onder 8.04 worden ze wel prima afgespeeld door (de oude) VLC. Vreemd....... Wellicht dat met toekomstige updates van VLC het probleem verholpen is?? Beschik je toevallig over een iso-bestand (video) om te testen of VLC bij jou dan wel goed functioneert of dat je tegen hetzelfde probleem als moi aanloopt? Wanneer VLC het dan ook bij jou niet doet, meen ik te mogen concluderen dat de 'fout' niet ergens in mijn systeem zit, maar van algemene aard is.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.