Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Ubuntu en Mobile Radeon 9600

None
28 antwoorden
  • Ik heb Ubuntu 8.10 geinstalleerd op een laptop maar heb problemen met de grafische kaart. Uiteindelijk heb ik nieuwere drivers gedownload van de de site van ATI en geinstalleerd in de home map.

    In het terminalvenster vervolgens het volgende commando ingetikt: sudo sh ./ati-driver-installer-9-3-x86.x86_64.run

    De installatie wordt dan gestart. Vervolgens krijg ik een scherm te zien van ATI waarbij ik kan kiezen uit de volgende opties:

    Install Driver 8.593 on X.Org 7.4
    Generate Distribution Specific Driver Package

    Er gebeurt echter niets als ik op één van de opties klik.

    De onderkant van het scherm kan ik niet zien omdat die buiten het beeld valt. Angry

    Ik kan het ATI scherm niet verkleinen. Wel groter maken. ?

    Wat nu…….
  • Probeer de volgende aanpak eens:

    1. Herstel je beeld:
    http://sites.google.com/site/computertip/geenbeeld
    (punt 1)

    2. Gebruik Envy om het nieuwste stuurprogramma van ATI te installeren (dus niet meer handmatig doen):
    http://sites.google.com/site/computertip/directdoen
    (punt 4)

    Helpt dit?

    P.S. Waarom trouwens 8.10? Pak liever 9.04, die is op 23 april verschenen….
  • Ik ga het proberen. Bedankt voor de tip.


    Versie 9.04 had ik ook al geinstalleerd. Volgens de informatie is er nog geen geschikte driver voor 9.04.

    Ga eerst jouw tips opvolgen.
  • in kde kun je te grote vensters verplaatsen door de Alt-toets ingedrukt te houden terwijl je met de muisaanwijzer het scherm versleept.
    Wellicht heeft gnome die mogelijkheid ook.
  • Volgens de videokaarten FAQ heeft de Radeon 9600 een RV350 core. Daarover is onlangs een bug gemeld. [rv350] DRI fails; drm module complains about agp ioremap waarin staat
    [quote:1d980505aa] What baffles me is that compiz worked fine in 8.10. [/quote:1d980505aa] Dat klopt ook wel. Want in één van mijn oude test PC 's. Een dual Pentium 3 & ATI x1650Pro met een RV560 core. Het verschil is dat via Systeem > Beheer > Hardwarestuurprogramma's er in Ubuntu 8.10 wel gesloten drivers beschikbaar zijn . En voor Ubuntu 9.04 niet. Deze laatste heeft een nieuwere X.Org versie.
  • ik krijg met geen mogelijheid dat envy geinstalleerd. Ik heb via synaptics alles aangepast er wordt aanvullende software gedownload. Als ik daarna echter bij toepassingen / beheer ga zoeken op envy dan zie ik alleen maar een utility voor sound cards.

    Geen idee hoe nu verder. Ook alle andere opties halen niets uit.
  • nvyng-gtk is wel goed geinstalleerd?

    Zo ja, je kunt het ook vanaf de commandoregel starten door bijv. [b:63830866b5]sudo envyng-gtk[/b:63830866b5] in te typen.
  • Ik heb Envy nu geinstalleerd. De geinstalleerde versie is gelijk aan de geadviseerde versie. Ik kan dus niets installeren, Helaas kan ik de schermresoluties nog steeds niet aanpassen, (Niet hoger dan 600 x 600) Weet niet meer wat te doen.
  • In jouw geval zou ik gewoon weer 9.04 installeren en bij het open-bron-stuurprogramma blijven. Dus (tijdelijk?) afzien van het fabrieksstuurprogramma "fglrx".
  • Ook bij 9.04 kwam ik niet verder dan een resolutie van 800 x 600.
    Het is een 15,4 inch scherm dus dat moet hoger kunnen.
  • Stel je vraag hier eens:
    http://forum.ubuntu-nl.org/
  • Daar loopt ook een discussie maar helaas ook hier nog geen oplossing.
  • ik zou verwachten dat je dit handmatig kunt regelen in het bestand xorg.conf.
  • [quote:c607a8dbb7="gerben3"]Ook bij 9.04 kwam ik niet verder dan een resolutie van 800 x 600. Het is een 15,4 inch scherm dus dat moet hoger kunnen. [/quote:c607a8dbb7] Dat zou inderdaad hoger moeten kunnen. Welke driver gebruik je nu? Check dit in je /var/log/Xorg.0.log

    Dit kan via een editor. Maar je zou het ook kunnen doen in een terminalvenster
    [code:1:c607a8dbb7] cat /var/log/Xorg.0.log | grep vesa [/code:1:c607a8dbb7] of [code:1:c607a8dbb7] cat /var/log/Xorg.0.log | grep VESA [/code:1:c607a8dbb7] om te controleren of de vesa drivers worden gebruikt. Als die gebruikt worden, zou het kunnen kloppen dat je niet hoger kunt komen dan 800 x 600.
    [quote:c607a8dbb7="pjotr123"]In jouw geval zou ik gewoon weer 9.04 installeren en bij het open-bron-stuurprogramma blijven. Dus (tijdelijk?) afzien van het fabrieksstuurprogramma "fglrx".[/quote:c607a8dbb7] Helaas, AMD schrijft geen nieuwere video drivers voor oude videokaarten. De nieuwere Catalyst 9.4 is bedoelt voor de HD 2400 of hoger.

    Die Radeon 9600 met een RV350 core van de TS is eigenlijk te oud. Want de open source 3D radeon drivers kwamen pas beschikbaar vanaf de radeon R500 series. En nu ook voor de R600 & R700. Die ATI x1650Pro met een RV560 core van mij werkt dus wel met de open source 3D radeon drivers. En heeft daardoor wel de juiste resolutie voor mijn 19 inch wide screen TFT monitor.
  • Ik ga ermee aan de slag. meld mij weer als ik de informatie heb.
  • Dit is de code die ik krijg:

    (II) LoadModule: "vesa"
    (II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
    (II) Module vesa: vendor="X.Org Foundation"
    (II) VESA: driver for VESA chipsets: vesa


    Zijn er nu nog opties?
  • Was dit de output van Ubuntu 8.10? Als je nog wel andere Ubuntu CD's hebt liggen, probeer elke daarvan als LiveCD. En doe dan nogmaals bij voorkeur [code:1:c6be47f7d2] cat /var/log/Xorg.0.log | grep VESA [/code:1:c6be47f7d2][Enter] Dus VESA met hoofdletters. Dat geeft meer info. Je zou daarin kunnen checken of je info vind over Configured Monitor.

    Ik heb zelf namelijk een vergelijkbaar probleem, maar dan met mijn 7600GS. Bij mij detecteert de VESA drivers de monitor niet juist.
    [code:1:c6be47f7d2]
    (II) VESA(0): Configured Monitor: Using hsync range of 31.50-37.90 kHz
    (II) VESA(0): Configured Monitor: Using vrefresh range of 50.00-70.00 Hz
    [/code:1:c6be47f7d2]
    Volgens de handleiding van mijn 19 inch TFT monitor. Analog: Horizontal 24.0-80.0kHz, Vertical 55-75Hz.

    Je zou dus kunnen proberen de Horizontal en Vertical frequenties handmatig toe te voegen in je /etc/X11/xorg.conf
    Hoe je dit kunt doen kun je checken in deze Video Modus FAQ http://www.x.org/wiki/FAQVideoModes

    Waarbij je die regel over de configured monitor kunt laten staan. En de HorizSync en VertRefresh aan Section "Screen" toevoegt. Maar dan met de gegevens van jouw monitor. Dit onderstaande is alleen een voorbeeld.

    [code:1:c6be47f7d2]
    Section "Screen"
    Identifier "Configured Monitor"
    HorizSync 31-80
    VertRefresh 56-76
    [/code:1:c6be47f7d2]
    Ik heb dit zelf uitgeprobeerd. Bij mij bleek deze mogelijkheid voor mijn PC met die oude 7600GS te werken met de vesa drivers. De resolutie is dan weer de gebruikelijke 1280x1024 voor mijn 19 inch TFT monitor.
  • Het gaat om een Tulip Centrino 1,5g Ghz notebook met een 15,4 inch tft scherm.

    Meer gegevens heb ik helaas niet beschikbaar. (op papier dan) Kan ik niet in in xorg de gewenste resolutie plaatsen.
  • [quote:f6c51df9ff="gerben3"]Kan ik niet in in xorg de gewenste resolutie plaatsen.[/quote:f6c51df9ff] Handmatig resoluties plaatsen is met een recente distributie zoals Ubuntu 8.10, niet meer nodig. Daarvoor heb je in Ubuntu toch Systeem > Voorkeuren > Scherm. Maar wat belangrijk is dat Xorg weet welke HorizSync en VertRefresh je monitor aan kan. Als de videodriver dat fout detecteert, is het handmatig toevoegen van de juiste frequenties vereist.
  • Het probleem is dat de resolutie in het beheersscherm niet hoger kan dan 800 x 600. Dat wil ik juist hoger krijgen.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.