Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

partities triple boot

Stu III
12 antwoorden
  • ok wederom een partitie vraag (bij deze nog bedankt voor de antwoorden op de vorige vraag).

    Het plan is een triple boot met XP, Ubuntu and openSUSE te maken. Op het moment heb ik
    1) een primary partition met Vista, wat dus XP moet worden.
    2) een extended partition met Ubuntu en waar Suse bij moet komen
    3) Twee primary partitions voor file storage.

    Wat zijn evt problemen die ik hier kan verwachten?
    a) blijkbaar moet Windows op partitie 1 blijven? kan de bootloader issues geven als ik Vista erafhaal en vervang door XP?
    b) de extended partition heb ik nu twee logical partition. Moeten deze vormgegeven worden als

    (__logical__)(_swap_)(__logical__)

    om beide Linux'en van dezelfde swap gebruik te laten maken? Gaat Yast een probleem geven als er al een swap is?
    c) is het beter om van de twee primary partitions 1 te maken om de vrijgekomen primary te gebruiken voor Suse?

    Hoop dat dit een beetje duidelijk is, ik heb op het moment niet de mogelijkheid om bijv een screendump te maken uit GParted.
    Dank.
  • [quote:7382c9d7ee="Stu III"]

    Wat zijn evt problemen die ik hier kan verwachten?[/quote:7382c9d7ee]

    Wat ik wel gehad heb is dat de partitie van linux te ver weg op de schijf lag voor de bios, waardoor de bootloader de kernel niet kan bereiken om te laden.
    Dat is op te lossen door de map /boot op een kleine partitie vlak na de windows-partitie te zetten, of door die in een map op de 2-elinux-partitite te plaatsen.

    [quote:7382c9d7ee]
    a) blijkbaar moet Windows op partitie 1 blijven? [/quote:7382c9d7ee]

    Is wel het gemakkelijkst. Windows voelt zich het prettigst op de eerste primaire partitie van de primaire master-schijf.

    [quote:7382c9d7ee]kan de bootloader issues geven als ik Vista erafhaal en vervang door XP?[/quote:7382c9d7ee]

    XP overschrijft de linux-bootloader.

    [quote:7382c9d7ee]
    b) de extended partition heb ik nu twee logical partition. Moeten deze vormgegeven worden als

    (__logical__)(_swap_)(__logical__)

    om beide Linux'en van dezelfde swap gebruik te laten maken?
    [/quote:7382c9d7ee]
    ik zou swap achteraan zetten. Verder maakt het voor linux niet zoveel uit waar de swap zich bevindt.

    [quote:7382c9d7ee]Gaat Yast een probleem geven als er al een swap is? [/quote:7382c9d7ee]

    Nee.
    Bij nieuwe installatie is de kans groot dat yast gewoon de bestaande swap uitkiest en geen nieuwe voor stelt.
    Enige probleem met een gedeelde swap is dat linux die gebruikt om bijv. bij de slaapstand-naar-schijf de data van het ramgeheugen in op te slaan. In de praktijk betekent dat je vanuit de slaapstand altijd terug moet naar de linux-versie die je in de slaapstand hebt gezet, anders verniel je de boel.
    Bij suse boot de pc altijd meteen naar linux, zonder keuzemenu. Dus dan kan het niet fout gaan.

    [quote:7382c9d7ee]
    c) is het beter om van de twee primary partitions 1 te maken om de vrijgekomen primary te gebruiken voor Suse?[/quote:7382c9d7ee]

    Voor linux maakt het niet uit of het een primaire of logische partitie betreft.
  • [quote:0bd22c1821="maximilaan"]Wat ik wel gehad heb is dat de partitie van linux te ver weg op de schijf lag voor de bios, waardoor de bootloader de kernel niet kan bereiken om te laden.[/quote:0bd22c1821]

    Is dat probleem niet allang opgelost in recente versies van lilo en grub?
  • Dat probleem had te maken met http://en.wikipedia.org/wiki/Cylinder_1024 dat zou zijn opgelost door het BIOS van je moederbord. Ik heb zelf vroeger ook losse boot partities gebruikt voor Linux. Met moerderborden vanaf ongeveer 2003 of later zou dit niet meer nodig zijn.

    Ik verwacht geen grote problemen bij een tripple boot met XP, Ubuntu en openSuSE. Het beste is het eerst Windows XP te installeren. Dan openSuSE en als laatst Ubuntu, waarvan je GRUB in de MBR laat installeren. Eerst Windows XP. Dan Ubuntu en als laatst openSuSE waarvan je GRUB in de MBR laat installeren, zou ook nog wel kunnen.

    Maar als je zoals maximilaan al zei, de Linux swap partitie deelt, dan zal openSuSE die swap partitie opnieuw formatteren. De swap partitie krijgt daardoor een andere UUID. Als deze niet meer overeenkomt met die van het /etc/fstab van Ubuntu, kan deze de swap partitie niet meer gebruiken. Deze zou dan handmatig kunnen worden gewijzigd. Welke UUID de swap partitie heeft, kan worden gecheckt via commando [code:1:fe0f50a043] /sbin/blkid [/code:1:fe0f50a043][Enter]

    Als je na XP openSuSE installeert en dan Ubuntu, heb je dit probleem niet. Want openSuSE maakt geen gebruik van UUID. Maar van /dev/disk/by-id.
  • bedankt voor de antwoorden. ik loop toch tegen een aantal problemen aan.
    Ten eerst wil, na het herindelen van de schijf dmv Gparted, Vista niet meer opstarten. Ik krijg een bootmenu met de optie voor Vista maar als ik dat kies, geburt er eigenlijk niets, ik kom weer uit op het bootmenu, waar ik dan Ubuntu kies, dat werkt wel. Is het fout dat de xtended op sda1 staat? Tijdens het partitioneren had ik, naar mijn idee, Windows op sda1 laten staan.
    Zie hier een stukje menu.lst



    [quote:2824997c67]## ## End Default Options ##

    title Ubuntu 9.04, kernel 2.6.28-11-generic
    uuid ae514135-6d25-438c-ae43-3f10ee7b0a71
    kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=ae514135-6d25-438c-ae43-3f10ee7b0a71 ro quiet splash
    initrd /boot/initrd.img-2.6.28-11-generic
    quiet

    title Ubuntu 9.04, kernel 2.6.28-11-generic (recovery mode)
    uuid ae514135-6d25-438c-ae43-3f10ee7b0a71
    kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=ae514135-6d25-438c-ae43-3f10ee7b0a71 ro single
    initrd /boot/initrd.img-2.6.28-11-generic

    title Ubuntu 9.04, kernel 2.6.27-14-generic
    uuid ae514135-6d25-438c-ae43-3f10ee7b0a71
    kernel /boot/vmlinuz-2.6.27-14-generic root=UUID=ae514135-6d25-438c-ae43-3f10ee7b0a71 ro quiet splash
    initrd /boot/initrd.img-2.6.27-14-generic
    quiet

    title Ubuntu 9.04, kernel 2.6.27-14-generic (recovery mode)
    uuid ae514135-6d25-438c-ae43-3f10ee7b0a71
    kernel /boot/vmlinuz-2.6.27-14-generic root=UUID=ae514135-6d25-438c-ae43-3f10ee7b0a71 ro single
    initrd /boot/initrd.img-2.6.27-14-generic

    title Ubuntu 9.04, memtest86+
    uuid ae514135-6d25-438c-ae43-3f10ee7b0a71
    kernel /boot/memtest86+.bin
    quiet

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Other operating systems:
    root


    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/sda3
    title Windows Vista/Longhorn (loader)
    root (hd0,2)
    savedefault
    makeactive
    chainloader +1[/quote:2824997c67]

    Ten tweede ben ik niet heel zeker over de voorgestelde set up van openSUSE wb partitioning tbv de installlatie. Zie bevoegd screenshots waar het sda5 wil overschrijven terwijl ik het op sda7 wil hebben.

    [img:2824997c67]http://i44.tinypic.com/2lng1mo.jpg[/img:2824997c67]

    [img:2824997c67]http://i42.tinypic.com/308z3b9.jpg[/img:2824997c67]

    [img:2824997c67]http://i40.tinypic.com/6pxjrn.jpg[/img:2824997c67]
  • [quote:e546f85800="Stu III"] Ten eerst wil, na het herindelen van de schijf dmv Gparted, Vista niet meer opstarten. Ik krijg een bootmenu met de optie voor Vista maar als ik dat kies, geburt er eigenlijk niets, ik kom weer uit op het bootmenu, waar ik dan Ubuntu kies, dat werkt wel. Is het fout dat de xtended op sda1 staat? [/quote:e546f85800] Ik zou verwachten dat de Windows partitie /dev/sda1 was gebleven. Maar zou niet de reden moeten zijn, dat Windows niet meer zou opstarten. Als je een echte Vista installatie DVD heb, zou je de repair optie kunnen proberen. Uitleg daarover staat onder andere op http://www.bleepingcomputer.com/tutorials/tutorial148.html Als je geen Vista installatie DVD hebt, check dan deze hyperlink http://www.howtogeek.com/howto/windows-vista/how-to-make-a-windows-vista-repair-disk-if-you-dont-have-one/ Als dat ook niet helpt, zit er niks anders op dan dat probleem voor te leggen in categorie OS Windows.
    [quote:e546f85800="Stu III"] Ten tweede ben ik niet heel zeker over de voorgestelde set up van openSUSE wb partitioning tbv de installlatie. Zie bevoegd screenshots waar het sda5 wil overschrijven terwijl ik het op sda7 wil hebben. [/quote:e546f85800] Dat is me bekend. Over het algemeen kun je dat voorstel het beste negeren. En kiezen voor de handmatige partitie keuze.
  • [quote:0853393268="Supersnail"]
    Is dat probleem niet allang opgelost in recente versies van lilo en grub?[/quote:0853393268]

    ik heb er zelf nog last van :)
  • [quote:b828bc0107="jolo"]
    Maar als je zoals maximilaan al zei, de Linux swap partitie deelt, dan zal openSuSE die swap partitie opnieuw formatteren. [/quote:b828bc0107]

    Als het goed is niet: suse gebruikt hem gewoon, maar formatteert hem niet nog een keertje.. Opnieuw formatteren is immers onzinnig.
  • Ok ik heb de sprong gewaagd en er zijn toch een aantal zaken fout gegaan :D

    Tijdens de installatie zag het er veelbelovend uit wb partitiekeuze en bootmenu maar na de installatie van OSuse is het me 1 keer gelukt van de harde schijf op te starten, liever gezegd, ik kreeg het Grub menu voor me neus.
    Keuzes voor Osuse, Ubuntu en Windows. Osuse werkte blijkbaar, Windows niet geprobeerd, maar Ubuntu kwam in haar eigen Grubmenu terecht (wat dus voor de installatie van Osuse het ""level 1" Grub menu was) en het opstarten van ubuntu zelf lukte niet, computer rebootte.
    Daarna kwam ik in een continuous loop terecht te weten het Dell opstartscherm met de BIOS opties, een cursor linksboven en weer opnieuw het opstartscherm. Alleen met een lice cd kwam ik in een OS zogezegd.

    1) iIn /boot kan ik zo te zien eindeloos verder gaan met de bootfolder /boot/boot/boot/boot/boot/boot/boot/boot/boot/boot etc etc.
    2) ik heb geen file /boot/grub/menu.lst of /etc//grub.conf
    edit
    Boot Loader Config zegt me dat menu.lst "modified is by Yast" en dat grubconf "setup –stage2=/boot/grub/stage2 –force-lba (hd0,0) quit"
    3) opstarten van Boot Config in Yast zegt me "vanwege partitioning kan bootloader niet correct gestart worden"….?
    4) Wat kan ik nog meer vertellen erover? Partitioning is nu als volgt..
    dev/sda1 extended
    dev/sda2-4 NTFS waarvan 2 en 4 file storage en 3 windows
    sda 5 en sda 7 logical partitions of sda1 en sda6 is swap.
    5) Arghgh
    6) Even bakkie koffie zetten
  • [quote:fe3de1f599="maximilaan"]Als het goed is niet: suse gebruikt hem gewoon, maar formatteert hem niet nog een keertje.. Opnieuw formatteren is immers onzinnig.[/quote:fe3de1f599] Ik denk ook dat opnieuw formatteren van de swap partitie niet echt nodig is. Maar dat het wel gebeurt, is gewoon mijn persoonlijke ervaring met verschillende Linux distributies.


    @Stu III, om welke versie van openSuSE ging het? LiveCD of DVD? En kun je iets zeggen over de installatie keuzes je hebt gedaan? Vergelijk dat eventueel met deze http://en.opensuse.org/Installation/11.0_DVD_Install Bij Step 6: Setting up your disk zou je kunnen gaan voor "Create Partition Setup."
  • [quote:b2e1f1dfda="jolo"]@Stu III, om welke versie van openSuSE ging het?[/quote:b2e1f1dfda]

    het betreft de Gnome Live CD. Partities ging wel ok, ik was op het verkeerde been gebracht door de terminologie die mij de gehele harde schijf aanbood, daardoor nam ik aan dat de CD geinstallleerd zou worden op de hele harde schijf en niet de partitie die ik had aangewezen. Na die keuze gemaakt te hebben kon ik alsnog die partitie kiezen dus geen probleem daar.

    Het probleem wat ik nog niet heb opgelost is de infinite opstart loop van Grub. Of liever ik kom niet eens tot Grub, hij start alleen maar op en op en op. Zie mijn bovenstaand bericht.
    Verder, mocht het helpen…:
    [quote:b2e1f1dfda]grub> find /boot/grub/stage1
    (hd0,4)
    (hd0,6)
    [/quote:b2e1f1dfda]

    Ik heb niet het idee dat OSuse een menu.lst file heeft aangemaakt, of overgelaten want het staat nergens in /boot/grub
  • [quote:223058f992="Stu III"] het betreft de Gnome Live CD. [/quote:223058f992] openSUSE 11.1 dus? Check dan nog even het volgende. De installatie vanaf de LiveCD zou als volgt kunnen verlopen.

    Dubbel-klik op Live Install
    Language: Dutch – Nederlands
    Keyboard Layout: Engels (US)
    Next
    Clock and Time Zone: Europe – Netherlands
    Next
    Suggested Partitioning
    Create Partition Setup > Custom Partitioning
    Next
    Dubbel-klik op de gewenste root partitie voor openSUSE
    Edit
    Formatting Options: Format partition
    Mounting Options: Mount Partition [b:223058f992] / [/b:223058f992]
    Finish > Accept
    Als de getoonde info klopt > Next
    Create New User
    Check de getoonde Installatie overzicht
    Install
    Na de reboot: Automatic configuration.

    Dit heb ik even geprobeerd op een oude Test-PC. Een dual Pentium3 1000 MHz met 1.0 GB werkgeheugen.

    In het openSUSE boot menu staan dan ongeveer

    openSUSE 11.1
    Mandriva Linux 2009.1
    Ubuntu 9.04
    Ubuntu 8.04.2
    Windows 2000
    Windows 7 RC
    Floppy
    openSUSE 11.1 (failsafe)

    openSUSE 11.1, Mandriva Linux 2009.1 en Ubuntu 8.04.2 starten bij mij goed op. Alleen net zoals bij jouw, zag ik ook bij Ubuntu 9.04 zijn eigen grub boot menu. En verscheen Error 15. File not found.

    En dit terwijl er niks fout staat in het grub boot menu van Ubuntu 9.04. Het lijkt erop dat het grub boot menu van openSUSE 11.1 het 'stokje' niet goed doorgeeft aan het grub boot menu van Ubuntu 9.04. Ik denk dat dit een 'bug' is.


    @maximilaan, het ziet er naar uit dat ik je gelijk moet geven. openSUSE 11.1 maakt standaard inderdaad gewoon gebruik van een al eerder geformatteerd partitie, zonder deze opnieuw te formatteren.

    @Stu III, een verklaring waarom je grub nu helemaal niet werkt, heb ik niet. Er zit denk ik niets anders op dat je nogmaals openSuSE 11.1 opnieuw probeert te installeren.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.