Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

NDAS schijf aan de praat krijgen

Anoniem
jolo
1 antwoord
  • Hoi,

    Ik heb nog niet zo lang geleden ubuntu geïnstalleerd en ben nog niet zo thuis in het hele linux gebeuren, dus ik hoop dat iemand me een beetje op weg kan helpen met hetvolgende:

    Ik heb een tijdje geleden een externe harddisc gekocht. (dane-elec) Het was een schijf die je op het netwerk kon aansluiten, dus ik dacht het is een NAS schijf, maar het bleek een NDAS schijf. Ik had echter van NDAS nog nooit gehoord, maar het bleek dat je er een extra clientsoftwarepakketje voor nodig had om de schijf te registreren. Onder windows geïnstalleerd en werkt prima. Nu heb ik echter ubuntu geïnstalleerd (9.04) en ben ik eens aan het surfen gegaan om NDAS software te vinden, maar hetgeen ik vind krijg ik niet aan de praat op mijn machine.
    Ik heb o.a. deze walkthrough geprobeerd: http://code.ximeta.com/trac-ndas/wiki/HowToBuildDEB

    [code:1:5978940640]
    sudo apt-get install dpkg-dev debhelper gcc bzip2 fakeroot module-assistant libc6-dev build-essential
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    dpkg-dev is already the newest version.
    debhelper is already the newest version.
    gcc is already the newest version.
    bzip2 is already the newest version.
    fakeroot is already the newest version.
    module-assistant is already the newest version.
    libc6-dev is already the newest version.
    build-essential is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    ndasadmin: Depends: ndas-modules but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    [/code:1:5978940640]

    [code:1:5978940640]
    sudo apt-get update
    Hit http://security.ubuntu.com jaunty-security Release.gpg
    Ign http://security.ubuntu.com jaunty-security/main Translation-en_US
    Ign http://security.ubuntu.com jaunty-security
    estricted Translation-en_US
    Ign http://security.ubuntu.com jaunty-security/universe Translation-en_US
    Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_US
    Hit http://security.ubuntu.com jaunty-security Release
    Hit http://nl.archive.ubuntu.com jaunty Release.gpg
    Ign http://nl.archive.ubuntu.com jaunty/main Translation-en_US
    Ign http://nl.archive.ubuntu.com jaunty
    estricted Translation-en_US
    Ign http://nl.archive.ubuntu.com jaunty/universe Translation-en_US
    Ign http://nl.archive.ubuntu.com jaunty/multiverse Translation-en_US
    Get:1 http://nl.archive.ubuntu.com jaunty-updates Release.gpg [189B]
    Ign http://nl.archive.ubuntu.com jaunty-updates/main Translation-en_US
    Ign http://nl.archive.ubuntu.com jaunty-updates
    estricted Translation-en_US
    Hit http://security.ubuntu.com jaunty-security/main Packages
    Ign http://nl.archive.ubuntu.com jaunty-updates/universe Translation-en_US
    Ign http://nl.archive.ubuntu.com jaunty-updates/multiverse Translation-en_US
    Hit http://nl.archive.ubuntu.com jaunty Release
    Hit http://security.ubuntu.com jaunty-security
    estricted Packages
    Hit http://security.ubuntu.com jaunty-security/main Sources
    Hit http://security.ubuntu.com jaunty-security
    estricted Sources
    Hit http://security.ubuntu.com jaunty-security/universe Packages
    Get:2 http://nl.archive.ubuntu.com jaunty-updates Release [57.9kB]
    Hit http://security.ubuntu.com jaunty-security/universe Sources
    Hit http://security.ubuntu.com jaunty-security/multiverse Packages
    Hit http://security.ubuntu.com jaunty-security/multiverse Sources
    Hit http://nl.archive.ubuntu.com jaunty/main Packages
    Hit http://nl.archive.ubuntu.com jaunty
    estricted Packages
    Hit http://nl.archive.ubuntu.com jaunty/main Sources
    Hit http://nl.archive.ubuntu.com jaunty
    estricted Sources
    Hit http://nl.archive.ubuntu.com jaunty/universe Packages
    Hit http://nl.archive.ubuntu.com jaunty/universe Sources
    Hit http://nl.archive.ubuntu.com jaunty/multiverse Packages
    Hit http://nl.archive.ubuntu.com jaunty/multiverse Sources
    Get:3 http://nl.archive.ubuntu.com jaunty-updates/main Packages [197kB]
    Get:4 http://nl.archive.ubuntu.com jaunty-updates
    estricted Packages [2599B]
    Get:5 http://nl.archive.ubuntu.com jaunty-updates/main Sources [55.4kB]
    Get:6 http://nl.archive.ubuntu.com jaunty-updates
    estricted Sources [509B]
    Get:7 http://nl.archive.ubuntu.com jaunty-updates/universe Packages [82.7kB]
    Get:8 http://nl.archive.ubuntu.com jaunty-updates/universe Sources [23.1kB]
    Get:9 http://nl.archive.ubuntu.com jaunty-updates/multiverse Packages [8128B]
    Get:10 http://nl.archive.ubuntu.com jaunty-updates/multiverse Sources [2505B]
    Fetched 430kB in 1s (255kB/s)
    Reading package lists… Done
    [/code:1:5978940640]

    [code:1:5978940640]
    sudo apt-get install -f
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Correcting dependencies… Done
    The following packages will be REMOVED:
    ndasadmin
    0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
    1 not fully installed or removed.
    After this operation, 123kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database … 143259 files and directories currently installed.)
    Removing ndasadmin …
    [/code:1:5978940640]

    (je ziet het, ik heb het al eens eerder geprobeerd ;-)

    [code:1:5978940640]
    sudo apt-get install dpkg-dev debhelper gcc bzip2 fakeroot module-assistant libc6-dev build-essential
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    dpkg-dev is already the newest version.
    debhelper is already the newest version.
    gcc is already the newest version.
    bzip2 is already the newest version.
    fakeroot is already the newest version.
    module-assistant is already the newest version.
    libc6-dev is already the newest version.
    build-essential is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    [/code:1:5978940640]

    [code:1:5978940640]
    sudo apt-get install linux-headers-`uname -r`
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package linux-headers-2.6.27-7-generic is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package linux-headers-2.6.27-7-generic has no installation candidate
    [/code:1:5978940640]

    No installation canditate… Hier gaat dus al wat mis…

    [code:1:5978940640]
    sudo tar zxf ndas-1.1-24.tar.gz
    rogier@rogier-desktop:~/downloads$ cd ndas-1.1-24/
    rogier@rogier-desktop:~/downloads/ndas-1.1-24$ dpkg-buildpackage -rfakeroot
    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CPPFLAGS to default value:
    dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    dpkg-buildpackage: source package ndas
    dpkg-buildpackage: source version 1.1-24
    dpkg-buildpackage: source changed by Ilgu Hong <ighong@ximeta.com>
    dpkg-buildpackage: host architecture i386
    fakeroot debian
    ules clean
    /usr/bin/fakeroot: line 176: debian
    ules: Permission denied
    dpkg-buildpackage: failure: fakeroot debian
    ules clean gave error exit status 126
    [/code:1:5978940640]

    Buildpackage failure… Zal vast ook te maken hebben met die no installation candidate…

    [code:1:5978940640]
    ls -l *.deb
    -rw-r–r– 1 rogier rogier 1887304 2009-04-22 21:17 audacity_1.2.4b-2ubuntu2.1_i386.deb
    -rw-r–r– 1 rogier rogier 21982 2009-10-23 21:25 ndasadmin_1.1-24_i386.deb
    -rw-r–r– 1 rogier rogier 22048 2009-07-12 14:49 ndasadmin_1.1-24_Ubuntu8.04-i386.deb
    -rw-r–r– 1 rogier rogier 194748 2009-10-23 21:25 ndas-modules-src_1.1-24_all.deb
    -rw-r–r– 1 rogier rogier 194920 2009-07-12 14:48 ndas-modules-src_1.1-24_Ubuntu8.04-all.deb
    -rw-r–r– 1 rogier rogier 4102922 2009-04-22 21:29 rosegarden_1.7.3-0~getdeb1_i386.deb
    [/code:1:5978940640]

    Blijkbaar zijn de packages wel aangemaakt

    [code:1:5978940640]
    sudo dpkg -i ndas-modules-src_1.1-24_all.deb
    (Reading database … 143250 files and directories currently installed.)
    Preparing to replace ndas-modules-src 1.1-24 (using ndas-modules-src_1.1-24_all.deb) …
    Unpacking replacement ndas-modules-src …
    Setting up ndas-modules-src (1.1-24) …
    [/code:1:5978940640]

    [code:1:5978940640]
    sudo m-a prepare
    Getting source for kernel version: 2.6.27-7-generic
    apt-get install linux-headers-2.6.27-7-generic
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package linux-headers-2.6.27-7-generic is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package linux-headers-2.6.27-7-generic has no installation candidate
    apt-get install build-essential
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    build-essential is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

    Done
    [/code:1:5978940640]

    Nog steeds geen release candidate…

    Dan met m-a autoinstall krijg ik een blauw scherm met:

    Bad luck, the kernel headers for the target kernel version could not be found and you did not specify othervalid kernel headers to use.

    If the running kernel has been shipped with the Debian distribution, please install the package linux-headers-2.6.27-7-generic. If your kernel source tree (orheaders) is located in some non-usual location, please set the KERNELDIRS environment variable to the path of this directory, or (alternatively) specify the source directory we build for with the –kernel-dir option in module-assistant calls. Package ndas-modules-src was not built successfully, see /var/cache/modass/ndas-modules-src*buildlog* for details! ^Y

    Verder kom ik niet… Ik heb al geprobeerd met export NDAS_KERNEL_PATH=/usr/src/linux-headers-2.6.28-16-generic/
    Maar dat helpt ook niet…

    [code:1:5978940640]
    sudo m-a auto-install ndas

    Updated infos about 1 packages
    Getting source for kernel version: 2.6.27-7-generic
    apt-get install linux-headers-2.6.27-7-generic
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package linux-headers-2.6.27-7-generic is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package linux-headers-2.6.27-7-generic has no installation candidate
    apt-get install build-essential
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    build-essential is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

    Done!
    [/code:1:5978940640]

    Ik hoop dat iemand mij verder kan helpen…

    groeten,

    Rogier











Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.