Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

externe harde schijven niet herkend onder ubuntu 10.04 LTS

None
20 antwoorden
  • Wanneer ik mijn externe harde schijven aansluit op mijn ubuntu 10.04 LTS pc's, worden deze niet herkend. Er verschijnt geen icoon op het bureaublad.
    In alle vroegere ubuntu versies was dit nooit een probleem en werden ze allemaal direct herkend.

    Weet iemand hoe dit kan en hoe m'n harde schijven wel direct herkend worden?

    Thx!
  • Hoi Jan,

    Ik gebruik geen Ubuntu meer, maar Debian. Wat je kunt doen, is kijken of je onder terminal de schrijven wel ziet. Open een console als root en typ in:

    fdisk -l

    Als ze daar bij staan, kan je ze mounten met:

    mount -t auto /dev/sda1 (of hda1) /mnt/folder

    Succes,

    Stephan
  • [quote:8a29520b98="jan13011965"]Wanneer ik mijn externe harde schijven aansluit op mijn ubuntu 10.04 LTS pc's, worden deze niet herkend. Er verschijnt geen icoon op het bureaublad. [/quote:8a29520b98] Als deze externe harddisk is aangesloten via USB of Firewire, zouden de partities daarop direct geopend getoond worden op het bureaublad. Handmatig mounten zoals sverrips voorstelt, is tegenwoordig niet meer nodig. Als je dat hebt uitgezet, dan zou je externe harddisk nog wel te zien behoren te zijn via Locaties > Computer.
  • Ik heb niets uitgezet, enkel ubuntu 10.04 LTS geinstalleerd op m'n pc's.

    Het vreemde is dat het een beetje wisselt, blijkt nu : de ene ehd (externe hard disk) wordt wel herkend en het icoon verschijnt keurig op het bureaublad, een andere ehd tref ik wel aan onder Places > Computer en wanneer ik er dan op klik verschijnt plotseling wel het icoon op het bureaublad en werkt alles naar behoren, terwijl op een andere pc de aangesloten ehd volstrekt niet herkend wordt. Ra,ra,ra hoe kan dit, vraag ik mij af?
    Zou dit te maken kunnen hebben met 'kinderziektes' in ubuntu 10.04 LTS?

    Dan krijg ik ook nog de volgende melding, wanneer ik via een rechtsklik een van m'n ehd's probeer te unmounten:

    "Unable to unmount EHD200A. umount: /media/EHD200A is not in the fstab (and you are not root)".
    Kan iemand mij wellicht uitleggen wat hier precies bedoeld wordt en hoe ik de betreffende ehd wel ge-unmount krijg?

    (Overigens sluit ik alles via USB 2.0 aan ; dus geen Firewire.)
  • [quote:f05e106e0b="jan13011965"]terwijl op een andere pc de aangesloten ehd volstrekt niet herkend wordt. Ra,ra,ra hoe kan dit, vraag ik mij af? [/quote:f05e106e0b] En je had elke keer consequent in Ubuntu gebruik gemaakt van de optie "Station veilig verwijden" en zoiets vergelijkbaars in Windows?

    Zelf deed ik vlak voordat ik mijn vorig bericht postte, een klein testje. Mijn externe usb hd op de laptop uit mijn onderschrift pluggen, onder Ubuntu 10.04. Deze werd ook niet gezien. Ook niet in Places > Computer of [code:1:f05e106e0b] sudo fdisk -l [/code:1:f05e106e0b]
    Ik zag echter wel het rode lampje van mijn externe usb hd knipperen. Omdat er verder niks gebeurde, heb ik 'm uitgezet, en even later weer aan. (Is 2,5 inch hd die voeding heeft via usb.) Toen werd deze wel gezien.

    //Edit

    [quote:f05e106e0b="jan13011965"]"Unable to unmount EHD200A. umount: /media/EHD200A is not in the fstab (and you are not root)". [/quote:f05e106e0b] Er wordt precies bedoelt, wat er staat. Deze regel staat niet in het fstab, en had 'm niet uitgevoerd als superuser. Over het algemeen zou het umounten in Nautilus wel behoren te werken. Is dit niet het geval, dan kun je dat altijd nog doen in een terminal. Dus
    [code:1:f05e106e0b] sudo umount: /media/EHD200A [/code:1:f05e106e0b][enter]
  • Het is bij mij een beetje van hetzelfde.

    Ik ben wat gaan testen met externe disks en wat usb-sticks en een deel wordt wel gewoon herkend en is ook regulier te unmounten (zoals het hoort te zijn dus), terwijl er af en toe ook een disk of usb-stick niet herkend wordt, maar na heraansluiten plotseling weer wel. Niet echt consequent dus.

    Wellicht ook nog kinderziektes van ubuntu 10.04 LTS die d.m.v. updates t.z.t. automatisch verholpen zullen zijn?
  • Nou, op een van mijn pc's met ubuntu 10.04 LTS is waarschijnlijk een 'interne staking' aan de gang of iets dergelijks, want nu wordt er dus GEEN ENKELE externe harde schijf, usb-stick of welk ander extern device dan ook meer herkend. Het blijft ijzingwekkend stil op m'n bureaublad … Nog niet eerder meegemaakt.

    Dit lijkt me niet meer met kinderziektes te maken te hebben. Heeft iemand soortgelijke ervaringen en (nog belangrijker) weet iemand hoe allerhande externe devices weer normaal herkend worden? Dit werkt nogal onpraktisch. (Ik kan wel workarounds bedenken, maar dat was niet echt de bedoeling toen ik ubuntu 10.04 LTS installeerde).
  • En als je die probleem PC opstart vanaf een Ubuntu 10.04 LTS CD als Live CD. Om wat voor een merk/type PC gaat het? Post daarvan de output van [code:1:e92b868c36] lspci -tv [/code:1:e92b868c36][Enter] en vergelijk de outputs van [code:1:e92b868c36] lsusb [/code:1:e92b868c36][Enter] zonder en met USB apparaten ingeplugd. Check dat bij voorkeur 1 USB apparaat tegelijk.
  • De desktop-PC waar het om gaat is merkloos (zelf samengesteld).

    Wanneer ik deze met de live-cd ubuntu 10.04 LTS boot, worden ALLE externe harde schijven en usb-sticks gewoon herkend! (Grrrrrrr …….)


    Externe harde schijf (usb 2.0) UITGESCHAKELD :

    Output van lspci -tv =

    -[0000:00]-+-00.0 Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller
    +-01.0-[0000:01]—-00.0 nVidia Corporation G84 [GeForce 8600 GTS]
    +-1a.0 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4
    +-1a.1 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5
    +-1a.2 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6
    +-1a.7 Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2
    +-1b.0 Intel Corporation 82801I (ICH9 Family) HD Audio Controller
    +-1c.0-[0000:04]–
    +-1c.4-[0000:03]–+-00.0 JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller
    | \-00.1 JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller
    +-1c.5-[0000:02]—-00.0 Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller
    +-1d.0 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1
    +-1d.1 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2
    +-1d.2 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3
    +-1d.7 Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1
    +-1e.0-[0000:05]—-03.0 Agere Systems FW322/323
    +-1f.0 Intel Corporation 82801IR (ICH9R) LPC Interface Controller
    +-1f.2 Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller
    +-1f.3 Intel Corporation 82801I (ICH9 Family) SMBus Controller
    \-1f.5 Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller

    Output van lsusb =

    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 002: ID 041e:3040 Creative Technology, Ltd SoundBlaster Live! 24-bit External SB0490
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 006: ID 05ac:0221 Apple, Inc. Keyboard (Aluminium) (ISO)
    Bus 002 Device 005: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
    Bus 002 Device 004: ID 046d:c404 Logitech, Inc. TrackMan Wheel
    Bus 002 Device 002: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    [u:2519360951][/u:2519360951]

    Externe harde schijf (usb 2.0) INGESCHAKELD :

    Output van lspci -tv =

    -[0000:00]-+-00.0 Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller
    +-01.0-[0000:01]—-00.0 nVidia Corporation G84 [GeForce 8600 GTS]
    +-1a.0 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4
    +-1a.1 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5
    +-1a.2 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6
    +-1a.7 Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2
    +-1b.0 Intel Corporation 82801I (ICH9 Family) HD Audio Controller
    +-1c.0-[0000:04]–
    +-1c.4-[0000:03]–+-00.0 JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller
    | \-00.1 JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller
    +-1c.5-[0000:02]—-00.0 Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller
    +-1d.0 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1
    +-1d.1 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2
    +-1d.2 Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3
    +-1d.7 Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1
    +-1e.0-[0000:05]—-03.0 Agere Systems FW322/323
    +-1f.0 Intel Corporation 82801IR (ICH9R) LPC Interface Controller
    +-1f.2 Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller
    +-1f.3 Intel Corporation 82801I (ICH9 Family) SMBus Controller
    \-1f.5 Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller

    Output van lsusb =

    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 002: ID 041e:3040 Creative Technology, Ltd SoundBlaster Live! 24-bit External SB0490
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 007: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
    Bus 002 Device 006: ID 05ac:0221 Apple, Inc. Keyboard (Aluminium) (ISO)
    Bus 002 Device 005: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
    Bus 002 Device 004: ID 046d:c404 Logitech, Inc. TrackMan Wheel
    Bus 002 Device 002: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Kun je hier wat mee?
  • Er zijn onlangs enkele updates binnengekomen voor 10.04, die op dit gebied betrekking hebben. Hebben die deze zaak bij jou verbeterd?
  • Ik heb de laatste updates binnengehaald en wederom een hele riedel externe disks en usb-sticks uitgeprobeerd en nu wordt plotseling wel alles weer herkend :o ! (???)
    Dit heb ik eerder meegemaakt dus ik roep nog geen hoera, maar zal de komende tijd blijven checken of de externe disks en usb-sticks ook daadwerkelijk herkend blijven worden, want het zou me niet verbazen wanneer er binnenkort weer een 'interne staking' in m'n pc plaatsvindt. Mocht dit weer het geval zijn, dan maak ik hier weer melding van.

    Wanneer er andere gebruikers zijn, die ook tegen dit probleem aanlopen met ubuntu 10.04 LTS, post dat dan even hier s.v.p.. Thx!

    Nog wel even dit : bij het unmounten van een van de externe harde schijven, kreeg ik wel onderstaande melding :

    "Unable to stop drive.

    Error detaching: helper exited with exit code 1: Detaching device /dev/sdb
    USB device: /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2/2-2.4)
    SYNCHRONIZE CACHE: FAILED: No such file or directory
    (Continuing despite SYNCHRONIZE CACHE failure.)
    STOP UNIT: FAILED: No such file or directory"

    Ik kan er weinig mee. Ik weet dus ook niet of dit verband houdt met het niet herkennen van de media (?).
    -
    -
    -
    -
    -
    (30 minuten later na een reboot) :

    Guess what??? Inderdaad ….. er wordt nu weer niets herkend. Het begint bijna lachwekkend te worden.
    Voor de zekerheid weer de update manager laten draaien en pc weer gereboot dit keer met een usb-stick in een poort, maar geen teken van leven!
    Ik kan me toch bijna niet voorstellen dat ik de enige ben die tegen dit euvel aanloopt.
  • Ik zit te denken aan twee mogelijkheden:
    1. de usb-controllers hebben geen goed stuurprogramma in 10.04;
    2. de hardware is rot…
  • [quote:0022a72b0c="jan13011965"]De desktop-PC waar het om gaat is merkloos (zelf samengesteld). [/quote:0022a72b0c] Ik heb niets vreemds kunnen vinden in jouw outputs. Zou je ook nog kunnen melden om welk merk/type moederbord het gaat?
  • @ pjotr :
    "1. de usb-controllers hebben geen goed stuurprogramma in 10.04;"

    Hier zat ik ook al direct aan te denken. Alleen zouden er dan toch veel meer mensen tegen dit probleem moeten aanlopen lijkt me? Verder zou dan d.m.v. de updates het probleem automatisch opgelost moeten worden, wanneer wel de correcte usb-drivers voor 10.04 LTS geinstalleerd zijn. We zijn nu al enkele weken verder en mochten betreffende drivers nog komen, dan is dat m.i. nogal laat. Het zou dan om de specifieke drivers van mijn moederbord (ASUS P5K-E ; pc is van april 2008 ; kast is van Coolermaster) moeten gaan, want op mijn andere, bijna 10 jaar oude pc (opm terzijde : en Ubuntu 10.04 LTS draait erop als een zonnetje :D) worden alle externe media keurig herkend.

    "2. de hardware is rot…"

    Aangezien ik inmiddels al een aardig tijdje met computers werk, weet ik bijna zeker dat dit geen hardwarematig probleem is.

    @ jolo :

    Gaat dus om het volgende moederbord : ASUS P5K-E. (Ik kies altijd voor een ASUS -moederbord omdat ik deze kwalitatief het beste vind).


    Uiteraard breek ik mezelf ook de hersens over deze kwestie. Het moet gewoon iets 'lulligs' zijn denk ik. Maar ja, even dat 'lulligs' zien uit te vinden, valt nog niet mee.
  • [quote:cd48555cc7="jan13011965"]ASUS P5K-E. [/quote:cd48555cc7] Asus is doorgaans inderdaad een goede keuze voor Linux. Zeker gezien deze review http://www.phoronix.com/scan.php?page=article&item=935&num=1 en ook deze http://linuxblog.pansapiens.com/2007/08/24/ubuntu-install-on-asus-p5k-e-core2-duo-e6750/ Een quote hieruit [quote:cd48555cc7] Not surprisingly, USB works fine, and the P5K-E boards have a PS2 keyboard port (not mouse, however), which saved my buying a new keyboard. [/quote:cd48555cc7] En dat onder Ubuntu 7.04 (Feisty Fawn).

    Hier meldt iemand wel problemen met een P5K en P5K-E. Maar dat is met een draadloze usb-stick https://bugs.launchpad.net/ubuntu/+source/linux/+bug/182473?comments=all

    Wellicht zou je zelf een bug melding kunnen proberen. Info hierover is te vinden in deze hyperlink https://help.ubuntu.com/community/ReportingBugs
  • Alvorens tot een bugmelding over te gaan, heb ik iets ontdekt.

    Mijn laserprinter HP M1120n heb ik geinstalleerd via de terminal (ja,ja en dat voor een non-terminaltijger als moi) via het volgende commando :

    sh hplip-3.10.2.run

    Op een andere manier krijg ik dat ding namelijk niet aan de praat.
    Nu komt het … soms verschijnt direct na het booten de volgende melding :

    "HPLIP Status Service
    No system tray detected on this system.
    Unable to start, exiting."

    en soms ook niet. Wanneer de melding verschijnt, sluit ik het betreffende venster en kan ik gewoon printen overigens (???).

    Daarnet heb ik m'n pc geboot en toen verscheen de melding NIET, waarna ik externe media aansloot en deze werden herkend!!
    Ik heb de pc gereboot en de melding verscheen WEL. Ik dacht laat ik de externe media eens aansluiten en kijken of ze nog steeds herkend worden : nee dus!
    Nou weet ik niet zeker of er een samenhang is tussen voornoemde zaken, maar het lijkt er wel op.

    Eigenlijk wil ik definitief van die printer-melding af en dan checken of inderdaad de externe media BLIJVEND gewoon door ubuntu 10.04 LTS herkend worden. Zo ja, dan kan geconcludeerd worden, dat die printer-melding de oorzaak is.

    De vraag is nu dus : hoe kom ik van die printer-melding af?
    Zou er wanneer de melding niet verschijnt een of ander bestand meegeladen worden waar ook het herkennen van externe media van afhankelijk is??? Ik doe maar een gooi …
  • Je zou ook eens kunnen kijken of een nieuw BIOS helpt:
    http://support.asus.com/download/download.aspx?SLanguage=en-us

    BIOS-updates zijn wel riskant: als het fout gaat, kun je mogelijk je moederbord weggooien. Zelf doe ik altijd BIOS-updates (leuk!), maar ik heb een paar jaar geleden inderdaad weleens een moederbord naar de eeuwige jachtvelden geholpen…..

    BIOS flitsen doe je zo in Linux:
    http://sites.google.com/site/computertip/biosflitsen
  • Bedankt voor je tip, maar ik ben bekend met het fenomeen bios-update en die gok neem ik liever niet. Dan is het middel straks erger dan de kwaal…
    Net te vaak gelezen over "effe bios-updaten" (snelle jongens met net iets te weinig verstand van computers) en daaaaaaag moederbord.
    Met een ouwe "bij-computer" no problem, maar niet met m'n hoofd-pc in m'n systeem!
  • Zelf is een BIOS update niet het eerste waar ik aan zou denken, voor een Ubuntu 10.04 gerelateerd probleem. Ook als omdat de nieuwste BIOS van je ASUS P5K-E als datum 2009/07/02 heeft. Waarom zou een BIOS van bijna een jaar oud, een Ubuntu 10.04 gerelateerd probleem kunnen oplossen? Of hebben oudere versies van Ubuntu ook ditzelfde probleem, met die ASUS P5K-E? Heeft ter vergelijking Windows Vista en/of Windows 7 nog wel probleemloos met USB apparaten kunnen werken?

    Overigens ontbreekt er nog een manier van BIOS updaten, op de site van pjotr123. De veiligste manier van BIOS updaten is in het BIOS zelf via EZ Flash 2 - the safest way to update BIOS. Zie daarvan deze afbeelding. Het is van een ander type Asus als voorbeeld.

    [img:ffc441f328]http://www.xbitlabs.com/images/mainboards/asus-p5e/ezflash-s.jpg[/img:ffc441f328]
  • Ik heb maar eens even een aantal weken de zaak aangekeken en steeds netjes alle updates laten installeren.
    De situatie is nu dat alle externe media keurig worden herkend en dit gaat reeds een dag of 10 goed! Dus toch waarschijnlijk de updates hebben het probleem (wat dat dan ook wezen moge) geelimineerd.
    Geen BIOS probleem zoals Jolo ook al aangeeft.

    Voor de komende tijd zie ik het aan. Mochten zich er toch weer problemen voordoen, dan meld ik dat hier weer.

    Nogmaals : Pjotr's tip om niet direct te upgraden na release van een nieuwe Ubuntu-versie is een wijze!
    Toch maar even een maand of 2 wachten zodat alle kinderziektes eruit zijn.
    Uiteraard blijft dat een keuze die ieder voor zich persoonlijk moet maken.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.