Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Ubuntu 10.04 Server ->fstab

opamax
34 antwoorden
  • Volgens Doc van Howtoforge moet er bij punt 12 worden toegevoegd aan /etc/fstab[code:1:e14fb8c317],usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0[/code:1:e14fb8c317]en dat heb ik toegevoegd aan de 2e regel, beginnend met /dev/mapper.
    Eigenlijk heb ik dat INgevoegd in die regel (als voorbeeld).
    Bij mount -o remount krijg ik de foutmelding dat die betreffende regel 'bad' is.

    Heb ik dat niet goed INgevoegd ? Of moet dat in/op een nieuwe regel en die begeinnen met '/ ' als mountpoint ?
    Heel graag advies van iemand die het al heeft geinstalleerd.
  • [quote:853f22c6d3="opamax"]Volgens Doc van Howtoforge moet er bij punt 12 worden toegevoegd aan /etc/fstab[code:1:853f22c6d3],usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0[/code:1:853f22c6d3]en dat heb ik toegevoegd aan de 2e regel, beginnend met /dev/mapper.
    Eigenlijk heb ik dat INgevoegd in die regel (als voorbeeld).
    Bij mount -o remount krijg ik de foutmelding dat die betreffende regel 'bad' is.

    Heb ik dat niet goed INgevoegd ? Of moet dat in/op een nieuwe regel en die begeinnen met '/ ' als mountpoint ? [/quote:853f22c6d3] Dan zal er iets fout gegaan zijn, bij het kopiëren en plakken.
    Je hebt het neem ik aan over deze http://howtoforge.net/perfect-server-ubuntu-10.04-lucid-lynx-ispconfig-2-p4 Dan moet je inderdaad zoals daar staat, die regel toevoegen aan die regel met de root mount punt. Dat is het makkelijkst op een breedbeeld TFT monitor, van bijvoorbeeld 22 inch of groter. Zodat die regel volledig op één lijn past, zonder te scrollen.

    Dus je had uiteindelijk toch maar besloten te wachten op Ubuntu 10.04 server. http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=205892&start=20
  • Hartelijk dank voor de snelle reactie !
    Klopt, heb inderdaad even gewacht op 10.04.
    Klopt ook dat ik die doc van howtoforge volg.
    Heb wel een flat screen, maar geen grote.
    Moet dus toch -ongeveer- op de manier zoals ik gedaan heb. Dus TOEGEVOEGD en wel IN de genoemde regel, maar zoals ik het heb ingevoerd is dat niet NA een "/". Weet u hoe die regel er dan PRECIES moet uit zien ?
    Bvd en vr groet
  • Ik denk dat je het beste je originele /etc/fstab hier kunt posten. En daaronder post je gewijzigde /etc/fstab zodat ik kan controleren, of je die howto goed hebt begrepen.

    Het origineel van die howto, dus zonder die wijziging, zal er zo uitgezien hebben
    [code:1:d2c770a670]
    /dev/mapper/server1-root / ext4 errors=remount-ro 0 1
    [/code:1:d2c770a670]
    Die toevoeging komt dus tussen die [b:d2c770a670] errors=remount-ro [/b:d2c770a670] en [b:d2c770a670] 0 1 [/b:d2c770a670] Omdat het om een voorbeeld gaat, zit jouw /etc/fstab er waarschijnlijk anders uit. Belangrijk is dat je die wijziging met een gewone tekst verwerker maakt, zoals gedit, kate. Of als je die wijzigingen uitvoert onder Windows, dan gebruik je een editor als notepad.
  • De originele fstab heb ik helaas niet meer (stom), maar de huidige ziet er zo uit:[code:1:16c7fcd0d5] # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier for a device; this may be used with UUID=
    # as a more robust way to name devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    /dev/mapper/ubuntu-root / ext4 errors=remount-ro, usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 1
    # /boot was on /dev/sda1 during installation
    UUID=e6362f2b-7459-4a8c-aac3-97e014cca131 /boot ext2 defaults 0 2
    /dev/mapper/ubuntu-swap_1 none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    [/code:1:16c7fcd0d5] Waar zit de fout ?
  • Omdat de forum software lange regels afbreekt, heb ik je code eerst naar een editor gekopieerd. En daarin zie ik een spatie tussen [b:88582f0409] errors=remount-ro, [/b:88582f0409] en [b:88582f0409] usrjquota [/b:88582f0409]
    Die spatie kun je weghalen. Verder zie ik geen fouten.
  • En de foutmelding zie ik niet meer. Klasse !
  • Aangekomen bij 13 DNS Server dan:
    [b:7b0c368f55]aptitude install bind9[/b:7b0c368f55]
    gaat goed, maar de volgende:
    [b:7b0c368f55]/etc/init.d/bind9 stop[/b:7b0c368f55]
    dan meldt hij:[code:1:7b0c368f55]-bash: /etc/init.d/bind9: No such file or directory[/code:1:7b0c368f55]
    Ra,ra. Tot hier geen foutmelding gezien en de CD laten controleren.
    Wat zou er dan hier zijn ?
  • [quote:bf0e8c6bf6="opamax"]aptitude install bind9[/quote:bf0e8c6bf6] Dat gaf dus geen foutmeldingen?
    [quote:bf0e8c6bf6="opamax"]
    /etc/init.d/bind9 stop
    dan meldt hij:
    [code:1:bf0e8c6bf6]
    -bash: /etc/init.d/bind9: No such file or directory
    [/code:1:bf0e8c6bf6][/quote:bf0e8c6bf6] Heb je gecheckt, of dat het geval is. [code:1:bf0e8c6bf6] ls -la /etc/init.d | grep bind9 [/code:1:bf0e8c6bf6][Enter]

    Want als /etc/init.d/bind9 niet bestaat, zou er iets misgegaan kunnen zijn met die [code:1:bf0e8c6bf6] aptitude install bind9 [/code:1:bf0e8c6bf6] commando.
  • aptitude install bind9 geeft als resultaat:[code:1:25c3a8d3ed]root@ubuntu:/etc/init.d# aptitude install bind9
    Pakketlijsten worden ingelezen… Klaar
    Boom van vereisten wordt opgebouwd
    De status informatie wordt gelezen… Klaar
    Reading extended state information
    Initializing package states… Klaar
    No candidate version found for bind9
    No candidate version found for bind9
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Writing extended state information… Klaar
    Pakketlijsten worden ingelezen… Klaar
    Boom van vereisten wordt opgebouwd
    De status informatie wordt gelezen… Klaar
    Reading extended state information
    Initializing package states… Klaar

    root@ubuntu:/etc/init.d#[/code:1:25c3a8d3ed]
    en de opdracht[code:1:25c3a8d3ed] ls -la /etc/init.d | grep bind9 [/code:1:25c3a8d3ed]geeft geen enkele reactie.
    Ga ik naar [b:25c3a8d3ed]/etc/init.d[/b:25c3a8d3ed] en geef een [b:25c3a8d3ed]ls -l[/b:25c3a8d3ed] dan zie ik echt geen bind9.
    Ja zie nu ook "geen candidaat" maar weet niet wat het inhoudt.
  • [quote:fb7381f7dc="opamax"]Ja zie nu ook "geen candidaat" maar weet niet wat het inhoudt.[/quote:fb7381f7dc] Dat er geen pakket bind9 aanwezig is op de server, die vermeldt staat in de /etc/apt/sources.list

    Post eventueel die /etc/apt/sources.list
    Zodat ik het morgen weer verder kan nachecken.
  • Hier dan de sources.list[code:1:8afc8c79d6] ## distribution.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid universe
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid universe
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

    ## Uncomment the following two lines to add software from the 'backports' repository.
    ## N.B. software from this repository may not have been tested as extensively as that contained in the main release,
    ## although it includes newer versions of some applications which may provide useful features. Also, please note
    ## that software in backports WILL NOT receive any review or updates from the Ubuntu security team.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

    ## Uncomment the following two lines to add software from Canonical's 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu lucid partner
    deb-src http://archive.canonical.com/ubuntu lucid partner

    deb http://security.ubuntu.com/ubuntu lucid-security main restricted
    deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
    deb http://security.ubuntu.com/ubuntu lucid-security universe
    deb-src http://security.ubuntu.com/ubuntu lucid-security universe
    deb http://security.ubuntu.com/ubuntu lucid-security multiverse
    deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
    (END)
    [/code:1:8afc8c79d6]
  • Hier dan de sources.list[code:1:56832ecad8] ## distribution.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid universe
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid universe
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid multiverse
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

    ## Uncomment the following two lines to add software from the 'backports' repository.
    ## N.B. software from this repository may not have been tested as extensively as that contained in the main release,
    ## although it includes newer versions of some applications which may provide useful features. Also, please note
    ## that software in backports WILL NOT receive any review or updates from the Ubuntu security team.
    deb http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
    deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

    ## Uncomment the following two lines to add software from Canonical's 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu lucid partner
    deb-src http://archive.canonical.com/ubuntu lucid partner

    deb http://security.ubuntu.com/ubuntu lucid-security main restricted
    deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
    deb http://security.ubuntu.com/ubuntu lucid-security universe
    deb-src http://security.ubuntu.com/ubuntu lucid-security universe
    deb http://security.ubuntu.com/ubuntu lucid-security multiverse
    deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
    (END)
    [/code:1:56832ecad8]
  • [quote:288a3ec645="opamax"]Hier dan de sources.list[/quote:288a3ec645]

    Zo te zien ontbreekt de lucid main restricted repository.

    En maak je gebruik van 'backports'- en Canonical's 'partner' repository. Die je beter niet kunt gebruiken.

    Waarschijnlijk kun je beter de originele /etc/apt/sources.list terugzetten.
  • Zooooo…., dat is een vroege vogel !!!!
    Die sources list heb ik NIET gewijzigd. Alleen, en dat conform de howto, heb ik van die howto de 1e 2 regels aan het begin toegevoegd en, weer conform howto, de aldaar genoemde 4 regels aan het einde van de sources.list toegevoegd. Dus als er iets NIET is dan heeft het er origineel ook niet gestaan. Dus moeten we het nog toevoegen.
    Weet u precies wat er dan nog BIJ moet?
  • Even helemaal opnieuwe begonnen. Herinstall dus. En bij punt 8 van de Howto helemaal niets gewijzigd en dan de opdracht:[code:1:c5449807ed]aptitude update[/code:1:c5449807ed] en die geeft als resultaat[code:1:c5449807ed] Kon 'nl.archive.ubuntu.com' niet vinden
    Pakketlijsten worden ingelezen… Klaar[/code:1:c5449807ed]en dat dan voor alle regels.
    Wat te doen ????
  • [quote:cc758b4616="opamax"] Zooooo…., dat is een vroege vogel[/quote:cc758b4616] Dat is omdat ik zo rond de tijd van posting vanmorgen, het tijd was om naar mijn werk te gaan.
    [quote:cc758b4616="opamax"]Even helemaal opnieuwe begonnen. Herinstall dus. En bij punt 8 van de Howto helemaal niets gewijzigd[/quote:cc758b4616] Dat is inderdaad niet nodig. Ik heb zelf inmiddels Ubuntu 10.04 Server geïnstalleerd op één van mijn oude PC's. In de howto staat de installatie CD regel af te hekken. Dat hoeft niet, want deze is al afgehekt. En checken of universe en multiverse repositories actief staan. Dat is zo te zien al het geval. Daar zou deze nog behoren te werken.

    Dat betekend dus stap zeven even nalopen.
  • Heel goed idee om naar netwerk terug te gaan. Dat doende met een kritische blik ontdekte ik dat ik het ip-nr van provider verkeerd had. En dat was de vorige keer ook zo. Heb dat destijds in prog aangepast, maar niet veranderd in de handgeschreven log die ik weer gebruikte. Stom, stom :cry: . en nu loopt de install als een trein. Hartelijk dank voor goed werk !
  • Install afgewerkt. Alles lijkt OK. It Works !
    In de howto(forge) is een link naar de howto van ISPConfig. Het blijkt hier om versie 2 te gaan. Die howto volgend moet je de opdracht[code:1:92d31850c7]tar xvfz ISPConfig*.tar.gz[/code:1:92d31850c7] uitvoeren. Die tar is toch uitpakken. Dan mis ik iets, nl vanwaar je moet installeren. Weet u dat ?
    En is het sterretje in die tar-regel een risico (versie 2 of 3)?
  • [quote:e1e02fca8e="opamax"] En is het sterretje in die tar-regel een risico (versie 2 of 3)? [/quote:e1e02fca8e] Dat sterretje vult de bestandsnaam aan, zodat je die niet volledig hoeft te typen. En kan je dus gebruiken voor beide versies. Je hebt dus ISPConfig 2.2.35 gedownload, neem ik aan.
    [quote:e1e02fca8e="opamax"] Dan mis ik iets, nl vanwaar je moet installeren.[/quote:e1e02fca8e] Vanuit die uitgepakte map. Als je die commando hieruit hebt, dan kun je de verdere instructies volgen. Je had toch wel aantekeningen gemaakt van die Perfect Server.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.