Vraag & Antwoord

OS Linux

[Ubuntu 10.04.1] Probleem met grafische driver compileren

8 antwoorden
  • LS, Ik heb naast mijn Windows XP nu ook Ubuntu 10.4.1 in dual boot geinstalleerd. Na de installatie kreeg ik netjes een melding dat ik ook "niet-open-source"-drivers van ATI kon installeren, dat heb ik toen gedaan. Helaas valt de performance een beetje tegen en wil ik kijken of ik misschien met een andere driver betere resultaten kan krijgen, in ieder geval wil ik graag hardwareversnelling. Na wat Googlen vond ik [url=http://wiki.x.org/wiki/radeonBuildHowTo]installatie-instructies voor radeon[/url], die volgens mij ook mijn ATI Radeon HD 4890 moet ondersteunen. Ik heb het stappenplan netjes gevolgd, maar bij[code:1:e2afbe7c7c]./autogen.sh --prefix=/opt/xorg[/code:1:e2afbe7c7c]gaat het mis. Ik krijg de melding[code:1:e2afbe7c7c]checking for XORG... configure: error: Package requirements (xorg-server >= 1.2 xproto fontsproto xineramaproto randrproto renderproto videoproto xextproto) were not met: No package 'xineramaproto' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables XORG_CFLAGS and XORG_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.[/code:1:e2afbe7c7c]Ik heb geprobeerd xineramaproto te installeren met [code:1:e2afbe7c7c]sudo apt-get install xineramaproto[/code:1:e2afbe7c7c]maar het pakket kan niet gevonden worden. Googlen naar de foutmelding heeft vooralsnog weinig nuttigs opgeleverd. Kan iemand mij verder helpen? - Bas
  • LS, Ik heb inmiddels het benodigde pakket gevonden via de Synaptic Package Manager, inmiddels heb ik de driver kunnen compileren en installeren. Helaas heb ik toch moeten afhaken, aangezien ik vervolgens xorg.conf moet aanpassen, welke niet blijkt te bestaan. Dit probleem uitdiepen en oplossen gaat me op het moment even te veel tijd kosten. Bedankt aan iedereen die de moeite heeft genomen mijn probleem te lezen! - Bas
  • [quote:96029bcca0="BasHamar"]Helaas heb ik toch moeten afhaken, aangezien ik vervolgens xorg.conf moet aanpassen, welke niet blijkt te bestaan. Dit probleem uitdiepen en oplossen gaat me op het moment even te veel tijd kosten.[/quote:96029bcca0] Moderne versies van Xorg hebben geen xorg.conf meer nodig. Ze detecteren de juiste instellingen automatisch bij het starten. Als je aangepaste instellingen nodig hebt kan je wel een xorg.conf aanmaken (bij mij in /etc/X11/) en dan wordt die gewoon gebruikt.
  • Handmatig compileren en installeren van (stuur)programma's is in Linux een uitermate vervelende rotklus. Zelfs voor gevorderden. In jouw plek zou ik óf het automatisch aangeboden gesloten stuurprogje gebruiken (aangeboden via Systeem - Beheer - Stuurprogramma's), óf het houden bij het standaard open-bron-stuurprogje. Gewone programma's installeren doe je overigens zo: http://sites.google.com/site/computertip/installerenvanprogrammas
  • [quote:011b171e7c="pjotr123"]In jouw plek zou ik óf het automatisch aangeboden gesloten stuurprogje gebruiken (aangeboden via Systeem - Beheer - Stuurprogramma's), óf het houden bij het standaard open-bron-stuurprogje.[/quote:011b171e7c]Dat heb ik zelf natuurlijk ook het liefst. Ik heb ervoor gekozen het proprietaire stuurprogramma van ATI te gebruiken aangezien dat "out-of-the-box" 2D- en 3D-versnelling zou moeten ondersteunen. Maar helaas zie ik tot vervelens toe "artifacts" bij het verplaatsen/vergroten van vensters en bij HD-materiaal zijn er haperingen en duidelijke problemen met de vsync. Ik zou dit graag oplossen, maar weet niet hoe. Aangezien mijn hierboven beschreven avontuur vroegtijdig is gestopt: iemand een idee hoe ik deze problemen kan oplossen? - Bas
  • [quote:b4ae1085ee="BasHamar"]Helaas valt de performance een beetje tegen[/quote:b4ae1085ee] Waarmee heb je vastgesteld dat de performance van de "niet-open-source"-drivers van ATI tegenvalt? Als je andere Linux drivers wilt proberen, zou je die kunnen downloaden vanaf http://support.amd.com/us/gpudownload/Pages/index.aspx Om welke ATI videokaart gaat het eigenlijk? Installatie instructies staan daar ook.
  • [quote:708a32b20d="jolo"]Waarmee heb je vastgesteld dat de performance van de "niet-open-source"-drivers van ATI tegenvalt?[/quote:708a32b20d]Door vast te stellen dat video afspelen minder soepel verloopt dan op Windows. 1080p en 720p video hapert (soms) en ik zie fouten in de vsync, iets dat ik niet zie op Windows. Wellicht ook een kwestie van configuratie, maar vooralsnog werkt het ondermaats. Wel heb ik problemen met de vsync al grotendeels verholpen bij het verplaatsen/veranderen van vensters. [quote:708a32b20d="jolo"]Als je andere Linux drivers wilt proberen, zou je die kunnen downloaden vanaf http://support.amd.com/us/gpudownload/Pages/index.aspx Om welke ATI videokaart gaat het eigenlijk? Installatie instructies staan daar ook.[/quote:708a32b20d]Ik heb een ATI Radeon HD 4890. Als ik dat menu doorloop krijg ik de "ATI Catalyst™ 10.9 Proprietary Linux x86 Display Driver", volgens mij dezelfde die ik nu heb, al kon ik dat niet zo snel verifiëren... Bedankt voor het meedenken, ik zal vandaag of morgen kijken of deze drivers beter werken dan mijn huidige drivers. - Bas
  • Je zou ook deze [url=http://dee.cz/lightsmark/]Lightsmark 2008[/url] benchmark kunnen draaien. Daarvan is zowel een Windows en Linux versie van beschikbaar. Ofschoon deze nog uit het jaar 2008 is, is deze nog wel te gebruiken in Ubuntu 10.04.1. In de meegeleverde readme.txt staat hoe deze te gebruiken. Ikzelf heb weliswaar geen ATI Radeon HD 4890. Maar wel een oude P3 met een ATI x1650Pro. En daarmee heb ik deze gebenchmarkt zowel in Ubuntu 8.04.4 en Windows XP. De fps in Windows XP was ongeveer 27.5 en in Ubuntu 8.04.4 was deze ongeveer 28.5. Voor beide besturingssystemen had ik de gesloten bron drivers van de ATI website gedownload en geïnstalleerd.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.