Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Linux Mint: trage opstart van Wifi

Ger
35 antwoorden
  • Het viel me eerder onder de Xfce omgeving al op en nu ook onder Mate: het duurt in Linux Mint vaak relatief lang voordat Wifi gevonden wordt. Zowel na een volledige herstart als na opstarten uit pauzestand.

    Onder Windows 7 ben ik meestal (vrijwel) direct verbonden met het draadloze netwerk hier in huis, terwijl met de laptop op dezelfde plaats (zo'n 5 meter met 1 muur verwijderd van de router) het onder Mint regelmatig bijna een minuut duurt voordat ik verbonden ben. Ik heb deze tip al nagekeken, maar die optie stond (zowel onder Xfce als onder Mate) al standaard aangevinkt. Uit iwconfig:

    [code:1:277d07816f]IEEE 802.11bgn ESSID:"***"
    Mode:Managed Frequency:2.412 GHz Access Point: ***
    Bit Rate=72.2 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thr=2347 B Fragment thr:off
    Power Management:off
    Link Quality=58/70 Signal level=-52 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:1 Missed beacon:0
    [/code:1:277d07816f]
  • Om wat voor draadloze chipset gaat het?
  • Uit lshw:

    [code:1:4ad7ed6213]network
    description: Wireless interface
    product: RTL8191SEvB Wireless LAN Controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:07:00.0
    logical name: wlan0
    version: 10
    serial: 70:1a:04:dc:3a:c9
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rtl8192se driverversion=3.2.0-23-generic firmware=N/A ip=192.168.0.101 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
    resources: irq:17 ioport:7000(size=256) memory:d5100000-d5103fff
    [/code:1:4ad7ed6213]
  • Is de SSID (netwerknaam) soms verborgen?

    Zo ja, maak 'm dan liever zichtbaar, want niet alleen de verbinding kan daardoor verbeteren maar zelfs….. de veiligheid:
    https://sites.google.com/site/computertip/draadlozeveiligheid
    (punt 1.1, linkerkolom)
  • Nope, niet verborgen.
    Overigens: het is niet altijd traag. Soms is het met enkele seconden verbonden (wat heel normaal is). Laten we zeggen: 50/50 met snel en traag.
  • OK…. Heb je al de nieuwste kernel in je Mint? Die krijg je door niveau 4 en 5 aan te vinken in Updatebeheer, of als volgt via de terminal (kopieer en plak):
    [code:1:1692a44a16]sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade[/code:1:1692a44a16]
  • Op de terminal manier gedaan. Ben benieuwd of het helpt. :)

    Edit: Eerste indruk is positief: na een herstart was de wifi nu direct actief.
  • Stuurprogjes zitten in de kernel, dus via kernel-updates krijg je vaak verbeterde en/of vernieuwde stuurprogjes mee…. :)

    Ik begrijp daarom ook niet, waarom Mint die als "gevaarlijk" bestempelt (niveau 5). Overdreven voorzichtig, want moederdistributie Ubuntu rolt die gewoon zonder meer uit, bij iedereen. En dit veroorzaakt vrijwel nooit problemen, want ze worden (net als alle andere updates) vooraf grondig getest.

    In het onwaarschijnlijke geval dat er wel problemen ontstaan door een nieuwere kernel (ik heb 't één keer meegemaakt, in 2006), dan kun je eenvoudigweg opstarten vanaf de oudere kernel, want die blijft gewoon aanwezig in je systeem.

    Nieuwere kernels hebben vaak een hele waslijst aan verbeteringen, dus het is zeer de moeite waard om ze standaard altijd direct te installeren.
  • Hmm… ik merk wel dat wifi naar mijn idee trager is (qua downloadsnelheid) dan onder Windows. Power management staat uit, de router staat op "N only", kan het nog andere oorzaken hebben?
  • Doe in beide besturingssystemen, eens *drie keer achter elkaar* een snelheidsproef op de volgende webstek:
    http://www.speedtest.net

    Meet je belangrijke verschillen?

    Terzijde: voor Mint Mate heb ik een direct-doen-lijst gemaakt, die je meteen na installatie kunt toepassen, om je Mint Mate helemaal netjes af te werken:
    https://sites.google.com/site/computertip/directdoenmint
    Een aanrader! :)
  • [quote:8fb7992ff0="pjotr123"]Doe in beide besturingssystemen, eens *drie keer achter elkaar* een snelheidsproef op de volgende webstek:
    http://www.speedtest.net

    Meet je belangrijke verschillen?[/quote:8fb7992ff0]Duurde ff voordat ik hier tijd en zin in had (gezien het weer), maar bij deze:
    Mint 1e run:
    [img:8fb7992ff0]http://www.speedtest.net
    esult/2835982407.png[/img:8fb7992ff0]


    Mint 2e run:
    [img:8fb7992ff0]http://www.speedtest.net
    esult/2835984420.png[/img:8fb7992ff0]


    Mint 3e run:
    [img:8fb7992ff0]http://www.speedtest.net
    esult/2835985522.png[/img:8fb7992ff0]


    Win 1e run:
    [img:8fb7992ff0]http://www.speedtest.net
    esult/2836003572.png[/img:8fb7992ff0]


    Win 2e run:
    [img:8fb7992ff0]http://www.speedtest.net
    esult/2836004519.png[/img:8fb7992ff0]


    Win 3e run:
    [img:8fb7992ff0]http://www.speedtest.net
    esult/2836005493.png[/img:8fb7992ff0]


    Als je dit dus ziet, dan zou je zeggen dat Mint sneller is; de download is consistent zo'n 60% sneller. Toch heb ik af en toe wel écht het idee (zelfs bij het laden van een pagina) dat het absurd lang duurt. De forumindex van Computer!Totaal die er bijv. een minuut over doet, dat soort dingen. Is maar soms hoor, dus wellicht was het ook een glitch ergens.


    [quote:8fb7992ff0="pjotr123"]
    Terzijde: voor Mint Mate heb ik een direct-doen-lijst gemaakt, die je meteen na installatie kunt toepassen, om je Mint Mate helemaal netjes af te werken:
    https://sites.google.com/site/computertip/directdoenmint
    Een aanrader! :)[/quote:8fb7992ff0]Had ik al gevonden en gedaan. :)
  • Hmmm….. Dan zou het ook kunnen liggen aan je webbladeraar.

    Vooral add-ons / plugins / extensies zijn de gebruikelijke verdachten bij vertragingen bij websurfen. Vandaar dat ik aanraad om geen kerstboom te maken van je webbrowser:
    https://sites.google.com/site/computertip/firefox#TOC-Maak-geen-kerstboom-van-Firefox

    De veroorzaker vind je dan, door eerst alle add-ons uit te schakelen en vervolgens één voor één weer in te schakelen. Merk je een plotselinge vertraging, dan heb je de boosdoener te pakken.

    Je kunt trouwens ook eens een schone tweede webbladeraar uitproberen, waarin je nog geen invoegtoepassingen hebt gestopt (Chromium of Chrome, bijvoorbeeld).
  • Hmm… ik heb alleen het NL taalpakket, speed dial, Last Pass en ABP geïnstalleerd in Mint, terwijl ik in Windows veel meer heb (waaronder ook deze vier). Natuurlijk verschillen beide versies van Firefox wel van elkaar, maar volgens mij zijn de plugins identiek.

    Zal 'ns kijken of uitschakelen verschil maakt.
  • Het NL taalpakket kan de oorzaak niet zijn, en van ABP heb ik nog nooit een vertragend effect meegemaakt. Kijk eens naar LastPass en vooral naar Speed Dial?
  • Vooralsnog geen merkbare effecten. Ik zag overigens wel dat er ook een plugin genaam Stylish geïnstalleerd was, die heb ik uitgeschakeld.
  • Hoe verloopt 't in Chromium of Chrome?
  • http://linuxg.net/fix-the-slow-connection-problem-when-using-wifi-on-ubuntu-13-04-12-04-or-linux-mint-13/

    http://askubuntu.com/questions/158517/linux-mint-enabling-networkmanager-at-startup
    Hier nog eens naar kijken of ie wel altijd meteen opstart, mss ligt daar het probleem dat die manager soms laat is met opstarten.
  • @ andre: het probleem ligt niet bij de internetverbinding: de proef op speedtest.net heeft uitgewezen dat die in orde is. :)

    Het probleem ligt hoogstwaarschijnlijk bij de webbrowser. Mogelijk een dwarsliggende add-on of een cache-probleem….
  • Inmiddels even wat verder, en vooralsnog kan ik er niet echt de vinger op leggen. Het treedt heel af en toe op (steeds minder lijkt het ook wel) dus misschien ligt het gewoon aan de internetverbinding. Ziggo is hier in de buurt flink aan het werk, misschien is het gewoon toeval dat dit samenvalt met mijn Mint experimenten.
    Doordat het maar af en toe optreedt, is het ook lastig om er een oorzaak aan te plakken. Ik kan ook niet zeggen of Chromium nu verschil maakt.

    Voorlopig laat ik het even rusten. Mocht het toch blijvend van aard zijn, dan meld ik me wel weer. :)
  • [quote:f64705251b="Ger"]Het treedt heel af en toe op (steeds minder lijkt het ook wel)[/quote:f64705251b]
    Heb je misschien het updatebeheer nog staan op de standaardinstelling van 1 x per 15 minuten controleren op nieuwe updates?

    Die controle kan je internetverbinding grotendeels opslurpen, wat een extra reden is om 'm op 1 x per dag te zetten….

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.