Vraag & Antwoord

OS Linux

Red Hat 7.1 houdt niet van Scsi

Anoniem
Mithrandir
15 antwoorden
  • Het probleem dat zich voordoet is dat de installatie stopt bij het laden van de drivers voor de Scsi-controller. Het systeem blijft gewoon wachten….. De configuratie :

    • Abit BX 6 rev. 2
    • PIII 500 Mhz.
    • 256 Mb. ram
    • Gforce 256 DDR 32 Mb.
    • 3com Etherlink busmaster PCI
    • Sound blaster Live 1024
    • Adaptec AHA 3950 U2B controller
    • Adaptec AHA 3940 UW controller
    • IBM DCAS-34330W (Scsi)
    • IBM DDYS-T36950N (Scsi)
    • IBM DNES-309170W (Scsi)
    • Waitec T-rex 16/10/40 (Scsi)
    • Plextor Ultraplex 40max (Scsi)
    • Pioneer DVD 305S (Scsi)
    • HP-Surestore DAT 8 (Scsi)
    • Iomega ZIP 100 + (Scsi)
    • CanonScan 300 (Scsi)
    • Nexland ISB2 LAN router
    • HP-deskjet 1220 C (USB)
    • HP-laserjet 4J (netwerk)
    • LS 120 diskettestation
    • Alcatel ADSL modem (netwerk)
    • Ednet USB-hub
    • Philips Toucam Pro webcam

    Verder dualboot Win98 Se /W2k
    Een jaartje geleden heb ik Suse 7.0 gedraaid maar dit heb ik er afgegooid omdat de USB ondersteuning niet goed werkte en ik ook niet goed in kleur kon afdrukken op A3 formaat… Mijn conclusie is dan ook dat de hardware zeker niet te exotisch is voor Linux, alleen denk ik dat Red Hat een beetje moeilijk doet omwille van de 2 Scsi-kaarten, (elke kaart heeft 2 controllers) en de optie om er eentje uit te halen is uit den boze daar 2 devices extern zijn en ik daar 1 kanaal aan kwijt ben; verder zit op het andere kanaal de 3 cd-roms. Op de U2W-controller zit op het 1e kanaal een LVD-schijf die uiteraard alleen zit om de bussnelheid niet naar beneden te halen. Op het andere kanaal zitten de 2 andere hd's tesamen met de tapestreamer. Onder Suse had ik het zaakje eerst aan de praat gekregen door met 1 controller te werken. Na de installatie de 2e kaart erbijgestoken maar dit leidde tot een "kernelpanic" wat meteen het overlijden betekende van de installatie en op dat ogenblik ook aan mijn "Linuxmicrobe"
    Ideeën zijn zeer welkom :grin:

    ——————

  • Linux schrikt zich kapot van jouw configuratie :smile:

    Haal eerst eens een bergje hardware uit de pc en installeer eerst de basis eens. Daarna ga je hardware toevoegen en stapje voor stapje werkend maken. In jouw geval een redelijke klus. Maar wel erg leuk!

  • quote:
    Originally posted by MrLeeJohn:
    Linux schrikt zich kapot van jouw configuratie :smile:

    Haal eerst eens een bergje hardware uit de pc en installeer eerst de basis eens. Daarna ga je hardware toevoegen en stapje voor stapje werkend maken. In jouw geval een redelijke klus. Maar wel erg leuk!


    Hoezo ??? kapot schrikken :smile: Ik dacht toch dat Linux op zijn minst geen problemen zou hebben met SCSI daar dit een van die dingen zijn die zeer veel voorkomen in Servers….

    Enfin na een beetje dieper gegraven te hebben kwamen we tot de volgende fout :

    - Loading Scsi driver : "Loading aic7xxx driver……..

    in console "F3" : Going ISMOD aic7xxx.0 (path is NULL)
    in console "F4" : (6)unexpected busfree (Scsi2:0:4:-1) lastphase =0 X 80 Seqaddress 0 X 116 ; 0 X 117


    ——————

  • In principe houdt Linux dus wel degelijk van scsi. Bij jou is er iets anders….
  • Dat was nu net de vraag….
    Dit probleem doet zich dus ook voor met alleen de 3940 controller in de computer. Blijkbaar kan Linux dus niet overweg met dubbele scsicontrollers… Op de meeste Linuxforums kwam ik dikwijls ook deze fout tegen met andere Scsikaarten maar helaas kon ook hier niemand antwoord op geven. Geen Linux dus …..
  • Het is een bekend probleem, met meerdere mogelijke oorzaken. Vaak lost het uitschakelen van "wide negotiation" in de SCSI BIOS voor de desbetreffende drive het probleem op. Voor welke drive je dit moet doen kun je opmaken uit Scsi2:0:4:-1. Anders weet ik het helaas ook niet :sad:.
  • Ik ben bezig Red Hat 7.2 op een ouwe HP doos (LC) met alleen SCSI schijven/CDROM te installeren en heb ook allerlei problemen…

    Ik kan vanaf CD booten en de install starten, maar dan kan ik niet kiezen om van CD te installeren…
    Als ik het via FTP doe lijkt het te werken, tot dat je diskdruid start… dan zegt ie geen schijven te kunnen vinden…

    Vaag..
  • [quote:1ccb937e7c]
    Op 21-02-2002 4:19, schreef toolkit:
    Ik ben bezig Red Hat 7.2 op een ouwe HP doos (LC) met alleen SCSI schijven/CDROM te installeren en heb ook allerlei problemen…

    Ik kan vanaf CD booten en de install starten, maar dan kan ik niet kiezen om van CD te installeren…
    Als ik het via FTP doe lijkt het te werken, tot dat je diskdruid start… dan zegt ie geen schijven te kunnen vinden…

    Vaag..
    [/quote:1ccb937e7c]

    Hier lijkt het erop dat je zodra je installatie gestart is linux nog even de drivers geïnstalleerd wil hebben.
  • je moet niet vergeten at redhat en suse linuxen zijn voor de gemiddelde desktop pc… en die hebben zelden scsi.

    je zou eens kunnen kijken op www.linuxdoc.org en lees daar de scsi howto/guide/fac

    wie weet, helpt dat eea op te lossen.

    suc7
  • [quote:2085ab2c2d]
    Op 21-02-2002 13:23, schreef Mithrandir:
    je moet niet vergeten at redhat en suse linuxen zijn voor de gemiddelde desktop pc… en die hebben zelden scsi.

    je zou eens kunnen kijken op www.linuxdoc.org en lees daar de scsi howto/guide/fac

    wie weet, helpt dat eea op te lossen.

    suc7

    [/quote:2085ab2c2d]
    Bedankt voor de link, veel info. maar niet wat ik zoek :sad: ik zoek dus nog ff verder…
  • met scsi controllers heb je imho vaak het probleem dat de distro de drivers er gewoon niet voor heeft meegecompiled - hetzij in kernel hetzij als module. en als ie ze al heeft dan zul je ze zelf moeten laden.

    zeg nu zelf: welke desktop pc is nu een scsi only systeem? :???:
  • gevonden:
    http://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/install-guide/ch-driverdisk.html
  • [quote:bdde251931]
    Op 21-02-2002 13:23, schreef Mithrandir:
    je moet niet vergeten at redhat en suse linuxen zijn voor de gemiddelde desktop pc… en die hebben zelden scsi.

    je zou eens kunnen kijken op www.linuxdoc.org en lees daar de scsi howto/guide/fac

    wie weet, helpt dat eea op te lossen.

    suc7

    [/quote:bdde251931]

    Van SuSE weet ik iig dat ze scsi goed ondersteund hoor maar voor je installatie werkelijk begint moet je natuurlijk wel de scsi modules installeren. Niet alles gaat automatisch en na installatie hardware toevoetgen is, vind ik, meestal toch iets lastiger.
  • [quote:f4284d399b]
    Op 22-02-2002 12:37, schreef wstolk:

    Van SuSE weet ik iig dat ze scsi goed ondersteund hoor maar voor je installatie werkelijk begint moet je natuurlijk wel de scsi modules installeren. Niet alles gaat automatisch en na installatie hardware toevoetgen is, vind ik, meestal toch iets lastiger.
    [/quote:f4284d399b]

    het punt is niet de hardware ondersteuning tijdens/na installatie maar voor c.q. aan het begin van de installatie, nog voordat er iets gedaan kan worden. Daar falen de meeste distributies. dat het na die tijd goed gaat ligt imho niet zozeer aan suse/redhat etc maar veeleer aan de kracht van linux.

    later toevoegen heb ik nooit problemen mee gehad. :razz:hew: (die bestaat niet :wink: )
  • In dit geval ben ik misschien wat onduidelijk maar bedoelde dus dat je zodra de installatie begint, dus je kernel geladen is en voor je setup proggie start ( dus bij SuSe nog voor YAST) je de modules moet laden voor je apparaten.

    Praktijkvoorbeeld:

    Ik had een 486dx4-100 met 1x IDE en een ncr53c810 controller onboard. Nu wilde de bios die controller niet meer goed uitlezen (weet echt niet waarom niet maar het was zo) dus wer er één hd en mijn cdrom die eraan hingen niet herkent tijdens booten en vaak bleef de machine er zelfs op hangen.

    Opstarten met diskette en nog voor YAST dus begon moest ik dan de modules voor die scsi controller laden waarna ik gewoon kon installeren. Echter dit ging wel met 6.0 maar vanaf SuSE 7.0 wilde dat ineens niet meer lukken :sad: enige mogelijkheid was hier dus 6.0 installeren en vervolgens upgraden :sad: en dat lukte dus ook alleen door één ide HD eruit te halen en hier een IDE-cdrom aan te hangen.module wilde persé niet laden ook niet met i/o en irq parameters.

    Maar waar het dus om gaat is die modules direct na het booten te laden en dus vanaf diskette op te starten niet van cdrom denk ik.

    Succes
    Walter

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.