Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

RH7.1 Lilo, HD in lba zetten

woutur
6 antwoorden
  • Het overkomt me altijd wanneer ik RH besluit te installeren. Lilo kan de boot sector niet vinden omdat hij boven de 1024 cylinders ligt. Nu heb ik in lilo aangegeven dat hij in lba moet staan i.p.v. linear. Nu moet ik dat ook in mijn bios aangeven en daar knelt de schoen. Ik heb een abit be6 mobo met daarop een highpoint 366 controller (voor udma 66) en nu begrijp ik niet waar ik mijn hd's op lba moet zetten. Als ik namelijk primary en secondery master ide op lba zet dan vindt het bios mijn schijven niet (ik vermoed dat hij dan de "echte" ide poorten op lba zet waar mijn cdrom's aan vast zitten en niet mijn harde schijven (be6 heeft 4 aansluitingen, 2 voor normale ide en 2 voor udma66)). Ik mag graag lilo gebruiken daar ik weet hoe alles daarin werkt met bv. nieuwe kernels e.d. Hoe los ik dit op?
  • het is niet de oplossing die jij zoekt denk ik, maar je kunt het probleem omzeilen door aan het begin van je schijf een kleine partitie aan te maken (zo'n 20 MB) en die in /boot te mounten en daar de kernel images op te zetten.

    evt je rootpartitie aan het begin van je schijf en zorgen dat ie onder de 1024 cylinders eindigt.
  • Ik weet niet hoe dat gaat met apparte controllers maar stel je in de bios in dat hij daar vanaf moet booten ??

    Dan zou linux deze idd als /dev/hda moeten zien en dan moet je in de bios (als die er opzit ??? ) van die controller moeten instellen dat je je schijf op lba wil hebben.

    tussentijds wisselen van normal naar lba is met een HD volgens mij niet mogelijk dan moet je partitie tabel volgens mij herschreven worden zover ik weet.

    Dus oplossing hierboven lijkt me de beste.
  • Ben maar weer aan het herpartioneren geslagen… Voor de informatie: Linux herkent mijn harde schijven als HDE en HDG. Als HD's op een controller zitten krijgen ze niet het HDA label mee. Die zit gewoon nog op de IDE master (wat bij mij de cdrom is)
  • ik heb dit probleem vaker gehoord..
    ga ff navragies doen!!
    ik kom hier nog wel op terug

    edit: mogelijke oplossing
    gebruik een andere boot image
    de standaard is de bare-ide.img maar gezien jij wat geanvanceerder hebt, zul je dus een andere nodig hebben.



    [ Dit Bericht is bewerkt door: KayJay op 2002-02-20 16:08 ]
  • Je moet /etc/lilo.conf handmatig aanpassen en dan

    [code:1:85c68239a6]
    boot=/dev/hde
    [/code:1:85c68239a6]
    maken als je lilo in die mbr wil hebben anders het part.num/ erachter
    dus bijv:
    [code:1:85c68239a6]
    boot=/dev/hde3
    [/code:1:85c68239a6]

    veel distro's gaan hiermee nml. de fout in.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.