Vraag & Antwoord

OS Linux

KDE upgrade

4 antwoorden
  • In mijn vorige topic over een UML tool kwamen we uit op een KDE upgrade, die min of meer noodzakelijk is. Aangezien de vragen die ik hier dan voor had niet meer passen bij de titel van die topic maak ik maar een nieuwe aan, zodat we niet zo off-topic bezig zijn... Ik heb momenteel dus KDE 2.1 draaien (op SuSE 7.2), en wil deze dan upgraden naar 2.2.2 Ik heb wel ongeveer een idee hoe ik dit aan zal moeten pakken, maar ben er nog niet zeker van. Als requirement staat er op de site dat QT 2.3.1 of 2.3.2 aanwezig moeten zijn. Beetje domme vraag misschien, maar hoe kan ik dat controleren? Verder lijkt het mij het beste dat ik het maar probeer te installeren via de RPM's. Welke heb ik echter nodig, en in welke volgorde kan ik dit dan het beste doen? Nogmaals: ik vind ook hierover wel het een en ander op de site van KDE, maar ben toch nog een beetje huiverig om dit zomaar te doen. Ik heb m'n X-windows systeem toch wel nodig! Alvast bedankt in elk geval!
  • Upgraden naar KDE 2.2 is op zich niet echt moeilijk. Wlke versie vna QT je hebt? Kijk even naar de map waar qt in staat. Bijv op mijn pc staat in de map /usr/lib een symbolische koppeling tussen qt en de map qt-2.3.1 Dat betekent voor mij dus dat ik als standaard QT-versie 2.3.1 gebruik. Hoe moet je KDE upgraden? Eerst download je de verschillende onderdelen van KDE: Je hebt tenminste kdebase en kdelibs nodig. wil je een Nederlandse KDE, dan donwlod je ook kde-18n-nl oid. Let op: als je de NL-versie installeert moet je [i:cb3ec4e0be]alle pakketten[/i:cb3ec4e0be] upgraden! Waar haal je KDE vandan? allereerst van de site van je distro. Hoe gaat het installeren te werk? eerst download je dus de pakketten die je nodig hebt. Vaak heeft de ftp-server al een indeling voor je gemaakt in de vorm van een basis-map, een i18n-map, een no-archive map etc.. Download dan zeker de inhoud van de basismap, en kijk in de no-archive map of daar zaken in staan die voor jouw van belang zijn. Vervolgens start je de installatie Welke volgorde? eerst qt, dan de niet-kde-pakketten, zoals ogg vorbis, lame, etc... Dan kdelibs en kdebase. daarna maakt het niet meer uit. Snellere methode: doe gewoon een rpm-commando met een jokerteken.. [code:1:cb3ec4e0be] rpm -i --force --nodeps *.rpm[/code:1:cb3ec4e0be] hoe je de installatie ook doet, gebruik altijd de flag --force --nodeps. Waarom? omdat je de fundering van andere kde-programma's aan het bijwerken bent. rpm weigert standaard een pakket te vervangen als andere applicaties aangeven afhankelijk te zijn van dat pakket. Vandaar dat je de boel forceert, waarbij niet naar dependencies moet worden gekeken. Gebruik je SuSE? Dan adviseer ik je via yast (niet yast2) te installeren.. Max
  • Bedankt! Ik ben nu alle base-rpm's aan het d/l vanaf de server van SuSE. De rpm's installeren via *.rpm, kan dat ook direct, of moet ik dan wel eerst de qt.rpm t/m de kdebase.rpm afgewerkt hebben? Dit dus omdat ik me voor kan stellen dat je de verplichte volgorde weer kwijt bent zodra je het via een joker doet! [edit] Verder nog een vraagje of je na het installeren van de rpm's KDE gewoon opnieuw op moet starten, of moeten er nog andere zaken gewijzigd worden voordat we dit doen...? [/edit] <font size=-1>[ Dit Bericht is bewerkt door: rkars op 2002-02-22 14:22 ]</font>
  • SLIK... Ik heb zojuist dus alle base-packages ged/l, en heb geprobeerd om ze te installeren. Toen ik de kdelibs wilde installeren gaf hij echter de foutmelding: error: kdelibs.rpm cannot be installed KDE start nu dus niet meer op, of start wel op maar geeft een zwart scherm zonder iets erop. Ik ben nu dus de kdelibs opnieuw aan het downloaden, misschien dat dat bestand corrupt was, maar mocht dat niet het geval zijn, wat kan dan het probleem veroorzaakt hebben? En hoe kan ik het oplossen?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.