Vraag & Antwoord

OS Linux

Heb ik weer: ZIP-drive werkt zomaar niet meer onder Linux

16 antwoorden
  • Hoi, Mijn altijd trouw dienst doende zip-drive (op mijn werkplek) onder Linux heeft zomaar besloten ermee op te houden. Als ik de drive wil mounten, krijg ik steevast een foutmelding. Dat terwijl de drive het altijd goed heeft gedaan. Onder Windows werkt de drive trouwens wel en thuis onder Linux ook. Ik heb dus geen flauw idee waar dit probleem vandaan komt. Ik heb niets veranderd aan de 'fstab' en zelfs al had ik dat wel, dan nog kan ik de zip-diskette met de hand onmogelijk gemount krijgen. Heeft iemand op dit forum al eerder hiermee te maken gehad? Ik draai al een tijdje kernel 2.4.17 en SuSE 7.3 (zonder problemen). Groet, Philip
  • hey, euh, gebruik je devfs? had onderlaatst ook zo'n soort probleem bij de hand. (via mail) dat is uiteindelijk opgelost, maar ik weet niet precies hoe :wink: je moet dan in lilo.conf een regel met: append="devfs=nomount" opnemen naar het schijnt en in fstab ook eea, maar dat staat blijkbaar wel goed. type eens mount en kijk of je ergens devfs ziet staan.
  • Hmmm, Dit is mijn output van de 'mount' opdracht: /dev/hda8 on / type ext2 (rw) proc on /proc type proc (rw) devpts on /dev/pts type devpts (rw,mode=0620,gid=5) /dev/hda9 on /home type ext2 (rw) /dev/hda1 on /windows/C type vfat (rw,nosuid,nodev,umask=000) /dev/hda5 on /windows/D type vfat (rw,nosuid,nodev,umask=000) /dev/hda6 on /var/log type ext2 (rw) usbdevfs on /proc/bus/usb type usbdevfs (rw) Alleen USB gebruikt blijkbaar devfs; maar ik heb geen USB apparaten. Dan nog: mijn zip-drive heeft wel gewerkt. Hoe kan devfs er dan NU mee interfereren? Groet, Philip
  • je gebruikt geen devfs :wink: was zomaar een gokje wat krijg je voor foutmelding?
  • mount: wrong fs type, bad option, bad superblock on /dev/hdb4, or too many mounted file systems En nee, het ligt niet aan het mounten of mijn fstab file (al zou je dat wel denken). Op mijn computer thuis kan ik de ZIP-diskette zonder probleem mounten. Op mijn werkplek dus niet (behalve onder windows). Ik heb ook al een schijfcontrole op mijn zip-diskette laten uitvoeren: geen probleem... Als jij het weet ==> GRAAG! Philip
  • thuis ligt het niet aan je fstab, maar post voor de aardigheid toch even de betreffende regel uit de fstab. kun je floppies mounten? en fat partities? probeer het eens met -t vfat, wie weet... edit: (in console:) mount -t vfat /dev/hdb4 /mnt/zipdisk (ervan uitgaande dat /mnt/zipdisk is waar de disk gemount moet worden. mag je zelf weten natuurlijk.) _________________ :evil: windows? :evil: wat is dat? YECH <font size=-1>[ Dit Bericht is bewerkt door: Mithrandir op 2002-02-25 17:38 ]</font>
  • *ZUCHT* Dat heeft deze ouwe rot allemaal allang gedaan... Maar bedankt voor de hulp. Philip
  • okay :wink: permissies van /dev/hdb4? (is maar een gokje) hij heeft het gedaan? op dezelfde bak? heb je toen iets veranderd (nieuwe kernel of zo)? worden de drivers voor de zipdisk nog goed geladen? kan de machine praten met je zipdrive? (heb helaas floppy support in kernel op dit systeem. nu kan ik niet testen wat er gebeurt als je de support-module unload en dan probeert te mounten, maar ik denk dat er dan ook geen lampjes op het ding gaan branden. een zelfde foutmelding als jij krijg ik als ik /dev/hda14 probeer te mounten... dat ding bestaat niet :wink: misschien kun je hier meer mee?
  • Hoi, Naar aanleiding van onderstaand mailtje: [quote:89348f1930] This is an automatic notification regarding your bug report. It has been closed by one of the developers, namely Stephan Kulow &lt;coolo@kde.org&gt;. Their explanation is attached below. If this explanation is unsatisfactory and you haven't received a better one in a separate message then please contact the developer directly, or email submit@bugs.kde.org or me. Stephan Kulow (administrator, KDE bugs database) [snip] Hi! I just tested my ZIP drive here and it works as expected. So I prefer to close the bug. Please reopen it, if you have more details. [/quote:89348f1930] Ik sla dus stijl achterover van dit mailtje, want IK heb GEEN bugrapport ingediend... Ik ben hier niet zo blij mee, want het is geen specifiek KDE-probleem. Op de console login werkt het mounten van de ZIP-drive namelijk ook niet (het probleem is nog steeds niet opgelost). Ik hou het op een vaag hardwareprobleem, want op oudere kernels blijf ik het probleem ook houden. Maximilaan, heb jij een bugrapport gestuurd? Groet, Philip
  • weird! automatische bug report? (da's wel M$-policy) werkt ie inmiddels?
  • Nee, de zip-drive werkt nog steeds niet. Ik moet eigenlijk een andere (lege) ZIP-diskette nemen en eens kijken wat er dan gebeurd. Groet, Philip
  • [quote:d14cb619ea] Op 18-03-2002 12:42, schreef philipg: Nee, de zip-drive werkt nog steeds niet. Ik moet eigenlijk een andere (lege) ZIP-diskette nemen en eens kijken wat er dan gebeurd. Groet, Philip [/quote:d14cb619ea] AHA, Grote kans dus dat de part. tabel naar de gloria is Heb eens gekeken hoe dat met LS120 zit en daar staan dus 4 partitie's op die mekaar ook nogeens overlappen tenminste: mount /dev/hdd doet het gewoon fdisk -l /dev/hdd geeft 4 part. zal vanavond dat lijstje hier eens neerzetten
  • Ik heb geen bugrapport ingediend (zou niet durven :smile: ) Maar dit is hem: [quote:5e57821b9c]] Message sent to kde-bugs-dist@master.kde.org, David Faure &lt;faure@kde.org&gt;: Subject: Bug#21120: ZIP-drive mounted as readonly Reply-To: philipg at baserv.uci.kun.nl, 21120 at bugs.kde.org X-KDE-PR-Message: report 21120 X-KDE-PR-Package: kdesktop X-KDE-PR-Keywords: X-Loop: owner at bugs.kde.org Date: 1 Mar 2001 07:19:23 -0000 From: philipg at baserv.uci.kun.nl Package: kdesktop Version: KDE 2.1.0 Severity: normal Installed from: SuSE RPMs Compiler: gcc 2.95.1 OS: Linux OS/Compiler notes: kernel 2.4.2 In KDE 2.01 my ZIP-drive works correctly on the desktop. After the Upgrade to KDE 2.1, the properties of the ZIP-drive has been chnaged to readonly. (Submitted via bugs.kde.org) Message sent to : From: owner at bugs.kde.org (Stephan Kulow) To: philipg at baserv.uci.kun.nl Subject: Bug#21120: Acknowledgement (ZIP-drive mounted as readonly) X-KDE-PR-Message: ack 21120 Thank you for the problem report you have sent regarding KDE. This is an automatically generated reply, to let you know your message has been received. It is being forwarded to the developers' mailing list for their attention; they will reply in due course. Your message has been sent to the package maintainer(s): David Faure &lt;faure@kde.org&gt; If you wish to submit further information on your problem, please send it to 21120@bugs.kde.org (and *not* to bugs@bugs.kde.org). Please do not reply to the address at the top of this message, unless you wish to report a problem with the bug-tracking system. Stephan Kulow (administrator, KDE bugs database) Message sent to kde-bugs-dist@master.kde.org, philipg@baserv.uci.kun.nl: Subject: Bug#21120: ZIP-drive mounted as readonly Reply-To: 21120 at bugs.kde.org Mail-Followup-To: 21120 at bugs.kde.org, David Faure &lt;faure at kde.org&gt; X-KDE-PR-Message: report 21120 X-KDE-PR-Package: kdesktop X-KDE-PR-Keywords: X-Loop: owner at bugs.kde.org From: David Faure &lt;faure at kde.org&gt; To: 21120 at bugs.kde.org Date: Fri, 1 Mar 2002 22:11:46 +0100 &gt; In KDE 2.01 my ZIP-drive works correctly on the desktop. After the &gt; Upgrade to KDE 2.1, the properties of the ZIP-drive has been chnaged to= =20 readonly Is this still a problem with KDE 2.2 ? If yes, can you send me the .deskt= op=20 file for it, and if possible the debug output from kio_file ? (it can be found in ~/.xsession-errors) Thanks. Message sent to : From: owner at bugs.kde.org (Stephan Kulow) To: David Faure &lt;faure at kde.org&gt; Subject: Bug#21120: Info received (was ZIP-drive mounted as readonly) X-KDE-PR-Message: ack-info-maintonly 21120 Thank you for the additional information you have supplied regarding this problem report. It has been forwarded to the developer(s) and to the developers' mailing list to accompany the original report. If you wish to continue to submit further information on your problem, please send it to 21120@bugs.kde.org, as before. Please do not reply to the address at the top of this message, unless you wish to report a problem with the bug-tracking system. Stephan Kulow (administrator, KDE bugs database)[/quote:5e57821b9c] Max <font size=-1>[ Dit Bericht is bewerkt door: maximilaan op 2002-03-18 13:00 ]</font>
  • Tja, Ik was dat bugrapport alweer helemaal vergeten. Vind je het gek: 1 maart 2001. Het was een heel ander probleem dan wat in dit topic speelt. Het gekke is dat ik destijds op aanraden van Maximilaan dit bugrapport (zelf) had ingediend, omdat ik dus inderdaad een probleem kreeg met mijn ZIP-drive na de upgrade van KDE 2.01 naar 2.1 omdat in KDE alles opeens op read-only stond. Een probleem dat met de hand makkelijk is op te lossen overigens. Mijn excuses Maximilaan! En Walter, jou opmerking dat de partities waarschijnlijk beschadigd zijn zou wel eens erg goed kunnen kloppen. Dat idee heb ik dus zelf ook. Ik dacht dus slim te zijn en de ZIP-drive helemaal te formatteren (onder Windows, want onder Linux kan dus niets meer), maar dat lost het probleem niet op. En een 'fdisk /mbr' op een ZIP-diskette heb ik nog niet geprobeerd. Kan ik wellicht eens een keertje doen. Ik heb de backup van deze ZIP-diskette toch op mijn windows-partitie staan (noodgedwongen). Maar het ligt voor de hand dat door een foute partitietabel mijn zip-diskette niet meet gemount kan worden! Verklaart ook meteen waarom het onder windows wel goed werkt (ahum?). Bovenstaande is van toepassing op mijn werkPC. De desbetreffende ZIP-diskette werkt op mijn computer thuis WEL goed onder Linux! Daarom heb ik verder niet meer met partities e.d. lopen stoeien. Groet, Philip
  • [quote:9ecab942d9] Bovenstaande is van toepassing op mijn werkPC. De desbetreffende ZIP-diskette werkt op mijn computer thuis WEL goed onder Linux! Daarom heb ik verder niet meer met partities e.d. lopen stoeien. Groet, Philip [/quote:9ecab942d9] Zou bijna zeggen dat dan toch je drive stuk is
  • bump

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.