Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Telnet wil niet gedeactiveerd worden

knopper
10 antwoorden
  • Hoi,

    ik heb mijn telnet uitgeschakeld staan in mijn rc.config, en in de rc3.d directory, maar op de een of andere manier wordt dit blijkbaar toch op gestart.

    Als ik namelijk vanaf mijn andere pc een telnet sessie start (via Putty), dan kan ik zonder problemen inloggen. Kijk in naar mijn processen dmv ps -A, dan zie ik er geen telnet bijstaan.

    Is er nog ergens anders een optie om dit aan/uit te zetten.

    Een ander vraagje in hetzelfde kader… Ik wil dus mijn pc wat meer beveiligen, maar hoe kan ik zien welke poorten er bij mij open staan.
    Een collega heeft me ooit een commando gegeven waarmee alle openstaande poorten werden getoond, en welke services daarbij behoorden. Ik weet echter niet meer wat dit commando was.

    Ik draai onder SuSE 7.2, kernel 2.4.17

    [ Dit Bericht is bewerkt door: rkars op 2002-03-26 16:15 ]
  • [quote:8094e582d9]
    Op 26-03-2002 15:56, schreef rkars:
    ik heb mijn telnet uitgeschakeld staan in mijn rc.config, en in de rc3.d directory, maar op de een of andere manier wordt dit blijkbaar toch op gestart.
    [/quote:8094e582d9]

    Kijk even of het nog aan staat in /etc/inetd.conf. Zoja, #-je ervoor en inetd opnieuw starten.

    [quote:8094e582d9]
    Een ander vraagje in hetzelfde kader… Ik wil dus mijn pc wat meer beveiligen, maar hoe kan ik zien welke poorten er bij mij open staan.
    [/quote:8094e582d9]

    Met bijvoorbeeld nmap.

  • Thnx,

    in m'n inetd.conf staat alles afgeblokt. Hier zal hij dus waarschijnlijk niet mee op worden gestart.

    Nmap heb ik al draaien, ik dacht echter dat er nog een systeemcommando voor was. 'k Zal me wel vergist hebben.

    In elk geval als ik met nmap -sT <ip> kijk, dan zie ik dus idd poort 23, telnet openstaan.
    Blijkbaar zit het probleem toch ergens anders dan in m'n inetd.conf

    Nog andere ideeen?
  • [quote:b7029b2f35]
    Op 26-03-2002 16:33, schreef rkars:
    Thnx,

    in m'n inetd.conf staat alles afgeblokt. Hier zal hij dus waarschijnlijk niet mee op worden gestart.

    Nmap heb ik al draaien, ik dacht echter dat er nog een systeemcommando voor was. 'k Zal me wel vergist hebben.

    In elk geval als ik met nmap -sT <ip> kijk, dan zie ik dus idd poort 23, telnet openstaan.
    Blijkbaar zit het probleem toch ergens anders dan in m'n inetd.conf

    Nog andere ideeen?
    [/quote:b7029b2f35]

    Dit wordt dus pas actief als je je pc herstart, maar dat wist je al…

    Probeer anders eens "killall telnet"
  • over die telnet kan ik ff nix over zeggen maar als je het proggie nmap heb. kun je via nmap (ext. IP) zien welke poorten je open heb staan

    heh iets te laat. ik had de topic al tijdje openstaan voor ik reply'de
    sorries

    [ Dit Bericht is bewerkt door: KayJay op 2002-03-26 17:05 ]
  • Dat ik eerst moet booten wist ik idd wel, dit probleem is trouwens al heel lang het geval, alleen nu had ik het idee opgevat om dat eens op te pakken. In elk geval bedankt voor de opmerking!

    Als ik een 'killall telnet' doe, dan krijg ik de melding 'telnet: no process killed'
    Kijk ik daarna met nmap -sT <ip>, dan staat er nog heel fijn:
    22/tcp open ssh
    23/tcp open telnet

    Startten we hierna putty weer op, dan kan ik idd weer een telnet-sessie opstarten!

    Beetje wazig allemaal!
  • ps -A

    kijk naar het pid van telnet en kill het dan
    (kill -9 <pid>;)

    als ie er niet bijstaat:

    /sbin/init.d/inetd restart

    dan laat ie de inetdaemon opnieuw.
    beter is overigens om de xinetdaemon te gebruiken.
  • Bedankt!!

    Het antwoord van Mithrandir deed bij ineens aan het denken zetten. Ik gebruik namelijk ook xinetd, en niet inetd.
    Heb dus in de xinetd.conf gekeken, en idd, daar stond telnet ge-enabled. Uitgeschakeld en xinetd ge-restart. Nu doet 'ie het niet meer, en is m'n pc weer iets veiliger!

    Bedankt allemaal!
  • [quote:3665d0473d]
    Op 26-03-2002 17:21, schreef rkars:
    Bedankt!!

    Het antwoord van Mithrandir deed bij ineens aan het denken zetten. Ik gebruik namelijk ook xinetd, en niet inetd.
    Heb dus in de xinetd.conf gekeken, en idd, daar stond telnet ge-enabled. Uitgeschakeld en xinetd ge-restart. Nu doet 'ie het niet meer, en is m'n pc weer iets veiliger!

    Bedankt allemaal!
    [/quote:3665d0473d]

    Grappig he, dat sommige dingen zo simpel zijn…. :grin:
  • jah :grin:

    we hebben op de univ een systeembeheerder (innt… :sad: ) en hij wilde iets als service installeren, zodat alle clients automatisch beschikking hadden over een werkende virusscanner.

    dat lukte maar niet…
    totdat bleek…
    dat ie geen account had voor het proggie…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.