Vraag & Antwoord

OS Linux

Beginner met Linux RedHat

9 antwoorden
  • Hallo Allen, Ik heb zojuist Linux RedHat geïnstalleerd. En dat ging heel goed. Internet werkt, de winamp kloon werkt en alle pre-installed apps ook. Alleen snap ik er nu geen bal meer van. Ik probeer nu app's te installeren via RPM bestanden maar die komen met allerlei foutmeldingen dat ze de lib bestanden niet kunnen vinden. Hoe werkt dit???? Maar het belangrijkste is eigenlijk een Proxy/NAT server programma voor Linux. Ik gebruikte 1st Wingate op mijn PC samen met de clients op de andere Windows PC's maar dat werkt utt niet onder Linux. Weet iemand hier een goeie vervanger voor???? En hoe installeer ik die dan???? En als laatste, volgens Linux heb ik een i686 machine, maar ik heb gewoon een AMD Athlon 1333......
  • [quote:71040480e3]Ik probeer nu app's te installeren via RPM bestanden maar die komen met allerlei foutmeldingen dat ze de lib bestanden niet kunnen vinden. [/quote:71040480e3] je moet de desbetreffende lib's ook zoeken (op de redhat cd of op internet) en die dan eerst installeren (via rpm) [quote:71040480e3] Maar het belangrijkste is eigenlijk een Proxy/NAT server programma voor Linux. Ik gebruikte 1st Wingate op mijn PC samen met de clients op de andere Windows PC's maar dat werkt utt niet onder Linux. Weet iemand hier een goeie vervanger voor???? En hoe installeer ik die dan???? [/quote:71040480e3] Deze functionaliteit is standaard aanwezig in linux, onder de vorm van iptables/netfilter. Kijk eens op http://www.netfilter.org, daar staat uitgelegd hoe je dat aan de praat krijgt. Waarschijnlijk moet je niet heel de uitleg doorlopen die daar uitgelegd staat, omdat redhat alle nodige dingen al aan boord heeft. Ik geloof dat je het hele zootje kunt aanzetten in de configuratie-tool van redhat (linuxconf of linuxconfigurator noemt dat geloof ik) [quote:71040480e3] En als laatste, volgens Linux heb ik een i686 machine, maar ik heb gewoon een AMD Athlon 1333...... [/quote:71040480e3] Is normaal. Athlons hebben geen eigen "benaming" in de processor hiërarchie, en worden gewoon aanzien als pentium II's (= i686).
  • Nou in ieder geval 1 "probleem" opgelost. Ik dacht dat alle pentium's 586 waren... Nou ja, weer wat geleerd. Maar van het NAT verhaal snap ik geen bal. Wat NAT is en doet is me duidelijk maar hoe en vooral WAAR ik het moet instellen is voor mij compleet duister...... Het installeren van nieuwe software vindt ik ook vaag (Zal wel wennen zijn denk ik). Ik moest een libary SCURSES installeren, dat heb ik gedownload uitgepakt (Is ook al een vak apart) daarna kreeg ik allemaal bestanden waaronder INSTALL maar waar ik ook op klik ik krijg alleen maar text of er gebeurd helemaal nix.... Ik ga er in iedergeval verder mee stoeien...
  • Zo'n bestand INSTALL is ook meestal om te lezen :smile: Meestal moet je even een console venster openen om wat commando's in te typen. Maar als je RPM pakketjes gebruikt kun je die met een RPM installer installeren. (Meestal rechts klikken -> Install) Als er dan wordt geklaagd over bibliotheken die ook nodig zijn, moet je eerst even bij de distributie zelf kijken. 10 tegen 1 dat ze daar bij geleverd worden. Is het echt iets exotisch dat niet bij de distributie zit, dan moet je ff het Internet op. Als je geen RPM maar een .tar.gz (oid) file hebt, is het meestal een source pakketje. Je moet dan compileren en installeren voordat het progje in gebruik kan worden genomen. hoe moet dat?[list=1:e300ae0219][*:e300ae0219]Ga naar de directory waar het pakketje uitgepakt is [*:e300ae0219]Lees README en INSTALL [*:e300ae0219]open een commandoregel in die directory (Terminal, Xterm of Konsole bijvoorbeeld) [*:e300ae0219]Volg de instructies op. Meestal is het: [b:e300ae0219]./configure make make install[/b:e300ae0219] (de 'make install' moet dan als root, bijvoorbeeld [b:e300ae0219]su -c 'make install'[/b:e300ae0219] [/list:o:e300ae0219] Succes!
  • Hi daar ben ik weer. Na wat gestoei heb ik alle Dependencies geinstalleerd op 1 na. Dat is libsigc++. Nadat ik de complete file bij de makers ([url]http://libsigc.sourceforge.net/[/url]) heb gedownload heb ik de install gevolgt: ./configure make make check (Moest niet maar toch gedaan en alles was goed) make install Daarna geprobeerd om de RPM te installeren maar die komt nog steeds met: rpmdepCheck() failed Als ik dan bij de Package Manager kijk zegt die: unsatisfied dependencies libsigc++ >= 1.0.0 ,libsigc-1.0.so.0 Maar volgens mij had ik die juist daarvoor geinstalleerd.. Ook voor de zekerheid reboot gedaan maar hetzelfde resultaat.... Ik hoop dat je me hiermee verder kan helpen..
  • Nadeel van rpm is dat deze niet op je schijf kijkt of alles aanwezig is, maar in zijn database. Deze database wordt alleen aangevuld met pakketjes die je via rpm hebt geinstalleerd. Als je dus iets installeert door het zelf te compileren, of vanuit een een ander type archief, dan weet rpm van niets. Oplossing: Als je zeker weet dat alles aanwezig is en op de juiste plek staat, voeg dan de optie --nodeps toe aan het rpm-commando. voeg eventueel ook de optie --force toe :wink: Om na de installatie na te gaan of alle bibliotheken aanwezig zijn, voer het volgende commando uit: ldd /pad/naar/applicatie (dus om na te gaan of gimp alles kan vinden doe je bijv. ldd /usr/local/bin/gimp -- uitgaande dat gimp in /usr/local staat :wink: ) Als ldd enkele bibs aangeeft als "not found", dan moet je er even voor zorgen dat ze wel gevonden worden. Hoe dat moet is een andere topic max
  • Ok, Inet delen werkt nu eindelijk... Maar ik zit nog steeds te k-en met die RPM. Ik heb de optie --nodeps gebruikt en er gebeurde het 1 en ander.... als ik nu met het ldd commando de install bekijk zegt hij nog steeds dat hij libsigc niet kan vinden :mad: Weet iemand misschien een ander pakket waarmee je kan &quot;msn-en&quot;?????? (Probeer nu centericq werkend te krijgen) Mijn dank ik groot <font size=-1>[ Dit bericht is bewerkt door: one_234 op 2002-04-04 18:36 ]</font>
  • OK waar staat libsig op je schijf? stel, hij staat in /opt/lib/hoi/ligsig2.203456 en de applicatie wil volgens ldd libsig2-8 hebben voer dan dit commando uit: [code:1:d8abfea476]ln -s /opt/lib/hoi/ligsig2.203456 /usr/local/lib/libsig2-8[/code:1:d8abfea476] kijk nog eens met ldd of hij hem kan vinden, en start vervolgens vanuit een terminal de applicatie op. Als deze geen gekke fouten tav de lib geeft, dan is de missie geslaagd. Krijg je wel gekke fouten, dan heb je de verkeerde libversie geinstalleerd :sad: Max
  • Ander msn-applicatie? Kijk op http://apps.kde.com voor kmerlin of een andere applicatie. Max

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.