Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

KDE 3.0 zelf compileren en installeren van source

None
6 antwoorden
  • Ik heb SuSE 7.3 met KDE 2.2.1 en wil graag upgraden naar KDE 3. Aangezien KDE op mijn computer nou niet echt uitblinkt in snelheid (vooral Konqueror is vaak zo traag als dikke str*** :sad:), wil ik gelijk maar de stap nemen om KDE 3.0 niet van vooraf gecompileerde RPM-packages te installeren, maar vanaf broncode te compileren en installeren.

    Ik heb een site gevonden met een beschrijving voor het installeren van KDE 2.2.2 van source: http://hints.linuxfromscratch.org/hints/kde.txt .. Ik neem aan dat ik deze omschrijving met aanpassingen ook voor KDE 3.0 kan gebruiken? Weten jullie hoe ik het ??n en ander aan moet pakken?

    Alvast bedankt.
  • eerst QT 3.0.3 installeren:
    [code:1:1ac2017fe4]cd /usr/lib
    tar xfj qt-x11-free-3.0.3.tar.bz2
    cd qt-x11-free-3.0.3
    ./configure -system-{zlib,libpng,libmng,libjpeg}
    -thread -qt-gif -no-g++-exceptions
    -qt-imgfmt-{png,jpeg,mng}
    make[/code:1:1ac2017fe4]
    (geen make install!) Dan kdelibs:
    [code:1:1ac2017fe4]CFLAGS='-O3' CXXFLAGS='-O3' ./configure –prefix=/usr
    –with-qt-dir=/usr/lib/qt-x11-free-3.0.3
    –with-alsa
    make
    make install[/code:1:1ac2017fe4]
    Dan kdebase:
    [code:1:1ac2017fe4]CFLAGS='-O3' CXXFLAGS='-O3' ./configure –prefix=/usr
    –with-qt-dir=/usr/lib/qt-x11-free-3.0.3[/code:1:1ac2017fe4]
    Daarna eventueel nog kdeartwork en kdemultimedia enz enz enz. Volgorde maakt hierna niet meer uit.


    Zie ook de link naar Compile instructies vanaf de officiële KDE3 announcement.

    _________________
    Wilbert (http://www.xs4all.nl/~wbsoft/)
    Wanneer gaat een HTML document onder Windows [b:1ac2017fe4]Microsoft(r) Internet Explorer Document[/b:1ac2017fe4] heten?
    Mijn [i:1ac2017fe4]LFS-install.log[/i:1ac2017fe4]

    [ Dit bericht is bewerkt door: wbsoft op 2002-04-12 17:20 ]
  • Als je kde wilt blijven compileren, dan is het te overwegen om niet met ftp maar met cvs te werken.
    voordelen:
    1 niet meer wachten tot de pakketjes op ftp staan, maar tot 1 week voor de officiele aankondiging de nieuwste kde installeren.
    2 nooit meer 130 MB moeten downloaden bij een upgrade van KDE, je download alleen de patches (ideaal als over een maand kde 3.01 uit komt, met slechts enkele bugfixes)
    3 nooit meer configure hoeven draaien. 1 x configre is genoeg, bij de opvolgende versies die je installeerd kun je onmiddelijk make && make install uitvoeren.
    4 profiteren van de laatste bugfixes.
    Zit er een hinderlijke fout in kde, en kun je niet wachten op de volgende uitgave? Geen nood, dankzij branching kun je de verbeterde stabiele code in een handomdraai ophalen en compileren. Doordat alleen de wijzigingen als patch worden opgehaald ben je ook zo klaar.
    5 preciesiedownloads. Als je exact weet welke bestanden van een bepaald pakket zijn verbeterd, dan download je alleen de patches van die bestanden, meer niet. mak && make install in de betreffende map doet de rest.

    Max
  • [oude reactie, bewaard toen posten niet lukte gister]

    ik bestel mijn stuff altijd bij http://www.munnikes.nl/cd/ en dan onder CD's op maat (ik zeg gewoon wat ik erop wil en dan stuurt hij dat op. Echt perfect, voor ¤ 3,75)

  • Ik ben bezig met het downloaden avn KDE 3 in rpm's. Begrijp ik het goed als uit het verhaal van Wilbert concludeer dat ik tenminste de volgende rpm's nodig heb:

    - QT 3.0.3
    - kdelibs
    - kdebase
    - "nederlandstige" rpm

    en dat ik dan genoeg heb om de boel draaiende te krijgen? Het probleem zit hierin dat de ftp-site van kde een hoop rpm's bevat, waar ik maar van moet gokken wat de inhoud is.
  • klopt.
    Je hebt de volgende additionele pakketjes voor KDE:
    kdeaddons -> kleine plugins voor veel kde-programma's.
    kde-admin -> daministratieprogramma's, zoals een takenplanner, een pakketbeheerder, sysv init-editor, liloconfiguratie, etc..
    kdeartwork -> veel artwork, zoals schermbeveiliging, thema's, pictogrammen, etc..
    kdeedu-> educatieve programma's, zoals een typcursus, een latijns programma, een programma voor het verbeteren van je Franse uitspraak, Sterrenkunde, etc..
    kdegames -> Spelletjes!!
    kdegraphics-> tekenprogramma's en viewers voor KDE
    kdemultimedia-> multimediaspelers etc..
    kdentwork -> Internet-programma's, zoals een e-mailprogramma, een niewslezer, een AOL-client, een inbelprogramma, een lanbrowser, eennieuwsticker, etc..
    kdepim-> een agenda, adressenboek, palmpilotsynchronisatie, notitieblokje, etc..
    kdesdk-> hulppropgramma's voor software-ontwikkelaars, zoals een cvs-browser, een vertaalprogramma, een diff-hulpprogramma, etc..
    kdetoys-> kleine geinige programmaatjes, zoals een theezetter, een dansende pinguin op je titelbalk, een wereldklok, etc..
    kdeutils -> serie hulpprogramma's, zoals een adressenboek (jawel :smile: ) een afdrukbeheerder, een hexeditor, een editor, een floppy-formatteerder, etc..
    koffice-> kantoortoepassingen, zoals een tekstverwerker, een rekenblad, een presentatieprogramma, etc..

    Verder zie je veel pakketten met de extensie -devel
    Die zijn bedoelt voor het zelf ontwikkelen/compileren van applicaties.
    Voor het zelf compileren heb je alleen qt-devel en kdelibs-devel nodig.

    Verder zie je veel afsplitsingen van de bovengenoemde pakketten, zoals kdepim-kpilot of kdebase-ksysguard: Dit zijn onderdelen die uit het eigenlijke pakket gehaald zijn omdat ze voor veel gebruikers niet van toepassing zijn (zoals kdepim-kpilot, die alleen handig is als je een palmpilot hebt..)

    Lees verder het persbericht op http://www.kde.nl

    Max

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.