Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

divx met xine & tijd aanpassen

aukehaanstra
10 antwoorden
  • Ik heb xine geinstalleerd (ik dacht wel goed) met divx 5.1 en met ./install.sh het geinstalleerd. Nu heb ik 2 probleempjes:

    1. als ik een bestandje vanuit konqueror of nautilus naar xine sleept gebeurt er helemaal niets dus moet ik op de commandline "xine bestand.avi" invoeren om iets af te spelen.
    2. als ik een divx film wil afspelen dan doe ik ditzelfde, maar waar normaal een filmpje wordt afgespeeld, hoor ik nu een of ander vaag geluid en geen beeld. Daarna verdwijnt xine ineens.

    Weet iemand misschien waardoor dit komt?
    heb ik xine of divx misschien fout geinstalleerd?

    Ik paste hieronder even de foutmeldingen (en goedmeldingen):

    This is xine - a mpeg 1, 2 player v0.4.01 - © 2000 by G. Bartsch.
    Allocating 2000 buffers of 4096 bytes in one chunk (alignment = 2048)
    No extra demux plugins found in /usr/local/lib/xine/plugins
    xine_init: demuxer initialized
    found yuy2 format
    found yv12 format
    video_out_xv: using Xvideo port 46 for hw scaling
    *** Settings:
    HUE SATURATION BRIGHTNESS CONTRAST COLORKEY *****************
    Using X Window System video extension for video output.
    set_image_format_xv(): width=720, height=405, ratio=3
    scaled picture size : 720 x 405 (corr_factor: 0.997768)
    Using MMX for IDCT transform
    Using 3DNOW for motion compensation
    xine_init: video thread created
    xine_init: SPU thread created
    autodetected OSS audio driver
    xine_init: audio thread created
    input plugin found : /usr/local/lib/xine/plugins/input_dvd.so(input_dvd.so)
    input plugin found : /usr/local/lib/xine/plugins/input_file.so(input_file.so)
    input plugin found : /usr/local/lib/xine/plugins/input_net.so(input_net.so)
    input plugin found : /usr/local/lib/xine/plugins/input_stdin_fifo.so(input_st
    _fifo.so)
    input plugin found : /usr/local/lib/xine/plugins/input_vcd.so(input_vcd.so)
    xine_init: plugins loaded
    video_out: set_logo_mode 0
    demux_avi: video format = div3, audio format = 0x55
    ac3_reset
    They want library divxc32.dll
    Can't open library divxc32.dll
    ICOpen failed! unknown codec / wrong parameters?
    audio_oss_out: ao_open rate=48000, mode=4
    They want library l3codeca.acm
    Can't open library l3codeca.acm
    They want library l3codeca.acm
    Can't open library l3codeca.acm
    They want library l3codeca.acm
    Can't open library l3codeca.acm
    ACM_Decoder: Unappropriate audio format
    audio_oss_out: ao_open rate=48000, mode=4
    layer3
    Segmentatie fout

    [ Dit bericht is bewerkt door: aukehaanstra op 2002-04-27 22:33 ]

    [ Dit bericht is bewerkt door: aukehaanstra op 2002-04-29 14:25 ]
  • Hoi,

    Volgens je bijgevoegde list:

    They want library divxc32.dll
    Can't open library divxc32.dll
    ICOpen failed! unknown codec / wrong parameters?
    audio_oss_out: ao_open rate=48000, mode=4
    They want library l3codeca.acm
    Can't open library l3codeca.acm
    They want library l3codeca.acm
    Can't open library l3codeca.acm
    They want library l3codeca.acm
    Can't open library l3codeca.acm
    ACM_Decoder: Unappropriate audio format



    Weet je zeker dat je die divxc32.dll nodig hebt? Heb je het path goed aangegeven? Heb je lddconfig gedraaid na het installeren van de divx files?



  • mmm, nou bij de divx installatie heb ik alleen ./install.sh gedaan… kwist niet dat ik nog meer moest doen.
    Ik zal eens kijken…
  • kan je me dan vertellen hoe ik lddconfig dan draai?
    sorry, maar ik ben nog steeds een beetje newbie :)

    [ Dit bericht is bewerkt door: aukehaanstra op 2002-04-27 23:00 ]
  • Ik heb geen ervaring met Xine, maar zou je niet MPlayer kunnen proberen?
    Het is waarschijnlijk de snelste player ter wereld (sneller dan Windows Media Player) en ondersteunt standaard MPEG 4 (dus ook DivX 4/5).

    Trouwens, DivX 4 en 5 zijn evil. Ze hebben een heleboel open source ontwikkelaar bedrogen. Maar da's een ander (lang) verhaal.

    _________________
    Copyleft 2000-2001 - All Rights Reversed

    [ Dit bericht is bewerkt door: RobertV op 2002-04-28 02:37 ]
  • Mja… daar dacht ik ook aan,
    alleen heb ik gcc 2.96 (standaard bij rh 7.2)
    Ik heb geprobeerd mijn gcc versie te upgraden maar ik ben teruggedeinsd door de lange readme (dan ben ik straks een week een engelstalige handleiding aant lezen waar ik nog niks van snap)
    Ik ben nu al een tijd bezig om nu eindelijk eens divx onder linux te laten draaien maar het lijkt alsof wat je met windows in 10s doet je met linux hetzelfde maar dan in dagen bezig bent :(
    Dus probeerde ik maar xine, nu kan ik gewone filmpjes wel kijken maar geen divx. Het commando wat zou moeten werken in linux dat hierboven staat kan bash bij mij niet vinden het commando "ldconfig" wat ik ergens anders weer zag staan werkt ook al niet bij mij (kheb t nat onder root geprobeerd)

    Ik vind het wel erg jammer… maargoed, ik denk dat divx onder linux nog een droompje voor mij is die niet erg snel waar zal worden als ik zo kijk.

    Weet iemand misschien nog iets wat ik zou kunnen proberen? :)
  • Heb je de windows 32 dll wel geinstallleerd. Daardoor kan xine divx ed wel afspelen.
  • O ja en er bestaat al een 0.9.9 versie, misschien is die wel up-to-date
  • Hoe kan ik dan windows 32 dll installen?
    kheb gewoon de rpm van divx 5.1 en xine geinstalled… khad nergens gezien dat je ook nog iets anders moest doen…
  • Mja.. hehe. nu probeer ik een nieuwe xine versie te installen doe ik ./configure.. zijn de bestandjes die die maakt weer ouder dan de andere omdat mn system time niet echt goed loopt… doet ie weer niks :sad:

    weet iemand misschien hoe ik makkelijk de tijd kan aanpassen?
    kan dat ook in gnome zelf?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.